none
failed-modification-via-web-services

    Domanda

  • Hi there,

    I've read the threads on this but still need help.

    I'm setting sup MIM 2016 SP1 (which is absolutely not my forte) and have run into the this problem when running the Export on the MIM MA.

    It seems to be the one detailed in https://social.technet.microsoft.com/wiki/contents/articles/17242.fim-troubleshooting-failed-creation-via-web-services-invalidrepresentationexception-valueviolatesuniqueness.aspx, which suggests creating an Import Attrib Flow for domain --> domain but I can't see how to do that... I don't get the option under Mgmt Agent/Properties/Configure Attribute Flow.

    The MIM server was set up according to the instructions at 

    https://docs.microsoft.com/en-us/microsoft-identity-manager/microsoft-identity-manager-deploy

    Full text of the error is below. Thanks in advance for any assistance.

    Fault Reason: The endpoint could not dispatch the request.\r\n\r\nFault Details: <DispatchRequestFailures xmlns="http://schemas.microsoft.com/2006/11/ResourceManagement" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><DispatchRequestAdministratorDetails><FailureMessage>Exception: Other 
    Stack Trace: Microsoft.ResourceManagement.WebServices.Exceptions.UnwillingToPerformException: Other ---&gt; System.Data.SqlClient.SqlException: Procedure or function 'GetDomainConfigurationIdentifiersFromDomain' expects parameter '@domainName', which was not supplied.
       at Microsoft.ResourceManagement.Utilities.ExceptionManager.ThrowException(Exception exception)
       at Microsoft.ResourceManagement.Data.Exception.DataAccessExceptionManager.ThrowException(SqlException innerException, TransactionAndConnectionScope scope)
       at Microsoft.ResourceManagement.Data.DataAccess.GetDomainConfigurationIdentifiersFromDomain(String domainName)
       at Microsoft.ResourceManagement.ActionProcessor.DomainConfigurationActionProcessor.AddDomainConfigurationFromDomain(CreateRequestParameter domainNameParameter, RequestType request)
       at Microsoft.ResourceManagement.ActionProcessor.DomainConfigurationActionProcessor.DoRequestCreationPreProcessByAttribute(RequestType request)
       at Microsoft.ResourceManagement.ActionProcessor.ActionDispatcher.DoRequestCreationPreProcessByAttribute(RequestType request)
       at Microsoft.ResourceManagement.WebServices.RequestDispatcher.CreateRequest(UniqueIdentifier requestor, UniqueIdentifier targetIdentifier, OperationType operation, String businessJustification, List`1 requestParameters, CultureInfo locale, Boolean isChildRequest, Guid cause, Boolean doEvaluation, Nullable`1 serviceId, Nullable`1 servicePartitionId, UniqueId messageIdentifier, UniqueIdentifier requestContextIdentifier, Boolean maintenanceMode)
       at Microsoft.ResourceManagement.WebServices.ResourceManagementService.Put(Message request)
       --- End of inner exception stack trace ---</FailureMessage><DispatchRequestFailureSource>Other</DispatchRequestFailureSource><AdditionalTextDetails>Request could not be dispatched.</AdditionalTextDetails></DispatchRequestAdministratorDetails><CorrelationId>d70ac3fc-6a00-4c6d-b369-e481bebab642</CorrelationId></DispatchRequestFailures>

    mercoledì 3 gennaio 2018 11:52

Tutte le risposte

  • Hi!

    Did you make a correct MIM MA flow (domain -> domain)?

    as writed here:

    https://docs.microsoft.com/en-us/microsoft-identity-manager/install-mim-sync-ad-service


    1

    mercoledì 3 gennaio 2018 13:19
  • Hi,

    Yes, I did. Just checked it again.

    Also the Inbound Sync Rule in the MIM portal has "domainname" => domain under "Inbound Attribute Flow" per the doc.

    f.

    mercoledì 3 gennaio 2018 13:33
  • Is your account in MIM scope?

    https://social.technet.microsoft.com/Forums/en-US/147d7c56-a9cd-4ae5-ac29-130cead782ce/fim-export-fails-fault-reason-the-endpoint-could-not-dispatch-the-request-fim-account-issue?forum=ilm2


    1

    mercoledì 3 gennaio 2018 13:46
  • Yes. The scope is the entire domain (unless there's a default filter that I can't see.)

    I can also see the MA account in the metaverse.

    mercoledì 3 gennaio 2018 13:52
  • Bump!

    Does anyone have another idea?

    venerdì 5 gennaio 2018 15:07
  • Did you ever figure this out?

    If it answered your question, remember to “Mark as Answer”.

    If you found this post helpful, please “Vote as Helpful”.


    Take a look at these checklist to aid you in your AD DS work
    Active Directory Migration Checklist
    Active Directory Domain Deployment Checklist
    Active Directory Domain Discovery Checklist

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchant ability and/or fitness for a particular purpose.

    mercoledì 4 luglio 2018 12:37
  • Hi all

    I have exactly the same issue and I have performed and checked all the steps of this questions' answers. 

    FergusStrachan have you figured it out?

    Anyone else?


    Cheers,
    Pantelis Apostolidis
    My blog: Apostolidis IT Corner | Twitter: @papostolidis | Linkedin: papostolidis

    -------------------------------------------------------------------------------------------------------------------------
    Do click on Mark as Answer on the post that helps you, this can be beneficial to other community members.

    domenica 17 febbraio 2019 19:12
  • Hi,

    Generally the error indicated that "domain" is missing on the object being created, as noted above.

    Could you check Pending Exports towards MIMMA/FIMMA?

    Br,

    Leo


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    lunedì 18 febbraio 2019 08:10