locked
Can I turn off the event logging for TermServDevices Event ID 1111 driver required for printer? RRS feed

  • Domanda

  • Every time I remote into my servers, I get a dozen TermServDevices Event ID 1111 errors stating that Driver "printer" required for printer "printer" is unknown.  I know why I'm getting these, but I'd like to turn them off.  They make my DCDIAG test fail due to errors in the even logs, clutter my event logs, and just bug me.  I have one of my printers setup on the server and I print to that one without a problem, but every other printer incluing the XML printer, PDF printer, quicken printer, quickbooks printer, etc fails.  I'd rather just not log these as they are really just informational.  Is there a way to turn the logging off for this part of RDP without disabling the remote printing all together?  I've already tried turning of the print queue error messages and that did not help.

    Thanks,

    Jeff


    venerdì 23 dicembre 2011 21:00

Risposte

  • Hi Jeff,

    Suggestions:

    1. Enable the TS fallback printer driver on the server using gpedit.msc.  This will change the behavior so that when a driver is not found it will use the fallback driver instead.  You will see warning entries from TermServDevices instead of errors.

    2. Create a print mapping file with entries for each one of the printers that do not have a corresponding driver installed on the server.  You could point them to HP LaserJet 4.  That way all of your printers will be auto-created and thus no error or warning entries in the log.  See below for instructions on creating the file and necessary reg entries:

    Windows 2000 or Windows Server 2003 Terminal Services server logs events 1111, 1105, and 1106

    http://support.microsoft.com/kb/239088

    3. Configure your local client user so that it will only map the default printer and make sure the one printer you use is set as default.  To do this you will need to make a registry entry on the client:

    HKCU\SOFTWARE\Microsoft\Terminal Server Client\Default\AddIns\RDPDR

    RedirectDefaultPrinterOnly     REG_DWORD     0x00000001

    -TP

    venerdì 23 dicembre 2011 22:57

Tutte le risposte

  • Hi Jeff,

    Suggestions:

    1. Enable the TS fallback printer driver on the server using gpedit.msc.  This will change the behavior so that when a driver is not found it will use the fallback driver instead.  You will see warning entries from TermServDevices instead of errors.

    2. Create a print mapping file with entries for each one of the printers that do not have a corresponding driver installed on the server.  You could point them to HP LaserJet 4.  That way all of your printers will be auto-created and thus no error or warning entries in the log.  See below for instructions on creating the file and necessary reg entries:

    Windows 2000 or Windows Server 2003 Terminal Services server logs events 1111, 1105, and 1106

    http://support.microsoft.com/kb/239088

    3. Configure your local client user so that it will only map the default printer and make sure the one printer you use is set as default.  To do this you will need to make a registry entry on the client:

    HKCU\SOFTWARE\Microsoft\Terminal Server Client\Default\AddIns\RDPDR

    RedirectDefaultPrinterOnly     REG_DWORD     0x00000001

    -TP

    venerdì 23 dicembre 2011 22:57
  • Hi,

    Looking forward to your feedback.


    Technology changes life……
    giovedì 5 gennaio 2012 18:57