none
script automatico alla disconnessione windows 10 RRS feed

  • Domanda

  • Buongiorno a tutti, 

    dovrei impostare per utente l'apertura di una pagina web nel momento in cui viene effettuata la disconnessione. 

    Vi spiego come è sorta la problematica, fino a poco adesso su tutti i client windows 7 64 bit in dominio lo script è impostato da group policy e funziona regolarmente ad ogni accesso e disconnessione. Il server master è windows server 2008.

    Su alcuni PC nuovi con windows 10 solo in disconnessione non viene eseguito.

    Ho provato ad impostarlo dalle attività pianificate ad ogni evento relativo alla disconnessione ma non funziona, di seguito le condizioni:

     script ("C:\Program Files\Internet Explorer\iexplore.exe")

     attivazione --> REGISTRO SISTEMA - WINLOGN -  ID EVENTO 7002

    Qualcuno  può suggerirmi qualcosa??

    Grazie

     

    lunedì 18 febbraio 2019 14:27

Tutte le risposte

  • Ciao,

    prova a vedere se questo può aiutarti:

    User Config->Policies->Admin Templates->System->Scripts>'Display instructions in logoff scripts as they run'

    Source: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-logoff-script-run-before-log-out/736a706c-8106-4ed6-a9d0-87de4260eabb

    Se non va, esegui un "gpresult /r" come amministratore su uno dei pc che dovrebbe avere la policy, e vediamo se almeno la policy da te creata viene correttamente applicata ai pc.

    Ciao.

      
    lunedì 18 febbraio 2019 16:46
  • purtroppo non riesco a fare eseguire lo script, all'avvio viene (stesso script) viene eseguito regolarmente mentre in fase di disconnessione non funziona.

    Il problema si verifica solo su windows 10 perchè su windows 7 non ho mai avuto problemi.

    Grazie

    giovedì 21 febbraio 2019 13:58
  • Hai letto e provato quanto suggerito nella discussione che ti ho linkato?

    Se non va, esegui un "gpresult /r" come amministratore su uno dei pc che dovrebbe avere la policy, e vediamo se almeno la policy da te creata viene correttamente applicata ai pc.

    Ciao.


    giovedì 21 febbraio 2019 15:53
  • Buon pomeriggio,

    sto riscontrando  sul dominio un problema sui client windows 10 riguardo l'esecuzione di uno script automatico gestito da policy di dominio (accesso e disconnessione). Su windows 7 funziona da sempre senza alcun problema. 

    Sui nuovi client invece con windows 10 viene eseguito lo script al login ma in fase di disconnessione lo stesso (file  e percorso uguali ) non viene eseguito (deve aprire una pagina internet specifica) .

    Qualcuno può aiutarmi?? Non so se sono stato chiaro, sono stato un pò sintetico ma se server posso fornire altre info necessarie.

    Grazie

    giovedì 21 febbraio 2019 16:17
  • Aprire più thread sullo stesso argomento non porta ad un numero maggiore di risposte, inoltre è vietato dal regolamento.
    Hai provato intanto a seguire i suggerimenti di Victor per cercare di capire se la policy viene effettivamente caricata?
    Ti suggerisco inoltre di inserire nello script dei comandi per il debug, ad esempio la scrittura dell'output in un file di testo sul client.
    giovedì 21 febbraio 2019 21:19
    Moderatore
  • Grazie mille, mi scuso per avere creato un nuovo post non era mia intenzione violare il regolamento. Per le prossime volte farò più attenzione.

    Grazie

    venerdì 22 febbraio 2019 08:33
  • Ciao Santo,

    continuo a non capire se hai provato a modificare la policy aggiungendo questa modifica:

    User Config->Policies->Admin Templates->System->Scripts>'Display instructions in logoff scripts as they run'

    Si o no?

    Se la modifica non va, apri il prompt dei comandi Dos COME AMMINISTRATORE su uno dei pc in cui non funziona la policy e digita:

    gpresult /r >> C:\gpresult.txt

    Dentro C: verrà quindi creato un file di test gpresult.txt, copia e posta il contenuto qui.

    Ciao.

    venerdì 22 febbraio 2019 11:31
  • Ciao Santo,

    continuo a non capire se hai provato a modificare la policy aggiungendo questa modifica:

    User Config->Policies->Admin Templates->System->Scripts>'Display instructions in logoff scripts as they run'

    Si o no?

    Se la modifica non va, apri il prompt dei comandi Dos COME AMMINISTRATORE su uno dei pc in cui non funziona la policy e digita:

    gpresult /r >> C:\gpresult.txt

    Dentro C: verrà quindi creato un file di test gpresult.txt, copia e posta il contenuto qui.

    Ciao.

    La policy non l'ho modificata, di seguito il risultato che visualizzo dopo aver lanciato il comando:

    trumento Risultati Criteri di gruppo del sistema operativo 

    Microsoft (R) Windows (R) versione 2.0
    ¸ 2018 Microsoft Corporation. Tutti i diritti sono riservati.

    Creato il ?22/?02/?2019 alle 14:00:28



    Dati RSOP per DOMINIO\santoad su NOMEPC: Modalit… di registrazione
    --------------------------------------------------------------------

    Configurazione SO:           Workstation membro
    Versione SO:                 10.0.17134
    Nome sito:                   Nome-predefinito-primo-sito
    Profilo mobile:             N/D
    Profilo locale:              C:\Users\santoad
    Connesso attraverso 

    un collegamento lento?:      No


    IMPOSTAZIONI COMPUTER
    ----------------------
        CN=ICT08,OU=wsus_test,DC=DOMINIO,DC=it
        Ultima applicazione dei

        criteri di gruppo:                   22/02/2019 in 13:13:31
        Criteri di gruppo applicato da:     nomeserver.capuasrl.it
        Soglia del collegamento lento 

        dei criteri di gruppo:               500 kbps
        Nome dominio:                        nome dominio
        Tipo di dominio:                        Windows 2008 o versione successiva

        Oggetti Criteri di gruppo applicati
        ------------------------------------
            wsus_test
            Criteri gruppo locale

        Il computer fa parte dei seguenti gruppi di sicurezza
        -----------------------------------------------------
            BUILTIN\Administrators
            Everyone
            BUILTIN\Users
            NT AUTHORITY\NETWORK
            NT AUTHORITY\Authenticated Users
            Questa organizzazione
            nomepc$
            Computer del dominio
            Livello obbligatorio di sistema
            

    IMPOSTAZIONI DELL'UTENTE
    -------------------------
        CN=santoad,CN=Users,DC=dominio,DC=it
        Ultima applicazione dei

        criteri di gruppo:                   18/02/2019 in 12:16:24
        Criteri di gruppo applicato da:     IBMX3650.capuasrl.it
        Soglia del collegamento lento 

        dei criteri di gruppo:               500 kbps
        Nome dominio:                        dominio
        Tipo di dominio:                        Windows 2008 o versione successiva
        
        Oggetti Criteri di gruppo applicati
        ------------------------------------
            Criteri gruppo locale

        L'utente fa parte dei seguenti gruppi di sicurezza
        --------------------------------------------------
            Domain Users
            Everyone
            BUILTIN\Users
            BUILTIN\Administrators
            NT AUTHORITY\INTERACTIVE
            ACCESSO CONSOLE
            NT AUTHORITY\Authenticated Users
            Questa organizzazione
            LOCALE
            Campioni
            Proprietari autori criteri di gruppo
            Domain Admins
            Enterprise Admins
            Schema Admins
            Utenti debugger
            Ogg. non autoriz. a replica passw. in controller sola lettura
            Livello obbligatorio alto


    venerdì 22 febbraio 2019 14:12
  • Ciao,

    prova a vedere se questo può aiutarti:

    User Config->Policies->Admin Templates->System->Scripts>'Display instructions in logoff scripts as they run'

    Source: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-logoff-script-run-before-log-out/736a706c-8106-4ed6-a9d0-87de4260eabb

    Se non va, esegui un "gpresult /r" come amministratore su uno dei pc che dovrebbe avere la policy, e vediamo se almeno la policy da te creata viene correttamente applicata ai pc.

    Ciao.

      

    l'ho eseguito, appare la finestra del cmd ma lo script in ogni caso non parte, l'utente si disconnette senza eseguirlo...

    Grazie

    venerdì 22 febbraio 2019 14:40
  • Come si chiama la policy che stai provando ad applicare? Leggo che le uniche policy effettivamente aaplicate (sia a livello di computer che di utente) sono:

    wsus_test
    Criteri gruppo locale

    E' una di queste due sopra che hai modificato per lo script di logoff?

    venerdì 22 febbraio 2019 15:23
  • la cosa strana è che lo stesso script è impostato per il login è parte regolarmente quindi la policy a mio avviso viene presa, è come se in fase di disconnessione windows 10 tronchi immediatamente il processo (si dovrebbe aprire una pagina di internet explorer).

    Abilitando la modifica che mi hai suggerito "User Config->Policies->Admin Templates->System->Scripts>'Display instructions in logoff scripts as they run'"   vedo la finestra del cmd aprirsi ma si disconnette immediatamente

    Grazie

    venerdì 22 febbraio 2019 15:40
  • Ti invito a "contrassegnare come risposta" solo l'intervento che risulta determinante per la risoluzione del problema.
    sabato 23 febbraio 2019 00:23
    Moderatore
  • OK mi scuso, sono nuovo sul forum. 

    Grazie mille

    martedì 5 marzo 2019 15:05