none
Exchange 2010: connettività da outlook fuori sede RRS feed

  • Domanda

  • Ciao a tutti

              volevo sapere se c'è una rapida guida (for dummies) per la configurazione di Exchange 2010 in modo che si possa utilizzare outlook fuori sede...spiego brevemente il mio problema:

    Ho installato exchange 2010 in azienda, l'ho configurato per posta interna ed esterna...funziona tutto alla grande

    Ora però avrei necessità di far collegare alcuni utenti (senza VPN) dai loro client outlook quando sono fuori azienda...quando vado a fare la configurazione su client mi dice che è impossibile connettersi a https://exchange.ufficio.it (indirizzo dell'owa fuori azienda) in quanto non dispongo di un certificato valido

    Io ho installato su un altro server una CA ed ho fatto lo wizard di exchange 2010 per la creazione di un nuovo certificato da assegnare a IIS...esporto la richiesta, genero il certificato dalla CA ed alla fine lo importo in Exchange...dicendo che dev'essere attribuito a IIS

    Installo il certificato su un PC fuori rete nelle autorità di certificazioni attendibili, ma quando vado a visitare OWA continua a dirmi che il sito non è attendibile...inoltre sulla rete interna continua ad apparirmi il messaggio del certificato all'apertura di Outlook (dovuto al fatto che da rete interna non si risolve exchange.ufficio.it)

    Sto letteralmente impazzendo da una settimana...qualcuno riesce ad inviarmi una procedura per aiutarmi a risolvere il mio problema?

    Grazie a tutti

    Alessio Veronese

    martedì 8 marzo 2011 16:05

Risposte

Tutte le risposte

  • Hola Alessio,

    esattamente perchè ti dice che il certificato non è attendibile?
    ci possono essere 3 cause, è importante sapere quela è la causa altrimenti non puoi capire come risolvere il problema.
    sul client hai installato il certificato root o solo quello exchange.ufficio.it?
    con quale indirizzo visiti owa?


    Mitch
    Microsoft Exchange MVP | MCSE | MCTS | MCITP | MCT
    http://blogs.dotnethell.it/mitch
    http://www.windowserver.it
    http://www.windowservers.es

    mercoledì 9 marzo 2011 13:57
  • Ciao e Grazie per la risposta.

    Sul client ho installato il certificato iniziale autogenerato da exchange e ho installato anche quello elaborato successivamente dall'autorità di certificazione.

    Internamente il sito owa ha come indirizzo https://exch.dominio.local/owa mentre esternamente https://exchange.dominio.it/owa

    Quando elaboro e vado ad installare il certificato della CA e da exchange lo attribuisco ad IIS, tutti i client outlook della rete mostrano una richiesta certificato da installare che corrispone all'indirizzo exchange.dominio.it che però dall'interno non viene risolto. Ecco non so nemmeno come spiegarmi!!!! :)

    Se lascio il certificato originario di exchange invece, il client outlook funziona normalmente, ma da esterno non riesco a sincronizzare la posta in quanto mi dice che il certificato per il sito exchange.dominio.it non è valido perchè non trova corrispondenza con EXCHANGE01 (nome server sulla rete interna).

    Mi spiace non riuscire a spiegarmi come si deve...ma non mastico molto bene questi certificati

    Grazie in anticipo


    Alessio Veronese
    giovedì 10 marzo 2011 14:32
  • Hola Alessio,

    dalla lan, il nome exchange.dominio.it  deve essere risolto con l'ip interno del server exchange.
    quindi se questo non avviene devi sistemarlo:
    -nel dns interno crea una zona "exchange.dominio.it" -dentro della nuova zona crei un record A senza nome mettendo la ip interna del server exchange

    adesso controlla quale è l'indirizzo che hai nell'autodiscovery con il comand
    Get-ClientAccessServer
    controlla il parametro AutodiscoverServiceInternalURI dovra essere "https://exchange.dominio.it/autodiscover/autodiscover.xml"

    se questo è ok, dovrebbe funzionare


    Mitch
    Microsoft Exchange MVP | MCSE | MCTS | MCITP | MCT
    http://blogs.dotnethell.it/mitch
    http://www.windowserver.it
    http://www.windowservers.es

    • Contrassegnato come risposta Anca Popa lunedì 14 marzo 2011 07:45
    giovedì 10 marzo 2011 15:06
  • Ciao Alessio,

    In attesa di ulteriori feedback, suppongo che i suggerimenti ricevuti ti sono stati utili e per ora ho segnato la risposta.

    Se hai risolto in altro modo, ti prego di voler condividere la soluzione con la community, in modo che possa essere trovata e utilizzata dagli altri utenti che hanno domande simili.

     

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 14 marzo 2011 07:45