none
Remote Desktop Win2K8 R2 chiusura sessione su disconnessione. RRS feed

  • Discussione generale

  • Ciao,

    sto cercando di risolvere un problema un un Windows Server 2008R2 con servizi Remote Desktop.

    In pratica succede che se per qualsivoglia motivo un client di disconnette dalla propria sessione, questa viene chiusa dopo pochi istante dal server, facendo perdere tutto il lavoro.

    La cosa brutta è che questo Remote Desktop è usato da nostra sede remota e quindi di probabili disconnessioni ce ne sono durante la giornata, con conseguente perdita di lavoro da parte degli utenti.

    L'unica cosa che al momento ho trovato è l'opzione "Rimuovi cartelle temporanee alla chiusura del programma", in Configurazione host sessione Desktop Remoto, abilitata.

    L'ho disabilitata e domani (dopo il riavvio) ne potrà avere riscontro.

    Voi avete qualche suggerimento?

    Grazie in anticipo

    • Tipo modificato Anca Popa martedì 13 agosto 2013 12:27 discussione in corso
    martedì 6 agosto 2013 14:29

Tutte le risposte

  • secondo me il problema potrebbe non essere del sistema operativo ma di connettività che ti cade...se il firewall\router non lavorano correttamente per un qualche motivo ti casca la connessione continuamente...provare a fare una connessione dall'interno o banalmente a mettere su una macchina client di test con rdp attivo e vedere se si comporta uguale? 

    A.

    martedì 6 agosto 2013 16:10
    Moderatore
  • Ciao, cerco di interpretare la tua non domanda...

    Hai delle policy attive che gestiscono i servizi RDS? Se si quali impostazioni hai abilitate.

    Puoi provare ad utilizzare l'impostazione "Set time limit for logoff of RemoteApp sessions"

    Saluti
    Nino

    mercoledì 7 agosto 2013 07:01
    Moderatore
  • Ciao nei RDS controlla se ci sono settati tempi  di disconnessioni per gli utenti inattivi e magari settali piu' alti o li rimuovi

    Saluti

    mercoledì 7 agosto 2013 07:35
  • secondo me il problema potrebbe non essere del sistema operativo ma di connettività che ti cade...se il firewall\router non lavorano correttamente per un qualche motivo ti casca la connessione continuamente...provare a fare una connessione dall'interno o banalmente a mettere su una macchina client di test con rdp attivo e vedere se si comporta uguale? 

    A.


    non sto chiedendo per quale motivo cade la connessione tra client e server, ma solo indicazioni su come far rimanere la sessione terminale attiva e operativa per un tot di tempo utile affinchè per qualsivoglia motivo (caduta di connessione, stanby del thin client, interruzione di energia elettrica per i client) l'utente non perda le operazioni che stava facendo.

    Ad esempio ogni mese vengono eseguito per un'intera giornata i calcoli per le provvigioni, se puta caso, come è capitato ieri, cade la connessione, il server dopo pochi secondi chiude la sessione facendo morire anche le operazioni in essere. Questo non dovrebbe avvenire.

    Sono stato più chiaro adesso?

    mercoledì 7 agosto 2013 08:50
  • vedi qui

    http://serverfault.com/questions/192268/connect-to-existing-remote-desktop-session-when-username-is-already-logged-in


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    non è questo il caso.

    La sessione terminale viene chiusa dal server dopo pchi secondi che il client ha effettuato la disconnessione.

    Attensione: disconnessione e non chiusura della sessione.

    mercoledì 7 agosto 2013 08:52
  • la disconnessione si verifica sia se la connessione è partita da thin client sia da un normale pc ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    mercoledì 7 agosto 2013 09:11
    Moderatore
  • Ciao, cerco di interpretare la tua non domanda...

    Hai delle policy attive che gestiscono i servizi RDS? Se si quali impostazioni hai abilitate.

    Puoi provare ad utilizzare l'impostazione "Set time limit for logoff of RemoteApp sessions"

    Saluti
    Nino

    Si, ci sono delle policy, ma sembra tutto ok.

    Eccole elencate:

    Criterio 'Amm' per la OU 'AmministrazioneRM': Configurazione utente > Modelli Amministrativi > Servizi Terminal > Sessioni:

    1) Imposta limite per le sessioni disconnesse: Attiva | 1 giorno

    2) Consenti la riconnessione solo dal client originale: Attiva

    Abbiamo 3 Remote Desktop Server e solo con questo succede questa eventualità.

    Ho dimenticato di specificare una cosa però e non so se sia più o meno importante:

    questo Remote Desktop Server ha abilitato il reindirizzamento delle cartelle utente su un secondo disco del server. Questo reindirizzamento è parziale in quanto ci si trova in un ambiente AD 2K3.

    mercoledì 7 agosto 2013 09:22
  • Ciao nei RDS controlla se ci sono settati tempi  di disconnessioni per gli utenti inattivi e magari settali piu' alti o li rimuovi

    Saluti


    Criterio 'Amm' per la OU 'AmministrazioneRM': Configurazione utente > Modelli Amministrativi > Servizi Terminal > Sessioni:

    1) Imposta limite per le sessioni disconnesse: Attiva | 1 giorno

    2) Consenti la riconnessione solo dal client originale: Attiva

    mercoledì 7 agosto 2013 09:24
  • la disconnessione si verifica sia se la connessione è partita da thin client sia da un normale pc ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org


    Da qualsivoglia PC o thin client parta la connessione, quando questa viene disconnessa o interrotta (che è la stessa cosa) dopo pchi secondi il server chiude definitivamente la sessione.
    mercoledì 7 agosto 2013 09:28
  • verifica attentamente l'impostazione di questi parametri

    http://technet.microsoft.com/en-us/library/cc754272.aspx


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    mercoledì 7 agosto 2013 09:44
    Moderatore
  • verifica attentamente l'impostazione di questi parametri

    http://technet.microsoft.com/en-us/library/cc754272.aspx


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org


    Guarda le ho verificate e riverificate svariate volte, ma non mi sembra ci sia niente di errato. Ma non è che il problema sta nel fatto che c'è un reindirizzamento delle cartelle utente?
    mercoledì 7 agosto 2013 10:49
  • verifica attentamente l'impostazione di questi parametri

    http://technet.microsoft.com/en-us/library/cc754272.aspx


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org


    Guarda le ho verificate e riverificate svariate volte, ma non mi sembra ci sia niente di errato. Ma non è che il problema sta nel fatto che c'è un reindirizzamento delle cartelle utente?

    provato anche con l'administrator che non ha reindirizzamento. il comportamento del server è sempre uguale.
    mercoledì 7 agosto 2013 10:51
  • guarda controllato, è tutto ok. non ci dovrebbe essere mai la chiusura della sessione.

    Forse però andando direttamente nel registro di sistema potrei avere qualche sorpresa.

    Sai dirmi dove potrei cercare questi valori?

    mercoledì 7 agosto 2013 12:20
  • prova a leggere tutti i suggerimenti in questo thread

    http://community.spiceworks.com/topic/200638-disconnecting-from-remote-desktop-causes-the-computer-to-log-off-user

    forse trovi qualche ispirazione anche per il tuo caso.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    mercoledì 14 agosto 2013 07:27
    Moderatore
  • Ciao a tutti,

    cerco di ravvivare il 3d perchè ad oggi non sono riuscito a risolvere sto maledetto problema, nonostante le abbia provate tutte:

    se posso dare un'altra indicazione nel registro eventi mi ritrovo i seguenti warning quando avviene la disconnessione:

    Il file del Registro di sistema � ancora in uso da altri servizi o applicazioni. Il file verr� scaricato ora. Dopo lo scaricamento i servizi o le applicazioni che stanno utilizzando il file del Registro di sistema potrebbero non funzionare correttamente.  
    
     DETTAGLI - 
     2 user registry handles leaked from \Registry\User\S-1-5-21-1647568672-934609752-3286287868-1143:
    Process 5384 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-1647568672-934609752-3286287868-1143
    Process 428 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-1647568672-934609752-3286287868-1143\Printers\DevModePerUser
    


    venerdì 13 giugno 2014 10:36
  • quello che hai aggiunto non aiuta molto.

    hai verificato bene i timeout di sessione ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 24 giugno 2014 13:54
    Moderatore
  • Guarda, ho definito addirittura la policy di chiusura della sessione per inattività disattivandola. Ho aumentato il timeout, ma le sessioni non smettono di chiudersi pochi secondi dopo essere avvenuta la disconnessione.
    martedì 24 giugno 2014 14:11
  • hai solo questo remote desktop server o ne hai altri per confrontare i comportamenti ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 24 giugno 2014 14:17
    Moderatore
  • 3 Remote Desktop, però il problema lo riscontro solo su questo.

    Considera però che solo su questo ho il redirect (AD Win2K3) delle cartelle utenti su disco aggiuntivo.

    Non so se sia o meno un problema questo.
    martedì 24 giugno 2014 14:34

  • Considera però che solo su questo ho il redirect (AD Win2K3) delle cartelle utenti su disco aggiuntivo.


    visto che questa è l'unica differenza io preverei a rimettere le cartelle utenti sul disco di sistema.

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    mercoledì 25 giugno 2014 07:28
    Moderatore
  • Guarda il problema si verifica anche con utenti che non hanno il Folder Redirect.


    giovedì 26 giugno 2014 08:58
  • Ciao, ma è stata fatta una prova internamente alla struttura? che il problema non risieda in realtà dal un'altra parte (firewall\networking esterno) che disconnette l'utente quando cade la connettività e questo venga visto come una chiusura sessione in realtà...andrebbe fatta una prova da dentro per dentro...per vedere se si comporta uguale...

    A.

    giovedì 26 giugno 2014 09:11
    Moderatore
  • Ho fatto la prova anche all'interno della rete, stesso risultato.
    giovedì 26 giugno 2014 09:27
  • Ma su sto server..quanta roba c'è? perchè scusami se è un anno che siamo su questo thread nel mentre avevo già affiancato un altro server terminal e fatto un po di prove con quello per poi piallare questo qui...un anno mi pare un po troppo...di quanti utenti stiamo parlando?
    giovedì 26 giugno 2014 09:47
    Moderatore
  • Guarda, avrei voluto rifarlo da capo, ma non mi è possibile, ecco perchè sto cercando di risolvere in qualche modo.
    giovedì 26 giugno 2014 12:59
  • in che senso non è possibile? è sempre possibile...se salta ti tocca rifarlo no? cioè, se è un anno che provi a risolverlo...vuol dire o che non impatta così tanto sul lavoro...oppure...che non ha priorità come criticità...almeno metti un'altra macchina terminal a fianco e prova a vedere se fa uguale anche su quella, così capisci se è proprio la macchina e il suo sistema o se invece è la rete e stai cercando nel posto sbagliato...

    A.

    giovedì 26 giugno 2014 13:10
    Moderatore
  • Purtroppo per ragioni non di natura logica e tecnica non posso, almeno al momento, rifare quella macchina, altrimenti l'avrei già rifatta.

    giovedì 26 giugno 2014 13:31