locked
Internet Explorer con connessione proxy non funzionante. RRS feed

  • Domanda

  • Salve,

    ho un problema con un PC dove c'è installato IE7. Siamo in una rete aziendale dove per uscire su internet ci colleghiamo con un proxy (ip e porta). Dal pc  interessato con IE7 si accede a tutti i servizi interni (anche autenticazione in https), ma quando si cerca di uscire verso internet non ci si riesce. Ho installato un altro browser e con questo funziona tutto.

    Non si attiva il servizio di aggiornamento e penso che dovrò installare diversi aggiornamenti manualmente. Prima di far questo volevo sapere se qualcuno ha qualche suggerimento da darmi o se mi conviene cercare di installare IE8 o altro?

    Grazie in anticipo

    venerdì 30 ottobre 2009 08:51

Risposte

  • Un' altra cosa .... ( anche se visto che con l'altro browser funziona, non dovrebbe servire)
    Se da prompt dei comandi esegui

    telnet ip_del_proxy porta

    cosa succede ?

    Altra stupida prova...

    Se immetti come indirizzo http://194.244.5.206 cosa vedi ?

    Il proxy su che  tipo di autenticazione si basa ? Ovvero... ti dovrebbe richiedere una user ed una password oppure no ?
    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience 2008 - 2009
    ITALY Se la risposta ti ha aiutato clicca su Vota come Utile.
    venerdì 30 ottobre 2009 12:39

  • Per quanto riguarda l'autenticazione mi sembra abbia già risposto che il proxy non la richiede anche se, per sicurezza, una azzerata alle credenziali salvate con successivo riavvio del browser io la darei

    Detto questo, mi sento di escludere che si possa trattare di un problema legato al networking dato che, usando un altro browser funziona tutto, a meno che... vedi, IE contrariamente ad altri browser non si limita ad inviare l'URL richiesto al proxy ma PRIMA avvia una query DNS per determinare l'indirizzo dell'host richiesto... ora, se per caso le impostazioni DNS del sistema in questione fossero in qualche modo diverse dal resto dei sistemi (e magari i DNS usati NON permettessero la risoluzione di hosts esterni) la cosa si potrebbe anche spiegare, in tal caso IE tentando la query e non ricevendo risultati ritornerebbe un errore mentre un altro browser invierebbe semplicemente la richiesta HTTP al proxy ricevendone poi risposta

    Per verificare la cosa bisognerebbe aprire un prompt comandi sul sistema "che non funziona" (start -> esegui -> cmd) e quindi immettere il comando

    ipconfig /all

    si dovranno quindi annotare gli indirizzi dei DNS e, dopo aver ripetuto quanto sopra su un PC che "funziona" si dovranno confrontare i valori e, nel caso fossero diversi, impostare i secondi IP DNS nel PC "che non funziona"

    L'unica altra alternativa che mi viene in mente è qualche impostazione GPO "strana", a quel punto IE obbedirebbe alle GPO mentre "l'altro browser" le ignorerebbe totalmente

    venerdì 30 ottobre 2009 15:29

Tutte le risposte

  • http://support.microsoft.com/kb/923737/it
    "Utilizzo della funzionalità Reimposta Internet Explorer".
    Leggi attentamente l'articolo e poi prova a reimpostare IE.

    Considera che l'esecuzione della funzionalità RIES (Reset Internet Explorer Settings) determina la reimpostazione del browser alle impostazioni "di fabbrica" sulla macchina client ma se esistono problemi di connettività (networking) l'operazione potrebbe risultare irrilevante.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    venerdì 30 ottobre 2009 09:04
    Moderatore
  • Grazie per la risposta più che immediata!

    Adesso provo il reset e ti faccio sapere.

    venerdì 30 ottobre 2009 09:13
  • Sistema operativo ? Se XP prova da prompt dei comandi a lanciare il comando

    proxycfg -p indirizzo_ip_del_proxy:porta

    Verifica inoltre che nela TAB Connessione --> LAN sia disabilitata la ricerca automatica delle impostazioni




    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience 2008 - 2009
    ITALY Se la risposta ti ha aiutato clicca su Vota come Utile.
    venerdì 30 ottobre 2009 09:17

  • Qualche richiesta per focalizzare meglio il problema
    (nel caso in cui il reset di IE non funzioni)

    1. hai verificato se le impostazioni proxy del "browser che funziona" e quelle di IE sono identiche ?
    2. Il proxy in questione richiede autenticazione ? Se si, prova a resettare le credenziali salvate in IE
    3. Hai contattato l'admin o comunque chi gestisce il proxy segnalando il problema ? Controllando i logs del proxy potrebbe essere possibile identificare le cause del problema e risolverlo

    ciao

    venerdì 30 ottobre 2009 09:40
  • Ringrazio tutti comunque il problema sussiste!

    Per Vincenzo : il reset non va! Mi resta il proxy settato! ho tolto IE7 e l'ho reinstallato! il problema sussiste! Hoi anche provato a cambiare l'IP e porta, con valori errati ho salvato, riavviato il sistema, e successivamente ho ripristinato i valori corretti. Niente da fare!

    Per Adriano :  il sistema operativo è XP professional. Il comando viene eseguito  e sembra ok; ma se vado nel path di registro di sistema seguente:

    HKEY_LOCAL_MACHINE\
    SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\
    non trovo queste chiavi di registro, anzi mi fermo a Internet Settings.

    Per ObiWan : Le impostazioni del browser che funziona sono identiche a quelle di IE. Il proxy non richiede autenticazione. Sto contattando la persona che gestisce il proxy (è in un altro ufficio) per farmi dare i log, ma penso che prima di lunedì non me li dia.

    Fatemi sapere se avete qualche altra idea mentre aspettiamo i logs.

    Grazie
    venerdì 30 ottobre 2009 12:17
  • Per Adriano :  il sistema operativo è XP professional. Il comando viene eseguito  e sembra ok; ma se vado nel path di registro di sistema seguente:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\
    non trovo queste chiavi di registro, anzi mi fermo a Internet Settings.
    Le impostazioni del proxy non sono sotto local machine ma sotto current user in
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings


    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience 2008 - 2009
    ITALY Se la risposta ti ha aiutato clicca su Vota come Utile.
    venerdì 30 ottobre 2009 12:35
  • Un' altra cosa .... ( anche se visto che con l'altro browser funziona, non dovrebbe servire)
    Se da prompt dei comandi esegui

    telnet ip_del_proxy porta

    cosa succede ?

    Altra stupida prova...

    Se immetti come indirizzo http://194.244.5.206 cosa vedi ?

    Il proxy su che  tipo di autenticazione si basa ? Ovvero... ti dovrebbe richiedere una user ed una password oppure no ?
    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience 2008 - 2009
    ITALY Se la risposta ti ha aiutato clicca su Vota come Utile.
    venerdì 30 ottobre 2009 12:39

  • Per quanto riguarda l'autenticazione mi sembra abbia già risposto che il proxy non la richiede anche se, per sicurezza, una azzerata alle credenziali salvate con successivo riavvio del browser io la darei

    Detto questo, mi sento di escludere che si possa trattare di un problema legato al networking dato che, usando un altro browser funziona tutto, a meno che... vedi, IE contrariamente ad altri browser non si limita ad inviare l'URL richiesto al proxy ma PRIMA avvia una query DNS per determinare l'indirizzo dell'host richiesto... ora, se per caso le impostazioni DNS del sistema in questione fossero in qualche modo diverse dal resto dei sistemi (e magari i DNS usati NON permettessero la risoluzione di hosts esterni) la cosa si potrebbe anche spiegare, in tal caso IE tentando la query e non ricevendo risultati ritornerebbe un errore mentre un altro browser invierebbe semplicemente la richiesta HTTP al proxy ricevendone poi risposta

    Per verificare la cosa bisognerebbe aprire un prompt comandi sul sistema "che non funziona" (start -> esegui -> cmd) e quindi immettere il comando

    ipconfig /all

    si dovranno quindi annotare gli indirizzi dei DNS e, dopo aver ripetuto quanto sopra su un PC che "funziona" si dovranno confrontare i valori e, nel caso fossero diversi, impostare i secondi IP DNS nel PC "che non funziona"

    L'unica altra alternativa che mi viene in mente è qualche impostazione GPO "strana", a quel punto IE obbedirebbe alle GPO mentre "l'altro browser" le ignorerebbe totalmente

    venerdì 30 ottobre 2009 15:29
  • Salve a tutti!
    Purtroppo lunedì mattina sulla macchina incriminata si è guastato il disco fisso e non riesco più ad accedere ne ai dati ne al sistema; sto provando con dei tools per recuperare i dati con il disco attaccato ad un altro sistema, ma non riesco a vedere nulla.

    Non so se questo problema hardware sia collegato al problema di IE7, ma mi sa tanto che il mio problema resterà irrisolto.

    Comunque per informazione, nel periodo interessato circa due giorni tra giovedì e venerdì, i log del proxy dall'IP del pc hanno rilevato soltanto accessi con Mozilla Firefox e non con IE7.

    Se ritenete opportuno chiuderei qui la discussione

    Ciao e grazie a tutti.
    martedì 3 novembre 2009 13:50
  • Salve a tutti!
    Purtroppo lunedì mattina sulla macchina incriminata si è guastato il disco fisso e non riesco più ad accedere ne ai dati ne al sistema; sto provando con dei tools per recuperare i dati con il disco attaccato ad un altro sistema, ma non riesco a vedere nulla.

    Non so se questo problema hardware sia collegato al problema di IE7, ma mi sa tanto che il mio problema resterà irrisolto.

    Comunque per informazione, nel periodo interessato circa due giorni tra giovedì e venerdì, i log del proxy dall'IP del pc hanno rilevato soltanto accessi con Mozilla Firefox e non con IE7.

    Se ritenete opportuno chiuderei qui la discussione

    Ciao e grazie a tutti.

    Chiudiamo qui il thread.
    Ho marcato come "Risposta" gli interventi dei miei colleghi MVP Adriano Arrigo ed Andrea Zenobi perchè ottimi per il troubleshooting del problema specifico.

    Cheers,
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    giovedì 5 novembre 2009 06:00
    Moderatore