none
Problemi IE 11 per installazione certificati .cer e pkcs7 RRS feed

  • Domanda

  • Ciao a tutti,<o:p></o:p>

    Recentemente devo installare su dei computer da 64-bit e su uno da 32-bit con Windows7 e IE 11   due certificati: .cer e .pcks7 . Quando faccio l'installazione va tutto a buon fine...eccetto che per il fatto che invece di finire nella cartella dei certificati "Personale" mi finiscono in tutt' altra cartella , cosa che causa il non funzionamento dei certificati e quindi il mancato accesso ai siti che li richiedono . 

    Avete qualche consiglio a riguardo?

    giovedì 5 maggio 2016 12:19

Risposte

  • in fase di installazione dei certificati non puoi indicare tu in quale cartella dei certificati vuoi che finisca il certificato da installare ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 9 maggio 2016 13:34
    Moderatore
  • Non segna nessun errore nel certificato, anzi:anche il sistema dice che "L'installazione è andata a buon fine" perchè si vede che è particolarmente burlone.; semplicemente non richiede la password ( cosa che dovrebbe fare se l'installazione va a  termine correttamente ) e non si trova il certificato nella cartella "Personale" .E onestamente non l'ho visto da nessun altra parte se non usando la ricerca di certmgr.msc , che paradossalmente lo mostra presente proprio nella cartella "Personale" dei certificati ...ma solo con certmgr.msc
    beh... questo significa che i certificati finiscono nella cartella corretta "Certificati personali" però non hanno come purpose la cifratura delle comunicazioni tra browser client e web server.

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 10 maggio 2016 14:03
    Moderatore

Tutte le risposte

  • in fase di installazione dei certificati non puoi indicare tu in quale cartella dei certificati vuoi che finisca il certificato da installare ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 9 maggio 2016 13:34
    Moderatore
  • Si, per indicarla la indichi ma dopo il sistema ti piazza il certificato dove vuole lui
    lunedì 9 maggio 2016 15:29
  • Forse l'ambito di applicazione di quei certificati specifici è diverso da quello che ti aspetti. In che cartella vanno a finire? Quando l'autenticazione sul sito non funziona riesci a leggere l'errore che viene riscontrato con il certificato? Magari si tratta di una catena di certificazione interrotta o comunque di un errore diverso da quello che pensi.

    lunedì 9 maggio 2016 15:48
  • Non segna nessun errore nel certificato, anzi:anche il sistema dice che "L'installazione è andata a buon fine" perchè si vede che è particolarmente burlone.; semplicemente non richiede la password ( cosa che dovrebbe fare se l'installazione va a  termine correttamente ) e non si trova il certificato nella cartella "Personale" .E onestamente non l'ho visto da nessun altra parte se non usando la ricerca di certmgr.msc , che paradossalmente lo mostra presente proprio nella cartella "Personale" dei certificati ...ma solo con certmgr.msc
    • Modificato Bort5 martedì 10 maggio 2016 13:56
    martedì 10 maggio 2016 13:54
  • Non segna nessun errore nel certificato, anzi:anche il sistema dice che "L'installazione è andata a buon fine" perchè si vede che è particolarmente burlone.; semplicemente non richiede la password ( cosa che dovrebbe fare se l'installazione va a  termine correttamente ) e non si trova il certificato nella cartella "Personale" .E onestamente non l'ho visto da nessun altra parte se non usando la ricerca di certmgr.msc , che paradossalmente lo mostra presente proprio nella cartella "Personale" dei certificati ...ma solo con certmgr.msc
    beh... questo significa che i certificati finiscono nella cartella corretta "Certificati personali" però non hanno come purpose la cifratura delle comunicazioni tra browser client e web server.

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 10 maggio 2016 14:03
    Moderatore
  • Porta pazienza ..non sono così pratico. Avresti qualche consiglio da darmi a riguardo?

    edit: O meglio: capisco cosa intendi , ma non so come cavarmela lo stesso

    • Modificato Bort5 martedì 10 maggio 2016 14:20
    martedì 10 maggio 2016 14:17
  • i certificati chi te li ha dati ?

    se vai a visualizzare le proprietà del certificato , vedi gli scopi per cui è stato emesso ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 10 maggio 2016 14:22
    Moderatore
  • Se ho guardato correttamente gli scopi sono tutti abilitati 
    martedì 10 maggio 2016 14:54
  • chi ha emesso i certificati ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 10 maggio 2016 15:04
    Moderatore
  • questo non lo so dire purtroppo.So solo che devo installarli e il loro formato. Li ho trovati così "pronti"
    martedì 10 maggio 2016 15:09
  • ma li hai trovati dove ? in un luogo pubblico ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    mercoledì 11 maggio 2016 06:54
    Moderatore
  • No, li devo installare per conto di un' altra persona su un altro computer. Per questo non ti so dire che fonte hanno
    mercoledì 11 maggio 2016 14:41
  • dovresti chiedere spiegazioni all'altra persona o fornire maggiori informazioni se questi certificati sono già installati ed utilizzati su un altra macchina, se la root certfication authority padre di questi certificati è installata oppure no, chi è l'emittente di questi certificati, ecc.ecc.

    maggiori dettagli riesci a fornire, più probabile è che riusciamo a trovare una soluzione.


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    giovedì 12 maggio 2016 08:02
    Moderatore
  • su altri pc funziona correttamente ;invece il pc in questione è stato addirittura formattato per cercare di risolvere il problema ma dopo la riformattazione e aggiornamenti ancora non carica i certificati correttamente, nemmeno quello di root certfication authority. Per inciso sono riuscito a vedere che uno di questi certificati ( il .cer) è rilasciato da InfoCert. 


    venerdì 13 maggio 2016 07:39
  • ottime informazioni.

    riesci a dirmi quali sono le principali differenze tra questo pc e gli altri su cui il certificato funziona ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    venerdì 13 maggio 2016 08:43
    Moderatore
  • sia i computer funzionanti e quelli non funzionanti sono pc HP windows 7 pro con l' ultimo service pack a 64 bit presi a 7 mesi di distanza l'uno dall' altro. Differenze grosse non ne vedo
    venerdì 13 maggio 2016 10:18
  • il certificato root della CA è già installato sul pc col problema ?

    prova a seguire qui

    https://www.firma.infocert.it/installazione/certificato3.php


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    venerdì 13 maggio 2016 10:40
    Moderatore
  • eseguita la procedura; adesso il certifcato .cer si vede però nella cartella "Altri utenti"
    venerdì 13 maggio 2016 11:09
  • ok, allora rimuovilo e prova a reinstallarlo indicando tu la cartella in cui deve finire ossia quello dell'utente connesso.


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    venerdì 13 maggio 2016 12:44
    Moderatore
  • fNon mi lasciava eliminare certificati da "Altri Utenti" quindi ho spostato su certmgr.msc il certificato da "Altri Utenti" a "Personale" ( e stranamente me lo segnava già presente lì) ma dopo il cetificato non si vede

    venerdì 13 maggio 2016 15:11
  • rimuovilo nuovamente e reinstallalo usando il wizard ma indicando tu in quale cartella deve finire il certificato e fammi sapere.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 16 maggio 2016 09:34
    Moderatore
  • ho fatto quanto hai scritto per scrupolo, ma onestamente è la procedura che seguo sempre. Avvio il wizard o cliccando due volte sul certificato o installando da certmgr.msc o importandolo da explorer, e sempre selezionando io in che cartella deve finire ("Personale")...e non funziona...
    • Proposto come risposta bruno crespi martedì 3 aprile 2018 13:38
    venerdì 20 maggio 2016 06:59