none
nel pannello settaggio permessi uno user lo si vede con il SID e non con nome RRS feed

  • Domanda

  • Un saluto a tutti,
    su un exchange 2003, dovrei dare una "directory rihgt permission" (un "send as") ad un utente, su una cartella pubblica.
    Dopo aver impostato la permission se torno a controllare noto che quell'utente compare con un sid con "account unknow" (una faccina con un punto di domanda..).
    In queste condizioni il permesso che ho dato, non viene applicato e l'utente non ha il permesso che vorrebbe (in questo caso l'invia per conto di).

    Ho fatto un controllo a livello di permissions di condivisione nel file system e, per esempio, sulla cartella personale di questo utente noto che compare il suo nome senza problemi.
    Sembra che exchange non capisca bene il nome di questo utente passatogli dal dominio.....

    Cosa posso controllare per ripristinare la giusta visualizzazione di quell'utente in exchange nel pannello dei right permission?
    Ripeto che durante l'inserimento dell'utente e nella impostazione del directory right permission compare correttamente,
    poi se si esce e si ritorna nel pannello di impostazione dei directory right permission ecco che compare come accont unknow.
    Sperando di essermi spiegato in modo esaustivo, vi saluto.
    Grazie

    venerdì 1 ottobre 2010 20:45

Risposte

Tutte le risposte

  • Ok, l'ho usato parecchio tempo fa....Non so cosa mi debbo attendere, intanto lo lancio e vedo che risultati mi da, ti farò sapere. Grazie
    domenica 3 ottobre 2010 07:07
  • <!-- [if gte mso 10]> <mce:style>

    Ho lanciato il BPA (ero troppo curioso di vedere cosa mostrava).
    Non mi pare ci sia niente che possa avere relazioni con il problema riscontrato. Ad ogni modo questo è quello che ho ottenuto:

    Item of Severity Errors
    Global incoming message size not set

    Global outgoing message size not set
    “HeapDeCommitFreeBlockThreshold” not set

    Item of Severity Warnings
    Network interface driver file I more than two years old
    Network interface driver file I more than two years old
    Network interface driver file I more than two years old
    Storage driver is more than two years old
    Connector restrictions enabled
    DNS search order is blank
    IMAP4 fast message retrieval
    Virtul memory warning

    Item of Severity Best Practices
    Application log size
    Enable automatic update for message filtering
    Auto debug disabled
    Crash upload logging disabled
    Outlook connection range

    Approfitto per chiederti a questo punto cosa ne pensi dei primi 3 punti:
    forse è meglio dare un limite per l'incoming e l'outgoing (diciamo massimo 50MB? Cosa ne pensi?
    Poi per
    "HeapDeCommitFreeBlockThreshold" pensi sia meglio settarlo come indica? Da dei vantaggi reali aver settato questo valore?

    Hai suggerimenti anche in merito ai warnings e agli item di Best Practices che ho indicato come risultato della scansione del BPA?

    Grazie

    domenica 3 ottobre 2010 08:47
  • Ciao Bob,

    Tra tutti gli avvisi critici questo "DNS search order is blank" mi sembra quello che dovresti controllare per primo.

    Anche se il problema non sembra interdipendente, verifica che il DNS contenga i riferimenti appropriati.

    Come seconda instanza verifichiamo che il SID sia veramente quello dell'utente che scompare. Per questo obiettivo useremo un tool che si chiama sid2user.

    Nel link di seguito trovi un articolo che ne spiega il funzionamento:

    http://www.windowsecurity.com/whitepapers/Windows-Enumeration-USER2SID-SID2USER.html

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposto come risposta Andreagx domenica 3 ottobre 2010 19:12
    • Contrassegnato come risposta Anca Popa lunedì 4 ottobre 2010 20:43
    domenica 3 ottobre 2010 09:13
  • Con il sid2user mi sono reso conto che il sid che vedo potrebbe essere quello di un utente non più presente. Il programma sid2user non riesce a rivelarlo, mentre un sid con un numero in meno e uno in più li rileva. A questo punto ho tolto l'utente di cui vedo il sid e ho reimpostato il mio utente ma questa volta gli ho lasciato directory right full e quindi ho dato apply. Poi sono rientrato nel pannello e ho cambiato le permission con solo il send us e fatto apply. Sono uscito e poi rientrato e ora l'utente compare correttamente e con il solo directory right di send Us. Quindi vediamo se si mantiene ma direi che questa cosa è domata.

    Per il DNS: in effeti questo server exchange è anche isa server (server sbs 2003) e ha 2 schede di rete una verso la lan aziendale e l'altra verso il firewall hardware che poi va su internet. La rete connessa al firewall non ha impostato il DNS ma penso che vada bene così. cosa ne dici?

    Mi fai sapere cosa ne pensi degli altri punti che ti ripeto:
    - è meglio dare un limite per l'incoming e l'outgoing?
    - per
    "HeapDeCommitFreeBlockThreshold" pensi sia meglio settarlo?
    - Hai suggerimenti anche in merito ai warnings e agli item di Best Practices che ho indicato come risultato della scansione del BPA?

    Grazie!

     

     

    domenica 3 ottobre 2010 17:54
  • Ciao Bob,

    Sono contento di sapere che il mio suggerimento ti è stato utile per risolvere il problema.

    In via generale è sempre meglio impostare dei limiti per la grandezza dei messaggi.

    Per il resto degli avvisi, dato che è emerso dal tuo post che si tratta di Small Business Server 2003 e che  è un prodotto indipendente ti suggerisco di eseguire il BPA relativo.

    Puoi effettuarne il download direttamente dal download center:

    Microsoft Windows Small Business Server 2003 Best Practices Analyzer .

    Cerca di risolvere i problemi evidenziati come critici seguendo i suggerimenti del BPA, se dovessi necessitare di ulteriore aiuto ti prego di voler aprire una discussione per ogni singolo problema.

    Certo della tua comprensione, ti ringrazio per il feedback.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    domenica 3 ottobre 2010 18:23
  • Confermo che ora le impostazione di send as per l'utente sono ok e funziona.
    Per il resto farò come dici tu. Debbo verificare che BPA ho installato su quel server ed eventualmente installare quello per sbs.
    Sicuramente avrò bisogno di consigli e mi farò vivo. Grazie ancora
    lunedì 4 ottobre 2010 20:35