none
DNS su Server 2008 STD R2 DC RRS feed

  • Domanda

  • Salve, ho un server 2008 STD R2 come DC con installato DNS. E' l'unico server della rete. Poi ho tre client nel dominio.

    Nella scheda di rete del server ho impostato nel DNS primario l'IP del server e non IP loopback, quindi 192.168.1.50

    Eppure continuo ad avere questi due errori:

    I ERRORE

    Titolo:
    DNS: i server DNS server in Connessione alla rete locale (LAN) devono includere l'indirizzo di loopback, ma non come prima voce.

    Gravità:
    Errore

    Data:
    29/01/2012 17:15:46

    Categoria:
    Configurazione

    Problema:
    Nella scheda di rete Connessione alla rete locale (LAN) l'indirizzo IP di loopback non è specificato come server DNS oppure è configurato come prima voce.

    Impatto:
    Se l'indirizzo IP di loopback è la prima voce dell'elenco dei server DNS, Active Directory potrebbe non essere in grado di trovare i partner di replica.

    Risoluzione:
    Configurare le impostazioni della scheda aggiungendo l'indirizzo IP di loopback all'elenco dei server DNS in tutte le interfacce attive, ma non come primo server dell'elenco.

    II ERRORE

    Problema:
    Per Connessione alla rete locale (LAN) è configurato solo il server DNS preferito.

    Impatto:
    L'utilizzo di un unico server DNS per interfaccia non consente le funzionalità di ridondanza e failover. Se il server DNS configurato non è disponibile, il computer non è in grado di risolvere i nomi e di connettersi ad altre risorse.

    Risoluzione:
    Per configurare almeno due server DNS per interfaccia, fare clic sul pulsante Start, scegliere Rete, quindi Centro connessioni di rete e condivisione, infine fare clic su Modifica impostazioni scheda.

    Per quanto riguarda il secondo errore, non avendo un secondo server è normale che mi restituisca l'avviso (warning), ma il primo errore, non so proprio da cosa dipenda. Mi sembra tutto settato Ok.

    Inoltre dai client riesco ad uscire in Internet, cosa che non avviene sul server. Non posso visualizzare nessuna pagina  web

    res://ieframe.dll/dnserror.htm#

    Grazie

    domenica 29 gennaio 2012 16:30

Risposte

Tutte le risposte

  • beh... non dovrebbe proprio dare questo errore perchè quanto hai fatto è corretto però puoi mettere l'indirizzo di loopback come dns secondario.
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    domenica 29 gennaio 2012 18:38
    Moderatore
  • Ciao Marco, gli errori che hai segnalato derivano da un'analisi effettuata con il Best Practices Analyzer?

    Puoi postare un ipconfig /all sia del server che di un client

     

    Saluti

    Nino

     

    domenica 29 gennaio 2012 21:01
    Moderatore
  • Ciao,

    Rispondo ad Edoardo dicendo che ho provato a mettere l'IP di loopback anche nel secondario, ma continua a darmi i due errori

    che, rispondendo a Nino si presentano solo nell'area di Best Practices Analyzer. Sopra ho solo i messaggio informativi dove riportano l'attesa della replica, se  non ricordo male (che penso non ci sarà non essendoci un server di replica del DNS).

    Purtroppo nei vari tentativi di cercare di visualizzare una qualsiasi pagina web (altro problema che non capisco da dove venga) ho modificato erroneamente il gateway ed ho perso la connessione al server (remoto). Quindi  per ora non posso fare nient'altro che aspettare la mattinata di lunedì per farmi ripristinare la connessione.

    Non mi ritengo un espertissimo, ma di server ne ho installati diversi dalla versione 2000 ad oggi. Questo mi sta dando molti problemi. In 15 gg ho rifatto la rete due volte. La prima si era bloccato completamente il firewall e non c'è stato nessun articolo TN o codici errori risolvibili per riattivarlo, se non la formttazione completa. Ora dopo una settimana, questo problema.

    Ma sto 2008 è affidabile?

    Versioni Enterprise non ho avuto problemi.

    Grazie comunque per ora. Vi aggiorno domani.

    Marco

    domenica 29 gennaio 2012 22:17
  • Ciao,

    Rispondo ad Edoardo dicendo che ho provato a mettere l'IP di loopback anche nel secondario, ma continua a darmi i due errori

    che, rispondendo a Nino si presentano solo nell'area di Best Practices Analyzer. Sopra ho solo i messaggio informativi dove riportano l'attesa della replica, se  non ricordo male (che penso non ci sarà non essendoci un server di replica del DNS).

    Purtroppo nei vari tentativi di cercare di visualizzare una qualsiasi pagina web (altro problema che non capisco da dove venga) ho modificato erroneamente il gateway ed ho perso la connessione al server (remoto). Quindi  per ora non posso fare nient'altro che aspettare la mattinata di lunedì per farmi ripristinare la connessione.

    se l'errore te lo da solo il Best Practices Analyzer puoi tranquillamente trascurarlo.

    per quanto riguarda il fatto che tu non riesca a navigare in internet, quando sei riuscito a ricollegarti a quel server controlla di aver configurato i Forwarders sul tuo DNS Server e poi posta l'ipconfig /all del server come suggerito da Nino.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 30 gennaio 2012 07:31
    Moderatore
  • Titolo:
    DNS: i server DNS server in Connessione alla rete locale (LAN) devono includere l'indirizzo di loopback, ma non come prima voce.

    [...]

    Risoluzione:
    Configurare le impostazioni della scheda aggiungendo l'indirizzo IP di loopback all'elenco dei server DNS in tutte le interfacce attive, ma non come primo server dell'elenco.

    Hai IPv6 abilitato sul server ? In caso affermativo, quale indirizzo IP è impostato come DNS in IPv6 :) ?
     

     

    lunedì 30 gennaio 2012 11:34
  • Rispondo ad entrambi.

    Si, l'errore è solo nel Best Practices Analyzer.

    IPv6 è abilitato, ma mi sembra di ricordare che non è impostato nel DNS. Ogni record riferito al server è su IP presente nella scheda (192.168.1.50)

    Non ho ancora avuto tempo e possibilità per ripristinare la connessione.

    Grazie,

    A dopo

    Marco

    lunedì 30 gennaio 2012 11:57
  • IPv6 è abilitato, ma mi sembra di ricordare che non è impostato nel DNS. Ogni record riferito al server è su IP presente nella scheda (192.168.1.50)


     

    Mi hai frainteso; apri le proprietà della scheda di rete, seleziona il protocollo IPv6 e controlla a quale IP punti il DNS nelle impostazioni IPv6; già che ci sei, controlla anche l'elenco dei DNS specificati nelle impostazioni IPv4; considera che se il server ha più schede di rete, dovrai verificarle tutte

    lunedì 30 gennaio 2012 12:00
  • Su IPv6 come DNS preferito (promario) c'è ::1

    Il server ha solo una scheda di rete.

    Ci metto 192.168.1.50 (indirizzo IP del DNS)?

     

    inoltro IPCONFIG

     del server

    C:\>ipconfig /all

    Configurazione IP di Windows

       Nome host . . . . . . . . . . . . . . : serverdc
       Suffisso DNS primario . . . . . . . . : studioxxxxxxxx.local
       Tipo nodo . . . . . . . . . . . . . . : Misto
       Routing IP abilitato. . . . . . . . . : No
       Proxy WINS abilitato . . . . . . . .  : No
       Elenco di ricerca suffissi DNS. . . . : studioxxxxxxxx.local

    Scheda Ethernet Connessione alla rete locale (LAN):

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : HP NC107i PCIe Gigabit Server Adapter

       Indirizzo fisico. . . . . . . . . . . : 08-2E-5F-32-8A-05
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì
       Indirizzo IPv6 locale rispetto al collegamento . : fe80::a580:1e66:4581:db1b%
    11(Preferenziale)
       Indirizzo IPv4. . . . . . . . . . . . : 192.168.1.50(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.0
       Gateway predefinito . . . . . . . . . : 192.168.1.1
       IAID DHCPv6 . . . . . . . . . . . : 235417183
       DUID Client DHCPv6. . . . . . . . : 00-01-00-01-E9-35-3B-EC-08-2E-5F-32-8A-05

       Server DNS . . . . . . . . . . . . .  : ::1
                                               192.168.1.50
       NetBIOS su TCP/IP . . . . . . . . . . : Attivato

    Scheda Tunnel isatap.{AB008701-C0B6-43D2-ADA9-AA4116DE16EB}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

    Scheda Tunnel Teredo Tunneling Pseudo-Interface:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

     di un client

    C:\>ipconfig /all

    Configurazione IP di Windows

       Nome host . . . . . . . . . . . . . . : POSTAZIONE4
       Suffisso DNS primario . . . . . . . . : studioxxxxxxxx.local
       Tipo nodo . . . . . . . . . . . . . . : Misto
       Routing IP abilitato. . . . . . . . . : No
       Proxy WINS abilitato . . . . . . . .  : No
       Elenco di ricerca suffissi DNS. . . . : studioxxxxxxxx.local

    Scheda Ethernet Connessione alla rete locale xxxxxxxx:

       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Controller di rete NVIDIA nForce
       Indirizzo fisico. . . . . . . . . . . : F4-CE-46-EF-CF-D3
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì
       Indirizzo IPv6 locale rispetto al collegamento . : fe80::bc90:7429:24ee:6e0b%
    10(Preferenziale)
       Indirizzo IPv4. . . . . . . . . . . . : 192.168.1.64(Preferenziale)
       Subnet mask . . . . . . . . . . . . . : 255.255.255.0
       Gateway predefinito . . . . . . . . . : 192.168.1.1
       IAID DHCPv6 . . . . . . . . . . . : 250924614
       DUID Client DHCPv6. . . . . . . . : 00-01-00-01-13-72-3B-21-F4-CE-46-EF-CF-D3

       Server DNS . . . . . . . . . . . . .  : 192.168.1.50
       NetBIOS su TCP/IP . . . . . . . . . . : Attivato

    Scheda Tunnel isatap.{0A99DB91-E0A0-45C3-B954-689BCBB11BCA}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

    Scheda Tunnel Teredo Tunneling Pseudo-Interface:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso
       Suffisso DNS specifico per connessione:
       Descrizione . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP abilitato. . . . . . . . . . . . : No
       Configurazione automatica abilitata   : Sì

    Grazie

    Marco

    lunedì 30 gennaio 2012 15:05
  • Su IPv6 come DNS preferito (promario) c'è ::1

    Il server ha solo una scheda di rete.

    Ci metto 192.168.1.50 (indirizzo IP del DNS)?

     

       Server DNS . . . . . . . . . . . . .  : ::1
                                               192.168.1.50

    La causa del "problema" ossia della segnalazione è quella visibile sopra; windows, nel caso in cui siano abilitati sia IPv4 che IPv6 "preferisce" gli indirizzi IPv6 e l'indirizzo IPv6 ::1 equivale a 127.0.0.1 in IPv4 :) a questo punto hai due possibilità; la prima è togliere la spunta da IPv6 nelle impostazioni della scheda di rete; la seconda è sostituire quel ::1 con l'indirizzo IPv6 equivalente, ossia, visto che il server ha indirizzo 192.168.1.50/24 l'equivalente in IPv6 sarà fe80:0:0:0:0:0:c0a8:132 - oppure... potresti anche usare l'indirizzo linklocal mostrato da ipconfig :)

     

    martedì 31 gennaio 2012 07:36
  • Ok, bisogna pensare al futuro!

    Dal momento che nel server il DHCP è disabilitato, e nelle prorpietà IPv6 è impostato come IP ottieni automaticamente ....

    ritengo che debba o abilitare il DHCP o immettere un IPv6 anche lì; giusto?

    Scusami, ma per indirizzo linklocal intendi "Indirizzo IPv6 locale rispetto al collegamento . : fe80::bc90:7429:24ee:6e0b%"


    Grazie

    Marco

    martedì 31 gennaio 2012 10:24
  • Ok, bisogna pensare al futuro!

    Dal momento che nel server il DHCP è disabilitato, e nelle prorpietà IPv6 è impostato come IP ottieni automaticamente ....

    ritengo che debba o abilitare il DHCP o immettere un IPv6 anche lì; giusto?

    Scusami, ma per indirizzo linklocal intendi "Indirizzo IPv6 locale rispetto al collegamento . : fe80::bc90:7429:24ee:6e0b%"

    Si, per indirizzo "linklocal" intendo proprio quello; per quanto riguarda invece l'IP v6, credo che dovresti disabilitare l'uso del DHCP ed impostare un appropriato indirizzo; allo scopo potresti usare questo tool online (o questo) per convertire indirizzo e netmask IPv4 in IPv6. Tornando al discorso DHCP, se vuoi utilizzarlo anche sulla LAN, ti converrà valutare l'implementazione di uno scope nel DHCP onde fornire indirizzi IPv6 ai clients; a tale scopo potresti dare un'occhiata qui 

    ciao

     

    martedì 31 gennaio 2012 10:45
  • Secondo me il problema non è IPv6.

    Come prima cosa ho provato a disabilitare il flag su IPv6.

    Se fosse stato il problema sarei stato in grado di navigare, invece nen succede. Impossibile connettersi ad internet.

    Ho fatto delle prove con nslookup e mi risulta tutto ok con la risoluzione di www.google.it (x esempio)

    Dai client invece la navigazione risulta regolare

    E' corretto che nei <parametri radice veda solo a.root-servers.net. ?
    Solitamente sono abituato a vederli tutti.

    Grazie

    Marco

    martedì 31 gennaio 2012 12:36
  • sei sicuro che non sia impostato nel browser un fake proxy per cui riesci a risolvere gli alias ma il browser non naviga ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 31 gennaio 2012 13:29
    Moderatore
  • sei sicuro che non sia impostato nel browser un fake proxy per cui riesci a risolvere gli alias ma il browser non naviga ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org


    GRANDEEEEEEEEEEE!

    Nelle impostazione LAN (Connessioni) non era attivato, ma guardando bene ed attivando il flag Server Proxy, il campo indirizzo era sporco (caratteri non ASCII). Ho cancellato i 4 /5 caratteri e tutto è ripartito.

     

    GRAZIE ANCORA A TUTTI

    Alle prossime a breve

    Marco

    martedì 31 gennaio 2012 13:38
  • beh... grazie per l'entusiasmo e per il feedback, ciao.
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 31 gennaio 2012 14:53
    Moderatore