none
Errore durante l'installazione/disinstallazione di Adobe Reader RRS feed

  • Domanda

  • Salve, nel tentativo di disinstallare Adobe Reader versione 9.3.4 da un server su cui gira Windows Server 2003 SP2 ricevo questo errore:

    E' in esecuzione un'istanza del programma di installazione del prodotto avviata in precedenza. Per continuare, è necessario annullare le modifiche effettuate da tale istanza del programma di installazione. Annullare le modifiche?

    Se clicco su SI, la procedura di disinstallazione resta bloccata per molto tempo (ho atteso anche 15 minuti) e sono costretto a forzare la chiusura tramite il task manager, mentre se clicco su NO ovviamente si interrompe.

    Probabilmente questo è dovuto ad un precedente aggiornamento dello stesso Adobe Reader non andato a buon fine.

    Il problema è che adesso ricevo lo stesso errore anche quando tento di installare un qualsiasi nuovo programma sul server...

    Cosa posso fare per risolvere il problema?

     

    Grazie...

    Nico Timeo

    mercoledì 20 ottobre 2010 18:19

Risposte

Tutte le risposte

  • Ciao Nico,

    hai provato a riavviare il server e riprovato a disinstallare Adobe?

    Se no prova ad installare nuovamente Adobe, dagli l'opzione "Ripara" e poi disinstallalo.

    Fammi sapere

    Saluti

    mercoledì 20 ottobre 2010 18:22
  • Ciao Fabio, grazie per la cortese risposta.

    Ovviamente avevo già provato a riavviare il server diverse volte... ho fatto anche un passaggio di "Pulizia Disco" eliminando file temporanei, tutto senza risolvere il problema.

    Purtroppo al momento sul server non ho un file di installazione di Adobe Reader, ma nel menu "?" dell'applicazione c'è la voce "Ripara installazione di Adobe Reader" che ho provato ad eseguire, ma il problema persiste ugualmente...

    Ripeto, lo stesso errore lo ricevo anche quando tento di installare altri programmi!

    mercoledì 20 ottobre 2010 19:40
  • Scusa per la risposta che ti ho dato in riferimento al riavvio!

    Si magari risolvendo il problema ad Adobe si poteva riparare qualche problema in questione.

    Dal registro eventi ti dice qualche errore?

    Se ti da l'errore 1721 prova questa soluzione:

    http://support.microsoft.com/kb/891985/it

    Fammi sapere

    Ciao

    mercoledì 20 ottobre 2010 19:48
  • (ripeto il post con il login corretto)

    nel task manager, nei processi, non ce n'è nessuno che fa riferimento a questa fantomatica installazione?

    Neppure nel menù avvio o processi che trovi in msconfig?

    Hai provato avviare in modalità provvisoria ed disinstallare il reader?


    Adriano Mariolini MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]my.sysadmin.it
    giovedì 21 ottobre 2010 07:24
  • Ciao! ti consiglio di provare REVO UNINSTALLER FREE.

    Rimuovi Adobe reader con quello facendo la pulizia dei files e dei registri, poi riavvia e vedrai che è tutto a posto.

    Ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    giovedì 21 ottobre 2010 09:22
  • Puoi utilizzare l'utilità di pulitura di Windows Installer

    http://support.microsoft.com/kb/290301

    seguendo le indicazioni in questo thread

    http://social.answers.microsoft.com/Forums/en-US/vistaprograms/thread/4f7f25a8-a7e2-444d-9a4e-7ebdfea91fe5

    1. Download and install the Windows Installer Cleanup Utility from the link below:
    http://support.microsoft.com/kb/290301
    2. After installing Windows Installer Cleanup Utility, click on start, click on All Programs and then click on Windows Installer Cleanup Utility.
    3. Select Adobe Acrobat Reader.
    4. Click on Remove.
    5. After removing Adobe Acrobat Reader, restart the computer once.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 21 ottobre 2010 11:25
  • Ciao Fabrizio, purtroppo il link che mi hai indicato non risolve il mio problema... ecco cosa leggo nella pagina che mi proponi:

    In precedenza questo articolo conteneva un collegamento all'utilità di pulitura di Windows Installer (MSICUU2.exe). Se si è stati indirizzati a questo articolo per risolvere un problema di installazione di un prodotto diverso da Microsoft Office, contattare il produttore del software per il supporto per l'installazione del prodotto.

    Sebbene l'utilità di pulitura di Windows Installer risolvesse alcuni problemi di installazione, a volte danneggiava altri componenti installati nel computer. Per questo, lo strumento è stato rimosso dall'Area download Microsoft. Le soluzioni Fix it in questo articolo forniscono la possibilità di rimuovere completamente la famiglia di prodotti Office 2003, 2007 e 2010 senza danneggiare gli altri componenti di Windows.

     

    In effetti la soluzione proposta sembrava quella giusta! Che dici, provo a cercare ugualmente sul web una vecchia copia di Windows Installer Cleanup Utility?

     

    giovedì 21 ottobre 2010 14:30
  • Al momento è l'unica soluzione disponibile (tra l'altro, indicata anche nel sito di Adobe).

    Certo, trattandosi di un server, ti consiglio prudenza.

    Il tool è comunque disponibile su diversi siti "terzi".


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 21 ottobre 2010 14:46
  • In effetti la soluzione proposta sembrava quella giusta! Che dici, provo a cercare ugualmente sul web una vecchia copia di Windows Installer Cleanup Utility?


    qui trovi qualche buona indicazione compresa l'utility indicata da Fabrizio

    http://forums.adobe.com/thread/727601?tstart=0


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    giovedì 21 ottobre 2010 16:17
    Moderatore
  • In questa pagina ho trovato la descrizione esatta del mio problema, anche se qui si riferisce a Visio 2002 piuttosto che Adobe Reader:

    http://support.microsoft.com/kb/312308/en-us/

    Ho seguito la procedura ed effettivamente, lasciando da parte Adobe Reader (che mi interessa relativamente...), quando ora cerco di installare la mia applicazione gestionale non ottengo più errori, ma comunque l'installer si "freeza" a metà percorso inspiegabilmente e sono costretto ad annullarla tramite task manager.

    Ho attivato la registrazione del log per Windows Installer ed ho ottenuto un file molto lungo e per certi versi incomprensibile... purtroppo non so come postarlo, magari qualcuno più esperto di me riesce a capire cosa può esserci sotto...

    In questo momento posso accedere al server solo da remoto, eventualmente mi consigliate di provare ad eseguire Windows Installer Cleanup Utility quando sono fisicamente davanti al server?

    venerdì 22 ottobre 2010 08:13
  • Se accedi da remoto in modalita rdp lanciando "mstsc /admin", è come essere fisicamente alla console.

    So di dirti una banalità, ma hai provato a cercare chiavi di registro legate al tuo gestionale (per rimuoverle) e/o a cambiare cartella di installazione.

    Si tratta di "trucchi della nonna" ma talvolta funzionano :-P


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 22 ottobre 2010 08:39
  • Grazie Fabrizio, anche i "trucchi della nonna" sono ben accetti quando non si sa cosa fare! :-)

    Il problema è che devo aggiornare il gestionale su questo server, ma inspiegabilmente il setup non va a termine. Tutto è cominciato con un aggiornamento di Adobe Reader non completato correttamente... secondo me è successo qualcosa con Windows Installer...

    Posso provare a cambiare cartella di installazione e proverò anche a connettermi alla console in modalità amministrativa.

    venerdì 22 ottobre 2010 13:30
  • Se hai il dubbio che l'installer sia danneggiato puoi anche provare a installare l'aggiornamento alla 4.5

    http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=5a58b56f-60b6-4412-95b9-54d056d6f9f4


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 22 ottobre 2010 14:02
  • Ho installato l'aggiornamento alla 4.5 di Windows Installer, ma il problema persiste...

    Se qualcuno volesse, può dare uno sguardo al file di log dell'installazione che linko zippato. Grazie!

     

    P.S. Ho inviato anche una segnalazione alla Software House che produce il programma... se ho novità vi tengo informati!

    lunedì 25 ottobre 2010 09:26
  • Ho installato l'aggiornamento alla 4.5 di Windows Installer, ma il problema persiste...

    Se qualcuno volesse, può dare uno sguardo al file di log dell'installazione che linko zippato. Grazie!

    ma tu hai mandato il log di installazione di Summa... non quello di disinstallazione di acrobat
    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    lunedì 25 ottobre 2010 13:46
    Moderatore
  • Cerco di ricapitolare:

    1) Il mio problema principale è l'installazione del Summa, un gestionale aziendale.

    2) Credo che tutto sia originato da un aggiornamento di Acrobat Reader 9.3.4 non riuscito. Ricordo che l'aggiornamento mesi fa si è "piantato" ed ho dovuto prima annullare e poi chiudere l'installazione con il task manager. Da quel momento non ho più installato applicativi sul Server.

    3) Ora avrei la necessità di installare il Summa. Quando ho provato la prima volta mi è comparso questo errore: "Un'installazione di Acrobat Reader è attualmente sospesa. Bisogna annullare le modifiche per continuare. Annullare le modifiche?" - Io ho risposto di SI. L'installazione del Summa però si è bloccata... esattamente come si bloccò quella di Acrobat Reader mesi prima.

    4) Ho riavviato il Server, ad un nuovo tentativo di installazione del Summa mi è comparso l'errore che ho postato ad inizio di questa discussione, cioè:"E' in esecuzione un'istanza del programma di installazione del prodotto avviata in precedenza. Per continuare, è necessario annullare le modifiche effettuate da tale istanza del programma di installazione. Annullare le modifiche?" - Anche in questo caso ho risposto di SI.

    5) Seguendo i suggerimenti di questa discussione nel forum ho abilitato i log ed ho aggiornato Windows Installer alla versione 4.5. Il problema persiste ed ho postato il log dell'ultimo tentativo di installazione del Summa.

     

    Spero di aver specificato tutto per bene... purtroppo ho paura di fare mosse azzardate peggiorando la situazione, ecco perché mi rivolgo a voi. Qualche altro suggerimento?

     

    Grazie mille...

     

    lunedì 25 ottobre 2010 15:49
  • All'inizio del log vedo una serie di riferimenti alle group policy, e nella fattispecie alle "software restrinction policy".

    Se sono presenti GPO o policy locali di quel genere, potresti metterle in disable (non basta rimuoverle, devi proprio mettere eventuali valori presenti in disable) e riprovare l'installazione ?


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 26 ottobre 2010 02:33
  • avevo già capito che il problema era nei termini che hai rispiegato.

    cosa succede se tenti di reinstallare Acrobat Reader 9.3.4 nella sua versione originale ?

    che errori ottieni ?


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    martedì 26 ottobre 2010 10:01
    Moderatore
  • Eccomi di nuovo qua... :-)

    Ieri ho provato a disinstallare Adobe Reader 9.3.4 tramite Installazione Applicazioni.
    Quando è partita la disinstallazione mi è comparso questo messaggio:

    Un'istanza del programma di installazione di Summa Azienda I24 v.5.0.2 è correntemente sospesa. Per continuare è necessario annullare le modifiche effettuate da tale istanza del programma di installazione. Annullare le modifiche?

    Ho cliccato SI.

    Anche in questo caso Windows Installer sembra piantarsi, ma questa volta ho atteso molto più del solito e dopo circa 40-50 minuti mi è comparso quest'altro avviso:

    Windows Installer non risponde
    Riprova – Annulla

    Ho cliccato su ANNULLA, ricevendo questo messaggio:

    Errore irreversibile durante l'installazione

    Per chi volesse, è disponibile il log qui: http://www.techpoint.catania.it/download/MSIa7979.LOG.zip

    A questo punto credo sia evidente un problema in Windows Installer (che ho anche provato ad aggiornare alla versione 4.5) che non permette più né la disinstallazione di Adobe Reader, né l'installazione del Summa... :-(

    Sinceramente non ho ancora provato a disabilitare le group policy, come suggerito da Fabrizio Volpe. Vale ancora questo consiglio?
    mercoledì 3 novembre 2010 16:18
  • Sinceramente non ho ancora provato a disabilitare le group policy, come suggerito da Fabrizio Volpe. Vale ancora questo consiglio?


    certo che vale ancora. prova a disabilitare quelle policies.

    ciao.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    mercoledì 3 novembre 2010 16:28
    Moderatore
  • Prova, dal prompt dei comandi, con un gpresult per vedere quali policy vengono applicate.

    Poi, quelle che vuoi escludere le devi configurare si disabled

    Infine, sempre dal prompt, un gpupdate /force per aggiornarle


    Adriano Mariolini MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]my.sysadmin.it
    mercoledì 3 novembre 2010 20:22
  • I suggerimenti non sono "a tempo" :-)

    In compenso questa tua ultima segnalazione mi ha fatto trovare questo articolo

    http://kb2.adobe.com/cps/332/332507.html

    Ovvero, rimuovendo la chiave

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Inprogres

    dovresti poter bypassare le installazioni lasciate "appese".

    Attendo tue nuove.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    mercoledì 3 novembre 2010 22:54
  • Salve a tutti... rieccomi purtroppo con lo stesso problema.

    Dopo aver tentato ogni cosa, sono sempre più convinto che la soluzione radicale sia quella di formattare a malincuore il server!

    Oggi ho voluto provare nuovamente a disinstallare Adobe Reader. Ho iniziato alle 20.51 ed ho ricevuto il messaggio di errore "Windows Installer non risponde" alle 21.30.

    Rileggendo il log di Windows Installer trovo due righe abbastanza indicative:

    MSI (s) (84:80) [20:51:38:607]: Opening Terminal Server registry propogation window.

    MSI (s) (84:5C) [21:29:08:469]: RunEngine wait timed out

    Quindi sembra un problema di timeout! Terminal Server ad un certo punto non risponde ed impedisce la disinstallazione (ma anche l'installazione) dei programmi...

    Chiedo allora disperatamente... qualcuno ha altri suggerimenti da dare?

     

    Grazie!

    martedì 28 dicembre 2010 20:55
  • Ciao.

    Hai provato a rimuovere la chiave di registro che ti ho indicato ?

    Comunque, seguendo questi passaggi, se l'installer è un .msi, dovresti poter creare un log "verbose" dell'installazione, che magari ci diranno di più

    Click on the Start menu, choose Run, type cmd and click OK
    Run this command in the cmd prompt:  reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer" /v Debug /t REG_DWORD /d 7 /f
    Run this command in the cmd prompt:  reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer" /v Logging /t REG_SZ /d voicewarmupx! /f
    Re-run the setup and let it fail one more time
    Go to your temporary folder (go to the Start menu, choose Run, and type %temp%)

    http://blogs.msdn.com/b/astebner/archive/2005/03/29/help-me-help-you-if-you-have-setup-bugs.aspx


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    mercoledì 29 dicembre 2010 03:09
  • Ciao, avevo già provato a rimuovere la chiave di registro, senza successo... Windows Installer comunque si blocca come descritto nel mio post precedente.

    Ho attivato il log verbose ed ho provato a rimuovere Adobe Reader tramite "Installazione Applicazioni", a questo link puoi scaricare il file del log sperando che tu possa trovare qualche indizio interessante! :-)

    Grazie ancora e a presto!

     

    mercoledì 29 dicembre 2010 16:31
  • Risultano una serie di errori (DEBUG: Error 2746) relativamente a C:\WINDOWS\Installer\c64b167.msi

    Sai di cosa di tratta e (a titolo di prova) puoi provare a rimuovere il file dalla cartella ?


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 30 dicembre 2010 09:03
  • Ho spostato il file c64b167.msi dalla cartella C:\WINDOWS\Installer al Desktop ed ho fatto ripartire la disinstallazione... purtroppo con lo stesso risultato.

    Secondo te può essere utile provare a rimuovere e reinstallare il Servizio di Terminal Server?

    martedì 4 gennaio 2011 16:34
  • Ho spostato il file c64b167.msi dalla cartella C:\WINDOWS\Installer al Desktop ed ho fatto ripartire la disinstallazione... purtroppo con lo stesso risultato.

    Secondo te può essere utile provare a rimuovere e reinstallare il Servizio di Terminal Server?


    lascia perdere il terminal server.

    io darei un'occhiata a questo thread

    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/b9e3f3dc-f2c1-473a-9c90-0c88884ddfb8

    e al suo link ossia

    http://social.microsoft.com/Forums/en-US/crm/thread/c4996835-77cd-4421-bc56-74bf29528446

    ciao.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    mercoledì 5 gennaio 2011 07:24
    Moderatore
  • Condivido la risposta di Edoardo : il terminal NON è il problema.
    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    mercoledì 5 gennaio 2011 11:18
  • In mancanza di ulteriori feedback ritengo valida la risposta di Edoardo.

     

    Restiamo a disposizione se il problema fosse ancora non risolto o per conoscere la soluzione eventualmente applicata.


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 15 febbraio 2011 11:04