none
Recuperare exchange da un disco/sistema non più avviabile. RRS feed

Risposte

  • Mi scuso se ho creato disagi.

    Ho capito la causa del problema.
    Un storage inutilizzato, ed ora rimosso, era la casua dello stallo.
    Ora riesco ad associare le cassette postali (e per giorni ho avuto la soluzione davanti agli occhi).
    Ora procederò con Exmerge.

    Grazie a tutti per l'aiuto.
    Vi sono molto grato.
    • Contrassegnato come risposta Anca Popa mercoledì 28 settembre 2011 07:25
    martedì 27 settembre 2011 15:40

Tutte le risposte

  • Salve.
    Dopo uno sbalzo di tensione, la MotherBoard di un server PIII (.....) è andata nei verdi pascoli :-)
    Ho recuperato il disco, PATA, ed ho provato ad inserirlo su un muletto PIV. Il tutto è a 32bit.
    Avvio in modalità provvisoria ma ottengo il messaggio in oggetto con blue screen.
    Ho eseguito una scansione AV, scansione disco - con windows tools - per errori, eventuali fixmbr, tutte con esito negativo, ma non riesco ad avviare lo stesso. Il disco, come passivo è perfettamente leggibile.
    A questo punto non so se il cliente avesse provato a reinstallare il software o se possa essere un tale insieme di variazioni HW, passando dal P3 ad altre macchine, a causare il problema.
    Avreste qualche suggerimento per me?
    Grazie in anticipo.

     

    • Unito Anca Popa martedì 13 settembre 2011 14:45 unito al thread esistente
    mercoledì 7 settembre 2011 17:31
  • se può consolarti ho avuto lo stesso problema io oggi, stesso errore ma SO diverso il mio è un windows server 2000, senza spostare o rimuovere il disco ho inserito il cd di windows sono entrato in console di ripristino e ho lanciato il comando "chkdsk /r" la prima volta mi è fallito al 70% e mi diceva che aveva trovato dei settori con errori irreversibili, testardamente ho lanciato lo stesso comando una seconda volta, ha impiegato moooolto più tempo del primo tentativo ma questa volta è andato a buon fine, il server mi è ripartito e anche tutti i suoi servizi, spero possa esserti utile il mio caso, ciao.
    mercoledì 7 settembre 2011 18:08
  • Domani ti farò sapere :-)
    mercoledì 7 settembre 2011 18:14
  • Dai anche una lettura alla seguente kb http://support.microsoft.com/kb/324103

     

    Saluti

    Nino

    mercoledì 7 settembre 2011 21:13
  • Salve Nino.
    Si, si, ero partto da quella KB prima di scrivere nel Forum e stavo provando alcune soluzioni.
    La rileggerò più a fondo. Vi farò sapere.
    Grazie mille.
    mercoledì 7 settembre 2011 21:22
  • Ottimo, rileggendo il tuo post mi sono reso conto che il disco è accessibile. Potresti prelevare i file generti dal sistema durante la fase di bluescreen per analizzare quale componente crea il problema. Forse riesci a trovare una strada più veloce alla risoluzione del problema.

     

    Saluti

    Nino

    giovedì 8 settembre 2011 05:50
  • Ciao. Dopo

    - ulteriore scansione con bartcd nod32 -> no virus
    - chkdsk -> rilevati errori e corretti.

    Al riavvio sempre schermata blue e sempre lo stesso errore.
    Dove trovo la segnalazione di errore montandolo come passivo su altro pc?

    Grazie in anticipo.

     

    giovedì 8 settembre 2011 10:03
  • tnx. provvedo subito.
    giovedì 8 settembre 2011 10:26
  • Però, scusami l'osservazione : non cercherei un problema disco.

    Stai montando un disco su una motherboard molto diversa da quella originale e l'errore che hai potrebbe essere dovuto a questa "novità".


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    VMware Certified Professional on vSphere 4
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 8 settembre 2011 11:43
  • Che versione di Exchange ? Cluster ?
    Per quanto riguarda AD hai ancora qualcosa o hai perso anche quella ?
    Se sì, puoi reinstallare il server usando opzioni tipo /disasterrecovery (E2K3), /recoverserver (E2K7 standalone), /recoverCMS (E2K7 Cluster).
    Questo tipo di setup "legge" le informazioni dall'oggetto in AD.
    Se hai perso anche AD fai un'installazioni di Exchange da zero.

    I file che ti interessano per il DB recovery sono .edb, .stm, .log e .chk (utile ma non necessario).
    Ricordati che il DB non si monterà se il nome dell'Organizzazione Exchange, dell'Administrative Group non sono identici a quelli precedenti

    Sulla base della versione ti posso trovare una reference.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    giovedì 8 settembre 2011 12:40
  • Ciao
    E' quello che tempo io. Solo che volevo eliminare progressivamente tutte le possibili altre cause! :-)
    Mi rimane solo quello... Non trovo file di dump con data di oggi, il sistema va in crash prima di definire il pagefile.sys e i dump files.
    Solo che non saprei cosa fare /capire come agire. La macchina originale è andata, non ho MB uguali o simili.
    Io mi occupo di networking, e di gestione active directory. Non sono un esperto di recuperi.
    Difatti, per mancanza di adeguata formazione in merito, opero sempre con sistemi RAID, UPS e pezzi di ricambio in caso di rottura di qualche elemento. Si rompe, sostituisco e/o ripristino. :-)

    In questo caso ho un solo disco:

    - scansione antivirus: fatta e negativa;
    - verifica file systems: fatta, chiusa positivamente;
    - ricerca file dump: negativa;
    - tentativo di avvio in modalità provvisoria: negativa;
    - non avendo accesso al sistema non posso lavorare di event.log

    sto cercando di capire come trovare quale componente blocca l'avvio, anche in modalità provvisoria.

     

    giovedì 8 settembre 2011 13:12
  • Non sapendo come è strutturata l'infrastruttura su cui stai operando butto là una provocazione... Recuperare i dati formattare e ricreare l'ambiente da zero non è possibile? A volte il tabularasa porta via meno tempo...

     

    Saluti

    Nino

    giovedì 8 settembre 2011 13:19
  • Grazie mille.
    Exchange 2003 su PDC (no cluster) Windows2003.
    Non so se ho perso l'active Directory.

    Appena pronto (se non mi decapitano prima),  mi faccio sentire.
    Se hai le reference, ti prego di mandarmi il link.

    giovedì 8 settembre 2011 13:28
  • Non saprei più cosa fare.
    Ho letto tutto. Ma il tutto prevede che si riesca ad accedere per avviare dei debug.
    Oppure qualcosa mi sfugge.
    giovedì 8 settembre 2011 13:52
  • Io cercherei di risolvere con una macchina virtuale.

    Se hai un backup puoi cercare di partire da quello per ottenere un hard disk utilizzabile in Hyper V o VMware

    Il tutto senza mettere "a rischio" l'installazione esistente.


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    VMware Certified Professional on vSphere 4
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 8 settembre 2011 13:55
  • Diciamo che AD è facile :-). Hai ancora un DC funzionante ? Se sì, hai AD. Se no, restore di AD da backup o devi rifare tutto da capo.

    Exchange 2003 Disaster Recovery Operation Guide

    Questa è lunga ma copre esaustivamente i vari scenari.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    • Proposto come risposta Anca Popa lunedì 12 settembre 2011 07:24
    • Proposta come risposta annullata Anca Popa martedì 13 settembre 2011 15:15
    giovedì 8 settembre 2011 14:12
  • Ciao,

    Ho proposto la risposta di Gabriele in attesa di ulteriori feedback da superataru.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 12 settembre 2011 07:27
  • Ciao superataru,

    Scusa, hai avuto modo di fare qualche prova, possiamo sapere com'e' andata?

    Grazie in anticipo di qualsiasi aggiornamento,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 13 settembre 2011 07:39
  • Eccomi.  Scusate il ritardo.
    Il proprietario ha optato per una macchina Windows 2008 .... ergo ... se ho letto bene i posts relativi, non c'è modo di installare sopra un Exchange 2003. Sto sbagliando?
    Nel caso dovrei passare al 2007 (come da questa nota: http://support.microsoft.com/kb/948680).

    Si può sempre ricorrere ad un tool di importazione o devo importarlo su un altro exchange 2003 attivo?

    Sono frustrato. Vi ringrazio per la pazienza.

    martedì 13 settembre 2011 09:08
  • http://technet.microsoft.com/en-us/library/cc164322(EXCHG.65).aspx per i riquisiti del 2003.

    http://www.edb-pst-converter.com/?gclid=CO7L5qmsmqsCFYK-zAodun-Anw per l'export dei pst pe importare i pst con exchange 2007 puoi farlo dalla console, su exchange 2003 puoi usare exmerge


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    martedì 13 settembre 2011 13:40
    Moderatore
  • Grazie mille.
    Il mio grosso problema è che parto da un disco che ha solo le cartelle di exchange 2003 ... ma nessun file .pst.

    Peggio di così ... :-)

    martedì 13 settembre 2011 14:17
  • Salve.
    Come da post http://social.technet.microsoft.com/Forums/it-IT/windowsserverit/thread/e8a08bcf-03b4-4f4f-a9a7-39e2af46e219, mi sto avviando a dover rimettere in piedi un exchange da un disco leggibile ma non avviabile di un Windows 2003 Server, controller di dominio.

    Come fare ad importare l'exchange da questo disco su un nuovo server? Non ho backup.
    Bastano solo le cartelle di exchange con i relativi db e log? Esiste un how-to?
    Grazie per le eventuali informazioni.

    Prima di tutto, credo che non sia una buona idea aprire un'altra discussione relativa allo stesso topic; sarebbe, secondo me, una buona idea, unire le due discussioni in questo gruppo (visto che la problematica principale sembra essere proprio Exchange) evitando di disperdere il tutto

    Detto questo

    Hai provato a seguire il suggerimento di Fabrizio Volpe e convertire il disco (i vari volumi dello stesso) in uno o più "virtual disks" usando tools come ad esempio questo e poi avviando il sistema all'interno di una VirtualMachine ?

    Vedi, considerando che, a quanto sembra, il disco è leggibile anche se l'OS non si avvia, usando un approccio del genere, potresti essere in grado di riparare (nella VM) il sistema danneggiato riuscendo ad avviarlo ed a procedere ad una migrazione "pulita" dei dati; sinceramente si tratta di un tentativo che mi sentirei di suggerirti dato che, in caso di successo, ti permetterebbe di recuperare tutti i dati e tutte le impostazioni

     

    martedì 13 settembre 2011 14:41
  • Prima di tutto, credo che non sia una buona idea aprire un'altra discussione relativa allo stesso topic; sarebbe, secondo me, una buona idea, unire le due discussioni in questo gruppo (visto che la problematica principale sembra essere proprio Exchange) evitando di disperdere il tutto 

    Ciao,

    Come accennato da Obi, ho sintetizzato il tutto nel forum di Exchange. (Vi invito a proseguire la discussione su questa pagina.)

    Grazie a tutti dell'interessamento,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 13 settembre 2011 14:50

  • Come accennato da Obi, ho sintetizzato il tutto nel forum di Exchange. (Vi invito a proseguire la discussione su questa pagina.)


    Grazie Anca; credo che in questo modo l'intero topic possa essere più chiaro e la discussione relativa allo stesso possa essere più utile a chiunque la leggerà.

     

    martedì 13 settembre 2011 15:02
  • Mi sa che una migrazione "pulita" sia ormai un miraggio :-(

    Installare un Exchange 2003 (con schema etc...) solo per fare un mvoe-mailbox diventa un macello (ammesso che ci siano delle mailbox da muovere in termini di oggetti AD)

    1. Crea la VM
    2. Falla diventare un DC poi installa Exchange 2003 e i vari SP
    3. Il nome della Foresta e dell'Admin Group devono essere quelli della precedente organizzazione
    4. Usa eseutil per fare il replay dei log sul DB e poi montalo
    5. esporta in PST
    6. importa nel nuovo ambiente

    Alternativa: Comprati un tool che faccia il ripristino dei dati dandogli in pasto i file del DB (i.e. Ontrack PowerControls)

    Come detto da SuperAtaru il proprietario ha optato per una macchina 2008. Dato che non si può avere la botte piena e la moglie ubriaca :-) sarà meglio che si installi un Exchange 2010 "pulito" senza mettersi a sporcare AD con un 2003 che starà su per 2 ore.

    Ciao

    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    martedì 13 settembre 2011 15:13
  • Grazie a tutti. Proverò tutto quello scritto.
    Avevo aperto due 3D perchè speravo
    1) di recuperare il disco - ed il punto due non sarebbe stato essenziale.
    2) in caso contrario capire come gestire l'alternativa, nel caso mi ricapitasse.

    Solo per quello. Comunque deduco che sono inguaiato!

    martedì 13 settembre 2011 15:59
  • Mi sa che una migrazione "pulita" sia ormai un miraggio :-(

    Installare un Exchange 2003 (con schema etc...) solo per fare un mvoe-mailbox diventa un macello (ammesso che ci siano delle mailbox da muovere in termini di oggetti AD)

    1. Crea la VM
    2. Falla diventare un DC poi installa Exchange 2003 e i vari SP
    3. Il nome della Foresta e dell'Admin Group devono essere quelli della precedente organizzazione
    4. Usa eseutil per fare il replay dei log sul DB e poi montalo
    5. esporta in PST
    6. importa nel nuovo ambiente

    Alternativa: Comprati un tool che faccia il ripristino dei dati dandogli in pasto i file del DB (i.e. Ontrack PowerControls)

    Come detto da SuperAtaru il proprietario ha optato per una macchina 2008. Dato che non si può avere la botte piena e la moglie ubriaca :-) sarà meglio che si installi un Exchange 2010 "pulito" senza mettersi a sporcare AD con un 2003 che starà su per 2 ore.

    Ciao

    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"

    Gabriele.
    Ho creato la Macchina Virtuale, Windows 2003 SP2 e sono pronto a reinstallere Exchange 2003.

    L'utente aveva una struttura di questo tipo (credo che abbia aggiunto un gruppo nel tempo):

    - c:\Programmi\Exchsrvr (con all'interno tutte le cartelle, da address -> srsdata - tranne log)
      unica cartella con file modificati di recente Programmi\Exchsrvr\mtadata

    - d:\DBOutlook con all'interno (mdbdata, log, priv1.mdb, priv1.stm)

    La riproduco in maniera identica?

    Grazie in anticipo.
    mercoledì 14 settembre 2011 09:41
  • Mi hanno dato un disco nel quale è presente un backup nt!!!
    E' abbastanza recente e sembra integro.
    Vado ad eseguire il ripristino ed ottengo un errore:

    ================================================================
    Stato: ripristino
    Operazione: ripristino

    Backup di "SERVER2003\Microsoft Information Store\Primo gruppo di archiviazione", Ripristinato a "SERVER2003\Microsoft Information Store\Primo gruppo di archiviazione"
    Set di backup #1 sul supporto #1
    Descrizione backup: "Set creato il 18/03/2009 alle 18.21"

    Ripristino avviato il 14/09/2011 alle 17.57.
    Impossibile ripristinare i dati di Exchange su SERVER2003\Microsoft Information Store\Primo gruppo di archiviazione.
    Per ulteriori informazioni, controllare il registro applicazione.
    Ripristino completato il 14/09/2011 alle 17.57.
    Directory: 0
    File: 0
    Byte: 0
    Durata:  1 secondi

    ================================================================

    Avete qualche idea?

    mercoledì 14 settembre 2011 16:02
  • Direi di consultare l'Application Log :-)

    Il DB destinazione è smontato ?

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    mercoledì 14 settembre 2011 17:56
  • Non è necessario riprodurla in maniera identica.

    Basta che i percorsi impostati sui DB e sugli Storage Group siano quelli corretti.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    mercoledì 14 settembre 2011 17:58
  • Ciao.
    Si, io ho disinstallato gli archivi cassette e pubblico. Avvio NTbackup-ripristino, cercando di sovrascrivere l'archivio.
    A livello di Event, trovo, senza che ci sia una spiegazione sui link proposti sul sito MS, quello più in basso.
    Ho sperato che questo provvidenziale file di backup del 04/09, che risultava integro, potesse essere utile.

    Eppure ho creato una macchina con stesso nome, stesso dominio, l'archivio primario è identico.
    ========================================
    Tipo evento: Errore
    Origine evento: ESE BACKUP
    Categoria evento: Richiamata
    ID evento: 904
    Data:  15/09/2011
    Ora:  9.06.53
    Utente:  N/D
    Computer: SERVER2003
    Descrizione:
    Information Store (2608) Chiamata ErrESECBRestoreGetDestination della funzione di richiamata conclusa con errore 0xC7FE1F46 Database non riscrivibile da un ripristino.
    ===================================


    Tipo evento: Errore
    Origine evento: MSExchangeIS
    Categoria evento: Ripristino backup di Exchange
    ID evento: 9635
    Data:  15/09/2011
    Ora:  9.06.53
    Utente:  N/D
    Computer: SERVER2003
    Descrizione:
    Impossibile trovare un database da utilizzare per il ripristino da Microsoft Active Directory.
     Gruppo di archiviazione specificato nel supporto di backup: 42d5e969-4005-4857-b23e-ce14f980fdda.
     Database specificato nel supporto di backup: Archivio cartella pubblica (SERVER2003). Errore: 0xc7fe1f46.

    ===================================
    Tipo evento: Errore
    Origine evento: NTBackup
    Categoria evento: Nessuno
    ID evento: 8003
    Data:  15/09/2011
    Ora:  9.06.53
    Utente:  N/D
    Computer: SERVER2003
    Descrizione:
    Fine ripristino su 'SERVER2003\Microsoft Information Store\Primo gruppo di archiviazione' 'Non riuscito'

    Verifica:  Off 
     
    ===================================
    Tipo evento: Errore
    Origine evento: NTBackup
    Categoria evento: Nessuno
    ID evento: 8019
    Data:  15/09/2011
    Ora:  9.06.53
    Utente:  N/D
    Computer: SERVER2003
    Descrizione:
    Fine operazione: Si sono verificati avvisi o errori.
    Per ulteriori dettagli, consultare il Rapporto di backup.

    ===================================

    Ho provato anche a creare un nuovo archivio e reinderizzarlo sulle cartelle mbdata copiate dal disco originale.
    Ma ogni volta mi dice che l'indice esiste già, oppure esiste già il file.

    LA DIRECTORY SPECIFICATA CONTIENE GIA' UN FILE CON LO STESSO PREFISSO
    a livello del registro transazioni. Viene invece accettata come Percorso di sistema

     


    Non ho capito se lo devo creare primo e poi sostituire i file (diciamo edb, stm etc   ...) Ma per i log come fare?
    Sto cercando di capire come usare esutil, ma francamente, con la mia formazione in merito ....




    • Modificato superataru giovedì 15 settembre 2011 09:09 aggiunte
    giovedì 15 settembre 2011 07:34
  • Quella di creare un nuovo SG è forse la soluzione più semplice ma non mettiamo il carro davantri ai buoi.

    Prima devi rendere il DB consistente :-) (altrimenti chi lo monta più)

    Fai una copia dei file e mettili tutti (edb, stm, log) nella stessa cartella (ad eccezione del file .chk).

    Esegui eseutil /ml E0x (E0x dipende dal suffisso sui file di log)

    Questo dovrebbe verificare la presenza di log corrotti o mancanti. Se non si sono problemi esegui

    eseutil /r E0x /i /d

    Vedi http://technet.microsoft.com/it-it/library/aa998074(EXCHG.65).aspx come reference.

    Per verificare se tutto va a buon fine esegui:

    eseutil /mh [nomefile.edb]

    All'interno dell'output dovresti trovare qualcosa come State: Clean Shutdown. Se non lo trovi posta ancora

    Se è in Clean Shutdown puoi mettere mettere i file al loro posto solo dopo aver creato gli oggetti e le cartelle (altrimenti salta fuori l'errore che segnali).
    In aggiunta a questo metti il flag su "This Database can be overwritten by a restore" (Proprietà del DB->Tab Database)

    IMPORTANTE: Tieniti una copia dei file a portata di mano. Se sbagli qualcosa con eseutil non puoi tornare indietro e non vorrei farti ripristinare i file da zero.

    l'export dei dati lo puoi fare con exmerge.

    Ciao
    Gabriele

     


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    giovedì 15 settembre 2011 20:59
  •  Dio ti benedica Gabriele!  Ecco lo stato dell'arte della verifica.



    D:\>D:\Programmi\Exchsrvr\bin\eseutil.exe /ml E00

    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...

    Verifying log files...
         Base name: E00

    No damaged log files were found.

    Operation completed successfully in 1.422 seconds.

    --------------------------------------------------------------------
    Ho due file nella cartella mdbdata (priv2.edb e priv1.edb)

     

    D:\DataBaseOutlook\mdbdata>D:\Programmi\Exchsrvr\bin\eseutil.exe /mh priv2.edb

    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: priv2.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,11
     Engine ulVersion: 0x620,11
    Created ulVersion: 0x620,11
         DB Signature: Create time:04/28/2009 18:25:55 Rand:678901420 Computer:
             cbDbPage: 4096
               dbtime: 52439711 (0x3202a9f)
                State: Dirty Shutdown
         Log Required: 19741-19741 (0x4d1d-0x4d1d)
       Streaming File: Yes
             Shadowed: Yes
           Last Objid: 27602
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x4D14,2679,9A)  09/05/2011 15:41:27
          Last Attach: (0x4D14,267B,96)  09/05/2011 15:41:31
          Last Detach: (0x0,0,0)  00/00/1900 00:00:00
                 Dbid: 3
        Log Signature: Create time:01/20/2005 12:31:23 Rand:11307452 Computer:
           OS Version: (5.2.3790 SP 2)

    Previous Full Backup:
            Log Gen: 19728-19728 (0x4d10-0x4d10)
               Mark: (0x4D10,1F17,115)
               Mark: 09/04/2011 03:01:14

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 3.94 seconds.


    D:\DataBaseOutlook\mdbdata>D:\Programmi\Exchsrvr\bin\eseutil.exe /mh priv1.edb

    Microsoft(R) Exchange Server Database Utilities
    Version 6.5
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: priv1.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,11
     Engine ulVersion: 0x620,11
    Created ulVersion: 0x620,11
         DB Signature: Create time:09/08/2009 20:09:52 Rand:418252901 Computer:
             cbDbPage: 4096
               dbtime: 1465205 (0x165b75)
                State: Dirty Shutdown
         Log Required: 19741-19741 (0x4d1d-0x4d1d)
       Streaming File: Yes
             Shadowed: Yes
           Last Objid: 786
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x4D14,2679,9A)  09/05/2011 15:41:27
          Last Attach: (0x4D14,267A,1CF)  09/05/2011 15:41:31
          Last Detach: (0x0,0,0)  00/00/1900 00:00:00
                 Dbid: 2
        Log Signature: Create time:01/20/2005 12:31:23 Rand:11307452 Computer:
           OS Version: (5.2.3790 SP 2)

    Previous Full Backup:
            Log Gen: 19728-19728 (0x4d10-0x4d10)
               Mark: (0x4D10,1F17,115)
               Mark: 09/04/2011 03:01:14

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 3.31 seconds. 

    DIRTY SHOUTDOWN, NON CLEAN...


    • Modificato superataru venerdì 16 settembre 2011 13:14
    venerdì 16 settembre 2011 13:12
  • Vedo che hai trovato il problema del "file not found" ;-)

    IMPORTANTE: Tieniti una copia di priv1.edb o priv2.edb prima di far girare qualsiasi altro comando.
    Il prossimo comando potrebbe incasinare di più le cose e non puoi tornare indietro se va a pallino :-)

    Io aggiungerei la BIN di Exchange ai PATH di Windows (vedi http://technet.microsoft.com/en-us/library/aa997841(EXCHG.65).aspx) per comodità e per semplificare l'uso di eseutil.

    1. Vai nella cartella dove hai priv1.edb e priv2.edb e i log (metticeli tutti per sicurezza anche se in realtà te ne basterebbe uno (Log Required: 19741-19741 (0x4d1d-0x4d1d))
    2. esegui eseutil /r E00 /i /d (Questo applica le transazioni dei log al DB. I parametri /i e /d li usiamo per sicurezza)
    3. Dopo aver fatto il replay dei log ricontrolla con l'MH e dovresti avere "Clean Shutdown"

    Se sono in Clean Shutdown allora sono montabili da Exchange

    Se non lo sono posta il risultato.

    Ciao
    Gabriele

     


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    venerdì 16 settembre 2011 13:26
  • Vedo che hai trovato il problema del "file not found" ;-)

    IMPORTANTE: Tieniti una copia di priv1.edb o priv2.edb prima di far girare qualsiasi altro comando.
    Il prossimo comando potrebbe incasinare di più le cose e non puoi tornare indietro se va a pallino :-)

    Io aggiungerei la BIN di Exchange ai PATH di Windows (vedi http://technet.microsoft.com/en-us/library/aa997841(EXCHG.65).aspx) per comodità e per semplificare l'uso di eseutil.

    1. Vai nella cartella dove hai priv1.edb e priv2.edb e i log (metticeli tutti per sicurezza anche se in realtà te ne basterebbe uno (Log Required: 19741-19741 (0x4d1d-0x4d1d))
    2. esegui eseutil /r E00 /i /d (Questo applica le transazioni dei log al DB. I parametri /i e /d li usiamo per sicurezza)
    3. Dopo aver fatto il replay dei log ricontrolla con l'MH e dovresti avere "Clean Shutdown"

    Se sono in Clean Shutdown allora sono montabili da Exchange

    Se non lo sono posta il risultato.

    Ciao
    Gabriele

     


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"

    Ora danno Clean Shutdown. Alè!!!!
    Ma come li monto? (e non mi mandare a quel paese .... :-) )
    Quando provo a creare una nuova unità di archiviazione mi risponde picche.
    Credo perchè in D:\Programmi\Exchsrvr\MDBDATA (da installazione) esiste già l'ID E00.
    • Modificato superataru venerdì 16 settembre 2011 13:37
    venerdì 16 settembre 2011 13:34
  • Ma come li monto? (e non mi mandare a quel paese .... :-) )

    Non credo che Gabriele ti manderà a "quel paese", al massimo ti manderà il conto :) !

     

    venerdì 16 settembre 2011 13:48
  • Ma come li monto? (e non mi mandare a quel paese .... :-) )

    Non credo che Gabriele ti manderà a "quel paese", al massimo ti manderà il conto :) !

     

    :-))))
    venerdì 16 settembre 2011 13:51
    1. Crea uno Storage Group e dai un percorso per i file di sistema e i log (ad esempio: C:\log)
    2. Crea un DB all'Interno dello Storage Group (ad esempio: C:\DB\priv1.edb)
    3. Crea un altro DB all'interno dello stesso Storage Group (ad esempio: C:\DB\priv2.edb)
    4. NON MONTARE I DB
    5. Vai sulle proprietà del DB e metti il flag "This Database can be overwritten by a restore"
    6. Copia priv1.edb e priv2.edb al loro posto nella cartella C:\DB
    7. Fai il mount del DB
    8. Nella tabella delle mailbox dovresti vederle tutte come disconnesse
    9. Riconnettile

    Dato che i DB sono già in Clean Shutdown non ti serve mettere i log al loro posto

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] Microsoft Certified Master: Exchange 2007 "This posting is provided "AS IS" with no warranties, and confers no rights"
    venerdì 16 settembre 2011 14:08
  • Aggiungo:

    una volta che il tutto sia "andato a posto" fai un bel backup ed  imposta anche un backup schedulato regolarmente, dopodichè...

    25 Avemaria

    110 Pater Noster

    143 Rosari completi

    ego te absolvo

     

    venerdì 16 settembre 2011 14:17
  • Gabriele: grazie infinite.
    Mi metto all'opera.
    Ti farò sapere (spero positivamente).
    venerdì 16 settembre 2011 14:50
  • Aggiungo:

    una volta che il tutto sia "andato a posto" fai un bel backup ed  imposta anche un backup schedulato regolarmente, dopodichè...

    25 Avemaria

    110 Pater Noster

    143 Rosari completi

    ego te absolvo

     

    :-)
    Riferirò ... non lo gestisco io.
    Io spero sempre che NTBackup non mi tradisca ...
    lunedì 19 settembre 2011 08:09
  • Salve,

    ho un problema analogo con SB Server 2000 e relativo Exchange 2000. Il cliente si è fumato il disco di sistema e non ha un backup di sistema valido ma solo quello del gruppo di archiviazione di Exchange e della cartella dei dati condivisi.

    Posso adottare le istruzioni consigliate sopra per ripristinare il backup di Exchange dopo aver reinstallato da zero su un nuovo HD il sistema SB Server 2000 con gli stessi parametri precedenti, compreso la creazione di un nuovo Exchange server vuoto, o AD non mi permetterebbe di fare il restore da un backup fatto da un'altra installazione?

    Grazie in anticipo per l'eventuale risposta.

    Fulvio


    P.S.

    Come è andata con il backup? :-)

    • Modificato fpolicardi martedì 20 settembre 2011 23:39
    martedì 20 settembre 2011 23:38
  • Salve,

    ho un problema analogo con SB Server 2000 e relativo Exchange 2000. Il cliente si è fumato il disco di sistema e non ha un backup di sistema valido ma solo quello del gruppo di archiviazione di Exchange e della cartella dei dati condivisi.

    Posso adottare le istruzioni consigliate sopra per ripristinare il backup di Exchange dopo aver reinstallato da zero su un nuovo HD il sistema SB Server 2000 con gli stessi parametri precedenti, compreso la creazione di un nuovo Exchange server vuoto, o AD non mi permetterebbe di fare il restore da un backup fatto da un'altra installazione?

    Grazie in anticipo per l'eventuale risposta.

    Fulvio


    P.S.

    Come è andata con il backup? :-)

    Io ho installato VMware, Win2003 Std SP2 e Exchange 2003 SP2
    Ho provato a recuperare il file di NTbackup: disastro.
    Ho proceduto come suggerito da Gagriele Tensini (vedere sopra):
    -Database edb recuperati dopo verifica e correzione log 
    -Sono riuscito a montarlo sul gruppo di archiviazione.
    -Vedo tutte le caselle.

    Ora devo riuscire solo a farle connettere, perchè non vengono accettati gli utenti AD cui vorrei attribuire le caselle stesse.
    Quando cerchi di connettere una casella, viene chiesto a quale utente associarlo.
    Dall'apposita form ricerchi gli utenti creati. Non li trova!!!!!!!!!!! 8-)

    Non desisto.
    Vi farò sapere

    giovedì 22 settembre 2011 06:56
  • Salve,

    ho un problema analogo con SB Server 2000 e relativo Exchange 2000. Il cliente si è fumato il disco di sistema e non ha un backup di sistema valido ma solo quello del gruppo di archiviazione di Exchange e della cartella dei dati condivisi.

    Posso adottare le istruzioni consigliate sopra per ripristinare il backup di Exchange dopo aver reinstallato da zero su un nuovo HD il sistema SB Server 2000 con gli stessi parametri precedenti, compreso la creazione di un nuovo Exchange server vuoto, o AD non mi permetterebbe di fare il restore da un backup fatto da un'altra installazione?

    Grazie in anticipo per l'eventuale risposta.

    Fulvio


    P.S.

    Come è andata con il backup? :-)

    Io ho installato VMware, Win2003 Std SP2 e Exchange 2003 SP2
    Ho provato a recuperare il file di NTbackup: disastro.
    Ho proceduto come suggerito da Gagriele Tensini (vedere sopra):
    -Database edb recuperati dopo verifica e correzione log 
    -Sono riuscito a montarlo sul gruppo di archiviazione.
    -Vedo tutte le caselle.

    Ora devo riuscire solo a farle connettere, perchè non vengono accettati gli utenti AD cui vorrei attribuire le caselle stesse.
    Quando cerchi di connettere una casella, viene chiesto a quale utente associarlo.
    Dall'apposita form ricerchi gli utenti creati. Non li trova!!!!!!!!!!! 8-)

    Non desisto.
    Vi farò sapere


    Ho cambiato idea. Desisto.
    Non riesco a riconnettere le caselle.
    Non è possibile associare gli utenti AD creati alle caselle recuperate.
    Ho creato una altra VM. Con Seven e OLook2010.- Connetto Outlook2010 ad Exchange2003 senza problemi.
    Ho l'utente superataru@dominio.abc. Ho già la relativa cartella superataru recuperata (da una AD della quale ho più nulla).
    Come connetto l'utente, mi trovo ad avere due caselle superataru, una gestibile, l'altra, quella recuperata, da associare, ma senza chance di poterlo fare perchè qualsiasi utente io passi alla casella di richiesta associazione ho sempre il solito errore: non esiste l'utente selezionato.

    Fusione!!!!!!!!!!!



     


    • Modificato superataru martedì 27 settembre 2011 14:55 errore di digitazione
    martedì 27 settembre 2011 14:52
  • Mi scuso per il messaggio parzialmente "off topic" ma, considerando l'interesse espresso in relazione all'argomento trattato in questa discussione, mi permetto di suggerire la stesura di un blogpost/articolo technet/forumpost o quello che è che tratti diffusamente il problema includendo gli steps necessari al recovery e, possibilmente, le "best practices" dal punto di vista dei backups etc... che permettano comunque di mettersi al riparo da "danni gravi"

    Ora, se qualcuno dei "guru" volesse mettere insieme una cosa del genere (o magari la potreste mettere in piedi a più mani) credo che la cosa farebbe felici molti exchange admins :D

     

    martedì 27 settembre 2011 15:11
  • Mi scuso se ho creato disagi.

    Ho capito la causa del problema.
    Un storage inutilizzato, ed ora rimosso, era la casua dello stallo.
    Ora riesco ad associare le cassette postali (e per giorni ho avuto la soluzione davanti agli occhi).
    Ora procederò con Exmerge.

    Grazie a tutti per l'aiuto.
    Vi sono molto grato.
    • Contrassegnato come risposta Anca Popa mercoledì 28 settembre 2011 07:25
    martedì 27 settembre 2011 15:40
  • Ciao superataru,

    Grazie di aver condiviso la causa del problema con la community.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    mercoledì 28 settembre 2011 07:25