none
Richiesta login Outlook dopo migrazione Exchange 2003 a 2010 RRS feed

  • Domanda

  • Ciao, questa richiesta è creata da Alberto del Microsoft Customer Service Twitter Team Italia –

    http://twitter.com/#!/MicrosoftAiuta per conto del nostro cliente Alessandro che ci chiede:

    “Ho effettuato in questi giorni una migrazione da Exchange 2003 a 2010, ho spostato tutti gli utenti sul nuovo server e sincronizzato le cartelle pubbliche.

    Sui client Outlook 2007 però dopo il passaggio al momento dell'apertura compare la schermata con la richiesta di autenticazione del server. I pc sui quali sto effettuando i test sono nel dominio.

    Ho controllato sui vari form la possibile problematica.

    Il certificato è stato acquistato (www.certificatesforexchange.com) UCC con 5 nomi: nomeserver,nomeserver.dominio.local,intranet.dominio.com,autodiscover.dominio.com..

    Ho provato dal client con il test di connessione di Outlook per il servizio autodiscover (facendo tasto DX+CNTRL sull'icona) e ottengo il messaggio:

    "autodiscover to https://nomeserver.dominio.local/autodiscover/autodiscover.xml succedeed (0x000000000)

    La rubrica fuori rete sembra funzionare correttamente (ho provato da un client con un nuovo profilo a scaricare la rubrica e poi metterlo in modalità offline e la rubrica la vedo correttamente).

    Ho visto che viene in automatico configurata la modalità RPC over HTTP sul client Outlook e la configurazione è anche giusta, però non credo che sia questo il motivo dato che la richiesta di autenticazione dovrebbe effettuarla solo quando è fuori rete (infatti sempre su Outlook se controllo lo stato connessione mi da correttamente TCP/IP invece che HTTPS).

    Se annullo la richiesta della password compare in basso la voce "Password Necessaria" ma la posta comunque funziona correttamente...

    Se immetto la password non mi viene riproposto di metterla nuovamente fino a quando non riavvio il client di Outlook.

    Il server Exchange 2003 è ancora in linea dato che non tutti gli Outlook si sono ricollegati per cui onde evitare di riconfigurarli sul nuovo server a mano, ho aspettato a toglierlo definitivamente, comunque non credo che sia dovuto a questo..

    Qualche info ?  che prove posso effettuare?”.

    Il cliente ha già postato la richiesta nel forum Technet http://t.co/grPMSZJ ma non è riuscito ancora a risolvere il problema e ha urgente necessità.

     

    Grazie per il supporto                                                                                                 

    Alberto Microsoft Customer Service Twitter Team Italia

    • Tipo modificato Anca Popa martedì 6 settembre 2011 09:15 in attesa di ulteriori aggiornamenti
    • Tipo modificato Anca Popa lunedì 17 ottobre 2011 09:43 risolto
    martedì 30 agosto 2011 13:23

Risposte

  • Chiudo l'argomento mostrando la soluzione che abbiamo trovato (dopo diverse sessioni di collegamento remoto) insieme al supporto Microsoft che ringrazio personalmente per la disponibilità e la cura della problematica, in particolare nella persona di Edine che mi ha seguito personalmente.

     

    Spero che queste informazioni possano essere utili a coloro che si potrebbero imbattere in questa problematica:

     

    Azione:  Exchange server 2010 Std Sp1 IT - Windows server 2008 STd R2 Sp1 IT
    You completed the migration from Exchange 2003 to Exchange 2010.
    After that the Outlook client 2007 are prompted for credentials when start outlook, and then randomly the credential prompt is displayed.
    This happen when outlook client is running in cache mode. If running in on-line mode hte credential prompt is displayed for 15-20 seconds and then disappear, and outlook works as expected.
    The issue do not happen with outlook 2003 clients

    Causa
    : na
     
    Risoluzione: Changed SSL configuration for IIS Virtual directories:
    Autodiscover vd, SSL required --> client certificate on Accept --> changed to Ignore
    OAB vd, SSL not required --> client certificate on Accept --> changed to Ignore
    ==================================================================================================== 

     


    Alessandro.

    • Contrassegnato come risposta Anca Popa lunedì 17 ottobre 2011 09:43
    lunedì 17 ottobre 2011 09:25

Tutte le risposte

  • Salve,

    ho effettuato in questi giorni una migrazione da Exchange 2003 a 2010, ho spostato tutti gli utenti sul nuovo server e sincronizzato le cartelle pubbliche.

    Sui client Outlook 2007 però dopo il passaggio al momento dell'apertura compare la schermata con la richiesta di autenticazione del server. I pc sui quali sto effettuando i test sono nel dominio.

    Ho controllato sui vari form la possibile problematica.

    Il certificato è stato acquistato (www.certificatesforexchange.com) UCC con 5 nomi: nomeserver,nomeserver.dominio.local,intranet.dominio.com,autodiscover.dominio.com..

    Ho provato dal client con il test di connessione di Outlook per il servizio autodiscover (facendo tasto DX+CNTRL sull'icona) e ottengo il messaggio:

    "autodiscover to https://nomeserver.dominio.local/autodiscover/autodiscover.xml succedeed (0x000000000)

    La rubrica fuori rete sembra funzionare correttamente (ho provato da un client con un nuovo profilo a scaricare la rubrica e poi metterlo in modalità offline e la rubrica la vedo correttamente).

    Ho visto che viene in automatico configurata la modalità RPC over HTTP sul client Outlook e la configurazione è anche giusta, però non credo che sia questo il motivo dato che la richiesta di autenticazione dovrebbe effettuarla solo quando è fuori rete (infatti sempre su Outlook se controllo lo stato connessione mi da correttamente TCP/IP invece che HTTPS).

    Se annullo la richiesta della password compare in basso la voce "PAssword Necessaria" ma la posta comunque funziona correttamente...

    Se immetto la password non mi viene riproposto di metterla nuovamente fino a quando non riavvio il client di Outlook.

     

    Il server Exchange 2003 è ancora in linea dato che non tutti gli Outlook si sono ricollegati per cui onde evitare di riconfigurarli sul nuovo server a mano, ho aspettato a toglierlo definitivamente, comunque non credo che sia dovuto a questo..

     

    Qualche info ?  che prove posso effettuare?

     

    • Unito Anca Popa mercoledì 31 agosto 2011 06:58 stesso thread
    giovedì 25 agosto 2011 10:50
  • che tipo di autenticazione hai configurato sui client? di base o ntlm?
    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    giovedì 25 agosto 2011 13:43
    Moderatore
  • Dove intendi, all'interno di Outlook nell'RPC? Li trovo come autenticazione: Autenticazione di Base...

    Anche se la metto in NTLM se riavvio l'outlook me la reimposta in autenticazione di base.

     

    MA posso disabilitare l'autoconfigurazione dell'RPC che per i client interni se non mi serve??  Se è quello il motivo della richiesta password, anche se non dovrebbe essere......

    giovedì 25 agosto 2011 13:55
  • Ciao, di solito mi capita la stessa tua cosa in 3 casi

    1) Outlook 2007 (e quindi office) non è sp2.

    2) I nomi dei certificati non combaciano.

    3) I dns dei client non sono corretti e puntano ad un dns errato.

    Nel caso 2 di solito sistemo a mano i certificati con queste righe di comando (l'ultima se non hai il ruolo installato va in errore).

    Set-ClientAccessServer -Identity nomeserver -AutodiscoverServiceInternalUri https://nomecertificato/autodiscover/autodiscover.xml

    Set-WebServicesVirtualDirectory -Identity "nomeserver\EWS (Default Web Site)" -InternalUrl https://nomecertificato/ews/exchange.asmx

    Set-OABVirtualDirectory -Identity "nomeserver\oab (Default Web Site)" -InternalUrl https://nomecertificato/oab

    Set-UMVirtualDirectory -Identity "nomeserver\unifiedmessaging (Default Web Site)" -InternalUrl https://nomecertificato/unifiedmessaging/service.asmx

    Mi è capitato però che non funzioni correttamente comunque ma solo su client fuori dal dominio. In quei casi uso un programma che si chiama "outlook autologin" E' gratuito e salva la pwd utente nel registry del sistema. In questo modo la chiede 1 volta solo alla prima apertura. Poi anche se riavvii la ricorda sempre. Non so se può fare al caso tuo. Sarebbe meglio capire il problema che comunque si verifica solo sui 2007 (2010 non ha queste problematiche) ma se non ne esci vivo puoi "salvarti" momentaneamente.
    A.

    giovedì 25 agosto 2011 15:08
    Moderatore
  • Ciao, di solito mi capita la stessa tua cosa in 3 casi

    1) Outlook 2007 (e quindi office) non è sp2.

    Ho controllato e sono SP2

    2) I nomi dei certificati non combaciano.

    Mi sembrano corretti, controllando su AutodiscoverServiceInternalURi c'è impostato: https://nomeserver.domino.local/Autodiscover/Autodiscover.xml e il nomeserver.dominio.local è presente tra i nomi alternativi del certificato che ho acquistato...

    Mi sono accorto però che...

    ho registrato solo autodiscover.domino.com, mentre io su alcuni utenti ho come email principale nome@domino.it e come aggiuntiva anche nome@dominio.com, mentre per altri ho direttamente nome@dominio.com...

    Non tanto per gli utenti esterni (che si collegano tutti via webmail) ma per gli interni, ho verificato che comunque l'Autodiscover interno viene raggiunto regolarmente...

    Controllando il test di Autodiscover di un Outlook 2007 da (succeded) ma poi compare la finestra di login ad ogni avvio... e la rubrica fuori rete la scarica...

    Invece sugli Outlook 2010 la finestra non compare la finestra di login, ma il test di Autodiscovery da HTTP 502 con errore anche sul nome locale... e la rubrica fuori rete da il solito errore 0x8004010F....

    3) I dns dei client non sono corretti e puntano ad un dns errato.

    Nel caso 2 di solito sistemo a mano i certificati con queste righe di comando (l'ultima se non hai il ruolo installato va in errore).

    Set-ClientAccessServer -Identity nomeserver -AutodiscoverServiceInternalUri https://nomecertificato/autodiscover/autodiscover.xml

    Set-WebServicesVirtualDirectory -Identity "nomeserver\EWS (Default Web Site)" -InternalUrl https://nomecertificato/ews/exchange.asmx

    Set-OABVirtualDirectory -Identity "nomeserver\oab (Default Web Site)" -InternalUrl https://nomecertificato/oab

    Quella della OAB è un punto critico, non capisco se va messa http o https, se la metto https però dovrei configurare anche in IIS l'utilizzo del certificato, no? Ho provato ma se la metto in https col certificato nemmeno i client Outlook 2003-2007 mi scaricano più la rubrica...

    Set-UMVirtualDirectory -Identity "nomeserver\unifiedmessaging (Default Web Site)" -InternalUrl https://nomecertificato/unifiedmessaging/service.asmx

    Mi è capitato però che non funzioni correttamente comunque ma solo su client fuori dal dominio. In quei casi uso un programma che si chiama "outlook autologin" E' gratuito e salva la pwd utente nel registry del sistema. In questo modo la chiede 1 volta solo alla prima apertura. Poi anche se riavvii la ricorda sempre. Non so se può fare al caso tuo. Sarebbe meglio capire il problema che comunque si verifica solo sui 2007 (2010 non ha queste problematiche) ma se non ne esci vivo puoi "salvarti" momentaneamente.

    A.

     

    Qual'è questo: http://www.mondada.net/gabriele/autologin/

    • Modificato Anca Popa venerdì 26 agosto 2011 12:07 formattazione blockquote
    giovedì 25 agosto 2011 15:24
  • Il sito dell'autologin è corretto. 

    Ti chiedo una cosa, come hai fatto a "spostare" gli utenti outlook 2007? Hai cambiato il nome del server dalle proprietà degli account oppure hai ricreato di peso l'ost facendogli riprendere giù tutta la cartella? Non vorrei che fossero rimaste tracce del vecchio server 2003 in AD e quindi il client agganciati non funzionino per quello.

    Riesci a fare una prova su un client creando un nuovo profilo ed agganciandolo ad exchange in maniera pulita? Perchè mi sembra più un problema di AD che del server sinceramente...

     

    giovedì 25 agosto 2011 15:32
    Moderatore
  • Ho semplicemente migrato le caselle tra i server exchange dall'utility "richiesta di spostamento locale" presente sull'EMC dell'Exchange 2010.

    Una volta spostata la casella di posta, quando ho riaperto l'Outlook mi ha in automatico sostituito il nome del server exchange dal 2003 al 2010, la posta si è riaperta regolarmente, il file OST è stato mantenuto lo stesso...

    L'unico problema è che ora chiede l'utente e password, una volta messi poi va avanti senza problemi fino a che non richiudo il client...

     

    Ho già provato a fare un nuovo profilo pulito con l'utente administrator, ma fa uguale...

    Ho notato che sull'Outlook 2007 mi configura automaticamente la parte della connessione RPC per collegarsi anche dall'esterno, sul client Outlook 2010 no...

    Anche disabilitandola, sul 2007 si riabilita in automatico, non vorrei fosse questa a causarmi il problema....

    giovedì 25 agosto 2011 15:52
  • In pratica ti si configura la rpc over http anche se sei dentro e si aggancia con quella automaticamente?

    Il problema allora risiede tutto li. Perchè internamente il server non si chiama come quello esterno. Prova a creare un profilo exchange di outlook manuale a non automatico e quando inserisci nome server e nome utente controlla in basso a destra nelle avanzate sotto connessione se non ci sia flaggata la http proxy, in caso positivo deflaggala. Internamente non deve dare il messaggio ma sinceramente migrazioni 2003-2010 non ne ho mai fatte di dirette, mi piacciono poco. Se la struttura non è perfetta (raramente lo è) non va ma a buon fine e c'è sempre qualcosina che stride. Vediamo se riusciamo a risolvere il tuo problema. Altrimenti qui c'è gente che ne sa sicuramente più di me su Exchange e ti darà qualche dritta più mirata.

    Senti ti chiedo un'altra cosa...il DC è rimasto sempre quello? Non è che il 2003 era installato su un DC? Perchè è il tipico problema di nomi errati e di quando non trova il dns corretto che ha in se stesso i record di Exchange...

     

    giovedì 25 agosto 2011 16:02
    Moderatore
  • Ho provato anche con un profilo manuale e verificare che non sia attivo  l'http proxy, al momento però che poi entro col client e vado a vedere le impostazioni mi viene configurato in automatico... credo sia l'autodiscover a farlo...

     

    Si, il server exchange 2003 era installato su un DC, su quel server però è stato fatto a suo tempo un DCPROMO spostando il DC su un nuovo server 2008. Attualmente il 2003 con exchange 2003 è sempre attivo e collegato...

     

    Sto facendo ancora qualche test...

    Mi sono accorto che modificando il valore del percorso dell'autodiscover col comando set-clientaccessServer e mettendo come dovrebbe essere https://autodiscover.nomedominio.com/...

    Ora quando il client Outlook accede non mi viene più la finestra di login  da "nomeserver" ma mi viene da "autodiscover.dominio.com"... Quindi è proprio lui che richiede l'autenticazione...

     

    E' come se l'autodiscover riuscisse a raggiungere il server ma l'autenticazione non è corretta oppure non sfrutta quella integrata ed è per questo che mi chiede l'utente...

     

    giovedì 25 agosto 2011 16:17
  • Guarda, qui i Moderatori ti daranno sicuro una mano...io mi chiamo fuori perchè per quelle che sono le mie conoscenze in merito, Exchange non va mai installato su un DC proprio perchè quando lo vai a spostare non riconosce altri che il suo DC. Quindi se lo fai (tipo SBS ad esempio ma anche con 2008 normale) poi muore dov'è. Nel tuo caso il problema è abbastanza complicato...credo che per risolverlo (sempre che si possa) ti serva qualcuno che mastica AD a livelli abbastanza elevati invece che Exchange. Ma magari sbaglio. Io avrei già messo l'autologin...viste le premesse.

     

     

    giovedì 25 agosto 2011 16:24
    Moderatore
  • L'autologin lo voglio usare come ultima spiaggia..

    Ho provato a disabilitare l'outlook anywere e così facendo il client non si autoconfigura più sulla parte  RPC over HTTPS... Però la richiesta di login rimane... Quindi non è l'outlook anywere la causa... almeno questo è appurato... 

    giovedì 25 agosto 2011 16:47
  • Guarda al 99% è perchè c'è un nome non corretto da qualche parte. Ti faccio un'ultima domanda...ma anche il 2010 è caricato su un DC? Perchè se così fosse la vedo molto grigia....

    P.S Di quanti client parliamo?

    giovedì 25 agosto 2011 18:31
    Moderatore
  • Ciao, senti, mi sono ricordato che un po di tempo fa ho avuto un problema analogo su SBS 2008 ed i client 2007 e sono riuscito a reperire la faq che avevo usato in quell'occasione. Te la giro. Secodo me puoi vedere se ti sistema qualcosa. Altrimenti vale sempre il discorso di cui sopra.

    1) Aprire Gestione Internet Information Services (IIS)
    2) Sotto la voce Siti espandere SBS Web Applications cliccare su Autodiscover
    3) Aprire Impostazioni SSL e selezionare “Richiedi SSL”, “Richiedi SSL a 128 bit” e “Accetta” nella sezione certificati client
    4) Ripetere i passi 2) e 3) anche per la voce “OAB”
    5) Riavviare IIS ed accertarsi che i siti ripartano dopo il riavvio

    Le stesse istruzioni funzionano in maniera analoga anche per Exchange installato su Windows Server Standard (non SBS) con le oppurtune modifiche ai percorsi di Autoriscover e OAB

     

    venerdì 26 agosto 2011 08:11
    Moderatore
  • Grazie ancora.. Ora non sono presente li, comunque vedo di collegarmi in remoto...

    Avevo però controllato quelle impostazioni, per quanto riguarda l'Autodiscover dovrebbe essere già così, per la OAB no, è senza certificato....

    Quello della OAB è un punto critico, ancora non ho capito se va impostato con il certificato oppure no... Se lo metto col certificato allora devo anche impostare correttamente il link interno che adesso è in http...

    Avevo provato, ma a quel punto la rubrica fuori rete mi dava sempre l'errore 0x800401F0... 

     

    comunque ci riprovo e poi aggiorno sui risultati...

    venerdì 26 agosto 2011 09:36
  • Allora...

    Ho controllato le proprietà di Autodiscover e sono tutte corrette.

    Poi ho provato a reimpostare la virtualdirectory di OAB dal comando di shell di exchange:

    set-OABvirtualDirectory -REquireSSL $True

    e controllando con get-OABVirtualdirectory ho verificato essere su "true", poi controllando su IIS manager ho visto che mi ha rimesso il flag si certificati, a quel punto ho modificato anche l'internal URL con "https://nomedomino.com/OAB".

    Controllando dai client Outlook2003 la rubrica fuori rete viene scaricata correttamente, dal client Outlook 2007 invece rimane la richiesta in sospeso...

    Inoltre mi sono accorto che se provo ad aprire la pagina web https://nomedominio.com/OAB dal client mi chiede utente e password, ce le metto e mi viene fuori un errore "403 Acceso Negato", mentre se la stessa pagina la apro dal server mi da "Errore 403.14 il server web non è configurato per la visualizzazione del contenuto della directory"..  Il discorso della password l'ho ovviato mettendo nella intranet locale il sito https://nomedominio.com  per l'errore  Accesso Negato rimane... Strano questo comportamento diverso tra il server e il client... Ho pensato anche ad un problema di firewall di windows del server ma anche disattivandolo l'errore rimane.

    E' un comportamento normale? 

    venerdì 26 agosto 2011 14:32
  • Alessandro, aspetta, il tuo problema secondo me c'entra poco con la OAB. La richiesta della pwd e del nome utente la fa prima di andare poi a caricare gli indirizzi offline. Il tuo è un problema di nomi. Chiede utente e password perchè secondo lui quelle del client con cui ti logghi non combaciano o non sono presenti nella la struttura AD da cui exchange va a pescare. Ti rifaccio quindi la domanda. Anche il 2010 è installato su un DC? Se è installato su un DC e quindi fa da DNS hai messo quel DNS come principale nelle impostazioni di rete?

     

     

    venerdì 26 agosto 2011 14:41
    Moderatore
  • L'Exchange 2010 non è installato su un server AD, è un server Windows 2008 R2 standalone nel dominio principale, ci sono 2 server domain controller, un Windows 2008 STD e un Windows 2003.

    Il discorso dell'autenticazione può tornare però:

    1. Prima della migrazione al nuovo exchange 2010, quando i client erano sul 2003 non c'erano questi problemi;
    2. La posta comunque funziona, anche se annullo la richiesta della password.. L'unica cosa è che quando annullo la richiesta della password e puoi foglio fare una nuova mail, al momento della apertura della rubrica di exchange allora la password viene richiesta nuovamente...  Immagino che se l'autenticazione non combacia anche la posta non funzionerebbe... Inoltre quando vado a creare un nuovo profilo e nelle impostazioni di exchange metto il server di posta e la password e poi verifico le impostazioni, le impostazioni vengono verificate senza problemi (cioè completa il nome del server di posta sottolineandolo), in caso di problemi di autenticazione mi dovrebbe già qui richiedere l'utente e la password....

    In altre occasioni con server Exchange 2007 avevo avuto più o meno lo stesso problema e banalmente avevo risolto aggiornando il service pack al 2 (ora al 3) e tutto tornava a posto...

    Ho installato anche un server Exchange 2010 in un ambiente nuovo e questi problemi non li ho riscontrati...  

    Questa volta però ho dovuto migrare i client dal server Exchange 2003... Ha funzionato tutto regolare se non che ho questo inconveniente...

    L'unica cosa è che ancora non ho rimosso l'Exchange 2003, potrebbe essere qui la problematica??? 

     

    Altri controlli che posso fare?

    lunedì 29 agosto 2011 08:20
  • 1) certo, il 2003 ha parecchi controlli in meno. Questo è un issue solo della 2007-2010 con Outlook 2007. Se agganci client Outlook 2003 alla 2007 non avviene, stessa cose se agganci client Outlook 2010, quindi il "prima" non conta niente. Hai fatto un salto di 2 versioni di server di posta, cambiata tecnologia, struttura, integrazione...ecc..ec..

    2)Errato. Cotrolla il nome, non inibisce il client a spedire se il nome utente è presente con casella associata. Questo problema si verifica anche quando vai a mettere certificati autocreati o in svariati altri casi.

    In ambiente di test sono sicuro che funziona. Non hai problemi di AD, bella pulita e lustra e tutto funziona come per magia. Il tuo problema ti ripeto è nella struttura. L'inconveniente non è grave, è solo un messaggio...ma trovare il problema non è semplice. Se togli il 2003 secondo me non risolvi a meno che non vai poi a pulire manualmente con l'adsiedit le chiavi. Con tutto che su quel DC rimarrà sempre traccia dell'ex 2003 nel registry. 

    Io ho finito le idee a parte una, guarda quandi server dns ci sono in AD e prova a sostituire il principale di un client con uno di questi, perchè se al momento puntano ancora tutti al dc dove c'era ex2003 il problema per me sta tutto li...se è l'unico DC della rete...allora...ho finito i bonus! Vediamo se qualcuno più esperto di me ha idee migliori!

    A.

    lunedì 29 agosto 2011 09:29
    Moderatore
  • Col DNS avevo già provato, niente da fare....

    Attendo info da qualcuno che può darmi una mano sulla soluzione.....

     

    Grazie ancora...

    lunedì 29 agosto 2011 15:46

  • Il cliente ha già postato la richiesta nel forum Technet http://t.co/grPMSZJ ma non è riuscito ancora a risolvere il problema e ha urgente necessità.
     
     
     
    Grazie per il supporto                                                                                                
     
    Alberto Microsoft Customer Service Twitter Team Italia

    ---------------------------------------------------------------------------------------------------------------------------------------------

     

    Dato il carattere di urgenza suggerisco un contatto diretto con il supporto tecnico professionale:

    http://support.microsoft.com/select/default.aspx?target=assistance&c1=508&

     

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposto come risposta Anca Popa mercoledì 31 agosto 2011 10:09
    • Proposta come risposta annullata Anca Popa venerdì 2 settembre 2011 06:09
    martedì 30 agosto 2011 16:23
  • Posso dare qualche altra indicazione, magari è una impostazione banale...

    Ho provato a rifare i profili di Outlook.

    Se lo configuro SENZA cache al momento dell'apertura del client in contemporanea compare la richiesta della password ma se attendo circa 15-20 secondi poi scompare e il client funziona correttamente...

    Se lo configuro CON la cache la momento dell'apertura del client in contemporanea compare la richiesta della password, se anche qui attendo 15-20 secondi avviene come un "refresh" della richiesta ma rispetto al caso di prima viene nuovamente ripresentata la finestra di richiesta password.

    La rubrica fuori rete in questo caso viene scaricata correttamente solo se inserisco la password, altrimenti da l'errore 8x800401F.

    Ho provato a configurare la directory virtuale OAB sia in modalità https://nomeserver.dominio.local/OAB che senza SSL con http://nomeserver.dominio.local/OAB, in entrambi i casi la rubrica è comunque scaricabile, sempre impostando la password..

    Ho controllato inoltre che sia correttamente disattivata l'autenticazione di tipo basic, mentre è attiva quella di tipo ntlm.

    Infine configurando in set-clientaccessserver la voce Autodiscoverserverinternaluri come https://nomeserver.nomedominio.local/autodiscover/autodiscover.xml nella finestra di login al prompt di outlook c'è nomeserver.nomedominio.local mentre se configuro la voce con https://autodiscover.nomedominio.com/autodiscover/autodiscover.xml nella finestra di login compare autodiscover.nomedominio.com.

    Infine in set-autodiscovervirtualdirectory ho provato a mettere in True solo il WindowsAuthentication lasciando tutti gli altri in False, ma la situazione persiste.

     

    Qualche altro test da fare???  

    giovedì 1 settembre 2011 14:27
  • Ciao Alessandro,
    non riesco a leggere tutto il thread per questioni di tempo.
    Riesci a farmi un sunto del problema?

    Saluti

    .m
    Massimiliano Luciani

    giovedì 1 settembre 2011 15:58
  • Ok, ecco il sunto.

    Installazione Exchange 2010 su nuovo server in una rete con exchange 2003 regolarmente funzionante.

    dopo l'installazione sposto le cassette postali sul nuovo server. Attualmente il 2003 è SEMPRE ATTIVO, ma le public folder (anche se non ne avevo) le ho comunque migrate sul 2010 (e le vedo regolarmente dal pannello di controllo delle cartelle pubbliche).

    Dato che sul 2003 avevo un certificato son 1 solo nome: intranet.domino.com, per l'exchange 2010 acquisto un nuovo certificato con domini multipli: intranet.dominio.com,autodiscover.dominio.com,nomeserver,nomeserver.dominio.local.

    Configuro il certificato sul nuovo server. TEst su OWA, OK. 

    Apro Outlook2003 e il client migrato viene "switchato" in automatico sul nuovo server, senza errori. E tutto va.

    Apro Outook2007, viene anch'esso switchato ma mi chiede utente e password, se non li metto la posta funziona ma se apro la rubrica me li richiede, se li metto funziona ma poi ad una nuova apertura del client mi li richiede.

    ho letto un centinaio si post su technet (anche quello inglese), ho fatto il test dell'Outlook per l'autodiscovery e lo da Ok, ho fatto il controllo della rubrica fuori rete e se metto le credenziali la scarica senza problemi, ho messo la OAB sia in http che in https.

    Non ho proxy, l'RPC (outlook anywere) ho provato sia in Basic che in NTLM... Ho provato anche a disabilitarlo.. La richiesta password la da .. SEMPRE... e solo sugli Outlook 2007.

    Sempre l'Outlook 2007, in modalità NO CACHE la richiesta password la da ma dopo 20 secondi scompare da se (??).. e tutto sembra funzionare...

    In modalità CACHE la richiesta la da e rimane senza scomparire...

     

    Spero di essere stato chiaro nella problematica....

     

    giovedì 1 settembre 2011 16:26
  • Iniziamo a vedere se hai realmente migrato tutte le pf.
    Apri una shell e lancia il seguente comando

    Get-PublicFolder "\" -recurse | ft name,replicas

    Sono tutte migrate o hai una replica su entrambi i servers?

    Ora apri un client outlook, tieni premuto ctrl e clicca col tasto dx sull'icona di outlook nella try bar, test E-mail configuration.
    Togli la spunta da use guessmart e secure... metti la password e verifica che tutti i valori url sono giusti.

    Postami inoltre le autenticazioni sulle singole virtual directory che hai cambiato tramite IIS

    Saluti
    .m

    Massimiliano Luciani

    giovedì 1 settembre 2011 16:47
  • Questo è il risultato delle public folder:

     

    Name                                                        Replicas

    ----                                                        --------

    IPM_SUBTREE                                                 {}

    Internet Newsgroups                                         {Public Folder Database Campus}

     

    Poi ti posto alcuni risultati delle configurazione via EMS:

    [PS] C:\Windows\system32>Get-ClientAccessServer | FL

     

     

    RunspaceId                           : 2c45d0f1-53ba-43be-a196-9d6eaee4c

    Name                                 : SERVERVM02

    Fqdn                                 : SERVERVM02.campuslu.local

    OutlookAnywhereEnabled               : True

    AutoDiscoverServiceCN                : ServerVm02

    AutoDiscoverServiceClassName         : ms-Exchange-AutoDiscover-Service

    AutoDiscoverServiceInternalUri       : https://servervm02.campuslu.local

    AutoDiscoverServiceGuid              : 77378f46-2c66-4aa9-a6a6-3e7a48b19

    AutoDiscoverSiteScope                : {Nome-predefinito-primo-sito}

    AlternateServiceAccountConfiguration :

    IrmLogEnabled                        : True

    IrmLogMaxAge                         : 30.00:00:00

    IrmLogMaxDirectorySize               : 250 MB (262,144,000 bytes)

    IrmLogMaxFileSize                    : 10 MB (10,485,760 bytes)

    IrmLogPath                           : C:\Program Files\Microsoft\Exchan

    MigrationLogLoggingLevel             : Information

    MigrationLogFilePath                 :

    MigrationLogMaxAge                   : 180.00:00:00

    MigrationLogMaxDirectorySize         : 10 GB (10,737,418,240 bytes)

    MigrationLogMaxFileSize              : 100 MB (104,857,600 bytes)

    IsValid                              : True

    ExchangeVersion                      : 0.1 (8.0.535.0)

    DistinguishedName                    : CN=SERVERVM02,CN=Servers,CN=Excha

                                           dministrative Groups,CN=CAMPUS,CN

                                           n,DC=campuslu,DC=local

    Identity                             : SERVERVM02

    Guid                                 : b8398f1d-1d40-46e1-addb-cd3501ec0

    ObjectCategory                       : campuslu.local/Configuration/Sche

    ObjectClass                          : {top, server, msExchExchangeServe

    WhenChanged                          : 22/08/2011 15:52:38

    WhenCreated                          : 05/08/2011 12:58:45

    WhenChangedUTC                       : 22/08/2011 13:52:38

    WhenCreatedUTC                       : 05/08/2011 10:58:45

    OrganizationId                       :

    OriginatingServer                    : ServerVm01.campuslu.local

    [PS] C:\Windows\system32>Get-OabVirtualDirectory | FL
    RunspaceId                      : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Name                            : OAB (Default Web Site)
    PollInterval                    : 480
    OfflineAddressBooks             : {\Elenco di indirizzi non in linea predefinito}
    RequireSSL                      : False
    BasicAuthentication             : False
    WindowsAuthentication           : True
    MetabasePath                    : IIS://SERVERVM02.campuslu.local/W3SVC/1/ROOT/OAB
    Path                            : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\OAB
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : SERVERVM02
    InternalUrl                     : http://intranet.campuslucca.it/OAB
    InternalAuthenticationMethods   : {WindowsIntegrated}
    ExternalUrl                     : https://intranet.campuslucca.it/OAB
    ExternalAuthenticationMethods   : {WindowsIntegrated}
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=OAB (Default Web Site),CN=HTTP,CN=Protocols,CN=SERVERVM02,CN=Servers,CN=Exchange A
                                      dministrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=CAMPUS,CN=Microsoft
                                       Exchange,CN=Services,CN=Configuration,DC=campuslu,DC=local
    Identity                        : SERVERVM02\OAB (Default Web Site)
    Guid                            : 69f959f2-3dbe-4f5c-9dcd-3756f3b85034
    ObjectCategory                  : campuslu.local/Configuration/Schema/ms-Exch-OAB-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchOABVirtualDirectory}
    WhenChanged                     : 01/09/2011 14:19:04
    WhenCreated                     : 22/08/2011 16:21:57
    WhenChangedUTC                  : 01/09/2011 12:19:04
    WhenCreatedUTC                  : 22/08/2011 14:21:57
    OrganizationId                  :
    OriginatingServer               : ServerVm01.campuslu.local
    IsValid                         : True
    [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory | FL
    RunspaceId                      : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Name                            : Autodiscover (Default Web Site)
    InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
    ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
    LiveIdSpNegoAuthentication      : False
    WSSecurityAuthentication        : True
    LiveIdBasicAuthentication       : False
    BasicAuthentication             : True
    DigestAuthentication            : False
    WindowsAuthentication           : True
    MetabasePath                    : IIS://SERVERVM02.campuslu.local/W3SVC/1/ROOT/Autodiscover
    Path                            : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : SERVERVM02
    InternalUrl                     :
    ExternalUrl                     :
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=SERVERVM02,CN=Servers,CN=E
                                      xchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=CAMPUS,CN=
                                      Microsoft Exchange,CN=Services,CN=Configuration,DC=campuslu,DC=local
    Identity                        : SERVERVM02\Autodiscover (Default Web Site)
    Guid                            : f4ef9536-c12a-4d25-900e-5291383bf0f4
    ObjectCategory                  : campuslu.local/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
    WhenChanged                     : 01/09/2011 18:03:06
    WhenCreated                     : 05/08/2011 13:07:01
    WhenChangedUTC                  : 01/09/2011 16:03:06
    WhenCreatedUTC                  : 05/08/2011 11:07:01
    OrganizationId                  :
    OriginatingServer               : ServerVm01.campuslu.local
    IsValid                         : True
    [PS] C:\Windows\system32>Test-OutlookWebServices -Identity:administrator@campuslucca.it
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1019
    Type       : Information
    Message    : Trovato un punto di connessione valido al servizio di individuazione automatica. L'URL dell'individuazione
                  automatica su questo oggetto è https://servervm02.campuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1006
    Type       : Information
    Message    : Servizio di individuazione automatica contattato (https://servervm02.campuslu.local/autodiscover/autodisco
                 ver.xml).
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1016
    Type       : Information
    Message    : [EXCH] AS è configurato per questo utente nella risposta AutoDiscover proveniente da https://servervm02.ca
                 mpuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1015
    Type       : Information
    Message    : [EXCH] OAB è configurato per questo utente nella risposta AutoDiscover proveniente da https://servervm02.c
                 ampuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1014
    Type       : Information
    Message    : [EXCH] UM è configurato per questo utente nella risposta AutoDiscover proveniente da https://servervm02.ca
                 mpuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1016
    Type       : Information
    Message    : [EXPR] AS è configurato per questo utente nella risposta AutoDiscover proveniente da https://servervm02.ca
                 mpuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1015
    Type       : Information
    Message    : [EXPR] OAB è configurato per questo utente nella risposta AutoDiscover proveniente da https://servervm02.c
                 ampuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1014
    Type       : Information
    Message    : [EXPR] UM è configurato per questo utente nella risposta AutoDiscover proveniente da https://servervm02.ca
                 mpuslu.local/autodiscover/autodiscover.xml.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1022
    Type       : Success
    Message    : Prova del servizio di individuazione automatica completata.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1024
    Type       : Success
    Message    : [EXCH] Servizio AS correttamente contattato in https://servervm02.campuslu.local/EWS/Exchange.asmx. Tempo
                 trascorso: 484 millesimi di secondo.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1026
    Type       : Success
    Message    : [EXCH] Servizio UM correttamente contattato in https://servervm02.campuslu.local/EWS/Exchange.asmx. Tempo
                 trascorso: 109 millesimi di secondo.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1024
    Type       : Success
    Message    : [EXPR] Servizio AS correttamente contattato in https://intranet.campuslucca.it/ews/exchange.asmx. Tempo tr
                 ascorso: 78 millesimi di secondo.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1026
    Type       : Success
    Message    : [EXPR] Servizio UM correttamente contattato in https://intranet.campuslucca.it/ews/exchange.asmx. Tempo tr
                 ascorso: 46 millesimi di secondo.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1124
    Type       : Success
    Message    : [Server] Servizio AS correttamente contattato in https://servervm02.campuslu.local/ews/exchange.asmx. Temp
                 o trascorso: 46 millesimi di secondo.
    RunspaceId : 2c45d0f1-53ba-43be-a196-9d6eaee4ca0a
    Id         : 1126
    Type       : Success
    Message    : [Server] Servizio UM correttamente contattato in https://servervm02.campuslu.local/ews/exchange.asmx. Temp
                 o trascorso: 46 millesimi di secondo.
    Per l'Outook non ho attualmente il client sotto mano per farti il test, comunque l'ho già provato e sembra tutto regolare, l'autodiscover da Succeded (0000000).
    Dimmi se ti serve qualche altro dato.
    Grazie.

    giovedì 1 settembre 2011 17:08
  • C'e' un errore nel valore AutoDiscoverServiceInternalUri       : https://servervm02.campuslu.local
    cambialo in https://servervm02.campuslu.local/autodiscover/autodiscover.xml

    Inoltre ci sono degli url con campuslucca a posto di camuslu.local dagli un occhio.

    Il comando di output che mi hai dato delle PF non prevede la parte di sottocartelle, copia il mio comando e lancialo con il recurse

    .m
    Massimiliano Luciani

    giovedì 1 settembre 2011 17:31
  • Ciao Alessandro,

    Visti i tempi trascorsi, ho modificato il tuo thread in "Discussione generale" siccome siamo in attesa di sapere l'esito delle prove.

    Se riesci a risolvere ti saremmo grati di aggiornare anche il thread (sarebbe d'aiuto per gli altri membri della community che magari si sono imbattuti in un caso simile al tuo).

    Grazie della collaborazione,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda


    • Modificato Anca Popa martedì 6 settembre 2011 09:20
    martedì 6 settembre 2011 09:19
  • Scusate il ritardo ma sono stato occupato...

    Per quanto riguarda l'autodiscoverServiceInternalUri il valore è giusto, ho soltanto tagliato la pagina durante l'operazione di copia-incolla, infatti nelle righe più sotto del comando di test dell'OutlookwebService è riportato il valore giusto...

     

    Per quanto riguarda le PF io ho ricopiato quanto mi hai scritto (non capisco cosa dici per "lancialo con il recurse"), comunque ti riporto nuovamente l'output comprensivo di comando:

    [PS] C:\Users\administrator.CAMPUSLU\Desktop>Get-PublicFolder "\" -recurse | ft name,replicas

     

    Name                                                        Replicas

    ----                                                        --------

    IPM_SUBTREE                                                 {}

    Internet Newsgroups                                         {Public Folder Database Campus}

     

     

    [PS] C:\Users\administrator.CAMPUSLU\Desktop>

    Grazie ancora.

    martedì 6 settembre 2011 13:55
  • Nessun altro suggerimento??

    Grazie.

    giovedì 8 settembre 2011 12:25
  • Chiudo l'argomento mostrando la soluzione che abbiamo trovato (dopo diverse sessioni di collegamento remoto) insieme al supporto Microsoft che ringrazio personalmente per la disponibilità e la cura della problematica, in particolare nella persona di Edine che mi ha seguito personalmente.

     

    Spero che queste informazioni possano essere utili a coloro che si potrebbero imbattere in questa problematica:

     

    Azione:  Exchange server 2010 Std Sp1 IT - Windows server 2008 STd R2 Sp1 IT
    You completed the migration from Exchange 2003 to Exchange 2010.
    After that the Outlook client 2007 are prompted for credentials when start outlook, and then randomly the credential prompt is displayed.
    This happen when outlook client is running in cache mode. If running in on-line mode hte credential prompt is displayed for 15-20 seconds and then disappear, and outlook works as expected.
    The issue do not happen with outlook 2003 clients

    Causa
    : na
     
    Risoluzione: Changed SSL configuration for IIS Virtual directories:
    Autodiscover vd, SSL required --> client certificate on Accept --> changed to Ignore
    OAB vd, SSL not required --> client certificate on Accept --> changed to Ignore
    ==================================================================================================== 

     


    Alessandro.

    • Contrassegnato come risposta Anca Popa lunedì 17 ottobre 2011 09:43
    lunedì 17 ottobre 2011 09:25
  • Grazie per essere tornato a condividere la soluzione con gli altri utenti del Forum, Alessandro.

    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 17 ottobre 2011 09:43