none
Exchange 2007: unable to verify account information su iPhone RRS feed

  • Domanda

  • Titolo originale: Exchange & I-phone

    Buongiorno a tutti.

    Nella mia organizzazione ho 2 utenti che utilizzano i-phone. Premetto già che  i dispositivi sono i-phone 3GS aggiornati alla versione 4

    Abbiamo da poco implementato un Windows Server 2008 Small Business quindi con integrato Exchange 2007.

    Il Windows Server e Exchange sono perfettamente aggiornati tutti alle ultime versioni.

    Il problema è che questi dispositivi sono vogliono sincronizzarsi con il server di exchange, quando provo ad aggiungere l'account sul dispositivo ritorna un messaggio che dice: "unable to verify account information".

    L'account è perfettamente attivo e il servizio di active sync di Exchange è abilitato, ho fatto anche un test da www.exchangeconnectivity.com, il risultato del test è negativo ma solo perchè non vi è installato un certificato firmato ad autority esterne ma è self-signed.

    Ho già altri server Exchange che hanno un certificato autogenerato e non danno alcun problema con i-phone.

    Non so più dove sbattere la testa.

    Qualcuno ha qualche idea? oppure qualcuno ha avuto lo stesso problema?

    Grazie

     

    • Modificato Anca Popa martedì 15 marzo 2011 13:58 titolo
    • Tipo modificato Anca Popa lunedì 21 marzo 2011 14:43 ricerca di una soluzione
    • Tipo modificato Anca Popa giovedì 28 aprile 2011 10:58 domanda con soluzione
    mercoledì 9 marzo 2011 10:54

Risposte

  • Ciao a tutti, Magari non è una soluzione valida alle persone che hanno questo problema, ma posto comunque quello che ho modificato:

    Dall'EMC sono andato nella "Server Configuration" - "Client Access" - "Exchange Active Sync", clic destro "Properties" su "Microsoft Exchange Server Ative Sync" nel tab "Authentication" ho selezionato la "Basic Authentication e ho selezionato "Accept Client Certificate".

    Con questa configurazione l'i-phone funziona e scarica tutti i contenuti correttamente.

    Grazie mille a tutti per l'aiuto. :-)

     

    • Contrassegnato come risposta Anca Popa giovedì 28 aprile 2011 10:59
    mercoledì 27 aprile 2011 15:50

Tutte le risposte

  • ma hai installato il certificato nell'iphone ?
    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    mercoledì 9 marzo 2011 11:37
  • Si l'i-phone mi ha chiesto di accettare il certificato self-signed di exchange, ovviamente ho premuto "si" per accettare ma non è servito a nulla.

    Sempre solito errore : "unable to verify account information"

     

     

    giovedì 10 marzo 2011 12:49
  • prova ad usare questo http://support.apple.com/kb/DL926 per configurare il tuo iPhone.

    ciao.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    • Contrassegnato come risposta Anca Popa martedì 15 marzo 2011 07:42
    • Contrassegno come risposta annullato Anca Popa lunedì 21 marzo 2011 14:40
    giovedì 10 marzo 2011 13:09
  • Ciao Dani,

    Suppongo che i suggerimenti ricevuti ti sono stati utili e per ora ho segnato la risposta. Comunque se ritieni di aver bisogno di ulteriori indicazioni non esitare a postare nel forum.

     

    Se hai risolto in altro modo, ti prego di voler condividere la soluzione con la community, in modo che possa essere trovata e utilizzata dagli altri membri che hanno domande simili.

     

    Un saluto,


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 15 marzo 2011 07:41
  • Ciao Anca Popa, scusa se non ho più risposto ma purtoppo non ho avuto molto tempo per testare la cosa.

    Purtoppo non sono riuscito a risolvere neanche con il software che mi avevi indicato, ho anche (nel frattempo) installato un certificato SSL validato da GeoTrust, ma nonostante l'installazione del certificato valido le cose non si sono  risolte, continua a tornarmi lo stesso errore, "unable to verify account information".

     

    Grazie mille per l'aiuto

     

    Un saluto

     

    lunedì 21 marzo 2011 14:36
  • Ciao,

    Ti è possibile di provare a accedere con lo stesso account tramite Windows Mobile invece di iPhone?

    Fai sapere se ti esce lo stesso errore.


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 22 marzo 2011 14:53
  • Ciao, purtoppo  non ho modo di provare perchè non ho nessun dispositivo con windows mobile. Ti confermo anche che l'errore non capita su un solo i-phone ma su + i-phone. Quindi si tratta (credo) di qualche impostazione generale..

     

    Grazie dell'aiuto, e della pazienza..

     

    mercoledì 23 marzo 2011 15:39
  • allora... comincia a scaricare su un pc ActiveSync Tester che trovi qui

    https://store.accessmylan.com/main/promo-testtool

    eseguilo verso il tuo server Exchange mettendo i parametri di autenticazione di uno dei tuoi account e riporta qui l'esito che ottieni.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 24 marzo 2011 08:32
  • Fino a quando riesci a eseguire ActiveSync Tester, come ti ha consigliato Edoardo, proverei a vedere se anch’io ottengo lo stesso errore.

    Sarebbe possibile di creare un utente di test e di girarmi via mail:

    il nome dell'account

    il dominio

    la password

    la URL per ActiveSync

    se usi SSL e se il tuo certificato non è gia installato sul device: anche il certificato

    all'indirizzo forumtechnet [at] hotmail [dot] com?  


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda


    • Modificato Anca Popa giovedì 28 aprile 2011 11:00 formattazione sorgente HTML
    giovedì 24 marzo 2011 09:00
  • Ciao a tutti, scusate il ritardo nella risposta ma la febbre ha vinto su di me!

    Comunque, ho scaricato il tool che mi avete consigliato, vi allego quindi il report che mi ha restituito:

    Testing exchange.miodominio.com (SSL, On Internet):

    Communications:
        Doing DNS lookup on exchange.miodominio.com  OK (indirizzo ip)
        Testing TCP to indirizzo ip port 443 ... OK
    SSL Certificate:
        Receiving ................................ OK
        Ensuring not Self-Signed ................. OK
        Verifying certificate .................... OK
    ActiveSync:
        Checking for application ................. OK
        Checking version ......................... FAIL

    Result:
        Username or Password incorrect.

        (For more detailed diagnosis and possible solutions, see www.accessmylan.com )

    ?

    La voce "checking version" fa riferimento alla versione di cosa ?

    Inoltre il log sostiene che inserisco username, password o dominio in maniera scorretta.. ma.. non è così, le credenziali sono corrette, sono riuscito a loggarmi su una macchina con quelle credenziali senza avere alcun problema.

    Grazie mille per l'aiuto.

     

    lunedì 28 marzo 2011 13:56
  • Ciao Dani,

    ti consiglierei di controllare i permessi sugli utenti,

    apri active directory, abilita la visualizzazione avanzata (view -> advanced features)

    a questo punto vai nelle proprietà dell'utente che stai provando ad usare e seleziona la scheda security, nei permessi che ti mostra clicca su advanced e a questo punto nella schermata che compare controlla che la check box "include inheritable permissions from this object's parent" sia abilitata.

     

    fammi sapere

     

    Alessio

    lunedì 28 marzo 2011 14:34
  • in fondo al test hai un pulsante "Diagnosis" che ti rimanda al sito di accessmylan dove ti vengono fornite le spiegazioni degli errori che hai ottenuto.

    l'errore sulla versione significa che non hai una versione aggiornata o identificata dal software di test (io ho fatto la prova adesso col mio ed ottengo il numero di versione corretta)

    l'errore sulle credenziali è più grave e può dipendere da come immetti le credenziali. per esempio io metto nello username sia il dominio che lo username nella notazione [dominio]\[username] e lascio il campo dominio in basso vuoto.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 28 marzo 2011 15:18
  • Ciao a tutti dinuovo...

    Risposta per Alessio:

    Le check box che mi hai indicato sono abilitate, per essere sicuro l'ho anche controllato su tutti gli utenti.

    Risposta per Edoardo:

    cliccando su "Diagnose" ottengo quanto segue:

    Diagnosis - The Username or Password incorrect.
    The username and/or password specified is incorrect. Your Exchange environment may require that the domain name is explicitly specified. If unsure, you can leave the domain field in the test tool blank.

    Ho provato ovviamente le varianti [dominio]\[username] con campo "dominio" vuoto; e la variante con tutti e tre i campi inseriti. Sono al 100 % certo di aver inserito le credenziali corrette perchè ho provato a fare un login e funzionano.

    Per quanto rigurda il FAIL sulla versione continua a rimanere.

    Come indicavo nei post precendenti sto utilizzando un Exchange 2007 su un server Win 2008 SBE, potrebbe essere legato a qualche problema di versione di active sync ? Non so più che pensare...

    Grazie

     

    lunedì 28 marzo 2011 20:43
  • Risposta per Edoardo:

    cliccando su "Diagnose" ottengo quanto segue:

    Diagnosis - The Username or Password incorrect.
    The username and/or password specified is incorrect. Your Exchange environment may require that the domain name is explicitly specified. If unsure, you can leave the domain field in the test tool blank.

    Ho provato ovviamente le varianti [dominio]\[username] con campo "dominio" vuoto; e la variante con tutti e tre i campi inseriti. Sono al 100 % certo di aver inserito le credenziali corrette perchè ho provato a fare un login e funzionano.

    Per quanto rigurda il FAIL sulla versione continua a rimanere.

    Come indicavo nei post precendenti sto utilizzando un Exchange 2007 su un server Win 2008 SBE, potrebbe essere legato a qualche problema di versione di active sync ? Non so più che pensare...

    Grazie

    hai provato ad eseguire il test con un account diverso ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 29 marzo 2011 09:30
  • Si ho provato ad eseguire il test con 3 account differenti... niente...

     

    martedì 29 marzo 2011 13:14
  • Si ho provato ad eseguire il test con 3 account differenti... niente...

     

    Hai letto anche quanto ti avevo suggerito sopra, di creare un account di test e di girarmi i dati necessari via mail?


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 29 marzo 2011 13:19
  • Si, scusa ho letto ora a che indirizzo posso mandare il tutto ?
    martedì 29 marzo 2011 13:46
  • Si, scusa ho letto ora a che indirizzo posso mandare il tutto ?

    forumtechnet [at] hotmail [dot] com


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 29 marzo 2011 14:27
  • Ti ho inviato i dati, grazie mille.

     

    martedì 29 marzo 2011 15:17
  • Grazie Daniele, ho visto la mail. Appena riesco a fare una prova, scrivo qui l'esito del mio test.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 31 marzo 2011 13:51
  • Ciao Daniele,

    Aggiorno anche il quesito sul forum, il mio consiglio è stato di creare un nuovo certificato, impostare correttamente il Subject Alternative Name (come spiegato via mail), poi metterlo sul server Client Access.

    In attesa di un gradito riscontro, spero che i miei suggerimenti ti siano di aiuto nel risolvere.

    Saluti, 


    Anca Popa Follow ForumTechNetIt on Twitter

    Dov'è finito l'event ID 1221 in Exchange Server 2010?  

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 5 aprile 2011 10:01
  • in tutti i casi, a questo punto, visto che non ti funziona neppure ActiveSync Tester, il problema non è certamente su Iphone ma sul tuo server Exchange.

    OWA funziona regolarmente ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 5 aprile 2011 10:53
  • Ciao a tutti, Magari non è una soluzione valida alle persone che hanno questo problema, ma posto comunque quello che ho modificato:

    Dall'EMC sono andato nella "Server Configuration" - "Client Access" - "Exchange Active Sync", clic destro "Properties" su "Microsoft Exchange Server Ative Sync" nel tab "Authentication" ho selezionato la "Basic Authentication e ho selezionato "Accept Client Certificate".

    Con questa configurazione l'i-phone funziona e scarica tutti i contenuti correttamente.

    Grazie mille a tutti per l'aiuto. :-)

     

    • Contrassegnato come risposta Anca Popa giovedì 28 aprile 2011 10:59
    mercoledì 27 aprile 2011 15:50
  • Dall'EMC sono andato nella "Server Configuration" - "Client Access" - "Exchange Active Sync", clic destro "Properties" su "Microsoft Exchange Server Ative Sync" nel tab "Authentication" ho selezionato la "Basic Authentication e ho selezionato "Accept Client Certificate".

     


    grazie del feedback ma se non era impostata la basic authentication sin dall'inizio non poteva funzionarti alcunchè.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 28 aprile 2011 07:41
  • Quindi sull'Exchange 2007 in Windows 2008 SBE la basic authentication non è selezionata di default? Pongo la domanda in quanto ho installato già degli Exchange 2007 su Windows 2008 STD e non ho dovuto abilitare e configurare niente per gli i-phone, sono andati subito al primo colpo.

    Grazie

    giovedì 28 aprile 2011 10:57
  • sei sicuro che qualcuno non sia andato a "smanettare" con le autenticazioni in iis manager ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 28 aprile 2011 11:10
  • L'autorizzazione d'accesso a questa macchina ce l'ho solo io, quindi escluderei che qualcuno ci abbia messo le mani..

    L'importante è che ora sia risolto! Grazie mille a tutti della pazienza e del supporto tecnico.

     

    giovedì 28 aprile 2011 11:27
  • Ciao Daniele,

    Ti ringrazio anch'io di aver condiviso la soluzione con la community, sono contenta di sapere che adesso e' tutto a posto.

    Per quanto riguarda la basic authentication, Edoardo ti ha risposto implicitamente: normalmente, quella dovrebbe essere abilitata di default.

    Molte grazie del feedback e buona giornata,

     


    Anca Popa Follow ForumTechNetIt on Twitter

    SBS 2011 Essentials: download, documentazione e video

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 28 aprile 2011 11:32