none
database corrotto ed Exchange fermo! RRS feed

  • Domanda

  • sbs 2008 con exchange 2007.

    Ho il database delle cassette postali ( first storage group) che risulta corrotto a seguito di uno spegnimento improvviso (UPS rotto).

    Ho tentato il ripristino attraverso le utilità messe a disposizione dalla consolle, ma il database risulta in dirty mode e non montabile.

    ho il backup eseguito con il wizard dello sbs ed ho seguito la procedura di recupero da Recovery Storage Group, come indicato qui:http://www.petri.co.il/restoring_exchange_mailbox_recovery_storage_group_part1.htm, ma al momento di copiare i dati mi dice che non ci sono email con i criteri scelti (ho lasciato tutte le impostazioni di default).

    Non riesco a far ripartire il server Exchange....help!

    inizio ad essere disperato!

    umbe


    • Modificato umbi.zeta giovedì 16 febbraio 2012 09:14
    giovedì 16 febbraio 2012 09:13

Risposte

  • grazie peppacci, ho appena risolto!! ecco cosa è successo, caso mai servisse a qualcuno.

    durante il ripristino da backup, avevo lasciata spuntata l'opzione di default "mantieni la copia dei dati", credendo che il sistema rinominasse i file già presenti e li sostituisse con quelli recuperati dal backup. Invece ha fatto esattamente il contrario e cioè ha lasciato i file originali e rinominato i file recuperati dal backup. Di questo me ne sono accorto andando a spulciare dentro la cartella dello First Storage Group e controllando le date.

    Ho quindi fermato il servizio Archivio informazione e rinominato correttamente i file , quindi riavviato e montato senza problemi il data base recuperato dal back up, previa analisi sullo stato del db. (che era in semplice "chiusura anomala" e non in "dirty state")

    Adesso smonto il recovery storage group e dovrei essere a posto.

    Grazie mille a tutti.

    Umbe

    giovedì 16 febbraio 2012 09:51

Tutte le risposte

  • Usa l'utility eseutil.exe, provando prima con un recovery e nel caso un un repair

    http://technet.microsoft.com/en-us/library/aa998249(v=exchg.80).aspx


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    giovedì 16 febbraio 2012 09:33
    Moderatore
  • grazie peppacci, ho appena risolto!! ecco cosa è successo, caso mai servisse a qualcuno.

    durante il ripristino da backup, avevo lasciata spuntata l'opzione di default "mantieni la copia dei dati", credendo che il sistema rinominasse i file già presenti e li sostituisse con quelli recuperati dal backup. Invece ha fatto esattamente il contrario e cioè ha lasciato i file originali e rinominato i file recuperati dal backup. Di questo me ne sono accorto andando a spulciare dentro la cartella dello First Storage Group e controllando le date.

    Ho quindi fermato il servizio Archivio informazione e rinominato correttamente i file , quindi riavviato e montato senza problemi il data base recuperato dal back up, previa analisi sullo stato del db. (che era in semplice "chiusura anomala" e non in "dirty state")

    Adesso smonto il recovery storage group e dovrei essere a posto.

    Grazie mille a tutti.

    Umbe

    giovedì 16 febbraio 2012 09:51
  • Grazie per il feedback

    Ciao.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    giovedì 16 febbraio 2012 09:55
    Moderatore
  • + 1

    Grazie di aver condiviso la soluzione con la community!


    Anca Popa Follow ForumTechNetIt on Twitter

    Versioni di valutazione gratuite dei software Microsoft

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    venerdì 17 febbraio 2012 09:45