none
Errori windows 2008 r2 con VSS RRS feed

  • Domanda

  • Ciao ragazzi,

    In questi giorni ho avuto dei problemi con un server 2008r2 (virtuale su vmware vsphere 4.1) che dopo aver disinstallato un agent di backupexec 2010, questo ha iniziato a dare degli errori del servizio vss quando faccio il backup del disco. Il problema, è il classico problema dei componenti com non registrati. In windows 2003 si risolveva il problema registrando con questa procedura:

    Cd %systemroot%\system32
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll
    regsvr32 vssui.dll
    Vssvc /Register
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 msxml3.dll

    Purtroppo con windows 2008 R2 questo funziona in parte anche provando la procedura per i 64bit:

    Cd %systemroot%\syswow64
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 msxml3.dll
    regsvr32 msxml.dll
    regsvr32 msxml4.dll

    Purtroppo registrando alcune librerie (es.dll) compare il messaggio "Il modulo "es.dll" è stato caricato, ma il punto di ingresso DllRegisterServer non è stato trovato."
    Putroppo Se non triesco registrare tutte le dll (a parte quelle che non ci sono nel disco :-) ) non posso far ripartire le snapshot.
    Potete darmi una mano ?

    Grazie

    mercoledì 10 novembre 2010 22:33

Risposte

  • Eppure, seguendo quanto scritto in questo aticolo (il riferimento è SBS2008) secondo me dovresti riuscire.

    Ricordati

    a) di stoppare i servizi, come vedi nel batch di "esempio"

    b) di verificare la lista dei provider VSS e rimuovere quelli non Microsoft

    http://forums.techarena.in/small-business-server/1289753.htm


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 16 novembre 2010 08:56

Tutte le risposte

  • Sarebbe meglio se tu postassi prima l'errore VSS di cui parli.

    Non è detto che il problema sia proprio sulle dll.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 11 novembre 2010 05:59
  • Scusatemi.. hai ragione, avevo dato per scontato la cosa.
    Questi gli errori nel registro applicazione dell event viewer, ve ne posto 2 che fanno riferimento ad una intrfaccia. In totale ho 2 interfaccie non registrate.
    Grazie

    ID Evento: 22

    Origine: VSS

    Errore del servizio Copia Shadow del volume: un componente critico richiesto dal servizio Copia Shadow del volume non è registrato. Il problema può essere dovuto a un errore durante l'installazione di Windows o di un provider di copie shadow. Errore restituito da CoCreateInstance sulla classe con CLSID {06d8e136-56f6-4048-93fb-a5943e949375} e nome SW_PROV: [0x80040154, Interfaccia non registrata.

    ].

    Operazione:

    Recupera un'interfaccia chiamabile per il provider

    Elenca le interfacce per tutti i provider che supportano questo contesto

    Controlla se il volume è supportato dal provider

    Aggiungi un volume a un insieme di copie shadow

    Contesto:

    ID provider: {5fdb6ef5-6ead-4610-995b-401c88626115}

    ID classe: {06d8e136-56f6-4048-93fb-a5943e949375}

    Contesto snapshot: 4194304

    Contesto snapshot: 4194304

    Contesto di esecuzione: Coordinator

    ID provider: {00000000-0000-0000-0000-000000000000}

    Nome volume:

    \\?\Volume{727c1ae2-f45f-11de-b9af-806e6f6e6963}\

    Contesto di esecuzione: Coordinator

    ID Evento: 12292

    Origine: VSS

    Errore del servizio Copia Shadow del volume: errore nella creazione della classe COM del provider di copie shadow con CLSID {06d8e136-56f6-4048-93fb-a5943e949375} [0x80040154, Interfaccia non registrata.

    ].

    Operazione:

    Recupera un'interfaccia chiamabile per il provider

    Elenca le interfacce per tutti i provider che supportano questo contesto

    Controlla se il volume è supportato dal provider

    Aggiungi un volume a un insieme di copie shadow

    Contesto:

    ID provider: {5fdb6ef5-6ead-4610-995b-401c88626115}

    ID classe: {06d8e136-56f6-4048-93fb-a5943e949375}

    Contesto snapshot: 4194304

    Contesto snapshot: 4194304

    Contesto di esecuzione: Coordinator

    ID provider: {00000000-0000-0000-0000-000000000000}

    Nome volume:

    \\?\Volume{727c1ae2-f45f-11de-b9af-806e6f6e6963}\

    Contesto di esecuzione: Coordinator

     

    giovedì 11 novembre 2010 08:48
  • riprova con i comandi indicati qui

    http://support.microsoft.com/kb/940032

    riportando quali non funzionano in win2k8 e con quale esito.

    ciao.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    giovedì 11 novembre 2010 09:00
    Moderatore
  • Infatti è la procedura che si segue di solito in win2003 e che risolve il problema ma in win2008r2 purtroppo no.
    Ti riporto sotto  i nomi delle dll che non vanno e queli errori danno.

    Swprl.dll (Il modulo "swprv.dll" è stato caricato, ma la chiamata a DllRegisterServer non è riuscita. Codice di Errore 0x8007015)
    Eventcls.dll (Il modulo "eventcls.dll" è stato caricato, ma la chiamata a DllRegisterServer non è riuscita. Codice di Errore 0x8007015)
    Vssui.dll (Il modulo "eventcls.dll" è stato caricato, ma la chiamata a DllRegisterServer non è riuscita. Codice di Errore 0x8007015)
    Es.dll (Il modulo "es.dll" è stato caricato, ma il punto di ingresso DllRegisterServer non è stato trovato. Controllare che "es.dll" sia un file OCX o una Dll valido)

    Grazie

    giovedì 11 novembre 2010 11:01
  • io proverei a rimuovere Windows Server Backup Features e a reinstallarlo.

    ho già sentito altre volte che la disinstallazione di backupexec provoca il danneggiamento di VSS.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    giovedì 11 novembre 2010 16:06
    Moderatore
  • E' vero, con backupexec può succedere ma con quella procedura postata ieri si recuperava.
    Non ho installato Windows Server Backup Features ma ho provato ad installarlo senza nessun risultato.

    Il problema è come fare a ripristinare i componenti del VSS in windows 2008 R2. Forse il problema sono i 64 bit ma sinceramente ho provato anche fare la procedura nella directory syswow64 ma il risultato è stato lo stesso.

    Grazie mille.

    giovedì 11 novembre 2010 21:22
  • Valuta anche questa possibilità (l'articolo non è legato a Windows 2008 ma vale la pena verificare)

    If you have installed a Backup Solution that uses its own Volume shadow Copy provider, switch back to the default provider. To do this, open the Registry Editor, and find and modify the following registry key:

    HKLM\SYSTEM\CurrentControlSet\Control\BackupRestore

    Value Name: UseMicrosoftProvider
    Value Type: REG_DWORD
    Value Data: 1

    http://blogs.technet.com/b/asksbs/archive/2008/04/23/troubleshooting-vss-and-backup.aspx


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 12 novembre 2010 00:45
  • Purtroppo non funziona. Ho le stesse segnalazioni.
    Il fatto che anche questa soluzione va bene per il 2003 e inoltre io già uso il provider di default di windows.

    Possibile che non si possa ri-registrare le interfacce VSS ?
    Oppure la possibilità di reinstallare la parte VSS di windows ?

     

    Grazie comunque

    venerdì 12 novembre 2010 23:00
  • prova a mettere il dvd del sistema oeprativo nel lettore e lanciare un sfc /scannow per vedere se la ri-registrazione dei files di sistema ristabilisce la funzionalità.

    ciao.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    domenica 14 novembre 2010 08:43
    Moderatore
  • Grazie per la risposta, ma purtroppo non è la soluzione corretta.
    Ho fatto delle prove e se provatre a registrare queste dll anche in un' installazione ex nova, vi accorgerete che restituisce loi stesso errorre.
    Possibile che ci siano delle dll che non si possono registrare ?

    Spero in un vostro aiuto.

    lunedì 15 novembre 2010 20:38
  • Eppure, seguendo quanto scritto in questo aticolo (il riferimento è SBS2008) secondo me dovresti riuscire.

    Ricordati

    a) di stoppare i servizi, come vedi nel batch di "esempio"

    b) di verificare la lista dei provider VSS e rimuovere quelli non Microsoft

    http://forums.techarena.in/small-business-server/1289753.htm


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 16 novembre 2010 08:56
  • Ciao a tutti,

    Scusate l'intrusione, inanzittutto ringrazio Fabrizio e Edoardo dell'interessamento.

    Per ora un piccolo commento: in attesa di ulteriori feedback, ho contrassegnato come risposta l'ultimo post di Fabrizio, ritengo che i consigli proposti siano validi.

    @Zaffo69: fai sapere com'e' andata.

    Ciao.

     


    Anca Popa Follow ForumTechNetIt on Twitter

    FAQ:

    Hyper-V Download e documentazione

    Gestione delle Performance in ambienti virtualizzati: Monitoraggio del Processore

    Virtualizzazione e Failover Cluster

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft. 

    mercoledì 17 novembre 2010 13:29
  • Ciao a tutti... scusate il ritardo della mia risposta, ma purtroppo sono stato molto indaffarato...
    Ho fatto quanto hai detto ed è bastato cancellare il provider "Backup Exec VSS" e il backup del sistema ha ricominciato a funzionare.
    Quindi penso che la tua soluzione sia quella corretta, anche se non mi spiego come mai gli altri server che hanno la stessa configurazione funzionano senza problemi.

    Domani farò dei test più approfonditi con backup più completi.
    Comunque ho la causa dell' errore e cercherò di capire qualche cosa di più.
    Vi terrò informati.

    Grazie di tutto

    Ciao

    mercoledì 17 novembre 2010 22:32