none
SQL Management Studio 2008 RRS feed

  • Domanda

  • Buongiorno. su un server dove c'era già installato sql express 2005, ho dovuto istallare il 2008 standard, facendo procedere alla creazione di una nuova istanza denominata diversamente. quando però sono andata per installare anche la management console di 2008, mi diceva di procedere prima alla disinstallazione di quella già esistente e che utilizzavo per il 2005. l'ho tolta, ho aggiutno il componente all'istanza 2008 precedentemente creata e me l'ha fatto senza segnalare errori. solo che ora che provo a far partire il management console mi dice che non trova file della libreria ecc ecc e dopo aver dato ok più volte alla fine il programma non si apre. vi mando in allegato esattamente lo screen dell'errore. grazie mille !
    mercoledì 24 agosto 2011 16:48

Risposte

  • assolutamente si, ma anche lì nulla di fatto. siccome avevo il sentore che il so proprio avesse dei problemi e siccome purtroppo tempo fa nel tentativo di "pulirlo" da un trojan i miei colleghi hanno provato un pò il tutto per tutto, alla fine abbiamo convenuto che era meglio formattare e ripartire da zero, tanto che ora infatti va tutto più che bene. grazie mille comunque
    mercoledì 31 agosto 2011 09:01

Tutte le risposte

  • Ciao Cristina,

    non ho mai avuto modo di vedere questo problema. Ti suggerirei di lanciare la riparazione dell'installazione di SQL Server 2008, lanciandola con un utente amministratore della macchina. Verifica, prima di lanciare il setup, che il framework 3.5 SP1 sia installato sul server in questione.

    Se non dovesse funzionare, prova ad utilizzare il tool Process Monitor di Microsoft (ex Sysinternals) per verificare se è un problema di permessi (Access Denied su filesystem o registry quando apri SSMS) ed eventualmente dai un occhiata a questo thread.

    HTH

     


    Danilo Dominici MCP MCDBA MCITP MCSE MCAD Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    giovedì 25 agosto 2011 13:49
  • effettivamente qualcosina potrebbe esserci..sul process monitor faccio uan ricerca solo su ssms.exe che è il tools che mi interessa e in alcune parti del registro mi dice che il dile è mancante, in explorer di mice che il file è disponibile solo in lettura..sono andata a verificare ed effettivamente a tutta la cartella programmi (che poi io vedo scritto programmi, per lui è program data) è cartella sola lettura...mha...l'unico problema è che se provo a togliere il flag su tutta la cartella programmi mi da errore di accesso e dice che non posso procedere, l'ho fatto solo su tutta la cartella di sql, me lo fa, ma se poi ci ritorno dentro mi rimette da solo sto flag di sola lettura......come mai??
    venerdì 26 agosto 2011 08:05
  • Hai già provato a fare la repair dell'installazione di SQL Server ?

    Per sistemare i permessi usa le indicazioni del thread che ti ho indicato ieri, sennò potresti rischiare di fare danni al S.O.

    Ciao!


    Danilo Dominici MCP MCDBA MCITP MCSE MCAD Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    venerdì 26 agosto 2011 08:15
  • assolutamente si, ma anche lì nulla di fatto. siccome avevo il sentore che il so proprio avesse dei problemi e siccome purtroppo tempo fa nel tentativo di "pulirlo" da un trojan i miei colleghi hanno provato un pò il tutto per tutto, alla fine abbiamo convenuto che era meglio formattare e ripartire da zero, tanto che ora infatti va tutto più che bene. grazie mille comunque
    mercoledì 31 agosto 2011 09:01