none
Problema singolare su DAG con Exchange 2010, nvspbind e APIPA RRS feed

  • Discussione generale

  • Salve a tutti,

    Sono cascato esattamente nel problema descritto da Henrik Walther in questo articolo http://technet.microsoft.com/en-us/magazine/gg314976.aspx e l'ho applicato come suggerito l'nvspbind per cambiare l'ordine di binding della scheda nascosta del cluster. 

    Tutto ha funzionato correttamente per circa 1 mese, quando poi improvvisamente il problema si è ripresentato. Oggi quando viene spedito un messaggio verso l'esterno, negli header compare 169.254.x.x come indirizzo interno del server anzichè l'indirizzo 10.x.x.x reale. Rieseguire "nvspbind /- "local area connection* 9" ms_tcpip" e riavviato i nodi, non ha portato a risultati

    Ad oggi se interrogo l'ordine delle schede trovo 

    1. LAN

    2. Heartbeat

    2. MS_TCPIP (che è la scheda nascosa del cluster)

    Questo non lo troverei nemmeno un problema se non fosse che mi sta impedendo un corretto message tracking dal Tracking Log Explorer. Infatti in ogni riga in cui trova 169.254.x.x non vedo il destinatario del messaggio tracciato (se questo è al di fuori della organization).

    Qualche idea? 

    Grazie mille!

    • Tipo modificato Anca Popa martedì 24 settembre 2013 13:08 discussione in corso
    giovedì 19 settembre 2013 20:42

Tutte le risposte

  • Ciao Massimo,

    quindi ora l'ordine di binding è corretto? Su entrambi i server?

    Puoi allegare un output di "nvspbind.exe /o ms_tcpip" dei server?

    Roberto


    IT Consultant | Microsoft MCSE MCTS MCITP MCT MCSA ------------------------------------------ If you found my post helpful, please give it a Helpful vote ------------------------------------------ If it answered your question, remember to mark it as an Answer -----------------------------------

    venerdì 20 settembre 2013 21:44
    Moderatore
  • Ciao Roberto

    L'ordine purtroppo sembra giusto. Per entrambi i nodi questo è il risultato

    PS D:\NVSPBind> .\nvspbind.exe -o ms_tcpip
    
    Hyper-V Network VSP Bind Application 6.1.7725.0.
    Copyright (c) Microsoft Corporation. All rights reserved.
    
    Protocols:
    
    {D7DBFF6D-F51F-4C94-BF35-9CFEBEBA7578}
    "ms_tcpip"
    "Internet Protocol Version 4 (TCP/IPv4)":
       enabled:   PROD
       enabled:   Cluster
       enabled:   Local Area Connection* 9
    
    cleaning up...finished (0)

    Ad oggi è questo ma l'ho provato anche lasciando la PROD come prima scheda e la scheda *9 come seconda scheda... il risultato non cambia... negli header mi trovo sempre il 169.254 (e ripeto... questo non sarebbe un problema) e di conseguenza anche nel msg tracking non riesco a tracciare dove comapre 169.254 

    Qua sotto: se viene mandato un messaggio INTRA-ORGANIZATION, compare sia l'IP giusto che il recipient giusto nella colonna relativa.... se invece viene mandato un messaggio verso internet, il ClientIP che compare è l'IP APIPA e la colonna recipient in corrispondenza è vuota.

    Di fatto, non riesco a tracciare i messaggi... e questo è un problema! :-(

    martedì 24 settembre 2013 08:22