none
memoria sql 2005 RRS feed

  • Domanda

  • Ciao,
    ho un cluster sql 2005 (con ultime sp) 2 nodi active\passive (win serv 2003 r2 come Sistema operativo). Su questo sql gira un unica istanza.
    Il problema è che poichè la macchina è sotto monitoring, sul nodo attivo mi scatta spesso l'allarme per la 'memoria libera' che scende sotto il 10%. La macchina non dà disservizio, non ho lamentele da parte degli utenti però vorrei evitare che sql si prenda tutta la memoria...
    La macchina ha 4 GB di ram e non ha il flag sul file boot.ini /3GB. Mi sembra di capire (da un post scritto in passato) che il parametro: maximum server memory non serve a molto...

    grazie

    Gianni

    venerdì 19 novembre 2010 09:36

Risposte

  • ho un cluster sql 2005 (con ultime sp) 2 nodi active\passive (win serv 2003 r2 come Sistema operativo). Su questo sql gira un unica istanza.
    Il problema è che poichè la macchina è sotto monitoring, sul nodo attivo mi scatta spesso l'allarme per la 'memoria libera' che scende sotto il 10%. La macchina non dà disservizio, non ho lamentele da parte degli utenti però vorrei evitare che sql si prenda tutta la memoria...
    La macchina ha 4 GB di ram e non ha il flag sul file boot.ini /3GB. Mi sembra di capire (da un post scritto in passato) che il parametro: maximum server memory non srve a molto...

    Ciao Gianni,

    SQL Server è progettato per utilizzare tutta la memoria disponibile, rilasciandola quando richiesto dall'OS. Dato che hai solo 1 istanza clusterizzata non vedo il motivo di doverla limitare.

    Ciao!


    Lorenzo Benaglia
    Microsoft MVP - SQL Server
    http://blogs.dotnethell.it/lorenzo
    http://social.microsoft.com/Forums/it-IT/sqlserverit
    • Contrassegnato come risposta gianni123 mercoledì 24 novembre 2010 11:54
    martedì 23 novembre 2010 08:59
    Moderatore

Tutte le risposte

  • ho un cluster sql 2005 (con ultime sp) 2 nodi active\passive (win serv 2003 r2 come Sistema operativo). Su questo sql gira un unica istanza.
    Il problema è che poichè la macchina è sotto monitoring, sul nodo attivo mi scatta spesso l'allarme per la 'memoria libera' che scende sotto il 10%. La macchina non dà disservizio, non ho lamentele da parte degli utenti però vorrei evitare che sql si prenda tutta la memoria...
    La macchina ha 4 GB di ram e non ha il flag sul file boot.ini /3GB. Mi sembra di capire (da un post scritto in passato) che il parametro: maximum server memory non srve a molto...

    Ciao Gianni,

    SQL Server è progettato per utilizzare tutta la memoria disponibile, rilasciandola quando richiesto dall'OS. Dato che hai solo 1 istanza clusterizzata non vedo il motivo di doverla limitare.

    Ciao!


    Lorenzo Benaglia
    Microsoft MVP - SQL Server
    http://blogs.dotnethell.it/lorenzo
    http://social.microsoft.com/Forums/it-IT/sqlserverit
    • Contrassegnato come risposta gianni123 mercoledì 24 novembre 2010 11:54
    martedì 23 novembre 2010 08:59
    Moderatore
  • si vero.

    L'unico problema è che mi scatta l'allarme. Cambio le soglie.

     

    Grzie MIlle

    Gianni

    mercoledì 24 novembre 2010 11:54