none
Windows Server 2012 R2 - problema RemoteApp e Windows XP - ridigitare password RRS feed

  • Domanda

  • Salve a tutti, ho questo scenario RDS:

    - 1 server principale SERVERT con i ruoli Gateway, Web, Gestore connessione e Licenze, a scopo puro desktop remoto

    - 1 server secondario SERVERT2 con il ruolo Gestore connessione a scopo RemoteApp

    Tramite "Connessione RemoteApp e desktop" di Windows 7 ho ricavato i file .RDP alle risorse. Su Windows XP salvo in "Gestione password" l'account a SERVERT.cliente.local. Se vado ad utilizzare il file RDP della risorsa Desktop Remoto, tutto parte in automatico e correttamente, se vado a utilizzare, sempre e solo su Windows XP, il file RDP della risorsa RemoteApp, mi viene richiesta continuamente la password con la motivazione: "Immettere le credenziali per SERVERT.cliente.local. L'utilizzo di credenziali salvate per l'accesso al computer remoto non è consentito dall'amministratore di sistema.". Ovviamente immettendo la password tutto funziona bene, ma io vorrei togliere questa continua richiesta. Su Windows 7, con le credenziali salvate, non viene mai richiesta la password ne per la risorsa Desktop Remoto ne per la risorsa RemoteApp.

    Mi sapete indicare quale autorizzazione configurare in modo tale da "agevolare" l'apertura della RemoteApp anche su Windows XP ?

    Grazie

    Simone Bosio

    venerdì 12 giugno 2015 09:16

Risposte

  • Come detto ho risolto il problema grazie ai vs. suggerimenti, ricerche e "olio di gomito" :-)

    Riassumo brevemente: Infrastruttura RDS 2012 R2, Windows XP SP3 (protocollo rdp 7.0, CreedSSP) continua a chiedere le credenziali all'apertura di una RemoteApp, non offre la possiblità di salvarle, e come motivazione dice "Immettere le credenziali per SERVERT.cliente.local. L'utilizzo di credenziali salvate per l'accesso al computer remoto non è consentito dall'amministratore di sistema."

    Soluzione: è necessario salvare le credenziali per ogni server RDS coinvolto nell'esecuzione della RemoteApp. Quindi: Windows XP --> Pannello di controllo --> Account utente --> Avanzate --> Gestione password --> aggiungere le credenziali sia per SERVERT.cliente.local che per SERVERT2.cliente.local

    Valutazione: il fatto che la sessione remote desktop classica funzionasse era perché il gestore coincideva con l'host sessione desktop remoto; nel caso della remoteapp, con gestore su SERVERT e host remoteapp su SERVERT2, si necessita della doppia autenticazione pre-salvata per evitare richieste

    Grazie a tutti

    Simone Bosio

    lunedì 15 giugno 2015 13:57

Tutte le risposte

  • Prova a installare la versione 7 del client e abilita CredSSP sul client (do per scontato che abbia SP3)

    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti


    • Modificato aperelli venerdì 12 giugno 2015 09:22
    venerdì 12 giugno 2015 09:21
  • Prova a installare la versione 7 del client e abilita CredSSP sul client (do per scontato che abbia SP3)


    Grazie per la risposta, si ti confermo che il client Windows XP è SP3, versione 7 del protocollo e CREDSSP attivata; questo infatti consente alla RemoteApp comunque di funzionare ma col problema appunto della continua richiesta della password solo su XP. Se il messaggio d'errore che ho indicato nel post principale è veritiero potrebbe esserci una qualche autorizzazione da modificare all'interno di XP, ma non so quale.

    Qualche idea?

    venerdì 12 giugno 2015 09:32
  • Hai verificato che le credenziali siano salvate?

    control userpasswords2, click Advanced tab, click Manage Passwords "

    Info


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    venerdì 12 giugno 2015 09:47
  • Hai verificato che le credenziali siano salvate?

    control userpasswords2, click Advanced tab, click Manage Passwords "

    Info


    Sì confermo, le credenziali sono salvate. Aprendo il file RDP della risorsa desktop remoto infatti vengono utilizzate, non viene richiesto quindi nessuna credenziale, e la sessione parte regolarmente in automatico. Il problema permane appunto solo con la RemoteApp. Sembra che la RemoteApp in Windows XP venga trattata in modo leggermente differente generando appunto il messaggio di richiesta continua delle credenziali.
    venerdì 12 giugno 2015 10:01
  • Ciao Simone, dai una lettura al seguente thread https://social.technet.microsoft.com/Forums/windowsserver/en-US/7fa8e22b-d779-4384-b939-6f8647eb1a65/remoteapp-returns-incorrect-password-error-when-launching-from-windows-xp-x64?forum=winserverTS ed al seguente post blog http://blogs.msdn.com/b/rds/archive/2007/04/19/how-to-enable-single-sign-on-for-my-terminal-server-connections.aspx

    Saluti
    Nino


    Grazie Nino per i link (il secondo mi era già capitato di vederlo durante varie ricerche).

    Non riesco a venirne a capo purtroppo, il cliente mi chiede di risolvere il problema in quanto non vuole digitare tutte le volte che apre una RemoteApp la password (su Windows XP, mentre su Windows 7 nessun problema)

    Attualmente i dubbi sono principalmente su 2 punti:

    1. trovare una chiave di registro in Windows XP che permetta di disattivare il messaggio "Immettere le credenziali per SERVERT.cliente.local. L'utilizzo di credenziali salvate per l'accesso al computer remoto non è consentito dall'amministratore di sistema."

    2. nel file RDP della RemoteApp c'è una variabile "sospetta": "prompt for credentials on client:i:1" attivata. Il file RDP non è modificabile perché contiene un CRC/MD5 (o simili); se lo modifico il sistema lo etichetta come corrotto. Come posso cambiare questo valore considerando che l'infrastruttura è RDS 2012 R2 ?

    lunedì 15 giugno 2015 09:30
  • Quello alla fine del file dovrebbe essere la signature.

    Se é cosí puoi rifirmarlo con rdpsign

    Oppure puoi fare un orribile workaround, togliere le righe con "signscope" e "signature" dal file rdp.

    Questo ti espone a seri problemi di sicurezza peró, qundi consiglio di rifirmare il file.


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    lunedì 15 giugno 2015 09:58
  • perchè non vai a ricrearti i file .rdp usando "Connessione RemoteApp e desktop" di Windows 7 dopo aver impostato "prompt for credentials on client" a zero ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    lunedì 15 giugno 2015 12:23
    Moderatore
  • perchè non vai a ricrearti i file .rdp usando "Connessione RemoteApp e desktop" di Windows 7 dopo aver impostato "prompt for credentials on client" a zero ?


    Grazie Edoardo, sì ci avevo pensato, ma non so come modificare i parametri nell'architettura RDP 2012 R2. Se non sbaglio in 2008 R2 si poteva editare nell'area di gestione remote desktop services, ma con la nuova struttura 2012/2012 R2 non saprei dove andare per fare la modifica e quindi ricreare poi, come hai suggerito, i file RDP sfruttando "Connessione RemoteApp e desktop" di Win7

    In ogni caso sono riuscito a risolvere il problema; sto razionalizzando un po' il tutto e poi posto la soluzione per chi si dovesse trovare nella mia stessa situazione.

    Grazie intanto

    lunedì 15 giugno 2015 12:55
  • Come detto ho risolto il problema grazie ai vs. suggerimenti, ricerche e "olio di gomito" :-)

    Riassumo brevemente: Infrastruttura RDS 2012 R2, Windows XP SP3 (protocollo rdp 7.0, CreedSSP) continua a chiedere le credenziali all'apertura di una RemoteApp, non offre la possiblità di salvarle, e come motivazione dice "Immettere le credenziali per SERVERT.cliente.local. L'utilizzo di credenziali salvate per l'accesso al computer remoto non è consentito dall'amministratore di sistema."

    Soluzione: è necessario salvare le credenziali per ogni server RDS coinvolto nell'esecuzione della RemoteApp. Quindi: Windows XP --> Pannello di controllo --> Account utente --> Avanzate --> Gestione password --> aggiungere le credenziali sia per SERVERT.cliente.local che per SERVERT2.cliente.local

    Valutazione: il fatto che la sessione remote desktop classica funzionasse era perché il gestore coincideva con l'host sessione desktop remoto; nel caso della remoteapp, con gestore su SERVERT e host remoteapp su SERVERT2, si necessita della doppia autenticazione pre-salvata per evitare richieste

    Grazie a tutti

    Simone Bosio

    lunedì 15 giugno 2015 13:57