none
Errore Certificato SSL Exchange 2010 su client outlook RRS feed

  • Domanda

  • Buongiorno, mi scuso se la domanda sia banale o se è gia stata trattata altrove, ma nella ricerca effettuata non ho trovato risoluzione. Ho installato un server exchange 2010 (sono agli inizi) e acquistato un certificato. Tutto funziona tranne per il fatto che su ogni client all'apertura di Outlook un avviso di sicurezza chiede di confermare se procedere o meno in quando il nome del certificato di sicurezza non è valido o non corrisponde al nome del sito. Premetto che ho gia provato ad installare il certificato sui client senza successo. Esiste un modo per evitare tale messaggio?

    Grazie in anticipo per le risposte.


    martedì 15 settembre 2015 07:49

Risposte

Tutte le risposte

  • Ciao, trattiamo la problematica continuamente...mi risulta strano che cercando su questo forum tu non abbia trovato almeno 10 thread identici al tuo che trattano la cosa..ti invito quindi, prima di iniziare l'ennesima trattazione dello stesso argomento a consultare il forum Exchange e cercare banalmente "errore certificato exchange 2010", poi se non ne esci ripartiremo ancora una volta...ma almeno ogni 2 mesi arriva qualcuno col tuo problema e posta la richiesta prima di aver guardato...

    Ora cambio anche il tuo titolo, prima di aprire una richiesta qui dovresti anche leggerti le linee guida: il sito è indicizzato ed il titolo deve essere descrittivo del problema altrimenti nessuno troverà mai nulla.

    Grazie della collaborazione.

    Ciao.

    A.


    martedì 15 settembre 2015 09:05
    Moderatore
  • Ciao,

    Exchange 2010 è fuori supporto ed Exchange 2016 è alle porte. Installare 2013 non sarebbe stato controindicato (tra l'altro, la gestione dei certificati con 2013 è più semplice) ;-)

    Il nome sul certificato è stato impostato sulle varie Virtual Directory di Exchange ? (OWA, ECP, Outlook Anywhere, OAB, EWS ed Autodiscover)

    Vedi https://technet.microsoft.com/en-us/library/aa997850(v=exchg.141).aspx per le varie procedure

    Ciao
    Gabriele

    P.S. Non ho visto il titolo prima della modifica ma ammetto che certe volte fatico anche io a trovare quello che mi serve :-)


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    martedì 15 settembre 2015 12:46

  • P.S. Non ho visto il titolo prima della modifica ma ammetto che certe volte fatico anche io a trovare quello che mi serve :-)


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    I agree..ma anche solo se googoli "errore certificato exchange 2010" forse 5 milioni di link li cavi fuori...;-) 

    A.

    martedì 15 settembre 2015 13:01
    Moderatore
  • I agree..ma anche solo se googoli "errore certificato exchange 2010" forse 5 milioni di link li cavi fuori...;-) 

    A.

    JOKE OT

    Ciao Ale e Gabriele,

    io "gugolato" con  stringa di Ale  "errore certificato exchange 2010"  e ho trovato solo questo thread!!!

    Gugle non è più quello di una volta ;)

    Ciao Gas


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    martedì 15 settembre 2015 21:34
    Moderatore
  • Io uso Bing.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    martedì 15 settembre 2015 21:37
  • @ Gas, ma che gugol usi? ah ah! a me il primo risultato da questo qui

    https://social.technet.microsoft.com/Forums/it-IT/4729e580-e850-4b4f-880d-62a8cd16d2d3/outlook-2010-exchange-2010-errore-certificato-apertura-outlook?forum=exchangeit

    che riporta qui da noi...

    @Gabriele..."io uso Bing" era assiomatico ;-)

    mercoledì 16 settembre 2015 07:22
    Moderatore
  • Ciao,

    Exchange 2010 è fuori supporto ed Exchange 2016 è alle porte. Installare 2013 non sarebbe stato controindicato (tra l'altro, la gestione dei certificati con 2013 è più semplice) ;-)

    Il nome sul certificato è stato impostato sulle varie Virtual Directory di Exchange ? (OWA, ECP, Outlook Anywhere, OAB, EWS ed Autodiscover)

    Vedi https://technet.microsoft.com/en-us/library/aa997850(v=exchg.141).aspx per le varie procedure

    Ciao
    Gabriele

    P.S. Non ho visto il titolo prima della modifica ma ammetto che certe volte fatico anche io a trovare quello che mi serve :-)


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"


    Grazie per la risposta, si è tutto impostato su mail.*******.it
    mercoledì 16 settembre 2015 07:38
  • Lanciando il comando Test-OutlookWebServices -Identity nomeutente, l'unico errore che da è il seguente:


           
    RunspaceId : 71f2fce7-91e8-4585-8e27-b9382ae85d6f
    Id         : 1004
    Type       : Error
    Message    : Il certificato per l'URL https://server2.*****.local/Autodiscover/Autodiscover.xml non è corretto. Aff
                 inché SSL funzioni, l'oggetto del certificato deve essere server2.*******.local, ma l'oggetto trovato è
                 mail.******.it. Si consiglia di correggere l'individuazione del servizio o di installare un certificato
                  SSL corretto.

    Ma non ho capito come risolvere.

    mercoledì 16 settembre 2015 08:34
  • Da Exchange Management Shell scrivi:

    get-clientaccessserver | set-clientaccessserver -autodiscoverserviceinternaluri https://mail.*****.it/Autodiscover/Autodiscover.xml 

    get-autodiscovervirtualdirectory | set-autodiscovervirtualdirectory -internalurl https://mail.*****.it/Autodiscover/Autodiscover.xml -externalurl https://mail.*****.it/Autodiscover/Autodiscover.xml

    N.B. Questo funzionerà solo per i PC joinati al Domino ed in grado di accedere ad AD.

    I PC non joinati o che non sono in grado di parlare con i DC useranno sempre https://autodiscover.*****.it/Autodiscover/Autodiscover.xml (avresti dovuto aggiungerlo al certificato) per cui l'errore continuerà a comparire.

    Exchange 2010 richiede certificati SAN o Wildcard in quanto deve "coprire" più nomi. Non solo mail.*****.it

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    • Contrassegnato come risposta Maria Atanassova martedì 22 settembre 2015 07:20
    mercoledì 16 settembre 2015 08:50
  • o cambi il record dns per l'autodiscover o cambi certificato.

    Questo articolo probabilmente ti puó chiarire alcune cose:

    http://exchangeserverpro.com/exchange-2010-ssl-certificates/


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    mercoledì 16 settembre 2015 08:50
  • Ciao Antonio,

    Il tuo thread nel Forum di TechNet è ancora aperto per noi.
    Se i consigli ricevuti ti sono stati utili, ricorda di evidenziare la soluzione cliccando su "Segna come Risposta". Aggiungo che il tuo riscontro tornerà sicuramente utile per chi si dovesse trovare nella medesima situazione, così è molto gradito dai membri della community se puoi condividere una soluzione tua.

    Grazie della collaborazione.


    • Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è e non comporta alcuna responsabilità da parte dell’azienda.

    venerdì 18 settembre 2015 09:08