none
WSUS: non compaiono i clients RRS feed

  • Domanda

  • Ho installato WSUS su un server membro di dominio Windows 2012 R2 che sembra funzionare correttamente e verifica e scrica regolarmente gli aggiornamenti.

    Ho poi configurato le GP di dominio per ordinare ai clients (tutti Windows 7 Pro) di recuperare gli aggiornamenti dal server con WSUS, ma i clients non compaiono nel server WSUS (che infatti avvisa che non si è registrato nessun computer per ricevere gli aggiornamenti) ed, ovviamente, manco ricevono gli aggiornamenti.

    Sembra tutto a posto, il percorso inserito nelle Group policy dovrebbe essere corretto (ho anche provato a giocare con le maiuscole/minuscole), ma l'elenco non viene alimentato ed il giochino non funziona.

    Cosa potrei controllare verificare?

    C'è un tool, un modo per capire / simulare / trovare qual è l'inghippo?

    Sul client, mediante GPRESULT le impostazioni di GP arrivano e risultano corrette. Anche le voci della registry riportano il percorso corretto, ma il tutto "non comunica"; visto così sembrerebbe che il percorso http://nomeserver non venga risolto correttamente (forse è un problema di case-sensitive?)......

    Grazie infinite a tutti coloro che tenteranno di aiutarmi.

    Giorgio

    giovedì 23 aprile 2015 15:42

Risposte

  • Pare che la porta sia cambiata su 2012:

    "After investigating I discovered in Server 2012 Microsoft changed the default WSUS port to 8530.  WSUS port by default was always port 80 in Server 2003 and Server 2008."

    REF: http://clintboessen.blogspot.ie/2013/07/clients-not-appearing-in-new-windows.html


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    • Contrassegnato come risposta Giorgio Premoli lunedì 27 aprile 2015 23:46
    venerdì 24 aprile 2015 07:35

Tutte le risposte

  • da quanto tempo i clients ricevono le policy per il server wsus ?

    i client sono stati installati mediante clonazione da immagine ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    giovedì 23 aprile 2015 15:45
    Moderatore
  • Ciao Edoardo,

    grazie per l'aiuto.

    I clients ricevono le policy da moolto tempo (quasi 6 mesi), ma se "interrogo" i clients, le policy risultano aggiornate; no, i clients non sono stati clonati.

    Prima, sullo stesso dominio c'era un server Windows 2003 con WSUS installato ed attivo; tutto funzionava benissimo ed i clients puntavano a quel server e funzionavano a dovere. Poi abbiamo dismesso quel server e sostituito con uno nuovo con Windows 2012 R2, installato il ruolo WSUS ed aggiornato le GP per puntare al nuovo server...... da allora i clients non hanno ricevuto più alcun aggiornamento e non sono comparsi nella lista della console WSUS......

    Ora ho ricambiato le GP dicendo che "non c'è" un server WSUS e quindi disabilitando la relativa voce ed i client hanno già cominciato a scaricare gli aggiornamenti direttamente da Windows Update.....

    Insomma si direbbe che le GP funzionano ed arrivano correttamente alle macchine, ma è come se poi non "trovassero" / "parlassero" col WSUS......

    Giorgio  


    • Modificato Giorgio Premoli giovedì 23 aprile 2015 16:36 errori battitura
    giovedì 23 aprile 2015 16:35
  • Pare che la porta sia cambiata su 2012:

    "After investigating I discovered in Server 2012 Microsoft changed the default WSUS port to 8530.  WSUS port by default was always port 80 in Server 2003 and Server 2008."

    REF: http://clintboessen.blogspot.ie/2013/07/clients-not-appearing-in-new-windows.html


    This post is provided AS IS with no warranties or guarantees, and confers no rights.
    ~~~
    Questo post non fornisce garanzie e non conferisce diritti

    • Contrassegnato come risposta Giorgio Premoli lunedì 27 aprile 2015 23:46
    venerdì 24 aprile 2015 07:35
  • Pare che la porta sia cambiata su 2012:

    "After investigating I discovered in Server 2012 Microsoft changed the default WSUS port to 8530.  WSUS port by default was always port 80 in Server 2003 and Server 2008."


    io ho sempre impostato la 8530 anche in win2k3 e win2k8 ed ha sempre funzionato...

    ... comunque suggeriamo a Reader65 di verificare la porta nelle policy


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org


    venerdì 24 aprile 2015 08:09
    Moderatore
  • Ok, provo e vi faccio sapere......

    Grazie.

    venerdì 24 aprile 2015 10:37
  • Ciao ragazzi!

    Confermo: impostando oltre al server anche la porta nelle GP, come server sia di stato che di aggiornamento, il tutto funziona.

    Quindi, la sintassi del server WSUS all'interno delle GP o della registry delle WS è:

    http://{nomeserver}:8530

    Da quel momento le workstations hanno cominciato a popolare e sono comparse nella lista dei computer della console WSUS.

    Grazie ancora a tutti per il prezioso aiuto.

    Ciaoooo! :-)

    lunedì 27 aprile 2015 23:45