none
Rimuovere DB guasto (Arbitration Mailbox e Pubic Folder) RRS feed

  • Domanda

  • Buongiorno a tutti,
    mi son trovato nella condizione di avere un DB guasto su Exchange server 2013 (installato su SRV2012).

    Backup fallato. Tralascio le vicissitudini. 

    Comunque ho una copia aggiornata .PST di ogni cassetta postale.

    A questo punto, dalla console, ho disabilitato una a una le cassette postali e le ho ricreate (ho creato 2 DB, spero di non dovermene pentire, solo per dividere utenti con mansioni diverse)

    Il cliente sta lavorando e ricevendo mail su nuovi profili Outlook.

    A questo punto vorrei togliere di mezzo il vecchio db, ma ho il problema delle arbitration mail e di una public folder inutile
    (non posso fare un move perché il vecchio db non si monta)

    Leggevo che un metodo è cancellare da AD i 5 utenti legati a tale mail, ricrearli con un Setup.exe /PrepareAD /IAcceptExchangeServerLicenseTerms  
    e poi abilitarli per le mail citate.

    E' corretto ?

    Ulteriori consigli e avvertimenti ?

    Grazie

    Carlo

     

    mercoledì 13 settembre 2017 10:08

Tutte le risposte

  • Ciao, per le arbitration puoi seguire questa procedura.

    https://jaapwesselius.com/2015/10/14/exchange-2013-recreate-arbitration-mailboxes/

    personalmente non avrei fatto 2 db se non in caso di una quantità e dimensioni di caselle molto importante..non sapendo quante ne hai non vado oltre.

    Mi permetto di consigliarti un backup con degli instant backup o repliche giornaliere..almeno se ricapita perdi la posta fino allo snap precedente ma non devi impazzire a rifare tutto...

    ciao.

    A.

    mercoledì 13 settembre 2017 10:27
    Moderatore
  • Grazie 1000 per la risposta.
    Ho provato a fare il tutto su una macchina di test ed è andato tutto bene.
    Sul server cliente non mi ricrea le arbitration mailbox

    Consigli ?

    LOG:

    09/21/2017 08:33:06.0227] [0] Starting Microsoft Exchange Server 2013 Setup
    [09/21/2017 08:33:06.0227] [0] **********************************************
    [09/21/2017 08:33:06.0227] [0] Local time zone: (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna.
    [09/21/2017 08:33:06.0227] [0] Operating system version: Microsoft Windows NT 6.2.9200.0.
    [09/21/2017 08:33:06.0227] [0] Setup version: 15.0.516.32.
    [09/21/2017 08:33:06.0227] [0] Logged on user: nomedominio\administrator.
    [09/21/2017 08:33:06.0258] [0] Command Line Parameter Name='preparead', Value=''.
    [09/21/2017 08:33:06.0258] [0] Command Line Parameter Name='iacceptexchangeserverlicenseterms', Value=''.
    [09/21/2017 08:33:06.0273] [0] Command Line Parameter Name='sourcedir', Value='Q:\EXCH2013\root'.
    [09/21/2017 08:33:06.0336] [0] RuntimeAssembly was started with the following command: '/preparead /IAcceptExchangeServerLicenseTerms /sourcedir:Q:\EXCH2013\root'.
    [09/21/2017 08:33:06.0336] [0] The registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0, wasn't found.
    [09/21/2017 08:33:06.0336] [0] The registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14, wasn't found.
    [09/21/2017 08:33:06.0336] [0] Copying Files...
    [09/21/2017 08:33:06.0351] [0] Starting copy from Q:\EXCH2013\root\Setup\ServerRoles\Common to C:\Windows\Temp\ExchangeSetup.
    [09/21/2017 08:33:11.0258] [0] Finished copy from Q:\EXCH2013\root\Setup\ServerRoles\Common to C:\Windows\Temp\ExchangeSetup.
    [09/21/2017 08:33:11.0258] [0] File copy complete. Setup will now collect additional information needed for installation.
    [09/21/2017 08:33:11.0274] [0] Assembly dll file location is C:\Windows\Temp\ExchangeSetup\Microsoft.Exchange.Setup.Console.dll
    [09/21/2017 08:33:18.0758] [0] Setup is choosing the domain controller to use
    [09/21/2017 08:33:19.0024] [0] The MSExchangeADTopology has a persisted domain controller: SRV02.nomedominio.locale
    [09/21/2017 08:33:19.0086] [0] [ERROR] Exception has been thrown by the target of an invocation.
    [09/21/2017 08:33:19.0118] [0] [ERROR] Method not found: 'Boolean Microsoft.Exchange.Data.Mime.MimeAddressParser.IsValidDomain(System.String, Int32, Boolean)'.
    [09/21/2017 08:33:19.0118] [0] The Exchange Server setup operation didn't complete.  More details can be found in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
    [09/21/2017 08:33:19.0118] [0] End of Setup
    [09/21/2017 08:33:19.0118] [0] **********************************************

    giovedì 21 settembre 2017 08:47
  • Risolto.

    Utilizzavo una CU precedente a quella in essere. Dovevo utilizzare o la stessa CU o superiore.

    Grazie ancora.

    Carlo

    martedì 26 settembre 2017 20:51