none
Errore con Import-SPWeb RRS feed

  • Domanda

  • Ciao a tutti,

    Stiamo effettuando il passaggio di dati da una farm ad un'altra con l'Import-SPWeb.

    L'importo però si ferma dopo un pò di tempo con la seguente eccezione:

    FatalError: Attempted to use an object that has ceased to exist. (Exception from HRESULT: 0x80030102 (STG_E_REVERTED))
    Debug: at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx)
    at Microsoft.SharePoint.Library.SPRequest.GetRoleDefsDataAsSafeArray(String bstrUrl, UInt32 dwRolesScope, Guid& pguidScopeId, UInt32& pdwRowCount, Object& pvarDataSet)
    at Microsoft.SharePoint.SPRoleDefinitionCollection.Init()
    at Microsoft.SharePoint.SPRoleDefinitionCollection.get_WebId()
    at Microsoft.SharePoint.Deployment.RolesImport..ctor(ImportStreamingContext context, SPSite site, SPWeb web, XmlReader xr, Int32 iBatchSize)
    at Microsoft.SharePoint.Deployment.SecurityObjectSerializer.SetObjectData(Object obj, SerializationInfo info, StreamingContext context, ISurrogateSelector selector)
    at Microsoft.SharePoint.Deployment.XmlFormatter.CallSetObjectData(Object obj, SerializationInfo objectData, ISerializationSurrogate surrogate, ISurrogateSelector selector)
    at Microsoft.SharePoint.Deployment.XmlFormatter.ParseObjectDirect(Object objParent, Type objectType)
    at Microsoft.SharePoint.Deployment.XmlFormatter.DeserializeObject(Type objectType, Boolean isChildObject, DeploymentObject envelope)
    at Microsoft.SharePoint.Deployment.XmlFormatter.Deserialize(Stream serializationStream)
    at Microsoft.SharePoint.Deployment.ObjectSerializer.Deserialize(Stream serializationStream)
    at Microsoft.SharePoint.Deployment.SPImport.DeserializeObjects()
    at Microsoft.SharePoint.Deployment.SPImport.Run()

    Sinceramente siamo alquanto disperati!!! La farm in cui stiamo portdando i dati è quella di produzione quindi è un rilascio molto importante per noi...

    Spero che qualcuno possa aiutarci!!!

    mercoledì 31 ottobre 2012 10:26

Risposte

Tutte le risposte

  • Ciao Marco,

    Ci daresti qualche informazione in più sul sito da cui fai l'export?

    1) template di base?

    2) variation attivate?

    3) resource throttling personalizzato?

    Saluti

    Mario Saccoia

    mercoledì 31 ottobre 2012 10:49
  • Ciao,

    grazie per la risposta

    ecco la nostra situazione:

    1) template di base? --> Publishing senza wf

    2) variation attivate? --> Si abbiamo 5 lingue (di base inglese), italiano, spagnolo, tedesco, francese

    3) resource throttling personalizzato? --> non è personalizzato, ma abbiamo provato ad aumentarlo sull'ambiente di produzione e comunque l'import va in eccezione...

    se guardiamo il log dell'import... ogni volta si blocca su più  pagine in lingue diverse... a noi sembra un problema con le variations ma non capiamo quale!!!

    mercoledì 31 ottobre 2012 10:58
  • Se non lo hai ancora fatto, prova ad installare il Cumulative Update di Aprile 2012.

    Naturalmente prima la versione per Foundation e poi quella Server (se stai usando una versione server).

    Se guardi nella descrizione del CU c'è  proprio la tua eccezione: http://blog.davidjwise.com/2012/05/02/april-2012-cumulative-update-all-changes/

    Ciao

    • Contrassegnato come risposta Marco Vargu mercoledì 31 ottobre 2012 13:06
    mercoledì 31 ottobre 2012 11:10
  • Grazie Mario,

    dopo l'installazione del CU l'import si completa correttamente!!! Ci hai salvato!!!

    mercoledì 31 ottobre 2012 13:07