none
Windows 2012 server standard e remote desktop RRS feed

  • Domanda

  • Buongiorno a tutti, ho un problema stranissimo che mi assilla da circa 2 mesi.Sono un tecnico informatico, non riesco a capire per quale motivo installando un windows 2012 R2 server standard e 5 accessi in remote desktop,succede che durante il copia e incolla di un file word e/o outlook (vs 2013 o 2007  indifferentemente),  verso  un editor  html, itesti copiati perdono completamente  la loro

    formattazione.

    Ciò non succede se l'account rd è l'administrator o se si opera fuori dal desktop remoto: in tal caso funziona  tutto perfettamente.

    Preciso che gli utenti rd hanno gli stessi privilegi e proprietà dell' utente administrator e comunque si perde la formattazione del testo.

    A qualcuno è capitato? Come lo avete risolto? Abbiamo provato di tutto, sia io sia i miei colleghi, ma non ne veniamo a capo.

    Grazie Luca

    venerdì 22 luglio 2016 13:56

Tutte le risposte

  • Il test di connessione con l'account administrator viene eseguito utilizzando lo stesso identico client RDP?

    venerdì 22 luglio 2016 16:05
    Moderatore
  • Si, è lo stesso
    venerdì 22 luglio 2016 22:07
  • Utilizzi sempre sessioni RDP complete oppure anche RemoteApp?

    Se utilizzi sempre sessioni complete, prova a vedere se il comportamento cambia in base all'abilitazione/disabilitazione del reindirizzamento automatico delle unità locali del client RDP. Se non noti differenze prova anche a disabilitare momentaneamente tutte le group policy da un account limitato da utilizzare per i test (soprattutto quelle di reindirizzamento cartelle, se presenti)

    venerdì 22 luglio 2016 23:04
    Moderatore
  • Ciao, ho provato i tuoi suggerimenti ma non funziona ugualmente.

    L'unico dubbio che mi viene è che sia un problema relativo a compatibilità tra il desktop remoto e Word 2013 (il quale è installato in multilicenza sul server).

    Ho pertanto  provato a crere un testo da Word 2010 (installato su un client), ma quando faccio il copia e incolla nel desktop remoto, comunque perde la formattazione. Quindi non penso sia una questione di versione di office....mi sembra piuttosto una questione di proprietà permessi del desktop remoto

    L'altra cosa è che le licenze di rds sono ancora nel periodo di prova... 

    Grazie 1000, attendo eventuali tuoi altri suggerimenti.

    Saluti

    Luca

    lunedì 25 luglio 2016 11:14
  • Le licenze di prova sono equivalenti a quelle complete, quindi non credo che dipenda da quello.

    Office 2013 è un'installazione di tipo click-to-run?

    lunedì 25 luglio 2016 13:43
    Moderatore
  • Office 2013 Pro ita (volume licensing) è stato installato su consiglio del supporto tecnico di Microsoft, in quanto la versione corrispondente 2016 non si riusciva ad installare a causa di un errore non ben specificato, cui nemmeno il supporto tecnico Microsoft è riuscito a risolvere, bisognava aprire un "ticket", ma il cliente era fermo e non c'era tempo,  così mi hanno consigliato di provare ad installare la vs 2013, più testata rispetto alla 2016: l'ho installata senza problemi nella modalità standard.

    Grazie,

    attendo tue.

    Saluti

    Luca

    martedì 26 luglio 2016 08:25
  • Sicuro che il reindirizzamento dell'unità C locale del client non è attiva durante la sessione? Hai group policy applicate al server RDS? Prova per sicurezza anche a configurare la policy "Non consentire il reindirizzamento degli Appunti" su disabilitato.
    martedì 26 luglio 2016 09:08
    Moderatore
  • Buongiorno a tutti, ho un problema stranissimo che mi assilla da circa 2 mesi.Sono un tecnico informatico, non riesco a capire per quale motivo installando un windows 2012 R2 server standard e 5 accessi in remote desktop,succede che durante il copia e incolla di un file word e/o outlook (vs 2013 o 2007  indifferentemente),  verso  un editor  html, itesti copiati perdono completamente  la loro

    formattazione.


    puoi spiegare meglio l'operazione che viene eseguita ?

    in una sessione rdp viene aperto un documento word, selezionato il testo, copia e successivo incolla in cosa ?

    di quale editor html parli ?

    questa cosa funzionava in altri ambienti ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    martedì 26 luglio 2016 09:23
    Moderatore
  • ciao, l'ho fatto ma non funziona ugualmente.

    Grazie

    mercoledì 27 luglio 2016 07:43
  • ciao, l'operazione che viene eseguita è la seguente: da un client windows con Windosw 7 viene preso/creato un classico testo da Word o da Outlook con una sua formattazione specifica, poi viene copiato e successivamente incollato, all'interno di una sessione di remote desktop, su un editor html (nBit Html Editor),  presente come addon all'interno di un software gestionale. Se l'utente si chiama administrator il tutto funziona perfettamente.<o:p></o:p>

    Se l'utente è un administrator (ho fatto addirittura il copia dell'utente administrator, rinominandolo test, ma non si chiama administrator, tale operazione riesce, ma il testo perde tutta la sua formattazione. <o:p></o:p>

    Se la stessa operazione viene fatta con tutti i vari utenti e il testo incollato fuori dall'ambiente remote desktop, funziona perfettamente.<o:p></o:p>

    Abbiamo fatto ulteriori prove di questo tipo: utilizzando la procedura descritta ma incollando il testo nell'editor html standard di Joomla: risultato identico. Se fatto fuori dal remote desktop funziona sempre, se fatto all'interno del remote desktop funziona solo se si chiama administrator. Penso sia qualcosa legato a qualche stranezza degli ultimi client remote desktop di Microsoft. <o:p></o:p>

    La particolarità e che non riusciamo a replicare il problema in altri ambienti Windows Server 2012 con client rdp: da tutti funziona perfettamente. L'unica cosa differente è che i client rdp Microsoft, dove abbiamo fatto i test per cercare di replicare il problema, sono installati da diverso tempo (almeno 1-2 anni), mentre quello incriminato è stato installato solamente a maggio 2016.<o:p></o:p>

    Sembra assurdo ma è così! Grazie per i suggerimenti che mi potrai dare

    Saluti Luca

    mercoledì 27 luglio 2016 08:26

  • La particolarità e che non riusciamo a replicare il problema in altri ambienti Windows Server 2012 con client rdp: da tutti funziona perfettamente. L'unica cosa differente è che i client rdp Microsoft, dove abbiamo fatto i test per cercare di replicare il problema, sono installati da diverso tempo (almeno 1-2 anni), mentre quello incriminato è stato installato solamente a maggio 2016.<o:p></o:p>


    puoi aggiungere anche la versione del client rdp dei due casi ?

    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    mercoledì 27 luglio 2016 08:56
    Moderatore
  • i client utilizzati per le prove sono diversi e sono quelli presenti sul sistema operativo di Windows 7 pro, Windows 10 e direttamente quelli di Windows 2012 R2 Server Standard quelli di Microsoft presenti sul sistema operativo e precisamente:

    Windows 2012 R2 server standard client rdp vs 6.3.9600 (Remote desktop protocol 8.1 supportato).

    Client rdp di windows 7 pro vs 6.3.9600 (Remote desktop protocol 8.1 supportato)

    Client rdp di windows 10  vs 10.0.10586 (Remote desktop protocol 10.0 supportato)

    ho rifatto ulteriormente le prove prima di risponderti: sul mio windows server 2012 r2 dell'ufficio funzionano  entrambi i client di 7 e 10 in quella modalità. Su quello del cliente non ne funziona nessuno dei due... 

    Grazie, attendo tue nuove

    Saluti

    Luca

    mercoledì 27 luglio 2016 15:26
  • bene, ma se tu hai fatto le prove nel tuo ambiente dove dal lato client ti sei messo nelle medesime condizioni del tuo cliente, dobbiamo esaminare quali sono le differenze lato server.

    su questo aspetto cosa riesci ad individuare come differenze ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    giovedì 4 agosto 2016 10:43
    Moderatore