none
Problemi di disconnessione ADSL e con i DNS RRS feed

  • Discussione generale

  • Ho una

    Ho una piccola rete aziendale con un Server 2008r2 Sp1 che funge da DC e quattro pc, due con Windows 7 Pro e Due con Windows 7 home edition.

    Di frequente si manifestano delle disconnessioni della rete da Internet ed il Router (192.168.1.150) diagnostica l'interruzione della linea adsl. Dopo alcuni minuti, il tutto riparte regolarmente.

    Ho verificato con il mio gestore il quale ha verificato che effettivamente vi sono queste disconnessioni, ma secondo lui sono imputabili ad un virus interno alla mia rete

    Tutta la rete è protetta da Symantec Endpoint Protection regolarmente aggiornato e tutti i test hanno darto esito negativo.

    Non sono un tecnico ma al momento non ho altre risorse se non la mia iniziativa.

    Ho eseguito Dcdiag sul server e vi riporto di seguito l'esito.

    *** Dcdiag /test:dns ***

    Diagnosi server di directory

     

    Esecuzione della configurazione iniziale:

     Ricerca dell'home server in corso...

     Home server: Server

     * Foresta di Active Directory identificata.

     Raccolta delle informazioni iniziali completata.

    Esecuzione dei test obbligatori iniziali

    Server in fase di test: Default-First-Site-Name\SERVER

    Inizio test: Connectivity

    Impossibile risolvere il nome host c435e716-5fbe-4b29-91b4-cde04c773a63._msdcs.nomedominio.local in un indirizzo IP. Controllare il server DNS, il DHCP, il nome server e cos via.

    E' stato ricevuto un errore durante la verifica della connettività LDAP e RPC. Controllare le impostazioni del firewall.

     ......................... SERVER non ha superato il test Connectivity

    Esecuzione dei test principali

    Server in fase di test: Default-First-Site-Name\SERVER

     

    Inizio test: DNS

    I test DNS sono in esecuzione e non bloccati. Attendere alcuni minuti...

     ......................... SERVER ha superato il test DNS

     Test partizione in esecuzione su: ForestDnsZones

     Test partizione in esecuzione su: DomainDnsZones

     Test partizione in esecuzione su: Schema

     Test partizione in esecuzione su: Configuration

     Test partizione in esecuzione su: Nomepartizione

     Test organizzazione in esecuzione su: nomedominio.local

     Inizio test: DNS

     Risultati dei test per i controller di dominio:

     

     Controller di dominio: Server.nomedominio.local

     Dominio: nomedominio.local

     TEST: Basic (Basc)

     Errore: connettivit… LDAP non disponibile

     Avviso: il server DNS per la scheda [00000007] Intel(R) 82578DM Gigabit Network Connection non valido: 192.168.1.150 (<name unavailable>)

     Errore: nessun server DNS valido

     Impossibile trovare record di host (A o AAAA) per il controller di dominio

     TEST: Dynamic update (Dyn)

     Warning: Failed to add the test record dcdiag-test-record in zone nomedominio.local

     

     TEST: Records registration (RReg)

     Errore: impossibile trovare registrazioni di record per tutte le schede di rete

     Riepilogo dei risultati dei test per i server DNS utilizzati dai controller di dominio specificati:

     Server DNS: 192.168.1.150 (<name unavailable>)

     Errore nel test 2 per questo server DNS

     Name resolution is not functional. _ldap._tcp.nomedominio.local. failed on the DNS server 192.168.1.150

     

     Riepilogo dei risultati dei test DNS:

     Aut Basc Inol Del Din RegR Est

     _________________________________________________________________

     Dominio: nomedominio.local

     Server PASS FAIL PASS PASS WARN FAIL n/a

     

     ......................... nomedominio.local non ha superato il test DNS

    Incuriosito dal primo errore (Impossibile risolvere il nome host c435e716-5fbe-4b29-91b4-cde04c773a63._msdcs.nomedominio.local in un indirizzo IP. Controllare il server DNS, il DHCP, il nome server e cos via) sono andato a vedere in Server Manager, nelle Zone di Ricerca diretta ed ho visto che oltre a "nomedominio.local" che quel dominio " c435e716-5fbe-4b29-91b4-cde04c773a63" che non so proprio cosa sia.

    Inoltre in "nomedominio.local" ci sono solo i client che hanno Windows 7 Pro ed il Server stesso (192.168.1.200).

    Vi inoltro anche il risultato di ipconfig eseguito sul server e su un client.

    La ma domanda: gli errori il fatto che Server e nomedominio.local non passino il test di connettività di Dcdiag, può essere la causa dei miei problemi? Se si, come risolverli?

    Grazie del vostro aiuto.

     

    *** ipconfig /all (Eseguito sul Server)***

     

    Configurazione IP di Windows

     

     Nome host . . . . . . . . . . . . . . : Server

     Suffisso DNS primario . . . . . . . . : nomedominio.local

     Tipo nodo . . . . . . . . . . . . . . : Ibrido

     Routing IP abilitato . . . . . . . . : Sì

     Proxy WINS abilitato . . . . . . . . : No

     Elenco di ricerca suffissi DNS. . . . : nomedominio.local

     

    Scheda Ethernet Connessione alla rete locale (LAN):

     

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Intel(R) 82578DM Gigabit Network Connection

     Indirizzo fisico. . . . . . . . . . . : 00-19-99-A3-74-1A

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : S

     Indirizzo IPv6 locale rispetto al collegamento . : fe80::b9d0:225f:62d4:4235%10(Preferenziale)

     Indirizzo IPv4. . . . . . . . . . . . : 192.168.1.200(Preferenziale)

     Subnet mask . . . . . . . . . . . . . : 255.255.255.0

     Gateway predefinito . . . . . . . . . : 192.168.1.150

     IAID DHCPv6 . . . . . . . . . . . : 234887577

     DUID Client DHCPv6. . . . . . . . : 00-01-00-01-15-19-3D-C4-00-19-99-A3-74-1A

     Server DNS . . . . . . . . . . . . . : 192.168.1.150

     NetBIOS su TCP/IP . . . . . . . . . . : Attivato

     

    Scheda Tunnel isatap.{11E7A8B8-0AC9-47A6-B697-25BF4FED9806}:

     

     Stato supporto. . . . . . . . . . . . : Supporto disconnesso

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter

     Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : S

     

    Scheda Tunnel Connessione alla rete locale (LAN)* 9:

     

     Stato supporto. . . . . . . . . . . . : Supporto disconnesso

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Microsoft 6to4 Adapter

     Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : Sì

     

    Scheda Tunnel Connessione alla rete locale (LAN)* 11:

     

     Stato supporto. . . . . . . . . . . . : Supporto disconnesso

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

     Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : S

     

     

     

     

    *** ipconfig /all (Eseguito su un client)***

     

    Configurazione IP di Windows

     

     Nome host . . . . . . . . . . . . . . : Albi-i7

     Suffisso DNS primario . . . . . . . . : nomedominio.local

     Tipo nodo . . . . . . . . . . . . . . : Ibrido

     Routing IP abilitato. . . . . . . . . : No

     Proxy WINS abilitato . . . . . . . . : No

     Elenco di ricerca suffissi DNS. . . . : nomedominio.local

     

    Scheda Ethernet Connessione alla rete locale (LAN):

     

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Realtek PCIe GBE Family Controller

     Indirizzo fisico. . . . . . . . . . . : 00-19-99-CC-EE-95

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : Sì

     Indirizzo IPv6 locale rispetto al collegamento . : fe80::d194:a2d0:f64c:fb16%11(Preferenziale)

     Indirizzo IPv4. . . . . . . . . . . . : 192.168.1.9(Preferenziale)

     Subnet mask . . . . . . . . . . . . . : 255.255.255.0

     Gateway predefinito . . . . . . . . . : 192.168.1.150

     IAID DHCPv6 . . . . . . . . . . . : 234887577

     DUID Client DHCPv6. . . . . . . . : 00-01-00-01-16-F5-35-3F-00-19-99-CC-EE-95

     Server DNS . . . . . . . . . . . . . : 192.168.1.200

     NetBIOS su TCP/IP . . . . . . . . . . : Attivato

     

    Scheda Tunnel isatap.{D74261AC-9CDB-4CF7-AB83-BB2E5CB14E35}:

     

     Stato supporto. . . . . . . . . . . . : Supporto disconnesso

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter

     Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : Sì

     

    Scheda Tunnel Connessione alla rete locale (LAN)* 4:

     

     Stato supporto. . . . . . . . . . . . : Supporto disconnesso

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Microsoft 6to4 Adapter

     Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : Sì

     

    Scheda Tunnel Connessione alla rete locale (LAN)* 3:

     

     Stato supporto. . . . . . . . . . . . : Supporto disconnesso

     Suffisso DNS specifico per connessione:

     Descrizione . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

     Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

     DHCP abilitato. . . . . . . . . . . . : No

     Configurazione automatica abilitata : Sì


    domenica 13 maggio 2012 10:13

Tutte le risposte

  • Ciao, dai risultati ottenuti c'è sicuramente un problema di configurazione del DNS. Assicurati di utilizzare su tutti i computer del dominio solo il server DNS del DC e di impostare come server di inoltro per quest'ultimo un server DNS esterno. Il router non va utilizzato come server DNS per nessun computer del dominio, il server DC con ruolo di DNS deve avere l'indirizzo di loopback configurato nei DNS della scheda di rete. Per ulteriori informazioni sulla configurazione dei DNS leggi qui http://support.microsoft.com/kb/825036 mentre per DCDiag ti consiglio la lettura di questo articolo: http://technet.microsoft.com/it-it/library/cc776854(v=ws.10).aspx

    In qualsiasi caso non è comunque detto che i problemi siano causati dal problema di DNS, verifica se quando non è presente internet la portante è ancora sincronizzata. Se si desincronizza anche la portante allora i problemi sono probabilmente dovuti a disturbi troppo elevati sulla tua linea.






    domenica 13 maggio 2012 11:08
    Moderatore
  • Ciao, la disconnessione casuale dalla rete, perdonami ma non può dipendere dal dns. Uno è un problema fisico, l'altro un problema di protocolli, se il dns non va al massimo ti dirà che non trova il sito ma che ti si disconnetta la linea proprio no.

    Il tuo è un problema che vedo spesso ed al 99% delle volte è dato da problemi di linea adsl o da router che si sono guastati e non funzionano correttamente.

    Quando hai questi problemi fai semplicemente un test dal server per vedere se quello naviga. Se anche lui è bloccato il problema è la linea, a quel punto vai sul router ed investiga di li.

    Ma potresti anche avere problemi di networking vero e proprio quindi gli switch che non lavorano bene, succede quando ci sono switch di fascia bassa molto spesso.

    Sul virus interno non commento nemmeno, l'operatore tipo ha due casistiche: un virus od il firewall, io gli farei fare qualche corso a chi risponde prima di dare risposte del genere. Mai che sia una volta la sua linea che invece è quasi sempre la causa del problema.

    Chiudo con un piccolo appunto. Il server ti fa da DC solo ai 2 sistemi PRO, agli Home sicuramente no perchè non supportano login a dominio, in una realtà così piccola ti consiglio almeno di prendere tutti sistemi PRO...altrimenti ha poco senso avere un domain controller per 2 macchine, tanto vale un server in workgroup.

    Segui comunque una semplice config di questo tipo per la tua rete: 

    Crea un range dhcp per  i tuoi client, ne hai solo 4, metti 10 indirizzi. Nel range metti come router l'ip del router e come dns l'ip del server DC poi configura così le intefacce di rete client e server.

    Interfaccia del server dc:

    ip il suo ip

    gateway ip del router

    dns primario 127.0.0.1 (se stesso)

    dns secondario: nessuno

    nelle impostazioni del dns di quel server metti un server di inoltro sempre disponibile (di solito uso google 8.8.8.8 ed un secondario fornito dal provider di connessione)

    Interfaccia dei client:

    lascia tutto in dhcp 

    Se poi ti scende la linea sai a chi andare a dare la colpa subito senza investigare. Lascia stare i virus. Di virus capaci di far disconnettere una rete basata tutta su 2008\windows 7 non ne esistono praticamente ed i pochi che ci sono sicuramente non te la fanno tornare su da sola.

    A.

    domenica 13 maggio 2012 12:02
    Moderatore
  • Ciao Fabrizio,

    nemmeno a farlo apposta ... due macchine avevano come dns sia l'indirizzo del server che il router. Ho corretto l'errore e messo l'indirizzo di loopbak sulla scheda di rete del server ... tutti i test sono stati brillantemente superati. :)

    Vediamo se adesso continuerò ad avere problemi con la connessione.

    Grazie della tu apreziosa collaborazione.

    Alberto

    domenica 13 maggio 2012 14:37
  • Ciao Alessandro, per quanto riguarda il problema dei test di connessione, ho risolto modificando i dns ed il loopbak come consigliatomi da Fabrizio. Ora funzona tutto a meraviglia.

    Mi sono stampato i tuoi prezioni consigli che mi aiuteranno certamente a capire meglio come funziona la mia rete.

    Mi sono ripromesso di fare qualche prova.

    Grazie tantissimo.

    Alberto

    domenica 13 maggio 2012 14:40
  • Ciao Fabrizio,

    nemmeno a farlo apposta ... due macchine avevano come dns sia l'indirizzo del server che il router. Ho corretto l'errore e messo l'indirizzo di loopbak sulla scheda di rete del server ... tutti i test sono stati brillantemente superati. :)

    Vediamo se adesso continuerò ad avere problemi con la connessione.

    Grazie della tu apreziosa collaborazione.

    Alberto


    Ciao, grazie per il feedback. Verifica in questi giorni se si trattava realmente solo di un problema di DNS (se non funziona correttamente si può avere l'impressione che non ci sia internet anche se in realtà è solo la risoluzione dei nomi a non funzionare) o di vera mancanza di connessione internet (dovuta alla desincronizzazione della portante per problemi di linea). Ciao.
    domenica 13 maggio 2012 16:53
    Moderatore