none
Dopo l'aggiornamento di Windows 10 alla versione 1709, SQL Server Express ha smesso di funzionare e non si reinstalla RRS feed

  • Domanda

  • Problema inatteso. Ieri ho fatto l'aggiornamento di Windows 10 alla versione 1709. Questa mattina, ho riscontrato che SQL Server Express 2017 non funzionava più: nonostante i servizi fossero al loro posto e avviati, non riuscivo più a collegarmi all'istanza con SSMS 17.3.

    Dopo che tutti i tentativi sono andati a vuoto, ho deciso di disinstallare SQL Server Express e di reinstallarlo... ma non ci sono riuscito, a causa di una miriade di errori, a partire da un irrisolvibile errore "sql server express failed to retrieve data for this request", passando per una serie di errori connessi a diritti insufficienti su una serir di chiavi di registro (nonostante sia amministratore e abbia eseguito tutte le operazioni come tale), per arrivare ad un errore "The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if Windows Installer is not correctly installed." Naturalmente, non sto usando il safe mode e non mi ha nemmeno lontanamente sfiorato l'idea di modificare in alcun modo Windows Installer (aggiornatissimo come tutto il resto).

    In tutto questo, si è inserita la "sparizione" (non saprei come altro definirla) dei driver video, che per fortuna ho risolto reinstallando i driver stessi.

    Voglio precisare che sono un tecnico preparato, con più di venticinque anni di esperienza professionale nell'assistenza informatica in ambienti Novell e Active Directory; non ho certo eseguito manovre errate "a caso". Il fattore scatenante di tutti i problemi è stato l'aggiornamento eseguito ieri sera. Questa mattina il problema si è manifestato immediatamente all'avvio.

    Chiedo scusa per la prolissità, ma ho bisogno di qualche lume per riuscire a risolvere il problema.

    ADDENDUM

    Dopo altre ventiquattro ore di prove, ho scoperto che se tento di installare una versione precedente di SQL Server Express (ho tentato con la versione 2014), l'errore di cui sopra non si manifesta; l'installazione fallisce però quando arriva intorno al 45%, si blocca sull'operazione in cui viene verificato se è installato il framework .NET 2.0, 3.5, 4.0 o 4.5, con un errore che riguarda Windows Installer, che risulterebbe non correttamente installato o funzionante in modalità provvisoria.

    Grazie

    Daniele Prevato

    <button class="c-button msgReplyBtn" data-bi-id="msgReplyBtn" style="box-sizing:inherit;color:#ffffff;font-style:inherit;font-variant:inherit;font-weight:inherit;font-size:15px;line-height:1;font-family:inherit;margin:12px 0px 0px;overflow:hidden;cursor:pointer;padding:9px 12px 10px;max-width:374px;min-width:120px;background-color:#0067b8;border-width:1px;border-style:solid;border-color:transparent;white-space:nowrap;vertical-align:bottom;transition:scale 0.2s ease-in-out;" title="Rispondi a questo post" type="submit">Rispondi</button>
    lunedì 11 dicembre 2017 13:30

Risposte

Tutte le risposte