none
Windows Server 2003 R2 Riavvio server RRS feed

  • Domanda

  • Buongiorno sono Luca,

    ho il seguente server:

    HP PROLIANT ML370G5

    Windows Server 2003 R2 Standard Edition con Service Pack 2

    Il problema:

    è da un paio di settimane che, in maniera autonoma e casuale, il server si riavvia da solo di notte.

    Ho provveduto a disattivare gli aggiornamenti automatici.

    Errori nell'event viewer non compaiono:

    Eppure ci sono "salti temporali" alle 2 alle 4 e alle 6. Come posso indagare?

    Devo usare uno strumento di diagnostica hardware HP?

    Grazie e saluti


    martedì 8 ottobre 2013 08:35

Risposte

  • Ciao Luca, da quando è in iniziato il problema hai eseguito delle modifiche al software installato? Visto che il problema lo riscontri solo di notte ed in base agli eventi 3 e 4 Virtual Disk Service potrebbe esserci un riscontro con eventuali attività di backup o di manutenzione in genere. Hai delle attività notturne che girano su quel server?

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    martedì 8 ottobre 2013 09:27
    Moderatore
  • Verifica nelle operazioni pianificate se e' presente un restart/shutdown al termine di qualche operazione.
    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    martedì 8 ottobre 2013 10:31
  • Ciao, consiglio di aprire una chiamata al produttore Hp, ti chiederanno di lanciare il diagnostic tool e di postargli il report. A mio avviso hai un problema hardware e mi è già successo che dei dischi in fault che stessero per saltare dessero questi problemi. Controllerei nei tools dell'HP raid manager se ci sono pallini gialli di avviso e se il raid è coerente. Darei un occhio anche nella ILO management per vedere se ha trovato incoerenze a livello fisico della macchina come overheat o altre cose.

    Presumo che il server sia mantenuto in garanzia col suo apposito care pack annuale\triennale dal momento che è un G5 e quindi avrà 6-7 anni. in caso contrario ti consiglio comunque di contattare l'HP per una diagnostica perchè quando mollano lo fatto tutto in una volta...e se il problema è sulla piastra...

    HP Italia 02/38591212

    Ciao.

    Alessandro

    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    martedì 8 ottobre 2013 15:31
    Moderatore
  • Ciao Luca,

    ho affrontato giusto la settimana scorsa una dinamica simile: server 2003R2 con tutti gli aggiornamenti che si riavviava o spegneva saltuariamente(anche 4 - 5 volte al giorno). Sui registri nessun errore. Andando ad analizzare a fondo i registri eventi ho ricostruito i tempi dei riavvii. Cercando eventi adiacenti al riavvio ho scovato un maledetto evento di livello Information, quindi invisibile ad una occhiata veloce, che riportava le ragioni del riavvio: "Legacy API shutdown". Le utenze associate all'evento erano utenti del dominio promossi da un ragazzino che aveva pasticciato sui server a Domain Administrator. Le chiamate "Legacy API shutdown" possono derivare, da quello che ho capito navigando i molti forum, da molteplici fattori, anche virus. Ho comunque risolto, quando me ne sono accorto, abbassando i diritti di accesso di quegli utenti a semplici domain users... e lanciando improperi all'indirizzo del ragazzino.

    Da quel momento il server non si è più riavviato o spento.

    Da te però succede di notte e dubito esistano altri ragazzini pasticcioni come quello che conosco io con accesso a server... possibile che qualche servizio o applicazione esegua con credenziali amministrative chiamate anomale che provochino l'evento "Legacy API shutdown"?

    Spero di esserti stato utile.

    Ciao

    Fabio

    Ps: magari la situazione che ti ho descritto non è la tua ma vale la pena dare una occhiata.

    • Modificato Fabio75 giovedì 10 ottobre 2013 22:14
    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    giovedì 10 ottobre 2013 22:12
  • Quei due salti temporali evidenziano semplicemente che il server non ha scritto eventi, aveva talmente poco da fare che non ha fatto nulla!

    Se si fosse riavviato ci sarebbero stati tutta una serie di startup dei servizi che non io non vedo nella tua img (leggi qui)

    Prova a fare un ping tutta notte (o se preferisci un pingplotter) da un pc verso il tuo server, scommetto che risponde sempre!


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    giovedì 10 ottobre 2013 22:47
    Moderatore

Tutte le risposte

  • Ciao Luca, da quando è in iniziato il problema hai eseguito delle modifiche al software installato? Visto che il problema lo riscontri solo di notte ed in base agli eventi 3 e 4 Virtual Disk Service potrebbe esserci un riscontro con eventuali attività di backup o di manutenzione in genere. Hai delle attività notturne che girano su quel server?

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    martedì 8 ottobre 2013 09:27
    Moderatore
  • Verifica nelle operazioni pianificate se e' presente un restart/shutdown al termine di qualche operazione.
    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    martedì 8 ottobre 2013 10:31
  • Ciao, consiglio di aprire una chiamata al produttore Hp, ti chiederanno di lanciare il diagnostic tool e di postargli il report. A mio avviso hai un problema hardware e mi è già successo che dei dischi in fault che stessero per saltare dessero questi problemi. Controllerei nei tools dell'HP raid manager se ci sono pallini gialli di avviso e se il raid è coerente. Darei un occhio anche nella ILO management per vedere se ha trovato incoerenze a livello fisico della macchina come overheat o altre cose.

    Presumo che il server sia mantenuto in garanzia col suo apposito care pack annuale\triennale dal momento che è un G5 e quindi avrà 6-7 anni. in caso contrario ti consiglio comunque di contattare l'HP per una diagnostica perchè quando mollano lo fatto tutto in una volta...e se il problema è sulla piastra...

    HP Italia 02/38591212

    Ciao.

    Alessandro

    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    martedì 8 ottobre 2013 15:31
    Moderatore
  • Ciao Luca,

    ho affrontato giusto la settimana scorsa una dinamica simile: server 2003R2 con tutti gli aggiornamenti che si riavviava o spegneva saltuariamente(anche 4 - 5 volte al giorno). Sui registri nessun errore. Andando ad analizzare a fondo i registri eventi ho ricostruito i tempi dei riavvii. Cercando eventi adiacenti al riavvio ho scovato un maledetto evento di livello Information, quindi invisibile ad una occhiata veloce, che riportava le ragioni del riavvio: "Legacy API shutdown". Le utenze associate all'evento erano utenti del dominio promossi da un ragazzino che aveva pasticciato sui server a Domain Administrator. Le chiamate "Legacy API shutdown" possono derivare, da quello che ho capito navigando i molti forum, da molteplici fattori, anche virus. Ho comunque risolto, quando me ne sono accorto, abbassando i diritti di accesso di quegli utenti a semplici domain users... e lanciando improperi all'indirizzo del ragazzino.

    Da quel momento il server non si è più riavviato o spento.

    Da te però succede di notte e dubito esistano altri ragazzini pasticcioni come quello che conosco io con accesso a server... possibile che qualche servizio o applicazione esegua con credenziali amministrative chiamate anomale che provochino l'evento "Legacy API shutdown"?

    Spero di esserti stato utile.

    Ciao

    Fabio

    Ps: magari la situazione che ti ho descritto non è la tua ma vale la pena dare una occhiata.

    • Modificato Fabio75 giovedì 10 ottobre 2013 22:14
    • Contrassegnato come risposta Anca Popa martedì 15 ottobre 2013 10:38
    giovedì 10 ottobre 2013 22:12
  • Quei due salti temporali evidenziano semplicemente che il server non ha scritto eventi, aveva talmente poco da fare che non ha fatto nulla!

    Se si fosse riavviato ci sarebbero stati tutta una serie di startup dei servizi che non io non vedo nella tua img (leggi qui)

    Prova a fare un ping tutta notte (o se preferisci un pingplotter) da un pc verso il tuo server, scommetto che risponde sempre!


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    giovedì 10 ottobre 2013 22:47
    Moderatore
  • Ciao Luca,

    In attesa delle tue notizie, ho evidenziato le risposte ricevute qui sopra.

    Grazie a tutti della participazione nel Forum di Windows Server ;-)


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    martedì 15 ottobre 2013 10:40