none
Hyper-V VM - DHCP - Netzwerkverbindung stürzt ab

    Frage

  • Hallo,

    wir haben einen DHCP Server von 2012 R2 auf Server 2019 umgezogen. 2019 wurde neu installiert und hat die IP / MAC des alten Servers. Der DHCP Server läuft als VM auf einem Hyper-V (Windows Server 2019) System.
    Es gibt noch einen zweiten DHCP (Failover) auf einer anderen VM mit Windows Server 2012 R2 (Upgrade auf 2019 steht noch aus) der problemlos funktioniert. Die Failover Sync funktioniert auch ohne Probleme. Im Ereignislog sind auch keine Fehler geloggt.

    Wenn nun ein Client versucht eine IP über den neuen DHCP zu bekommen stürzt das Netzwerk der VM, sowie des Hosts ab (gelbes Ausrufezeichen). Nur ein Neustart der VM und des Hyper-V Hosts kann das Problem beheben. 

    Treiber und Windows Updates sind auf aktuellem Stand...

    Kennt das Problem jemand?

    vG Markus

    Mittwoch, 17. April 2019 14:22

Antworten

  • Moin,

    ich würde mal vermuten, der physikalische Switch hinter dem Hyper-V hat ein Problem mit diesem Setup und macht den Port dicht. Hatte es einen besonderen Grund, dass ihr beim Upgrade die MAC-Adresse übernommen habt, und lief die 2012er VM auf einem anderen Host? Manchmal können Switch einfach nicht vergessen, dass die MAC-Adresse X am Port Y zu erreichen ist, und wenn sie dann plötzlich von einem anderen Port kommt, gibt es diverse Phänomene...


    Evgenij Smirnov

    http://evgenij.smirnov.de

    • Als Antwort markiert MarkMae Donnerstag, 18. April 2019 05:50
    Donnerstag, 18. April 2019 05:00

Alle Antworten

  • Ich würde da erst mal den alten DHCP-Server stilllegen ob der neue als Standalone-DHCP funktioniert.
    Wenn das der Fall ist, würde ich den alten Server ganz schnell auf 2019 hochbringen (Neuinstsallation ist da wohl zu bevorzugen), denn dann ist da zwischen 2012 und 2019 schwer was inkompatibel.
    Mittwoch, 17. April 2019 17:19
  • Moin,

    ich würde mal vermuten, der physikalische Switch hinter dem Hyper-V hat ein Problem mit diesem Setup und macht den Port dicht. Hatte es einen besonderen Grund, dass ihr beim Upgrade die MAC-Adresse übernommen habt, und lief die 2012er VM auf einem anderen Host? Manchmal können Switch einfach nicht vergessen, dass die MAC-Adresse X am Port Y zu erreichen ist, und wenn sie dann plötzlich von einem anderen Port kommt, gibt es diverse Phänomene...


    Evgenij Smirnov

    http://evgenij.smirnov.de

    • Als Antwort markiert MarkMae Donnerstag, 18. April 2019 05:50
    Donnerstag, 18. April 2019 05:00
  • Die Vermutung mit dem Switch hatte ich auch schon. Leider habe ich kein Zugriff darauf, da das Netzwerk von einer Fremdfirma supported wird. 
    Dort hatte ich auch schon angerufen und deswegen gefragt. Man sagte mir, dass wäre kein Problem mit der MAC Adresse...

    Edit:
    so, habe den Fehler gefunden!
    Es lag daran, dass die neue Hardware nicht am Core-Switch sondern an einem Memberswitch (gleiches VLan) angeschlossen war. Da ist wohl ein Funktion aktiviert die DHCP Server ausschaltet (was ja auch nicht verkehrt ist!)...

    @Evgenij Smirnov 
    danke für den Hinweis! Wer weis wie lange ich noch an anderer Stelle gesucht hätte... ;-)

    Achja, die alte MAC Adresse habe ich genommen weil ich auf dem Server Lizenzserver laufen habe die aus der MAC und der IP einen HASH-Wert bilden und so die Lizenzdatei erstellen.

    vG Markus

    • Bearbeitet MarkMae Donnerstag, 18. April 2019 05:49
    Donnerstag, 18. April 2019 05:31