Windows 7 Install is stuck at "Setup is Starting" RRS feed

  • Question

  • Hi,

    I am attempting to install windows 7 x64 onto my pc and it hangs at the "Setup is Starting..." screen.  I waited for the screen to go away overnight but to no avail. 

    My system's specs are:
    Phenom II x3 720 be
    MSI 790GX-G65 Motherboard with integrated video and the latest bios
    2 Gigs of ram (going to expand to 6)
    640 gig Seagate sata hard drive in IDE mode
    firewire and integrated audio have been disabled
    usb enabled but usb compatibility mode disabled
    no floppy drive and it has been disabled
    onboard lan has been disabled

    There was an instance where the installation got past that screen and asked me to choose a drive to install but none were selectable.  I used seagates utility to set up the drive with ntfs but that didn't solve the issue.  Is there anything else that I should try? 
    Monday, August 24, 2009 6:11 AM


All replies

  • Have you tried Starting the installation after changing the HDD from IDE to ACHI mode in bios.
    If not try it and let us know how it goes...
    Monday, August 24, 2009 6:36 AM
  • I changed the hard drive mode from IDE to ACHI in the bios and the setup still hangs.  Is there anything else that I should try?
    Monday, August 24, 2009 9:59 AM
  • Which DVD ROM are you using, also check the following thread where the installation process was very slow and
    some changes in the BIOS related to HyperTransport solved the problem.
    Your being the new Phenom II cpu, cannot say if this option is there in bios or not, just give it a try....

    And you sure that the installation media is good.
    Monday, August 24, 2009 11:18 AM
  • I am sure my installation media is good because it was used without incident the day before.  I will look into the hypertransport resolution and let you know.
    Monday, August 24, 2009 12:00 PM
  • I made the change to the bios and that did not solve the issue.  Afterwards, i disconnected the hard drive, left one memory stick inside the computer and I loadeded the optimized bios defaults.  It still hangs at the setup is starting screen.  It seems as though windows is having a hard time detecting my hardware.  Is there a windows hardware diagnostic that I can run to be sure?
    Monday, August 24, 2009 10:37 PM
  • Hi,

    You can run Windows 7 Upgrade Advisor, it will tells you about any known compatibility issues.  If you have 64-bit version of Windows XP installed, trying to perform Upgrade install and check if the issue persists. 
    Thomas Lin
    Wednesday, August 26, 2009 9:00 AM
  • HI,

    At the "setup is starting" process, it will load some drivers for your devices. I recommned you replaced the disk drive and checkthe issue .
    Thomas Lin
    Monday, August 31, 2009 2:45 AM
  • This is old but in case someone runs in to this thread.


    In Your bios -> for AMD turn hypertransport to 8bit and x1.

    disable all non-essential such as usb/onboard sound/serial/legacy floppy/legacy usb support


    It went from having an install that hung at every screen 10-20 mins until i gave up.

    to blazing fast install.


    hopefully this message reaches and does some good to somebody out there.

    Friday, December 17, 2010 9:27 AM
  • im having this same problem.. tried loading windows 7 onto a laptop, disabled all non essentials (usb's etc) in the bios and still nothing..
    Monday, February 7, 2011 11:29 AM
  • Try disabling the floppy disk drive in BIOS, whether or not you have one.


    Saturday, May 7, 2011 10:07 AM
  • Thank you thank you thank you geseki. Changing the hypertransport from 16 to 8 bits did the trick. 
    Monday, May 23, 2011 2:14 PM
  • If you have a computer like Dell or lenovo you should consider this.... delete oem partition -----> explain how to remove oem partition that resolve the problem for me
    Thursday, June 9, 2011 7:28 PM
  • I know this is an old post, but I just wanted to let somebody else know that might have the same problem. I had the same issue on a dell Optiplex 790. I booted to flash drive bios and did an fdisk. Killed the OEM partition. No the install is running smoothly.
    Friday, April 5, 2013 9:56 PM
  • Try disabling the floppy disk drive in BIOS, whether or not you have one.


    I had overlooked the floppy setting in the BIOS...disable the floppy 1.44MB option, and VOILA...


    • Proposed as answer by scwatson Saturday, May 3, 2014 2:19 AM
    Friday, February 28, 2014 2:19 AM
  • I had the same problem and changed my HDD from AHCI to IDE and this worked.. thanks mate
    Wednesday, March 5, 2014 10:56 AM
  • This floppy setting apparently was the key to my issue tonight as well. Doesn't make any sense to me as I have re-installed windows a couple of times on this pc without issue. but I can't argue with it tonight.
    Saturday, May 3, 2014 2:18 AM
  • Thank you. This was helpful.

    Actually i've changed mine from ACHI do IDE.

    Sunday, June 8, 2014 6:33 AM
  • A super easy fix that often solves this problem (worked for me on numerous occasions where this problem happened) is to unplug any hardware/devices that aren't vital to the install.

    Examples of these devices include:

    • A disk drive
    • A floppy drive
    • A secondary hdd that isn't going to contain the windows installation
    • Your keyboard
    • Your mouse
    • External hard-drives or flash-drives
    • Networking antennae

    Good luck :)

    Monday, July 28, 2014 6:20 PM
  • Years later, I looked up this issue and found this post.  This is how I fixed it with a similar setup.

    Here's how it was setup when it would freeze. 

    New HDD hooked up-

    CDRW - Master

    DVD ROM - Slave

    I tried every BIOS switch and took memory sticks out.  It did not run smooth until I switched the Master/Slave relationship on my cd rom drives.

    Once I switched my CDRW to Slave 

    DVD ROM to Master

    The installation ran flawless.

    Not sure how or why, that's above my understanding but just offering my experience of a days worth of troubleshooting between sleep and work.


    Friday, August 29, 2014 12:01 AM
  • Okay so here's what i did. i took out the HDD and connected my USB(Win7 installation) and the "setup is starting screen" came off. so what i am going to do is use a HDD enclosure(a device that helps you to use your internal HDD as an external), copy the important files i want and then format the HDD. it should work. haven't tried it. somebody can and tell me.
    Thursday, January 15, 2015 12:55 AM
  • After you install the OS, make sure you remove the CD when restarting
    Thursday, January 15, 2015 1:09 AM
  • My Dell XPS 8500 just did the same upon attempting to do a fresh Win7 Ultimate 64-bit install onto a new hard drive.  I got past this by booting first from a GPartEd disc (UNIX), deleting all the partitions and retrying the Win7 install again.  Did not have to do anything in the BIOS, etc.  (It must have been grinding on the previous partitions trying to understand them.  They were leftover from a Windows Restore failed attempt.)  There is likely a much more tedious version of this using Microsoft's DISKPART command line tool.

    Not sure if it's pertinent but this computer has both a CD/DVD drive as well as a DVD RW+ drive in it and I'm now installing from the CD/DVD for what it's worth.

    Thursday, October 8, 2015 6:39 PM
  • This worked for me. Thanks alot
    Wednesday, March 15, 2017 11:50 AM
  • I was facing the same problem and it worked after following steps mentioned by you. Thanks
    Sunday, September 1, 2019 11:51 AM
  • Removing the partitions with GPartEd worked perfectly. Thank you.
    Thursday, September 12, 2019 10:21 PM