none
IE 11 - Open in new Tab Not Working

    Question

  • When I click on a link that should open in a new tab (or right-click and select Open in new Tab), IE11 Opens a new tab but the screen is blank, the URL is about:blank and the tab title is 'Blank Page'.

    Windows 8.1 x64
    Internet Explorer 11 (Desktop)

    The 'Metro' version of IE 11 still works fine, it's just the Desktop version which is broken.

    I've tried all the fixes listed in the similar thread, but none have helped.

    IE 11 TABS NOT WORKING
    IE 11 opens blank tab

    Wednesday, April 16, 2014 11:47 AM

Answers

  • Thanks, I ran a Command Prompt (Admin) and ran the following scripts:
    ie8-rereg.32on64.cmd
    ie8-rereg.64on64.cmd

    Both seemed to execute correctly, but haven't made a difference.

    Unfortunately they have never been a complete repair and now, due to security/obscurity have been made even less effective.  There was an example in here a while ago in which the poster helped me see that exploiting the original manifests might have been a better tack for a repair.  IIRC they uncovered some registry corruption which seemed related to mshtmled.dll but which was not repaired by registering that module and was damage which was only hinted at by looking at the manifest.  The poster's repair was found by comparing registries from otherwise identical systems...

    OMG look what this recollection has dredged up:  <lol/>

    http://social.technet.microsoft.com/Forums/ie/en-us/08f7a0f7-6f4b-4def-b399-12a0c281655a/ie9-wont-open-pages-just-give-a-new-tab-thats-blank?forum=ieitprocurrentver

       

    Interestingly, I came across another oddity which might indicate the behaviour is some sort of change to the IE security settings. On a site I frequent http://www.makegamessa.com/ none of the links work. They've all previously worked and they still work in other browsers, just not my IE. If you click a link it is supposed to open the page in the current window (i.e. not opening a new tab), but nothing happens. However, if I have the F12 developer tools open, then the links all work as expected OR if I add the site to Trusted Sites the links also work.

    That sounds like Active Scripting is inhibited.  Scripting would be disabled in a Restricted security zone or in an Internet zone which was set to High level.  Scripting would be enabled in a Trusted security zone.  Scripting would be required in order to use IE11 Developer Tools since that is its implementation.  It hadn't occurred to me that that might provide an override for Scripting which had been otherwise inhibited.

     
    FYI



    Robert Aldwinckle
    ---

    Sunday, April 20, 2014 4:05 PM
    Answerer

All replies

  • I have the same issue. had a recent update.  some pages work, others do not, specifically google search, right click new open in new tab, off yahoo home page. really annoying, may send me back to Mozilla. following for help.


    also, just tried to confirm this account in email and hit link in email, went to blank about. had to copy and paste. it is ridiculous, fix it Microsoft.
    Wednesday, April 16, 2014 4:36 PM
  • Hi,

    The open in new tab option when right click the links works well from my side. Windows 8.1 Enterprise X64, IE 11.0.9600.16659.

    Before going further, could you please tell something about recent changes made on your PC?

    Also take a check with the tools->internet options->programs->choose how you open links, if it is set to let Internet Explorer descide, please take a try to set it to always in Internet Explorer on the desktop. Then check if issue insists.

    If the above didn't work, please take a try to reset IE on the desktop. Follow this guide:

    How to reset Internet Explorer settings

    Best regards


    Michael Shao
    TechNet Community Support


    Thursday, April 17, 2014 8:09 AM
    Moderator
  • Hi,

    I'm using Windows 8.1 pro with IE 11.0.9600.17031
    This configuration was working fine for me until recently.

    > Before going further, could you please tell something about recent changes made on your PC?

    I haven't installed anything recently, however updates did install because I received the (annoying) 'your system will automatically be rebooted in1 day...' message.  I re-booted and after that I started having the 'open in new tab' issues.

    > choose how you open links...

    I have changed it to 'Always in internet explorer on the desktop', but I'm still getting the issue.

    > please take a try to reset IE on the desktop...

    I ran the reset including 'delete personal settings' but the issue persists.

    Regards,
    Michael

    Thursday, April 17, 2014 9:04 AM
  • just the Desktop version which is broken.

    At least that gives you a better chance to do diagnostics.  E.g. Developer Tools is not available in MUF IE.  But it sounds like some kind of third-party interference, e.g. pop-up blocker, parental blocker, security zone difference, etc. so running ProcMon might yield better clues.  Best to have two otherwise identical traces from ProcMon (.pml files) but I don't think your MUF IE case would be a good comparison case.  For a start you could see if the default popup-blocker override has any effect, e.g. Ctrl+Alt-Click.

    HTH



    Robert Aldwinckle
    ---

    Thursday, April 17, 2014 8:20 PM
    Answerer
  • > For a start you could see if the default popup-blocker override has any effect, e.g. Ctrl+Alt-Click.
    When I 'Ctrl+Alt+Click' a link which tries to open a new tab, I have the same issue i.e. It opens a blank tab

    FYI:
    In Manage add-ons, 'All add-ons' and 'Run without permission' : I've disabled all addons except the Microsoft ones (and half of those)
    In internet Options > Privacy : I've Un-Ticked 'Turn on pop-up Blocker' And Ticked 'Disable toolbars and extensions when InPrivate Browsing starts'
    I've also disabled my antivirus (AVG)

    If I start InPrivate browsing and try open a link in a new tab I still get a 'blank tab'.

    i.e. I believe I've ruled out most if not all 3rd Party add-ons, but that hasn't solved my problem.

    Friday, April 18, 2014 9:46 AM
  • I think it was that update. Pretty annoying. Mozilla working fabulous. Years ago I used IE. Then it had crashing issues. All the time. Switched to Mozilla. Got a new computer. IE worked fine till the other day. After "update". Which really was a down date setback. Do off to mozilla I go. I have to be able to work in tabs. It's so useful. Figure it out and maybe I'll use IE. pos
    Friday, April 18, 2014 10:30 AM
  • I believe I've ruled out most if not all 3rd Party add-ons

    Unfortunately all you have done is tried to rule out the most common cases and only if those add-ons which were listed all play by the rules.  So, now you will have to try doing some more comprehensive diagnosis, e.g. clean-boot troubleshooting.  E.g. simplest case would be to try booting in safe mode, so then if that worked you could compare what was being started in each case.  BTW sometimes disabling a security product is found not to be the same as uninstalling and reconfiguring it.



    Robert Aldwinckle
    ---

    Friday, April 18, 2014 12:17 PM
    Answerer
  • >  try booting in safe mode....

    Just spent 2 frustrating hours trying to boot into safe mode with networking, and can't get it right.
    I get to the screen which says ... F4 for Safe mode, F5 for Safe mode with Networking etc..

    I select the F5 Safe mode with Networking and it re-boots into Safe mode but I have no network access.
    Even tried the old msconfig way, same issue.

    I tried connecting to a site on my local IIS but that doesn't work unless networking is enabled. (It actually says re-boot to exit safe mode to enable networking)

    aarrgggg

    Friday, April 18, 2014 6:01 PM
  • I select the F5 Safe mode with Networking and it re-boots into Safe mode but I have no network access.

    Could be a sign that you normally need a proxy running to use networking but the proxy can't run in safe mode.



    Robert Aldwinckle
    ---

    Friday, April 18, 2014 9:12 PM
    Answerer
  • Thanks, but no proxy required. Direct connection on my home adsl.

    Just to double check, Internet Options > LAN Settings > Use a proxy server is UnTicked.

    Saturday, April 19, 2014 7:34 AM
  • no proxy required.

    That doesn't mean there isn't one or some kind of network filter, having an interfering effect even during a safe mode boot.  Did you try uninstalling Norton?  Was McAfee ever installed?


    Robert Aldwinckle
    ---

    Saturday, April 19, 2014 2:24 PM
    Answerer
  • AVG is the only Antivirus I've installed on this machine. I've now uninstalled it (and rebooted) and the issue with the blank tabs is still there as well as the issue with not being able to boot into Safe Mode with Networking.
    Saturday, April 19, 2014 3:53 PM
  • the issue with the blank tabs is still there

    Another incident just reminded me that we once relied on regsvr32 commands for their "repair" effect.

    http://iefaq.info/index.php?action=artikel&;cat=42&id=133&artlang=en

    Make sure that you do it elevated or it will have even less effect.  



    Robert Aldwinckle
    ---

    Saturday, April 19, 2014 11:24 PM
    Answerer
  • Thanks, I ran a Command Prompt (Admin) and ran the following scripts:
    ie8-rereg.32on64.cmd
    ie8-rereg.64on64.cmd

    Both seemed to execute correctly, but haven't made a difference.

    Interestingly, I came across another oddity which might indicate the behaviour is some sort of change to the IE security settings. On a site I frequent http://www.makegamessa.com/ none of the links work. They've all previously worked and they still work in other browsers, just not my IE. If you click a link it is supposed to open the page in the current window (i.e. not opening a new tab), but nothing happens. However, if I have the F12 developer tools open, then the links all work as expected OR if I add the site to Trusted Sites the links also work.

    Neither of those two fixes the New Tab is Blank issue however.

    Sunday, April 20, 2014 12:53 PM
  • Thanks, I ran a Command Prompt (Admin) and ran the following scripts:
    ie8-rereg.32on64.cmd
    ie8-rereg.64on64.cmd

    Both seemed to execute correctly, but haven't made a difference.

    Unfortunately they have never been a complete repair and now, due to security/obscurity have been made even less effective.  There was an example in here a while ago in which the poster helped me see that exploiting the original manifests might have been a better tack for a repair.  IIRC they uncovered some registry corruption which seemed related to mshtmled.dll but which was not repaired by registering that module and was damage which was only hinted at by looking at the manifest.  The poster's repair was found by comparing registries from otherwise identical systems...

    OMG look what this recollection has dredged up:  <lol/>

    http://social.technet.microsoft.com/Forums/ie/en-us/08f7a0f7-6f4b-4def-b399-12a0c281655a/ie9-wont-open-pages-just-give-a-new-tab-thats-blank?forum=ieitprocurrentver

       

    Interestingly, I came across another oddity which might indicate the behaviour is some sort of change to the IE security settings. On a site I frequent http://www.makegamessa.com/ none of the links work. They've all previously worked and they still work in other browsers, just not my IE. If you click a link it is supposed to open the page in the current window (i.e. not opening a new tab), but nothing happens. However, if I have the F12 developer tools open, then the links all work as expected OR if I add the site to Trusted Sites the links also work.

    That sounds like Active Scripting is inhibited.  Scripting would be disabled in a Restricted security zone or in an Internet zone which was set to High level.  Scripting would be enabled in a Trusted security zone.  Scripting would be required in order to use IE11 Developer Tools since that is its implementation.  It hadn't occurred to me that that might provide an override for Scripting which had been otherwise inhibited.

     
    FYI



    Robert Aldwinckle
    ---

    Sunday, April 20, 2014 4:05 PM
    Answerer
  • Thank You!  That thread solved (sort of) my problem!

    From Marcelo S' original solution :

    Open registry editor and navigate to HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
    create a DWORD value, and name it TabProcGrowth
    TabProcGrowth=0: Tabs will be created as threads(instead of processes)

    I can open a link in a new tab AND the links I mentioned at MakeGamesSA now work without having to add the site to 'Trusted Sites'.

    Why I say 'Sort Of' works is that it doesn't solve the issue, it just side-steps it (moved to creating tab InProc). 

    Maybe now that I can switch between a working (TabProcGrowth=0) and not-working (TabProcGrowth=1) configuration, I can spot something that's causing the issue.

    Thank you Robert for all the assistance!

    Sunday, April 20, 2014 8:48 PM
  • The problem is with Windows 8.1 Update 1. My desktop IE worked perfectly until that update and there have been no other changes made to my system.
    Monday, April 21, 2014 2:43 PM
  • The problem is with Windows 8.1 Update 1.

    Not here.  Care to share some details that you would like to have some help with?  Since you are posting your Me too! in this thread you could also describe how all of the symptoms and suggestions given here so far apply or don't apply to your case.  Otherwise please start your own new thread with your own details.



    Robert Aldwinckle
    ---

    Sunday, June 01, 2014 2:10 PM
    Answerer
  • Try to re-register "proxy.dll" library. This helped for 90 % of our PCs.

    regsvr32 "c:\Program Files (x86)\Internet Explorer\ieproxy.dll" 

    Monday, July 21, 2014 7:06 AM
  • This command along with the 64 bit version of the same name DLL resolved this issue for me with IE 8, 9, 10 and 11.  Excellent!
    Monday, July 21, 2014 3:42 PM
  • This command along with the 64 bit version of the same name DLL resolved this issue for me with IE 8, 9, 10 and 11.  Excellent!

    Then, that would have been this:

    http://support.microsoft.com/kb/2574731

    or at least Kai's scripts (ie8-rereg -- for both 32 and 64 bit re-registrations)



    Robert Aldwinckle
    ---

    Monday, July 21, 2014 5:04 PM
    Answerer
  • Hello,

    To fix this problem, I'v disabled the protected mode feature.

    Go to: Setting --> internet option --> security --> then uncheck the box for enable protected mode option.

    I don't know what will be the risks amplifications  for this but it does solve the problem

    Thanks

    Fahad

    • Proposed as answer by cprassas Saturday, October 18, 2014 5:54 PM
    Monday, August 04, 2014 7:25 AM
  • have you ever seen where you right click open in new tab and it opens in a new window instead ?


    • Edited by Mike_Kubi Tuesday, August 05, 2014 6:11 PM
    Monday, August 04, 2014 2:52 PM
  • I have the same problem. Mine also occured immediately after a Windows update. I've found many other reports of this same problem and most of them say that it also occurred right after a Windows update. I do not want to turn off protected mode to fix this. I  just switched to Firefox. All the links work fine in that.
    Friday, August 29, 2014 4:41 PM
  • I have had the same problem show up recently, my work around is to refresh the screen and lo and behold the new page shows up. I was hoping to find an easy solution to the problem but from what I have read there isn't one. This seems to be a simple work around. Hope it helps
    Wednesday, October 08, 2014 11:55 PM
  • Since recently doing a system recovery and updating from IE 8 to IE 11, I had this same issue. Nearly every link either opened no page at all or a blank page when using open in new tab option (from right click.) After reregistering several IE dll's, and having IE "fixed" for that particular browsing session,  I decided to try unchecking the "enable protected mode" box in IE security settings.  This has so far fixed the issue, but I have to say I don't feel all that confident about security in IE now. If the protected mode is causing this problem, it seems that MS might find the reason why and either fix it with an update, or resubmit a working IE 11 as an updated browser. Going around in circles with temporary fixes or troubleshooting techniques that help nothing is just frustrating to an already frustrated consumer expecting help for a problem that should never have left MS servers as a browser. It isn't shocking when people just change browsers. No one wants to spend the majority of their spare time trying to fix something when a different product immediately allows them to do what they were initially attempting without a "try this, then try that list." I love MS for bringing us all the wonderful products they have rolled out, but I only have a certain amount of free time, and I cannot spend it fixing the other MS products that aren't so wonderful (and definitely not when I'm doing so without payment.)  
    Saturday, October 18, 2014 6:23 PM
  • After reregistering several IE dll's, and having IE "fixed" for that particular browsing session,  I decided to try unchecking the "enable protected mode" box in IE security settings.  This has so far fixed the issue, but I have to say I don't feel all that confident about security in IE now. 

    Then now you have security equivalent to any non-IE browser.  However, this would show that you have some undiagnosed interferer which is preventing IE from running normally but which doesn't cause a symptom when you let it run the way it wants.  Then you might want to investigate that to know how much you trust or need whatever it is.



    Robert Aldwinckle
    ---

    Sunday, October 19, 2014 6:39 PM
    Answerer
  • Even worse for us non-techy ludites who don't know our dlls from our xyzs.  IE was working fine this morning but then this afternoon my browser has come down with the dreaded new tab blank page (NTBP) virus.  I don't understand any of the 'solutions' being proposed and certainly don't have the time, inclination or skills to spend the rest of the day trying them out for myself so I'm dumping IE and returning to Mozilla. 
    Friday, October 24, 2014 2:00 PM
  • IE 11 open new tab is not working for me as well (11.0.9600.16663). It worked before but suddenly it just does nothing. I have tried it on both Bing and Google Search. None of the links open when I select open in new tab.


    Wednesday, December 03, 2014 7:24 AM
  • Sorry, I know this is an old thread, but it's appearing at the top of Google searches so I thought I would post what I have found .....

    I have had this problem for many months now, but only with IE and not FireFox or Chrome. It happens worst when I open a Google link into a new tab which temporarily led to a conspiracy theory of Google vs MS.

    When I go to the new tab, I can get the page to load by hitting F5, which suggested that something was interfering with the javascript page redirectors.

    PROBLEM SOLVED

    In my case, I have disabled the Avast Online Security add-in (Manage Add-Ons / Extensions). After closing Internet Explorer and restarting it, not only is the tab issue resolved, but my browser is loading pages much faster. No need to uninstall Avast, just disable the IE extension.

    I hope this solves this issue for a few other people.

    Sunday, January 04, 2015 7:17 AM
  • Disabling Avast Online Security add in fixed my issue, thanks
    Sunday, January 25, 2015 9:54 AM
  • Thanks i working fine

    This command regsvr32 "c:\Program Files (x86)\Internet Explorer\ieproxy.dll" 

    Monday, February 23, 2015 1:56 PM
  • As stated in this helpful thread: https://social.technet.microsoft.com/Forums/ie/en-US/f3bedf45-bb5d-47d4-998f-84c91e21a231/ie-11-tabs-not-working?forum=ieitprocurrentver

    in some cases it is necessary to UNregister the dll first:

    %SystemRoot%\System32\regsvr32 -u "%programfiles%\Internet Explorer\ieproxy.dll"
    %SystemRoot%\System32\regsvr32 "%programfiles%\Internet Explorer\ieproxy.dll"
    %SystemRoot%\Syswow64\regsvr32 -u "%programfiles(x86)%\Internet Explorer\ieproxy.dll"
    %SystemRoot%\Syswow64\regsvr32 "%programfiles(x86)%\Internet Explorer\ieproxy.dll"

    Monday, May 16, 2016 6:33 PM