none
移行エンドポイントの確認でサーバーに接続できない RRS feed

  • 質問

  • お世話になります。

    Exchange Server2016からExchange Onlineへの移行検証を行っております。

    ハイブリッド構成の完了後に移行バッチの作成を行いましたが、
    移行エンドポイントの確認でExchange サーバーへ接続ができません。
    そもそも自動検出がされていない状態です。

    MRSプロキシの有効化は行いました。
    確認が必要な設定があれば、ご教示頂きたく。

    よろしくお願いいたします。

    2018年1月19日 12:27

回答

  • 入力したメールアドレスとアカウント情報に基づく Autodiscover が失敗したとのことですので、チェックするのは

    ・autodiscover.[メールアドレスのドメイン名] のDNSレコードが正しくオンプレミスを向いているか
    ・リバースProxy(もしくは直接NATしているのであればExchange MBXサーバ)で正しいSSL証明書が利用されているか
    ・入力したアカウント、ID/PASSが正しいか
    ・EWS仮想ディレクトリのExternalUrlに正しいFQDNが設定されているか

    あたりかと思います。

    ただ、MRS Proxyが有効化されたEWSのエンドポイントのFQDN情報の入力を求められていることからもわかる通り、Autodiscoverで検出できなくてもこちらで正しいFQDNを入力すれば先に進むことが可能です。

    https://blogs.technet.microsoft.com/exovoice/2016/09/19/troubleshooting-issues-where-the-migration-endpoint-cannot-be-created-in-hybrid-scenarios/

    • 回答としてマーク S.Ikegami 2018年1月26日 0:12
    2018年1月22日 0:41

すべての返信

  • 入力したメールアドレスとアカウント情報に基づく Autodiscover が失敗したとのことですので、チェックするのは

    ・autodiscover.[メールアドレスのドメイン名] のDNSレコードが正しくオンプレミスを向いているか
    ・リバースProxy(もしくは直接NATしているのであればExchange MBXサーバ)で正しいSSL証明書が利用されているか
    ・入力したアカウント、ID/PASSが正しいか
    ・EWS仮想ディレクトリのExternalUrlに正しいFQDNが設定されているか

    あたりかと思います。

    ただ、MRS Proxyが有効化されたEWSのエンドポイントのFQDN情報の入力を求められていることからもわかる通り、Autodiscoverで検出できなくてもこちらで正しいFQDNを入力すれば先に進むことが可能です。

    https://blogs.technet.microsoft.com/exovoice/2016/09/19/troubleshooting-issues-where-the-migration-endpoint-cannot-be-created-in-hybrid-scenarios/

    • 回答としてマーク S.Ikegami 2018年1月26日 0:12
    2018年1月22日 0:41
  • genki.w 様

    ご返信頂きありがとうございます。

    上記事項について確認いたします。

    >ただ、MRS Proxyが有効化されたEWSのエンドポイントのFQDN情報の入力を求められていることからもわかる通り、
    >Autodiscoverで検出できなくてもこちらで正しいFQDNを入力すれば先に進むことが可能です。

    申し訳ございません。説明不足です。
    FQDNを入力したところ、「サーバー●●への接続を完了できませんでした。」という旨のエラーメッセージが出力されました。

    2018年1月22日 2:42
  • 手動でもEWSのエンドポイントに接続できないということですので、リモート接続アナライザーを利用してテストを頂くのが詳細なエラー内容も表示されますので適しているかと思われます。

    Remote Connectivity Analyzer
    https://testconnectivity.microsoft.com/

    Exchange Server
     Microsoft Exchange Web Services Connectivity Tests
      Synchronization, Notification, Availability, and Automatic Replies

    AutodiscoverではなくSpecify Exchange Web Services URLを指定頂き、以下の様なEWSのアドレスを入力頂ければテストできます。
    https://mail.contoso.com/EWS/Exchange.asmx

    2018年1月22日 3:22
  • Remote Connectivity Analyzer にてテストを行ったところ、問題はないようでした。

    以下、結果キャプチャです。

    2018年1月22日 5:53
  • RCAのテストが問題ないという事であれば、EWSの公開に関するネットワーク周りの設定は問題ないという事ですね。

    後はMRSProxyへの接続ということになりますが、以下の流れでの確認をお願いできますでしょうか。

    ①MRS Proxyの有効化後にEWSのアプリケーションプールのリサイクルを実施されていないのであれば、実施する(うまく設定が反映されていないケースもあるので)

    ②以下のテストコマンドを実行して詳細を確認する。また、オンプレミス側のIISのログも確認する。

    $Cred=Get-Credential (ローカルのExchange管理者の資格情報を入力)
    Test-MigrationServerAvailability -ExchangeRemoteMove -RemoteServer mail.contoso.com -Credentials(Get-Credential)

    2018年1月23日 0:24
  • >①

    リサイクル実施後も状態は変化なしです。

    >②

    テストコマンドを実行いたしました。

    RunspaceId         : ●●
    Result             : Success
    Message            :
    ConnectionSettings : <ExchangeConnectionSettings HasAdminPrivilege="True" HasAutodiscovery="False" HasMrsProxy="True" A
                         utodiscoverUrl="" IncomingEmailAddress="" IncomingRPCProxyServer=" ●● " IncomingExc
                         hangeServer=" ●● " IncomingNSPIServer="" IncomingDomain=" ●● " IncomingUserN
                         ame=" ●● " EncryptedIncomingPassword=" ●● " IncomingAuthentication="Basic" ServerVersion="" TargetDomainName="" SourceMailboxLe
                         gDn="" PublicFolderDatabaseServerLegacyDN="" />
    SupportsCutover    : False
    ErrorDetail        :
    IsValid            : True
    Identity           :
    ObjectState        : New

    IISのログを確認したところ、EWSに関係するログが5行ありました。(IP部分は削っています)

    2018-01-23 01:27:05  POST /EWS/mrsproxy.svc &CorrelationID=<empty>;&ClientId=●●&cafeReqId=●●; 443 - - 401 0 0 8937
    2018-01-23 01:27:06  POST /EWS/mrsproxy.svc &CorrelationID=<empty>;&ClientId=●●&cafeReqId=●●; 443 - - 200 0 0 1078
    2018-01-23 01:27:06  POST /EWS/mrsproxy.svc &CorrelationID=<empty>;&ClientId=●●&cafeReqId=●●; 443 - - 200 0 0 78
    2018-01-23 01:27:06  POST /EWS/mrsproxy.svc &CorrelationID=<empty>;&ClientId=●●&cafeReqId=●●; 44  - - 200 0 0 15
    2018-01-23 01:27:06  POST /EWS/mrsproxy.svc &CorrelationID=<empty>;&ClientId=●●&cafeReqId=●●; 44  - - 200 0 0 0

    2018年1月23日 1:48
  • テスト、成功してますね…。

    同じ情報(FQDNや認証情報)をEACから移行エンドポイントの作成で入力してもできないということであれば、一度Exchange OnlineからCLIで作成してみて頂けますでしょうか。

    New-MigrationEndpoint -Name [EndpointName] -ExchangeRemoteMove -RemoteServer mail.contoso.com -Credentials (Get-Credential)

    2018年1月23日 2:10
  • Exchange Onlineに接続し、作成を試みましたが、
    同様のエラーが発生いたしました。。

    サーバー ' ●● ' への接続を完了できませんでした。
        + CategoryInfo          : NotSpecified: (:) [New-MigrationEndpoint], MigrationServerConnectionFailedException
        + FullyQualifiedErrorId : [Server=TY1PR01MB1529,RequestId=6ab84e36-affe-4679-92b7-c128c81181e0,TimeStamp=2018/01/2
       3 5:40:46] [FailureCategory=Cmdlet-MigrationServerConnectionFailedException] 343B2AB2,Microsoft.Exchange.Managemen
      t.Migration.MigrationService.Endpoint.NewMigrationEndpoint
        + PSComputerName        : outlook.office365.com

    2018年1月23日 5:42
  • 上記コマンドを実行した際のログ(Exchange ServerのIIS、リバースProxyを通しているのであればそのサーバ)には何か記録されていますでしょうか。

    2018年1月23日 23:59
  • イベントログには、何も記録されておりません。

    エラー以外も特に記録はないです。

    2018年1月25日 0:23
  • IISのログについては、エラーログ(C:\Windows\System32\LogFiles\HTTPERR)も含めて当該時間帯の情報は記録されていないということになりますでしょうか。

    もしそうである場合、そもそもExchange Serverに要求自体が来ていないという事になりますので、ネットワーク側を中心にご確認いただく形になろうかと思いますが。

    2018年1月25日 5:37
  • 解決しました。

    ログにも記録されていなかったので、一度戻って確認事項を見直したところ、
    証明書が自己証明になっていました。

    第三者証明書を入れ直したところ、autodiscoverもうまくいきました。

    最初の方にご案内頂いたのに確認できていなくて申し訳ございません。
    ご対応頂きありがとうございました!

    2018年1月26日 0:18
  • 無事解決したようでよかったです。こちらこそ、色々時間がかかってしまい申し訳ございませんでした。

    Remote Connectivity AnalyzerでSSL証明書関連のエラーを無視する( Ignore Trust for SSL )をチェックするとエラーが表示されないこともこちらでも見落としており、問題ないと思ってしまっておりました。

    2018年1月26日 7:37