none
win7のPCがドメインに参加できない RRS feed

  • 質問

  • ドメインサーバ:2008server クライアントPC:win7
    本社と拠点間はインターネットVPN。本社LAN内はDHCP、拠点は手動IP。
    本社LANに接続すると正常にドメインに参加できているが、拠点LANに繋ぐと、ネットワークと共有コンピュータでドメインが表示されない。

    PING 拠点PC⇒本社サーバ OK 名前解決済み
    NSlookup ドメイン名 正常
    クライアントPCのファイアーウォール無効
    NetBIOS over TCP/IPを有効 
    ドメインに参加させる場合、完全修飾ドメイン名を使用

    エクスプローラのアドレス欄に(共有フォルダ名)でアクセスできない

    本社LANにてドメイン参加した状態で拠点LANに繋ぐとドメインユーザでログオンは出来る。
    但し、現地で一度workgroupに落として再度ドメインに参加させようとするとDNSに接続できないというエラー。

    一度ドメインから抜けているはずなのにADのcomputerの項目に該当のコンピュータ名が残存。
    残存していたコンピュータ名を削除。

    もう一度本社でドメイン参加させた別PCを再度拠点LANに接続すると、本社サーバから拠点PCへのリモートデスクトップが出来るがリモートデスクトップはすぐに切断される。
    本社サーバからリモートデスクトップが出来ているのに、拠点PCにはドメインコンピュータは一切表示されない。

    追記:
    クライアントPCでログイン後、DNSキャッシュクリアを実施。
    DNSマネージャの該当ドメインの一覧より該当PCのデータを削除

    現在、ネットワークと共有センターにドメインネットワークが表示されるようになり、Active Directoryの検索で本社LAN内にあるコンピュータ名が検索出来るようになりました。
    またIPアドレスで指定をすればネットワーク共有フォルダにもアクセスできます。

    が、名前解決が全く出来ていません。当然クライアントPCから本社LAN内にあるPCのアイコンは表示されません。またping ホスト名だとホスト名が見つかりませんというエラーが表示されます。
    さらにDNSマネージャのリスト(前方参照ゾーンの該当ドメイン)には該当コンピュータが表示されていません。別の拠点のPCでも同様の現象が発生している為、PC固有の問題ではなさそうです。

    何が考えられますでしょうか。
    対処法、原因の切り分け方法のご教授お願いします。 

    • 編集済み syslady2 2010年12月1日 8:07 追記
    2010年11月25日 2:59

回答

  • ブラウズには、マスタブラウザが必要になりますが、ルータ越えであれば

    基本的にブロードキャストが到達できないので他のサブネットの情報を受け取って

    ブラウズリストを作成することはありません。各拠点内ではマスタブラウザが居るため

    ブラウズできますが、拠点間ではマスタブラウザ同士が情報をやり取りすることはないので

    ブラウジングできないのではないかと思います。

    これを可能にするのがドメインマスタブラウザですが、Windows2008はディフォルトで

    Computer Browserサービスが開始していないためマスタブラウザにはなりません。

    Windows 2008 Active DirectoryのComputer Browserサービスが

    開始していることを確認してみてはどうでしょうか。

    参考:

    連載: Microsoft ネットワークを解剖する

    http://www.monyo.com/technical/windows/msnet/

    コンピュータ・ブラウジングについての解説

    http://www.geocities.jp/hanoura123/browse/noframe.htm

     

    • 回答としてマーク syslady2 2011年1月18日 6:42
    2010年12月13日 17:18

すべての返信

  • 状況が変わりドメインには参加出来るようになりました。
    が、ブラウジングが上手くいきません。
    またリモートデスクトップで接続すると、数秒毎に再接続していますというポップアップがあがります。
    そもそもルータ越えのブラウジングではWINSを使用しないと出来ないといったような事があるのでしょうか。

    ちなみに、拠点の親ルータから拠点PCをリモートデスクトップで繋ぐと通常に繋がります。
    但し、本社LAN内から拠点PCにリモートデスクトップで接続すると再接続のポップアップが数秒毎に出続けます。

    拠点ルータ側には一切フィルタリングはしていないとの事で、社内LAN側のルータ及びDNSサーバでも特にファイアーウォールやフィルタリング、セキュリティ設定等はしていないとの事です。

    何が考えられますでしょうか。
    対処法、原因の切り分け方法のご教授お願いします。

    2010年12月6日 2:12
  • ブラウズには、マスタブラウザが必要になりますが、ルータ越えであれば

    基本的にブロードキャストが到達できないので他のサブネットの情報を受け取って

    ブラウズリストを作成することはありません。各拠点内ではマスタブラウザが居るため

    ブラウズできますが、拠点間ではマスタブラウザ同士が情報をやり取りすることはないので

    ブラウジングできないのではないかと思います。

    これを可能にするのがドメインマスタブラウザですが、Windows2008はディフォルトで

    Computer Browserサービスが開始していないためマスタブラウザにはなりません。

    Windows 2008 Active DirectoryのComputer Browserサービスが

    開始していることを確認してみてはどうでしょうか。

    参考:

    連載: Microsoft ネットワークを解剖する

    http://www.monyo.com/technical/windows/msnet/

    コンピュータ・ブラウジングについての解説

    http://www.geocities.jp/hanoura123/browse/noframe.htm

     

    • 回答としてマーク syslady2 2011年1月18日 6:42
    2010年12月13日 17:18
  • assa-huhuhu 様
    ご教授ありがとうございます。

    仰るとおりComputer Browserサービスは無効になっています。
    こちらのサービスを有効にすればADサーバがドメインマスタブラウザとして機能してくれるはずなので見えるのではないかという事ですね。

    早速ベンダーに確認させます。
    大変有力な情報をありがとうございました。

    2010年12月15日 1:39