none
Hyper-V エクスポートファイルの互換性 RRS feed

  • 質問

  • Windows Server 2008 R2 Hyper-V 2.0で作成したエクスポートファイルを
    Windows Server 2008 Hyper-V1.0でインポートしようとしたところ、
    「仮想マシンのインポート中にエラーが発生しました」と表示されインポートできませんでした。

    作成したエクスポートファイルは上位互換のみで下位互換はないのでしょうか?
    それとも、Hyper-V 2.0からエクスポートする際に何か方法があるのでしょうか?

    操作した手順は下記の通りです
    1.Windows Server 2008 SP2 Hyper-V1.0に、仮想マシンをインストール
    2.仮想マシンの設定を変更し、スナップショットを作成
    3.Windows Server 2008 SP2 Hyper-V1.0から、仮想マシンをエクスポートする
    4.Windows Server 2008 R2 Hyper-V2.0に、仮想マシンをインポート(正常にインポートできる)
    5.仮想マシンの設定を変更し、スナップショットを作成
    6.Windows Server 2008 R2 Hyper-V2.0から、仮想マシンをエクスポートする
    7.Windows Server 2008 SP2 Hyper-V1.0に、仮想マシンをインポート(インポートに失敗する)

    2009年9月11日 5:45

回答

すべての返信

  • 互換性については、少なくともスナップショットは上位互換もありません。
    スナップショットが無い場合は、

    他のサーバのVMをHyper-VにインポートするとError 0x80070057が発生する
    http://techbank.jp/Community/blogs/nora/archive/2009/07/11/10046.aspx

    が参考になるかもしれません。

    イベントビュワーでエラーの詳細を確認すると問題の切り分けにやくだつと思います。


    http://techbank.jp/nora/(SQL Serverを中心に情報発信中)
    2009年9月11日 12:20
  • 野良さま 回答ありがとうございます。

    >他のサーバのVMをHyper-VにインポートするとError 0x80070057が発生する
    http://techbank.jp/Community/blogs/nora/archive/2009/07/11/10046.aspx

    インポートの際に0x80070057のエラーは発生していませんでしたので、
    今回はこの現象ではないと思われます。

    こちらで、エクスポートについて試した内容です。

    スナップショットなし
     Hyper-V1.0からHyer-V2.0:正常にインポートでき、起動する。
     Hyper-V2.0からHyer-V1.0:正常にインポートでき、起動する。

     ・新規仮想マシンから、「既存の仮想ハードディスクを使用する」でも問題なく起動する。

    スナップショットあり
     Hyper-V1.0からHyer-V2.0:正常にインポートでき、起動する。
     Hyper-V2.0からHyer-V1.0:インポート不可。下記のイベントを含み複数のエラーが発生する。

     >>ログの名前:         Microsoft-Windows-Hyper-V-VMMS-Admin
     >>イベント ID:       18240
     >>説明:
     >>仮想ハード ディスク ファイル 'E:\Hyper-V\新しい仮想マシン\Snapshots\C813CB63-900B-403C-BF14-9F7AF11D9F4A\新しい仮想マシン_3FF9346D-B746-4A65-BC59-37467F933E6A.avhd' が見つかりません。エラー: 指定されたファイルが見つかりません。 (0x80070002)。

    状態ファイルあり(スナップショットなし)
     Hyper-V1.0からHyer-V2.0:正常にインポートできるが、起動できない。下記のイベントが発生する。
     Hyper-V2.0からHyer-V1.0:正常にインポートできるが、起動できない。下記のイベントが発生する。

     >>ログの名前:         Microsoft-Windows-Hyper-V-Worker-Admin
     >>イベント ID:       3082
     >>説明:
     >>'新しい仮想マシン' の保存された状態ファイルのバージョンは互換性のない E:\Hyper-V\新しい仮想マシン\Virtual Machines\B666DB2B-21D5-42C7-8892-0743B13DE0D7\B666DB2B-21D5-42C7-8892-0743B13DE0D7.vsv です。(仮想マシン ID B666DB2B-21D5-42C7-8892-0743B13DE0D7)

     ・「保存された状態を削除」すると、起動できる。(エラー回復処理が表示される場合がある)

    上記の事から、
     スナップショットなし:上位互換、下位互換あり
     スナップショットあり:上位互換あり
     状態ファイルあり:互換なし
    と認識していましたが、

     スナップショットなし:上位互換、下位互換あり
     スナップショットあり:互換なし
     状態ファイルあり:互換なし

    ということなのでしょうか?

    2009年9月14日 5:21
  • 1.0⇒2.0についてはこのKBが参考になると思います。

    http://support.microsoft.com/kb/957256/ja


    スナップショット・状態ファイルの互換性については、あまり良いことが書いていないので、
    あまり期待しない方が良いのだと思います。
    2009年9月14日 5:40
  • TENKI28さま

    回答ありがとうございます。

    スナップショットについては基本的に互換性なし。と理解しました。
    ありがとうございました。

    2009年9月24日 3:49