locked
Windows7 XP-Modeの導入失敗

    質問

  • 続けて質問させていただくのは恐縮なのですが

    Windows7 X64 にWindows Virtual PCを導入して、XP-Modeを試そうと思ったのですが、導入で失敗して再度実行する旨のメッセージが表示された
    のですが、何度やってもうまくいきません。

    すでに作成していたWindows7 Starterの仮想環境は実行出来たのですが。

    以前β(32bit版)やRCの時は、実行出来たのですが、RTM版から動かなくなった感じです。

    同様の現象を解決された方がいらっしゃいましたらご教授頂ければ幸いです。

    なんとなく、OSからもう一度入れなおせばいいような気がしますが・・・・



    SRHSRH
    2009年10月16日 6:13

回答

  • 返信、遅くなりました。(先ほど、客先から戻りました。)

    明日インシデントを使うなら、ダメもとで、他の仮想化アプリをインストールして起動/停止したところ、
    すんなりXP-Modeが動くようになりました。
    CPUがAMDだと、OSのインストールをした状態で、レジストリのどこかに仮想化アプリが立てるビットでも立ったままになったのでしょうか?

    とにかくAMD Phenomで動くようになりました。
    以下は、あくまでも対処療法です。

    1.Sun VirtualBox(VirtualBox-3.0.8-53140-Win.exe) をダウンロード/インストール
    2.Sun VirtualBoxを起動して、仮想マシンを1つ作成(Windows7 64bit)
    3.CDにMSDNからダウンロードした製品版Windows7 Ultimate 64bitのISOファイルをマウント
    4.仮想マシンを起動
    5.Windows 7のインストール画面が出たら、仮想マシンを停止。
    6.Sun VirtualBoxを終了する。
    (もしかしたら、1,2,4、6だけで動くようになるかも知れません。)

    その後で、XPモードの設定を行うと、今までのエラーがうそのように、ちゃんとWindows XPのウィンドウが開くようになりました。

    • 回答としてマーク SRHSRH 2009年10月21日 0:05
    2009年10月20日 11:53

すべての返信

  • 続けて質問させていただくのは恐縮なのですが

    Windows7 X64 にWindows Virtual PCを導入して、XP-Modeを試そうと思ったのですが、導入で失敗して再度実行する旨のメッセージが表示された
    のですが、何度やってもうまくいきません。

    すでに作成していたWindows7 Starterの仮想環境は実行出来たのですが。

    以前β(32bit版)やRCの時は、実行出来たのですが、RTM版から動かなくなった感じです。

    同様の現象を解決された方がいらっしゃいましたらご教授頂ければ幸いです。

    なんとなく、OSからもう一度入れなおせばいいような気がしますが・・・・



    SRHSRH
    私も、駄目でした。

    「他の仮想化ソフトウェアの実行中にWindows Virtual PCを起動することはできません。
    他の仮想化ソフトウェアを終了し、やり直してください。」
    というメッセージでは、ないですか?

    RTM版 Windows 7 Ultimate 64bitです。

    Phenom X4のマシンは、駄目で、
    Core i7のマシンは動きました。

    まだ解決方法がわかりません。
    2009年10月19日 4:24
  • 情報ありがとうございます。
    mkamataさんのご指摘通りのメッセージです。

    そういえば、私は詳細なハードウェア情報を載せていませんでしたね。

    -- 動かなかった環境 ---
    CPU        AMD Athlon X2 5600  
    MEMORY  5.0GByte
    OS          RTM版 Windows 7 Ultimate 64bit

    ただし、以下は実行できました。
     RTM版 Windows7 Starter(J/E)は実行可能(VistaSP2上でVirtualPC2007SP1で作成)
     WindowXP SP3  (VistaSP2上でVirtualPC2007SP1で作成)

    -- 動いた環境 ---
    CPU        上記とおなじ
    MEMORY  4.0GByte
    OS          RC版  Windows 7 Ultimate 32bit(だったような)

    ------
    もしかして、AMDは駄目?
    駄目ならば32bitに変更するしかないですかね。

    家の環境ではWindows7 が動かせる環境はあと1つしかなくてatom 330・・・・
    VTサポートしてないですから試せないですね。

    蛇足ですが
    Windows7 βの時はVirtual PC 2007 SP1 を導入して 上記AMD 系CPUでVista で作成した仮想環境は以下の物が稼動させられることを確認して
    います。

    ・Vine Linux
    ・MS-DOS 6.2
    ・Window 3.1
    ・lindows 4.0
    ・Windows2000
    ・Windows Home Server
    などなど

    導入できなかったものは以下の通りです。
    ・jaris(Virtual Boxでは稼動確認)
    ・Open soraris
    ・Ubuntu(VM Playerでは稼動確認 video 24bitの問題を解決すればいいんですよね・・・)

    ってこれくらいみなさん 検証しているんですよね きっと



    SRHSRH
    2009年10月19日 6:36
  • 知人からの情報です。
    動いたのはやはりIntelです。
    PC:NEC Express5800/110 Ge
    CPU:Intel Core2Duo E8500
    製品版Windows7 Ultimate x64でXP-Mode問題なく動いているそうです。

    どなたかCPUがAMDで
    製品版Windows7 Ultimate x64でXP-Modeが動作している方いませんか?

    2009年10月20日 0:06
  • 「2ch Windows 7 64bit版限定スレ Part5」にも出ていますね。
    713~715

    715によると、32bitも駄目だとか。
    ただしCPUについての情報は出ていません。
    2009年10月20日 0:23
  • 安藤@大分です。

    うまくいかない環境のPCのBIOS更新があったらアップデートしてみるのも
    一つの手かもしれません。

    若干リスクはありますが。


    ANDO Koji (https://mvp.support.microsoft.com/profile/Ando)
    2009年10月20日 2:12
  • 動かないAMD Phenom 9850の
    MB:Gigabyte GA-MA78GM-S2H (rev. 2.x)は、
    Windows 7をインストールする前に最新のBIOSにアップデートしました。

    MSDNのプロフェッショナル インシデントを使って解決するより、
    もうすぐWindows 7発売なので、サポートにいろんな情報が集まるまで
    待ったほうが賢明でしょうか?

    2009年10月20日 2:44
  • 安藤@大分です。

    あと当然メッセージの通り、他の仮想化アプリケーションは動かしてませんよね。
    当方ではVMware と VirtualPCを同時に動かしたらすでに動いている方にアプリケーションエラーが起きてました。
    (ゲストは青画面で落ちる)


    ANDO Koji (https://mvp.support.microsoft.com/profile/Ando)
    2009年10月20日 2:46
  • もちろん、このPCには、VMwareやVirtualBoxなど仮想化ソフトは、インストールしたことさえありません。
    OSをインストールしたてで、ほとんどまっさらな状態です。
    2009年10月20日 2:51
  • 安藤@大分です。

    これはあきらかに不具合だと思われますので、インシデントは消費されないと思います。
    使えるなら使って問題解決を依頼する方が賢明と個人的には思います。


    ANDO Koji (https://mvp.support.microsoft.com/profile/Ando)
    2009年10月20日 2:56
  • 安藤@大分です。

    すでにレスポンスしていますが、インシデントが利用可能なら、問題解決を依頼する方がよろしいかと思います。
    解決したときにインシデントが消費されない保証は出来かねますが(^^ゞ
    ANDO Koji (https://mvp.support.microsoft.com/profile/Ando)
    2009年10月20日 2:58
  • 返信、遅くなりました。(先ほど、客先から戻りました。)

    明日インシデントを使うなら、ダメもとで、他の仮想化アプリをインストールして起動/停止したところ、
    すんなりXP-Modeが動くようになりました。
    CPUがAMDだと、OSのインストールをした状態で、レジストリのどこかに仮想化アプリが立てるビットでも立ったままになったのでしょうか?

    とにかくAMD Phenomで動くようになりました。
    以下は、あくまでも対処療法です。

    1.Sun VirtualBox(VirtualBox-3.0.8-53140-Win.exe) をダウンロード/インストール
    2.Sun VirtualBoxを起動して、仮想マシンを1つ作成(Windows7 64bit)
    3.CDにMSDNからダウンロードした製品版Windows7 Ultimate 64bitのISOファイルをマウント
    4.仮想マシンを起動
    5.Windows 7のインストール画面が出たら、仮想マシンを停止。
    6.Sun VirtualBoxを終了する。
    (もしかしたら、1,2,4、6だけで動くようになるかも知れません。)

    その後で、XPモードの設定を行うと、今までのエラーがうそのように、ちゃんとWindows XPのウィンドウが開くようになりました。

    • 回答としてマーク SRHSRH 2009年10月21日 0:05
    2009年10月20日 11:53
  • マシンを起動するたびに、元のエラーの状態に戻ることがわかりました。

    起動したら、一度、Sun VirtualBoxで、仮想マシンの起動/停止を行う必要があります。

    やはり、明日、インシデントを使うしか無いようですね。

    2009年10月20日 14:20
  • mkamataさん

    いろいろとご回答や調べていただいて感謝です。
    私のほうでも実施された作業を試してみて、インシデント使って見ます(使ったことないんで(^^;)

    ありがとうございました。



    SRHSRH
    2009年10月20日 23:59
  • SRHSRHさん

    > 私のほうでも実施された作業を試してみて、インシデント使って見ます(使ったことないんで(^^;)
    実は、私も使ったことが無いです。

    Sun VirtualBoxは、オープンソースなので、ソースをダウンロードしてみました。
    仮想マシンの停止部分のソースを読んでみて、不具合の原因をもう少し突き止めてから、
    インシデントを使ってみようかと思っていました。

    うまくすれば、AMD CPUのエラー解除のコマンドが作れるかと思います。

    進展があれば、報告します。
    2009年10月21日 0:29
  • mkamataさん

    私もVirtual Boxのソース今朝家でダウンロードしてました。(^^;;

    最近プログラム作ってないんで自信ないんですが私もソースみてみようと思っています。

    でも、解除コマンドまで考えませんでした

    重ねてありがとうございました。
    また、進展があれば教えていただければ幸いです。





    SRHSRH
    2009年10月21日 1:25
  • こんにちは、フォーラムオペレーターの三沢健二です。

    ご投稿された内容について、私の方でも少し調べてみたところ、海外のフォーラムでも同じようなご質問が投稿されていました。

    - 参考スレッド
    Cannot start Windows Virtual PC while another virtualization software is running.
    http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/a5ad0258-6c46-4ee3-89ff-3373d9a12030

    Windows XP Mode virtualization installation error
    http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/23b11210-74e7-4fb2-9503-97b351d1e99a

    Gigabyte AMD motherboards having problems Running XP Mode
    http://techreport.com/forums/viewtopic.php?f=36&t=67888&p=971067


    上記各スレッドの共通点として、Gigabyte 製のマザーボードと AMD 製 CPU の組み合わせで XP-MODE が動作しない場合があり、マザーボードの BIOS のバージョンアップで回避出来ているようですが、以下のような少し気になるコメントも投稿されていました。

    -- 抜粋 --
    i contacted gigabyte, they gave me a beta version for my motherboard, but it is not listed on their website. so here it is, i uploaded it; until they get their final bios out. my board is GA-MA790GP-DS4H.
    ----------
    (タイトル 「Cannot start Windows・・・」のスレッド、10/7 の thetonestarr さんのコメントです)

    どうも、一般公開されていないベータバージョンの BIOS をメーカーより入手されたようです。
    そのため、現在公開されている最新の BIOS に更新されても問題が回避出来ない可能性がありますので、一度メーカーにお問い合わせいただくか、より新しいバージョンの BIOS が公開されるのをお待ちいただければと思います。


    それでは、こちらの情報が少しでもお役にたてれば幸いです。

    ______________________________________
    マイクロソフト株式会社 フォーラムオペレーター 三沢健二

    2009年10月22日 2:46
    モデレータ
  • 三沢様、有益な情報をどうもありがとうございました。

    さっそく、「Gigabyteのサポートにエラーが起きないBIOSの最新版を下さい」とメールしました。

    エラーの起きないBIOSが来るまでは、マシン起動時に、Sun/VirtualBoxを起動/停止して逃げることにします。

    SRHSRHさんへ
    Sun VirtualBoxのオープンソース、なかなか、ビルドしてEXEができるまでになりません。まだ少しかかりそうです。

    2009年10月22日 5:26
  • Gigabyteのサポートから最新のBIOSを教えてもらいダウンロードして、BIOSを最新にしたところ、
    マシンを起動しても普通に、XPモードが動くようになりました。

    三沢様、どうもありがとうございました。

    2009年10月22日 6:37
  • 三沢さん
    mkamataさん

    情報ありがとうございました。

    さて、私の状況ですが、なんとSun VirtualBoxを導入しただけでXP-MODEが導入できてしまいました。
    私のPCもGigabyteのマザーボードなのですがBIOSの更新なしでVirutalBox導入だけで、仮想OSを構築もしない状態です。

    ちょっと失敗したのは、その前にAdobe Reader9も導入したので本当にVirtualBoxだったのかは定かではありません。




    SRHSRH
    2009年10月22日 12:43