none
SharePoint Foundation 2010 Searchで警告(0x80041205) RRS feed

  • 質問

  • 当方SharePoint環境を初めて構築する者ですが、ひとつうまくいかないことがあり困っています。
    現在SharePoint Foundation 2010のFoundation Searchで問題が発生しています。
    インデックスサーバーがクロールを開始するタイミングで、アプリケーションイベントに以下の警告イベントが記録されインデックスが作成されません。

    --------------------------
    レベル:警告
    ソース:Microsoft-SharePoint Products-SharePoint Foundation Search
    イベントID:14
    タスク:Gatherer

    開始アドレス sts4://アプリケーションサーバーのFQDN/contentdbid={********-****-****-****-************} をクロールできませんでした。

    コンテキスト: アプリケーション '検索サーバー上の検索インデックス_ファイル'、カタログ 'Search'

    詳細 :
    アクセスが拒否されました。既定のコンテンツ アクセス アカウントにこのリポジトリへのアクセス権が付与されていることを確認するか、このリポジトリをクロールするためのクロール ルールを追加してください。クロール対象のリポジトリが SharePoint リポジトリである場合は、使用しているアカウントに、クロール対象の SharePoint Web アプリケーションに対する "すべて読み取り" のアクセス許可があることを確認してください。   (0x80041205)
    --------------------------

    環境
    AD    WindowsServer 2008R2 SP1(ドメイン機能レベル WindowsServer2003)
    SQL    WindowsServer 2008R2 SP1 + SQL Server 2008 R2 SP2
    SharePoint(アプリケーションサーバー)
        WindowsServer 2008R2 SP1 + SharePoint Foundation 2010
    SharePoint(インデックスサーバー)
        WindowsServer 2008R2 SP1 + SharePoint Foundation 2010

    コンテンツアクセスアカウントには、SharePointのサービスアカウントと同じものを設定していて、サイトへのフルのアクセス権を持っていますので、アクセス許可に問題はないと思うのですが....

    ちなみに、以下のレジストリ追加はSharePointインストール前に実施済みです。
    HKLM\system\CurrentControlSet\Lsa\DisabaleLoopbackCheck = 1


    何か解決のヒントになることがあればご教授いただきたく存じます。
    よろしくお願いします。
    • 移動 星 睦美 2012年12月21日 2:15 適切なフォーラム (移動元:SharePoint - インストールと設定、管理)
    2012年12月7日 8:33

回答

  • 自己レスになります。

    Proxyが関係しているようでした。

    コンテンツサーチ用のアカウントでインデックスサーバーにログオンし、インターネットオプションでプロキシサーバーの使用をしないよう設定すると上記警告はなくなりインデックスが作成されました。

    ユーザープロファイルのプロキシ設定を止めることとサービスの動作が関係している理由が釈然としませんが....

    とりあえずご報告まで。

    • 回答としてマーク 星 睦美 2012年12月21日 2:10
    2012年12月11日 5:39

すべての返信

  • 330mil さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    私のほうでも何か関連する情報がないか調べてみたところ、
    英語のブログに今回の質問内容と関連した内容を見つけました。
    参考までにご紹介します。

    (参考情報)
    SharePoint Foundation 2010 Search Failing with Event ID 14 and Access Denied Errors:
    http://blog.mjhamilton.com/?p=65

    ブログでは最後にコマンド プロンプトから"iisreset" を実行しています。(こちらも実行済みでしょうか?)


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美

    2012年12月10日 7:56
  • 星様

    ご返信ありがとうございます。

    IISRESETは実行しています。何度か再起動もしていますが改善しません。

    その後いろいろと試していてわかったことがあります。

    Webアプリケーション作成の際にパブリックURLに「FQDN」を設定するとこの現象が発生し、「NetBIOS名」で設定すれば現象は発生せず正常にインデックスが作成されることがわかりました。

    インデックスサーバーのブラウザからは、FQDNでもちゃんとアプリケーションサーバーのサイトが表示できているので、名前解決の問題ではないと思いますが....

    引き続き何か情報があればご教授ください。よろしくお願いします。

    2012年12月11日 2:44
  • 自己レスになります。

    Proxyが関係しているようでした。

    コンテンツサーチ用のアカウントでインデックスサーバーにログオンし、インターネットオプションでプロキシサーバーの使用をしないよう設定すると上記警告はなくなりインデックスが作成されました。

    ユーザープロファイルのプロキシ設定を止めることとサービスの動作が関係している理由が釈然としませんが....

    とりあえずご報告まで。

    • 回答としてマーク 星 睦美 2012年12月21日 2:10
    2012年12月11日 5:39
  • 解決の結果をお知らせいただきありがとうございます。

    私のほうでこちらのスレッドに[回答としてマーク]して、参考のスレッドとさせていただきます。
    今後ともTechNet フォーラムをよろしくお願いします。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美

    2012年12月21日 2:14