none
TS Webアクセス管理画面の構成タブでのターミナルサーバ接続エラーについて RRS feed

  • 全般的な情報交換

  • 現在WindowServer2008RC1でTSWebアクセスの検証をしていますが、、TSゲートウェイ上のWebサイトに接続先となるターミナルサーバ上のTSWebサイトの内容を表示させることができません。

    以下、具体的な内容となります。

     


    【実現したい内容】
    TSゲートウェイサーバ上のTSWebサイトに、ターミナルサーバ(TSゲートウェイとは別サーバ)上のTSWebサイトに登録してあるアプリアイコンを表示させたい。

    (全体的な構成としては、クライアントPCからTSゲートウェイ経由で接続先のターミナルサーバのWebサイトを表示させる形)

     

    ■TSゲートウェイサーバ:Win2008Server)
    TSWebサービスをインストールし、TSWebへの接続可能な状態。
    *TSゲートウェイ兼ドメインサーバ(ドメイン名をDomain1.co.jpとする)として構築。
    ■接続先となるターミナルサーバー(Win2008Server)
    Excel2003をサーバにインストールし、RemoteAppプログラムに登録。
    TSWebサービスをインストールし、TSWeb上にExcelのアイコンが表示される状態になっている。
    *ドメインDomain1.co.jpに参加させた状態。

     

    【問題点】
    TSゲートウェイサーバにログオンし、IEでhttps://<TSゲートウェイサーバ名>.<ドメイン名>/tsにアクセスし、管理者権限付のドメインユーザ(IDをadmin1とする)でログオン後、【構成】タブを選択し、画面右側にある【TSWebアクセスのプロパティ】で、接続先のターミナルサーバのホスト名を指定しても以下のエラーメッセージが表示されて接続に失敗してしまう。

     

    「TS Webアクセスは指定のターミナルサーバにアクセスできませんでした。TSWebアクセスサーバのコンピュータアカウントが
    ターミナルサーバ上のTSWebAccessComputersセキュリティグループに追加されていることを確認してください。」

     

    しかし、接続先のターミナルサーバにログオンして、【ローカルユーザとグループ】のグループを参照しても、「TSWebAccessComputers」というグループは存在していません。

    存在していないこと自体、何か問題があるのではないかと考えていますが・・


    【補足】
    実現したい内容と逆のケース(ターミナルサーバ上のTSWebサイトにTSゲートウェイ上のTSWebの内容を表示させる。)を試してみましたが、この場合、エラーメッセージの内容のとおり、接続先となるTSゲートウェイサーバ上の【管理ツール】>【Active Directoryユーザとコンピュータ】の【Users】を参照すると、【TSWebAccessComputers】というセキュリティグループが存在していたので、そこにTSWebにログオンする際に使用するドメインユーザadmin1を登録することで接続することができました。
    *念のため、【TS Web Access Administrators】というセキュリティグループにもadmin1を追加してあります。

     

    ターミナルサーバはTSゲートウェイのドメインに参加しているため、ターミナルサーバもしくはTSゲートウェイ上のTSWeb管理のサイトにアクセスする場合、同一のドメインユーザ(admin1)を利用するため、ドメインサーバ(兼TSゲートウェイサーバ)上のTSWebAccessComputersグループにadmin1を追加してあげるだけで、双方の通信が取れるのではないかと思ったのですが、そうではないようです。

    上記問題について、解決策を知っている方がいましたらご教授の程、宜しくお願い致します。

     

    2008年1月18日 2:47

すべての返信

  • 本問題ですが、接続先のターミナルサーバにTSWebAccessComputers」というグループが存在していないことが問題と思われたため、別の接続先のターミナルサーバを用意して確認したところ、ターミナルサービスのインストールの際に、このTSWebAccessComputersというセキュリティグループが作成されることが分かりました。

    問題の発生するターミナルサーバには既にターミナルサービスはインストールされていましたが、TSWebAccessComputersが存在していないことから正常にインストールがされていなかったようです。

    再度ターミナルサービスをインストールしなおしたところ、TSWebAccessComputersグループが作成され、TSWebAccessComputersにログオンユーザIDを追加することで、TSWebにおいてTSゲートウェイからターミナルサーバ上にアクセスすることができました。

     

    2008年1月18日 8:06
  • こんにちは。森田 知良です。


    TSWeb太郎さん、フォーラムのご利用ありがとうございます。

    また、大変有用な情報を投稿してくださりありがとうございます。


    ご投稿の内容については、TSWeb太郎さんのほうで解決されたようですので、
    よろしければ投稿メッセージの種類を「質問」から「コメント」に変更していただけないでしょうか?


    「質問」のままですと、せっかくの有用な情報が埋もれてしまい、
    他のフォーラム利用者の方に活用して頂けなくなってしまいますので。。。

     

    また、追加の質問などがありましたら、是非もう一度投稿してくださるようお願いします。

     

    それでは、これからもフォーラムのご利用をよろしくお願いいたします。

    2008年4月22日 5:54
  • こんにちは。森田 知良です。

     

    TSWeb太郎さんが投稿してくださった解決方法をフォーラム利用者の方々が
    有効に活用して頂けるよう、勝手ながらメッセージの種類を
    「質問」から「コメント」に変更させていただきました。

     

    それでは、これからもフォーラムのご利用をよろしくお願いいたします。

    2008年4月28日 5:48