none
windows7 でBASIC認証のかかったWEBDAVにログインできません

    質問

  • Windows7でbasic認証のかかったwebdav folderを作成してログインしようとしてもできません。 windowxpあるいはxpモードでは問題なくログインでき、MSIEでも表示されます。

     

     

    2010年4月4日 2:15

回答

  • やじ さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ご質問の件に関しまして、私の方で調べてみましたところ、海の向こうのサイトに、参考になりそうな情報が公開されていました。
    http://www.liferay.com/web/guest/community/forums/-/message_boards/message/3987708 (英語)

    上記のリンク情報によりますと、「Windows 7 では、SSL 接続を使用しない基本 HTTP 認証によるアクセスが Windows のセキュリティで制限されているため、レジストリ キーを変更する必要がある」 とのことですので、上記のリンク先で詳細を確認されてみてはいかがでしょうか?
    もし英語の表現で不明な箇所がありましたら、お気軽にお尋ねください。 (^^)

    もしこちらの情報があまり参考にならないようでしたら、、、お手数ですが、
    やじ さんの環境に関する詳細 (ご使用の WEBDAV サーバーの種類など) をいただくことはできますでしょうか?
    もしかすると、WEBDAV サーバー側の設定などが関係しているかもしれませんので・・・

    こちらの情報がお役に立てることを願っています。
    それでは、また! (^_^)/

    _______________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2010年4月7日 5:51
    モデレータ

すべての返信

  • やじ さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ご質問の件に関しまして、私の方で調べてみましたところ、海の向こうのサイトに、参考になりそうな情報が公開されていました。
    http://www.liferay.com/web/guest/community/forums/-/message_boards/message/3987708 (英語)

    上記のリンク情報によりますと、「Windows 7 では、SSL 接続を使用しない基本 HTTP 認証によるアクセスが Windows のセキュリティで制限されているため、レジストリ キーを変更する必要がある」 とのことですので、上記のリンク先で詳細を確認されてみてはいかがでしょうか?
    もし英語の表現で不明な箇所がありましたら、お気軽にお尋ねください。 (^^)

    もしこちらの情報があまり参考にならないようでしたら、、、お手数ですが、
    やじ さんの環境に関する詳細 (ご使用の WEBDAV サーバーの種類など) をいただくことはできますでしょうか?
    もしかすると、WEBDAV サーバー側の設定などが関係しているかもしれませんので・・・

    こちらの情報がお役に立てることを願っています。
    それでは、また! (^_^)/

    _______________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2010年4月7日 5:51
    モデレータ
  • こんにちは、フォーラムオペレーターの三沢健二です。

    やじ さん、その後問題は解決できましたか?

    弊社 服部 の案内した内容は有用な情報と思いましたので、勝手ながら [回答としてマーク] を付けさせていただきました。
    よろしければ、試された結果などをお知らせいただけると嬉しいです。


    それでは、今後とも TechNet Forum をよろしくお願いします。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    2010年4月15日 7:20
    モデレータ
  • いろいろ調べてみました。

    私がアクセスしているWebDavは

    https://jpitor.ittec.ne.jp/member/test1/docs

    です

    ID:test1

    Password:test1

    です。 WindowsXPでは問題なくログインできます。試してみてください。

    次にWindows7で2つの方法で試して見ました。

    Change or create the Registry key “HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel” (REG_DWORD) and set its value to “2“.

    を実行しました。 

    (これは非SSLでの問題で今回はSSLですので関係ないと思いますが)

    ① コンピュータ→ネットワークドライブの割り当て→ドキュメントと画像の保存に使用できるWebサイトに接続します→次へ→

    カスタムのネットワークの場所を選択→https;//jupitor.ittec.ne.jp/member/test1/docs→次へ→

    ユーザ認証画面が出るので、ユーザ名:test1、 Password:test1を入れる→

    名前:jupitor.ittec.ne.jp→次へ→

    (message) このネットワークの場所は正しく作成されました

    (message) jupitor.itttec.ne.jp

    →[完了]

    →コンピュータのネットワークの場所にjupitor.ittec.ne.jpが表示される

    →jupitor.ittec.ne.jpをクリックしても開かない。

    なお、jupitor.ittec.ne.jpのプロパティは

    種類:ファイルフォルダー

    リンク先:https://jupito.ittec.ne.jp/member/test1/docs/

     

    > net use https://jupitor.ittec.ne.jp/member/test1/docs →

    (system message) 'jupitor.ittec.ne.jp' のユーザ名を入れてください: test1

    (system message) jupitor.ittec.ne.jpのパスワードを入れてください:(test1)

    (system message) システムラー 1219が発生しました

    同じユーザーによるサーバーまたは共有リソースへの複数のユーザ名での複数の接続は許可されていません。サーバーまたは共有リソースへの以前の接続をすべて切断してから再試行してください

    > net stop webclient

    (system message) システムエラー 5 が発生しました。

    アクセスが拒否されました。

    なお、試験に使用したサーバーOSはCentOS4.6、webdavロケーションはhttps://jupitor.ittec.ne.jp/memmber,

    BASIC 認証はhttps://jupitor.ittec.ne.jp/member/test1 に設定されています。 https://jupitor.ittec.ne.jpはサーバー認証が(RAPID SSL)インストールされています

    https://jupitor.ittec.ne.jp/member/test1/docsは現在公開されています。

    なお、BASIC認証をはずすと問題なくアクセスできるようです。

     

     

     

     

     

     

     

     

     

     

    2010年4月15日 12:38
  • いろいろ調べてみました。

    私がアクセスしているWebDavは

    https://jpitor.ittec.ne.jp/member/test1/docs

    です

    ID:test1

    Password:test1

    です。 WindowsXPでは問題なくログインできます。試してみてください。

    次にWindows7で2つの方法で試して見ました。

    Change or create the Registry key “HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel” (REG_DWORD) and set its value to “2“.

    を実行しました。 

    (これは非SSLでの問題で今回はSSLですので関係ないと思いますが)

    ① コンピュータ→ネットワークドライブの割り当て→ドキュメントと画像の保存に使用できるWebサイトに接続します→次へ→

    カスタムのネットワークの場所を選択→https;//jupitor.ittec.ne.jp/member/test1/docs→次へ→

    ユーザ認証画面が出るので、ユーザ名:test1、 Password:test1を入れる→

    名前:jupitor.ittec.ne.jp→次へ→

    (message) このネットワークの場所は正しく作成されました

    (message) jupitor.itttec.ne.jp

    →[完了]

    →コンピュータのネットワークの場所にjupitor.ittec.ne.jpが表示される

    →jupitor.ittec.ne.jpをクリックしても開かない。

    なお、jupitor.ittec.ne.jpのプロパティは

    種類:ファイルフォルダー

    リンク先:https://jupito.ittec.ne.jp/member/test1/docs/

     

    > net use https://jupitor.ittec.ne.jp/member/test1/docs →

    (system message) 'jupitor.ittec.ne.jp' のユーザ名を入れてください: test1

    (system message) jupitor.ittec.ne.jpのパスワードを入れてください:(test1)

    (system message) システムラー 1219が発生しました

    同じユーザーによるサーバーまたは共有リソースへの複数のユーザ名での複数の接続は許可されていません。サーバーまたは共有リソースへの以前の接続をすべて切断してから再試行してください

    > net stop webclient

    (system message) システムエラー 5 が発生しました。

    アクセスが拒否されました。

    なお、試験に使用したサーバーOSはCentOS4.6、webdavロケーションはhttps://jupitor.ittec.ne.jp/memmber,

    BASIC 認証はhttps://jupitor.ittec.ne.jp/member/test1 に設定されています。 https://jupitor.ittec.ne.jpはサーバー認証が(RAPID SSL)インストールされています

    https://jupitor.ittec.ne.jp/member/test1/docsは現在公開されています。

    なお、BASIC認証をはずすと問題なくアクセスできるようです。

    以下の方法でアクセスできました。

    net use w: https://jupitor.ittec.ne.jp/member/test1/docs

    ネットワークドライブ名(w:)を入れていなかったのが原因でした。

     

     

     

     

     

     

     

     

     


    2010年4月23日 7:49
  • いろいろ調べてみました。

    私がアクセスしているWebDavは

    https://jpitor.ittec.ne.jp/member/test1/docs

    です

    ID:test1

    Password:test1

    です。 WindowsXPでは問題なくログインできます。試してみてください。

    次にWindows7で2つの方法で試して見ました。

    Change or create the Registry key “HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel” (REG_DWORD) and set its value to “2“.

    を実行しました。 

    (これは非SSLでの問題で今回はSSLですので関係ないと思いますが)

    ① コンピュータ→ネットワークドライブの割り当て→ドキュメントと画像の保存に使用できるWebサイトに接続します→次へ→

    カスタムのネットワークの場所を選択→https;//jupitor.ittec.ne.jp/member/test1/docs→次へ→

    ユーザ認証画面が出るので、ユーザ名:test1、 Password:test1を入れる→

    名前:jupitor.ittec.ne.jp→次へ→

    (message) このネットワークの場所は正しく作成されました

    (message) jupitor.itttec.ne.jp

    →[完了]

    →コンピュータのネットワークの場所にjupitor.ittec.ne.jpが表示される

    →jupitor.ittec.ne.jpをクリックしても開かない。

    なお、jupitor.ittec.ne.jpのプロパティは

    種類:ファイルフォルダー

    リンク先:https://jupito.ittec.ne.jp/member/test1/docs/

     

    > net use https://jupitor.ittec.ne.jp/member/test1/docs →

    (system message) 'jupitor.ittec.ne.jp' のユーザ名を入れてください: test1

    (system message) jupitor.ittec.ne.jpのパスワードを入れてください:(test1)

    (system message) システムラー 1219が発生しました

    同じユーザーによるサーバーまたは共有リソースへの複数のユーザ名での複数の接続は許可されていません。サーバーまたは共有リソースへの以前の接続をすべて切断してから再試行してください

    > net stop webclient

    (system message) システムエラー 5 が発生しました。

    アクセスが拒否されました。

    なお、試験に使用したサーバーOSはCentOS4.6、webdavロケーションはhttps://jupitor.ittec.ne.jp/memmber,

    BASIC 認証はhttps://jupitor.ittec.ne.jp/member/test1 に設定されています。 https://jupitor.ittec.ne.jpはサーバー認証が(RAPID SSL)インストールされています

    https://jupitor.ittec.ne.jp/member/test1/docsは現在公開されています。

    なお、BASIC認証をはずすと問題なくアクセスできるようです。

    以下の方法でアクセスできました。

    net use w: https://jupitor.ittec.ne.jp/member/test1/docs

    ネットワークドライブ名(w:)を入れていなかったのが原因でした。

     

     

     

    おかしな現象を発見しました。

     net useでログインできるのですが、PCを再起動すると、Xがついていて、ログインできません。

    ユーザ、パスワードを聞いてくるので、ユーザパスワードを入れても駄目です。

    一旦ネットワークプレースを削除して再度作成すれば可能ですが。

     

     

     

     

     



    2010年4月27日 0:33