none
2008R2リモートデスクトップのドライブリダイレクトについて RRS feed

  • 質問

  • お世話になります。

    Windows Server 2008 R2 SP1のリモートデスクトップセッションホストにクライアントから接続した時にリダイレクトされたドライブの表示が適切に表示されません。エクスプローラ の”ネットワーク”からは\\tsclient\"ドライブ名"で表示されて利用できますが”コンピュータ”の"その他"の項目内には真っ白なアイコンが リダイレクトされるであろうドライブ分だけ並んでいて利用できません。一旦ログオフし、再度接続すると正常表示になる時があります。しかし時間をおいて(5時間程度と思われます。)接続をする とまた問題が発生します。

    前回5月4日にWindowsUpdateを手動で行い、今回11月12日にWindowsUpdateを手動で行いました。11月12日までは問題はありませんでしたが、その後から発生致しました。

    リモートデスクトップセッションブローカー1台、セッションホスト3台、クライアントはrdp7.1、8.0混在です。問題は全てのクライアント、セッションホストの組み合わせで起こっています。

    最近server2008のHyper-Vに2008r2をインストールして、12月8日現在までの重要な更新を適用して試しましたが、同じ症状が確認できました。

    microsoftコミュニティに先日投稿いたしましたが、返信がいただけずこちらにも投稿させていただきます。

    何卒よろしくお願いいたします。

    2014年12月9日 8:04

回答

  • 皆様

    ありがとうございました。

    ”¥¥tsclient¥ドライブ名”で運用することになりました。

    症状についてはwindowsupdateを行いながら確認いたします。(きちんと検証していませんが2015年4月分までのupdateで改善しているような気がします。)

    本件クローズいたします。

    • 回答としてマーク 佐伯玲 2015年5月14日 2:01
    2015年5月14日 1:38

すべての返信

  • ご投稿ありがとうございます、mrs06 さん
    フォーラムオペレータの佐伯 玲 です。

    マイクロソフトコミュニティのほうは一般利用を目的としたフォーラムですのでServer製品に関するご質問は取り扱っておらず情報は集まりづらそうですね。
    そういった意味では企業利用等を目的としたTechNetフォーラムのほうが情報が集まりやすいと思います。

    ただ、現在2つのフォーラムにて同時にご質問している状態になってしまっておりますので
    マイクロソフトコミュニティの方では一旦質問を締め切ってTechNet フォーラムで現在ご質問いただいている旨ご記載いただいても宜しいでしょうか?

    もし2か所でバラバラに返信が寄せられてしまいますと両方のスレッドを同時にケア出来なくなってしまったり
    互いのフォーラムの回答者は状況がわからず同じことを何度も聞いてしまったり重要な情報を見逃してしまうことが考えられます。

    その上で引き続きこちらのスレッドでご質問をご継続いただけましたらと思います。


    お手数ではございますが宜しくお願い致します。

    TechNet Community Support 佐伯 玲

    2014年12月10日 4:53
  • 佐伯様

    アドバイスありがとうございました。今Microsoftコミュニティの質問は締め切りの意思を通知するスレッドを入力致しました。

    こちらのスレッドにて質問を継続したいと思います。何卒よろしくお願いいたします。

    2014年12月10日 6:19
  • mrs06 さん

    ご確認、ご対応のほどありがとうございます。

    ご質問に関して情報をお持ちの方がいらっしゃいましたらこちらのスレッドへお寄せいただけましたらと思います。


    TechNet Community Support 佐伯 玲

    2014年12月10日 6:25
  • 手元の環境でも同様の事象が発生しているため、こちらでは KB3003743 をアンインストールして回避しています。
    KB3003743 (MS14-074) は 2014 年 11 月の月例セキュリティパッチなので、時期的にも同様の事象のように思われます。

    なお、セキュリティパッチをアンインストールする場合は、下記情報などを元にご自身でリスク等鑑みてご判断ください。
    http://blogs.technet.com/b/jpsecurity/archive/2014/11/12/201411-security-bulletin.aspx
    https://technet.microsoft.com/library/security/ms14-074
    https://support.microsoft.com/kb/3003743
    http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-6318
    アンインストールしてリスク受容するか、このままで機能制限を受容するか、個々の事情によって変わるものですのでどちらが良いかは分かりませんが、この投稿はセキュリティパッチのアンインストールをお勧めするものではありません。


    MCITP(Database Developer/Database Administrator)

    2014年12月10日 7:35
  • nagino様

    お世話になります。情報有り難うございます。Hyper-Vのテスト環境で試験を致しました後、リスクについて十分検討し、私の責任においてアンインストールの判断を致します。まずはテスト環境で試験をしたいと思います。今後とも宜しくお願い致します。

    2014年12月10日 8:23
  • お世話になります。

    12/10 18:00Hyper-Vテスト環境サーバ側でKB3003743をアンインストール、再起動してクライアントからリモートデスクトップ接続し、ドライブリダイレクト正常表示を確認しました。

    12/11 08:30にクライアントからリモートデスクトップ接続しドライブリダイレクトの確認をしましたら症状が発生しました。

    12/11 08:40一旦ログオフし再度ログオンしましたら表示は正常でした。

    正常表示された後、ログオフし、時間をおいて再度ログオンすると発生するようです。検証に時間がかかるため、このままの状態で何回かテストして結果ご報告申し上げます。しばらく質問継続させてください。

    何卒よろしくお願いいたします。

    2014年12月11日 0:02
  • フィードバックありがとうございます。

    こちらの環境では本日朝一のログオンで再発を確認しました。
    しかしその後はログオフから 50 分ほど間をあけてのログオンでも再発しないため、実用上問題無しという判断をしており、調査を打ち切っている状態です。

    こちらの環境ではネットワーク探索とファイル共有が無効に設定しておりネットワーク下には何も表示されない環境であったり、AWS 上の環境のため EC2Config という AWS 環境用のサービスが入っているなど、多少ネットワーク周りに関して差異があるため、挙動に差異が出ているのかもしれませんね。


    MCITP(Database Developer/Database Administrator)

    2014年12月11日 2:20
  • nagino様

    御連絡ありがとうございます。そうなんです。ログオフからログオンの時間が短ければ発生しない問題と思われるのです。

    本日朝08:40のログオンの後、08:50に一旦ログオフし、13:30に再度ログオンしたところ症状が出ませんでした。

    また症状が出たあとログオフしログオンするとその時は正常表示なのです。

    これから5時間、6時間と少しづつ間隔を広げて検証いたします。

    時間がトリガーであると前日18:00に業務終了して、翌日朝08:30のログオンの際は必ず発生することとなります。

    実環境はセッションブローカーで負荷分散をしているため、どこのサーバにログインするかわからないため、ユーザーは毎朝何回ログインしても症状が出るような感覚になります。

    申し訳ございません。引き続き質問を継続させてください。

    何卒よろしくお願いいたします。

    2014年12月11日 4:49
  • 皆様

    ありがとうございました。

    ”¥¥tsclient¥ドライブ名”で運用することになりました。

    症状についてはwindowsupdateを行いながら確認いたします。(きちんと検証していませんが2015年4月分までのupdateで改善しているような気がします。)

    本件クローズいたします。

    • 回答としてマーク 佐伯玲 2015年5月14日 2:01
    2015年5月14日 1:38