none
承認済みドメインや受信コネクタが突然なくなる RRS feed

  • 質問

  • Exchange2007の導入を検討して、現在、評価環境を構築しております。
    ハブトランスポートサーバの構築において、承認済みドメインと受信コネクタ、送信コネクタが突然なくなるという事態が発生しているのですが、何がいけないのでしょうか?
    デフォルトで作成されている承認済みドメイン、受信コネクタもなくなるのですが。
    よろしくお願いします。

    2010年3月12日 9:47

すべての返信

  • hiroz42様

    もしかしたら、HUBサーバーが提供するサービスが落ちているのでそうなっている可能性があります。
    以下のことを確認してみることをまずはお勧めします。

    ・イベントビューアよりエラーがないか確認すること
    ・サービス一覧より、Exchangeに関するサービスが起動しているか確認すること


    そこに何か情報があり、記載していただければお力になれるかも知れません。
    2010年3月16日 8:34
  • ありがとうございます。
    hiroz42です。
    ログとサービスは特にエラーも無い状態です。
    気になるエラーは「CN=Servers...」のセキュリティ記述子を読み取るためのアクセス許可がありません。これはコマンド"get-ExchangeAdministraor"を実行していました。」というメッセージが表示されます。
    ちなみにExchangeSeverのバージョンは2007SP2でOSはWinodwsSever2003R2の64bitです。

    ベストプラクティスアナライザも実行してみました。重大な問題はオフラインアドレス帳の定義がありません。でしたので作ろうとしても、親オブジェクトがないと言ってはねられます。

    お手数をおかけしますが、よろしくお願いします。
    2010年3月16日 9:43
  • ドメインコントローラとの通信状態を確認してみた方が良いのかもしれないですね??

    Exchange 2007では 様々な構成情報がAD内に記録されています。
    AD情報としては残っているけれども、DCとの通信が上手く行っていないので情報を拾えていないのではないでしょうか?

    可能であれば、評価環境のDCで ADSIEdit ツールを用いて 必要な情報が存在していることを確認してみてください。
    ※ ADSIEditツールで アイテムの変な変更や削除を行うと AD情報がおかしくなるので慎重に作業を行ってください。

    評価環境のネットワーク設定などを見直してみるとか??

    DCコントローラと通信が上手く行っていない or いかない 条件として DNSサーバでの名前解決問題もあるかもしれません。
    コマンドプロンプトで以下のコマンドを試してみてください。
    > ipconfig /flushdns
    > ipconfig /registerdns

    そのあと ADtopologyサービス の再起動。 ※ 今実際の画面見れてないのでサービス名が一致していないかもしれませんが、、、

    そして管理ツールを再起動してみてください。


    2010年3月16日 15:12
  • hiroz様

    ご確認ありがとうございます。
    おそらく、受信コネクタや承認済みコネクタの情報をADから持ってくるための権限がログインアカウントにないものと思われます。
    ログインしているユーザーには、Exchange組織管理者の権限はついていますでしょうか?
    この辺のアクセス権を意図的につけて検証しているのであれば、その辺を意識して各ユーザーにアクセス権を振る必要性はありますが、
    もし機能だけを検証したいのであればExchange組織管理者の権限を付与してあげてください。

    ちなみに、アクセス権限によってはメールデータベースのマウント状態がアンマウントと表示される場合もありますので、
    ご注意いただければと思います。
    2010年3月17日 1:21
  • shimsoft様、sakuma様
    hiroz42です。
    ご回答有難うございます。

    adsieditでの確認やDNSの名前解決は出来ているみたいです。また、インストールをadministratorで行っており、Exchange組織管理者の権限もついているみたいです。
    それなのに「セキュリティ記述子を読み取るためのアクセス許可がありません。」が出て何もいじれない状態は続いています。

    もしかすると、評価機に既存とは別のドメインを作って、インストールしているのですが、ネットワークカードを2枚刺しにして、外部との接続検証等を行っているせいでしょうか?ADとDNSとExchangeは1台の環境になっております。

    メールデータベースはちなみに見えなくなっています。しかし、ADにユーザを登録して、メールボックスを作る事は可能です。

    ぽろぽろと思いつくままで申し訳ありません。
    2010年3月17日 6:31
  • hiroz42様

    こちらもだめだったみたいですね。申し訳ありません。
    僕も思いつきで申し訳ありませんが、2008で構築しておりますでしょうか?
    UAC機能(ユーザーアカウント制御)が関係している可能性も考えられる気がします。
    #おそらく、OFFになっているとは思いますが。

    ご確認してみてください。
    僕もちょっと調査してみます。

    また、ネットワークの優先順位は関係ないとは思いますが、検証用のNICを優先に
    使わせた方がいいかもしれませんね。
    2010年3月17日 7:42
  • ネットワークが2つあるのなら、デフォルトゲートウェイ等の設定はどうなっていますでしょうか?

    仮に、IPアドレスなどが、
    社内のネットワーク:  10.10.10.0/24
    検証環境ネットワーク:10.20.30.0/24

    で、検証環境内の
    ADDC: 10.20.30.1
    Exch2007: 10.20.30.2 (NIC1)  / 10.10.10.45 (NIC2)
    テストクライアント:10.20.30.3

    社内用PC: 10.10.10.50

    とかなら、Exch2007のサーバにて、ルーティングの設定を明示的に設定してみるといかがでしょう?
    コマンドプロンプトにて

    > route add -p 10.20.30.0 mask 255.255.255.0 10.20.30.1

    これで検証環境ネットワークのIPアドレス行きパケットは NIC1から流れると思うのですけれども、、、

    2010年3月17日 7:56
  • hiroz42様

    確認させてください。
    評価機に既存と別ドメインを作ってインストールとおっしゃっていますが、
    どのような構成になっているのですか?

    おそらく原因はアクセス権だと思いますので適切なアクセス権が付与されれば
    見れるのではないかなと考えております。
    2010年3月17日 8:09
  • SHIMSOFT様、sakuma様
    hiroz42です。
    お忙しい中を有難うございます。

    評価機のOSはwindows2003R2SP2です。
    ドメインは仮称になりますが、以下の通りです。
    ・ドメイン:ABC(社内で運用中) 192.168.0.0/255.255.255.0 ADとDNSは192.168.0.21
    ・今回のテストドメイン:ITSABC  192.168.3.0/255.255.255.0 ADとDNSは192.168.3.150。Exchangeも同じPCにインストール。

    評価機ではAdministratorでまずはOSとADやDNSをインストール。その後、Exchange関連をADに参加後にAdministratorでインストールしてます。

    本来であれば、ローカル権限(ITSABC01)が無いと行けないのかとは考えたのですが。ローカルログオンは出来ない状況です

    お手数をおかけして、申し訳ありません。
    2010年3月17日 8:51
  • hiroz42様

    ご質問させてください。

    >評価機ではAdministratorでまずはOSとADやDNSをインストール。
    これは、ITSABCとしてITSの子ドメイン?として作成したのでしょうか。
    それとも、WORKGROUP端末のままITSABCというドメイン名でADとDNSを構築したということでしょうか。

    >その後、Exchange関連をADに参加後にAdministratorでインストールしてます。
    AD参加後にって言うのが理解できなかったのですが、ABCドメインのコンピューターにも
    なっているということでしょうか?

    色々と質問してしまい申し訳ございません。よろしくお願いいたします。
    2010年3月17日 9:10
  • hiroz42さん、追加情報どうもです。

    この情報からすると、 テストドメインの AD,DNS,Exchange 2007は全て 同一マシンに同居している環境、ということでしょうかね。

    んんん???
    ~~~~
    ・今回のテストドメイン:ITSABC  192.168.3.0/255.255.255.0 ADとDNSは192.168.3.150。Exchangeも同じPCにインストール。
    評価機ではAdministratorでまずは OSとADやDNSをインストール。その後、Exchange関連をADに参加後にAdministratorでインストールしてます。
    ~~~~
    すみません、
    ここのところが良くわかりません。
    「その後、Exchange関連をADに参加後に」 これは テスト環境の ADDC/DNS と Exchangeをインストールしたマシンは別物という事でしょうか???
    「Exchangeも同じPCにインストール。」の説明からすると、、、同じに見えるけれども、、、
    同じ物理マシン内に別仮想マシンとか の流れでしょうか??

    2010年3月17日 9:12
  • SHIMSOFT様、sakuma様
    hiroz42です。

    説明の仕方が悪くて申し訳ありません。
    ADDCとDNS、Exchangeは1台のPCにインストールしています。
    ドメインについて、WORKGROUP端末のままITSABCというドメイン名でADとDNSを構築しました。

    何度ももうしわけありませんです。
    2010年3月17日 9:40
  • SHIMSOFT様、sakuma様
    hiroz42です。

    原因解決はともかく、SP1でもう一台ExchangeSever2007を立ち上げてみました。こちらは特に承認済みドメインと受信コネクタ、送信コネクタが無くなる、メールボックスデータベースがマウント出来ない等の状況は発生していません。

    SP2とそれに付随するパッチが原因なのかははっきりしませんが。週末にSP2とかをあてて現象が発生するかを報告します。

    2010年3月26日 6:13