none
Hyper-V 2.0でWindowsServer2008R2全般エディションのWindowsUpdateとライセンス認証が通らない RRS feed

  • 質問

  • TechNetより、8月15日にダウンロードした、Windows Server 2008 R2 Enterprize (RTM) 日本語版に、Hyper-V2.0をインストールし、仮想にWindowsWebServer2008 R2をインストールしました。
    ネットワークの設定を行い、インターネットを閲覧できる状態にはなりましたが、WindowsUpdateを行おうとすると、コード 80072EE2 によるエラーが、ライセンス認証では、0x80072EE2 と同じ現象が発生しました。
    FAQとおり、FWを切ったり許可サイト登録しましたが、現象は同じなのですが。

    WindowsWebServer 2008 R2 が問題あるのかと思い、StdやEnterprizeも入れてみましたが同様の現象です。
    ホストOS側では、WindowsUpdateもライセンス認証も通るのですが、何が原因でしょうか?

    ちなみに、WindowsServer2003を仮想に入れてWindowsUpdateしてみましたが、正常に動作しました。
    2009年8月15日 14:03

回答

  • 僕が使っているテスト機では、Hyper-V 2.0の子パーティションにインストールしたWindows Server 2008 R2のライセンス認証/Windows Updateとも特に設定もせずデフォルト状態で正常に出来ています。
    環境依存の何かがありそうですね。
    ちなみに、子パーティションのWindows Server 2008 R2が参照しているDNSはどこを見ていますか? ひょっとして、Windows Serve 2008 R2 上に作成した (Active Directoryの)DNS を参照していて、そのDNSはルートヒントを使って自力で名前解決していたりしませんか?
    MVP for Virtual Machine : Networking
    2009年8月17日 9:07
    モデレータ
  • tenki28です。

    テストに使っている端末は自作PCとかですか?

    ゲストOSから他の端末に -t オプション付きでPingを送ってみて
    timeが大幅にばらついたり、つながったり繋がらなかったりを繰り返すのであれば
    ネットワーク周りを確認が必要かと思います。



    以前、普通のPCでHyper-Vのテストを行っていたとき、
    NICを増設して、Win2008用のドライバが無かったのでVista用のドライバを使ったのですが、
    たまに不安定になったり、ホストOSでのCPU負荷が常時10%位上がってしまって、
    やっぱりWin2008用のドライバを使わないとだめだなぁ・・・って思ったことを思い出しました。


    Win2008 とR2でドライバを変える必要があるのかは不明なのですが、
    NICなどの新しいドライバが入手できれば試してみると良いと思います。
    あとはセキュリティーソフトなんかも気になります。

    2009年8月19日 4:59

すべての返信

  • 僕が使っているテスト機では、Hyper-V 2.0の子パーティションにインストールしたWindows Server 2008 R2のライセンス認証/Windows Updateとも特に設定もせずデフォルト状態で正常に出来ています。
    環境依存の何かがありそうですね。
    ちなみに、子パーティションのWindows Server 2008 R2が参照しているDNSはどこを見ていますか? ひょっとして、Windows Serve 2008 R2 上に作成した (Active Directoryの)DNS を参照していて、そのDNSはルートヒントを使って自力で名前解決していたりしませんか?
    MVP for Virtual Machine : Networking
    2009年8月17日 9:07
    モデレータ
  • ご回答ありがとうございます。

    ActiveDirectoryについては導入しておらず、ゲートウェイやDNSもルーターを指すようにしていました。
    あと、他の現象として、共有フォルダを仮想化上で構築した場合に、セッションが頻発して切れる症状が発生してました。
    あと、リモートデスクトップで、WindowsServer2008R2系に接続すると、ログイン直後から真っ暗になるなど、よくわからない現象が頻発しました。なお、共有フォルダのセッション接続切れ頻発は、RCからでしたので、ドライバーとかが怪しいかもしれないのですが...

    とりあえず、評価として使用していたので、ホストOSをWindowsServer2008に戻し、ためしにHyper-V1.0の仮想環境でWindows2008R2を仮想で動かしたところ、Updateにつながらない、認証ができない、共有ディレクトリでセッション切れは発生しない、リモートデスクトップで接続しても異常がないということでした。

    環境依存かドライバー依存か、現在わからない状態です。
    CPUは、AMD社製の一般向け(Phenom)で、マザーボードなども一般向けのものを使用しています。

    また、時間が合ったら試してみようと思います。
    ありがとうございました。
    2009年8月18日 23:52
  • tenki28です。

    テストに使っている端末は自作PCとかですか?

    ゲストOSから他の端末に -t オプション付きでPingを送ってみて
    timeが大幅にばらついたり、つながったり繋がらなかったりを繰り返すのであれば
    ネットワーク周りを確認が必要かと思います。



    以前、普通のPCでHyper-Vのテストを行っていたとき、
    NICを増設して、Win2008用のドライバが無かったのでVista用のドライバを使ったのですが、
    たまに不安定になったり、ホストOSでのCPU負荷が常時10%位上がってしまって、
    やっぱりWin2008用のドライバを使わないとだめだなぁ・・・って思ったことを思い出しました。


    Win2008 とR2でドライバを変える必要があるのかは不明なのですが、
    NICなどの新しいドライバが入手できれば試してみると良いと思います。
    あとはセキュリティーソフトなんかも気になります。

    2009年8月19日 4:59
  • ご回答ありがとうございます。

    テストに使ってる端末は、自作PCです。
    NICは別途に取り付けたものです。

    一度、ping でのテストをRCのときに行っていますが、その時は定期的に接続が切断されるという現象は確認していました。
    RTMではやっていません。

    ドライバーは、Win2008R2標準のものを使用していましたので、もしかするとそれが原因かとは思ってます。

    ちょっと、時間がないので再度テストすることが困難ですがとりあえずドライバ(Windows7系)がそろったら、またテストしてみようかと思います。

    なお、セキュリティソフトはいれずにやってましたので、こちらも違うと思います。
    (基本的にHyper-V2.0のみインストールして、テストしていました)
    2009年8月20日 12:28
  • 私の使用している環境でも同様の現象が発生しました。
    http://codename2010.blog11.fc2.com/blog-entry-21.html

    さらに、電話の自動応答によるライセンス認証も通らないといった状態です。

    同様のisoを使用してインストールした他のサーバーでは問題なくライセンス認証が通っているので、プロダクトキーの問題ではなさそうです。
    環境はスタンドアローンのサーバー単体で、ネットワーク通信やDNS参照は問題ありません。

    どうやって認証をすれば???といった状態です。


    WIN1
    2009年8月24日 13:39
    モデレータ
  • 本日改めて、エラーの出たサーバーでライセンス認証を行ったところ、あっさりと完了しました。

    認証を行うサーバー側の問題だったのでしょうか。
    WIN1
    2009年8月25日 6:36
    モデレータ