none
ネットワーク接続の時、勝手にユーザ名の前にホスト名がついてしまいます。 RRS feed

  • 質問

  • 宜しくお願いします。

    ネットワークの共有ストレージ(NAS)に接続する時に、勝手にホスト名がついてしまって、接続できません。ユーザ名は、同じユーザです。恐らく、別のマシーンのユーザだと認識されてしまって、NASに設定したユーザとは別のユーザだと思われているのだと思います。以前はXPから接続していた時は、同じユーザ名で接続出来ておりました。(下記に例)

    共有名 ; \\HDD\share

    NASユーザ ; kyoro

    XPの時は、「kyoro」で接続出来ましたが、Windows7 やVistaから同じように接続すると、勝手にホスト名が付加されてしまいます。

    Win7のホスト;PC1 とすると、「kyoro」とボックスに入力しても「PC1\kyoro」でアクセスしてしまいます。

    例えば、NASが「NAS1」というホスト名だとして・・・ユーザ名に「NAS1\kyoro」でアクセスしても「NASのIPアドレス\kyoro」でアクセスしても接続出来ません。

    NASは、Workgroupに所属して、XPマシーンはドメインに所属してましたので、PC1もドメインに産させてみましたが、やはり接続出来ませんでした。


    uedan

    2012年3月15日 7:06

回答

  • Vista以降LAN Manager認証レベルのデフォルト値が[NTLMv2 応答のみ送信]に変更されたため、これに非対応のNASにはそのままでは接続ができないので、そのような状況なのかもしれませんね。

    NASのメーカーのサポートなどでWindows VistaやWindows 7の対応状況を確認し、以下のページなどを参考にWindows側のLAN Manager認証レベルを変更してみることで接続が可能になるかもしれません。

    [参考]
    Windows 7から古いNASにアクセスできない場合の対処方法
    http://www.atmarkit.co.jp/fwin2k/win2ktips/1401win7nas/win7nas.html


    2012年3月15日 13:48

すべての返信

  • Win Vista/7 は、PC名を自動付与するように変更されたはずです。

    NAS1\kyoro でだめとのことなので無理かもしれませんが、.\Kyoro ではどうでしょうか?

    2012年3月15日 7:25
  • Vista以降LAN Manager認証レベルのデフォルト値が[NTLMv2 応答のみ送信]に変更されたため、これに非対応のNASにはそのままでは接続ができないので、そのような状況なのかもしれませんね。

    NASのメーカーのサポートなどでWindows VistaやWindows 7の対応状況を確認し、以下のページなどを参考にWindows側のLAN Manager認証レベルを変更してみることで接続が可能になるかもしれません。

    [参考]
    Windows 7から古いNASにアクセスできない場合の対処方法
    http://www.atmarkit.co.jp/fwin2k/win2ktips/1401win7nas/win7nas.html


    2012年3月15日 13:48
  • OMEGATさん、まさしく・・「それ」でした。本当に的確なご回答、有難うございました。

    SMBプロトコル2.0でなく3に対応してないNASだったので認証され

    なかったみたいです。

    ちなみに

    BUBBALOのHD-H1.0TLGです。ファ

    ふぁームウエアのVerを2.18βまであげましたが・・・Vistaからは、認証されませんでした。リーカルポリシーをNTLM認証にまでゆるゆるに下げると認証してくれる事を確認しました。

    LM認証レベルを下げるとアクセスできるようになりましたが、ちょっと危ないのでXPか2003ServerからNASに接続することにしました。


    uedan

    2012年3月16日 6:50
  • K.Takaokaさん。

    回答有難うございました。「.\Kyoro」ダメでした~~。


    uedan

    2012年3月16日 6:53