none
LAN Diskへの接続 RRS feed

  • 質問

  • Windows7 Professional(64bit) をインストールしましたが、ファイルサーバ(LAN Disk/玄人志向 GW3.5MM-U2/LAN )
    につながりません。
    他のマシン上のWindows2000や同じHWでデュアルブートの Xp Pro からは問題なく
    (LAN DiskのSpecで若干反応時間は遅いのですが)つながっています。
    Vista Ultimate(64bit)では、ネットワークドライブを割り当てたドライブをクリックすると
    ユーザ名とパスワードの問い合わせが出て(LAN Diskにはファイルアクセスのユーザの設定をしてないので)
    クライアント側のコンピュータ名\ユーザ名とログインパスワードで接続できます。
    Windows7のネットワークにコンピュータ名(ファイルサーバ名:ABCD)は表示されるのですが、
    クリックすると「\\ABCD にアクセスできません。このネットワークリソースを・・・」
    「ネットワークエラーです(1208)」と表示されてサーバに接続できません。
    ホームネットワークを社内ネットワークに切り替えたり、ルータのポート設定を初期化すると
    「リモートプロシージャコール(RPC)でプロトコルエラーが発生しました」
    というエラーメッセージになったりします。
    Windows7 側のネットワークの設定は一通り変更してみましたが、状況は変わりません。
    また、ファイルサーバの中のフォルダに対してネットワークドライブの割り当てをしようとすると、
    ユーザ名とパスワードを聞かれ、XYZ\user (クライアントコンピュータ名:XYZ ユーザ名:user)
    とクライアントコンピュータのログインパスワードを入力してもアクセスが拒否されます。
    http://social.technet.microsoft.com/Forums/ja-JP/w7itprogeneralja/thread/105b306f-f324-41b1-9374-553e660f0766
    などの情報を元に、わかる範囲で設定を変えてみましたが状況は変わりません。
    2010年1月26日 12:56

すべての返信

  • Windows 7のLan Manage 認証レベルを変更してみると繋がるかもしれません。

    ・[スタート][ファイル名を指定して実行](Windowsキー + Rキーで起動可)でsecpol.mscと入力
    ・[ローカルポリシー][セキュリティオプション]の中の[ネットワークセキュリティー:LAN Manager認証レベル]の項目を[NTLMv2 応答のみを送信する]に設定します
    ・コンピュータを再起動します
    ※上記でダメな場合、さらに[NTLM 応答のみ送信する]などに変更してみます。

    2010年1月26日 13:26
  • OMEGATさん、アドバイスありがとうございました。

    どこかの Web情報で [NTLM 応答のみ送信する]には既に設定してありました。
    [NTLMv2 応答のみを送信する] に設定してみても状況は変わりませんでした。
    しかし、その後何回か接続動作を繰り返しているうちに、2回だけ接続できました。
    接続できなかった時と、出来たときの間には何も設定変更は行っていません。
    Explorerのネットワークの中のサーバーアイコンをクリックしたら、内部のフォルダが
    展開され、フォルダ・ファイルにアクセスが出来ました。
    その状態では、アプリからサーバに対してファイルのR/Wも可能になりました。
    しかし、一旦 Explorerを閉じて、そのまま(ログアウトなどせずに)もう一度
    Explorerを立ち上げなおしたら、再び接続できなくなってしまいました。
    同じ動作(と言ってもExplorerの立ち上げ・クローズだけ)を何度か繰り返している間に
    もう一度だけ同じ状況が発生し、その後再び接続不可になりました。
    GW3.5MM-U2/LAN は、安価なH/Wで Win NTベースのO/S搭載だったと思いますが、
    最新の Vista対応の F/Wバージョン NAS-BASIC48B2 では一層応答が遅くなったような
    気もしており、素人の想像ですが、Windows7が 接続要求を送信してから応答なしと
    判断するまでの時間が Xpなどに比べて短くなっているのではないかという気がします。
    そのため、サーバ側・Win7側の処理のサイクルで、たまたま要求に対して応答が
    早く帰ってきたときに接続が確立され、その状態では他のプロセスもR/Wが
    可能になっているような感じです。
    Win7はネットワーク関連でもいろいろと高度な処理が盛り込まれて、変更規模も大きいようですが、
    サイクルタイムが同じだったりすると、その分応答待ちの時間が足りなくなってしまったのかな?
    と・・・・あくまで想像ですが。
    このあたりのタイミングの設定が変更出来れば試してみたいのですが、方法がよくわかりません。

    2010年1月27日 5:46
  • 玄蔵の詳細な仕様やWindows 7対応状況を知らないのですが、

    ・エクスプローラのアドレス欄や検索ボックスに、\\<玄蔵のIPアドレス> を入力してみる
    ・[ローカルエリア接続]のプロパティでIPv6のチェックをはずしてみる
    ・LAN Manager認証レベルを変更して
     [LMとNTLMを送信する(ネゴシエートした場合NTLMv2 セッションセキュリティを使う)]
     [LM と NTLN 応答を送信する]
    なども可能であれば試してみていただけますか。

    Vistaと比べて、認証時間などに変更があったというのは見たことがありませんが、もう少し確認してみます。
    2010年1月27日 23:38
  • 返信が遅くなってすみません。
    (電源ON/OFFの繰り返し途中で、電源ボタンから静電気が飛び込みMBを壊してしまい
    MB交換しておりました。旧MB:M2N-E >> 新MB:M3N78-EM/ASUS)
    アドバイスいただいた項目はすべて試しましたが、状況は同じです。
    (まだ前回の接続動作と比較すると、接続動作の回数が少ないためか
    Explorerのネットワークからは一度も接続に成功しておりません)

    ただし、たまたま接続できたときにLAN Disk内のフォルダーのショートカットを
    デスクトップに作っておいたのですが、こちらからは毎回接続できます。
    (MB交換前にも確認したのですが、そのときは接続できていなかったような気がしますが
    ネットワークドライブの割り当てが出来なかったのを勘違いしたのかも知れません。
    MBの故障で浮き足立ってしまったので、それ以前の記憶には自信はありません)
    フォルダがいくつかあるのですが、ショートカットはそのうちの一つしか作ってなかったので
    そのショートカットをコピーして、コピーしたショートカットのプロパティで
    リンク先を別フォルダに変更したら、そちらにも接続できました。
    しかし、フォルダ直のショートカットではなく LAN Diskのルートのショートカットも
    作ってあるのですがこちらからは接続できません。
    (両者はリンク先が \\ABCD というのと \\ABCD\efgh という違いだけですが)

    また、Explorerのアドレスバーに \\ABCD と入れただけではネットワークエラーになりますが
     \\ABCD\efgh とフォルダ名まで入れるとエラーにならずに接続できます。

    ということは、タイミングとは関係ないのかな? ますますわからなくなってしまいました。
    とりあえず、フォルダのショートカットやアドレスバーからフォルダ名まで入れれば接続できることが分かったので、
    私の場合は何とかなりますが、もしまだ何か 確認することがあれば、引き続きアドバイスお願いいたします。
    (Vistaからは Xpであった上位の「親フォルダ」を表示するアイコンがなくなってしまいました。
    これがあると、フォルダ直のショートカットからLAN Diskのルートへ上がってからすべてのフォルダに
    アクセスできそうですが、Win7も この点はなんとなく不便ですね。)

    2010年1月30日 1:30