none
クロールの設定が元に戻らない RRS feed

  • 質問

  • クロールの設定で以下の検証をしたところ
    設定を元に戻したのですがクロール対象件数が元に戻らなくなってしまいました。
    コンテンツソースの編集画面で見ると検証前後で設定に変わりは無いのですが、どのようにしたら良いでしょうか。

    1.開始アドレスをデフォルトのコンテンツソースからいったん削除
    2.新しく作成したコンテンツソースにNo.1で削除した開始アドレスを記載。
    3.新しく作成したコンテンツソースのクロールをしたところ、保存できずエラー発生。
    4.クロール設定で「各開始アドレスからSharepointサイトのみをクロールする」を選択し、保存。→エラー出ず保存OK
    5.新しいコンテンツソースを削除。
    ~以下、設定戻し~
    6.デフォルトのコンテンツソースにNo.1で削除した開始アドレスを再登録。(No.4と同様にクロール設定を変更し、保存)
    7.クロール設定を「各開始アドレスから、ホスト名下にあるすべてをクロールする」に戻し、保存。
    8.フルクロール実行
     →この作業をする前クロール対象となっていたファイルが対象とならなくなってしまった。
     (サーバ再起動するも事象は変わらず)
     
    バージョン:Office SharePoint Server 2007、Windows 2003 Server Standard Edition
     
    ご教示お願いいたします。
    2011年10月4日 14:20

回答

  • 実環境を触らないと確認が難しいため、思いつきレベルの切り分けですが、

    まずフルクロールの実行前に「クロールされたすべてのコンテンツをリセットする」を

    管理画面から実行してみてください。

    クロールログを眺めて、該当するサイトがクロールされていることを確認してください。

    その他、なにかエラーや気になる点はないでしょうか?

    その上でフルクロール後に、増分を2回ほど回してみてください。

    (経験上、フルクロールは1度では「とりこぼし」を案外するので)


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答の候補に設定 山本春海 2011年10月28日 7:54
    • 回答としてマーク 山本春海 2011年11月7日 6:48
    2011年10月5日 4:07
  • > 別のコンテンツソースを作成し、開始アドレスを付け替えた事により、設定を戻しても紐づかなくなってしまっているのでしょうか。

    障害としてありえないとは思いませんが、コンテンツソースの作成/削除、開始アドレスの再設定は

    普通の作業ですので、考えにくいですね。

     

    障害でないとすると、検索関連の設定を全面的に洗い直す必要があると思います。

    対象コンテンツは本当に検索を拒否していないか?想定外の除外ルールが設定されていないか?等。

    サイトレベルでかからないのか?コンテンツレベルなのか?も確認しておきたいところです。

    また、一つ気になるのが「新しく作成したコンテンツソースのクロールをしたところ、保存できずエラー発生」

    という状況がいまひとつ想像できない点でしょうか。クロールの実行に「保存」アクションは無い筈ですので、

    何を保存されて、どんなエラーが表示されたのか…?


    SharePoint/Office365導入検討・運用・活用支援: http://simplesso.jp BLOG: http://sharepointmaniacs.com/
    • 回答の候補に設定 山本春海 2011年10月28日 7:54
    • 回答としてマーク 山本春海 2011年11月7日 6:48
    2011年10月19日 7:40

すべての返信

  • 実環境を触らないと確認が難しいため、思いつきレベルの切り分けですが、

    まずフルクロールの実行前に「クロールされたすべてのコンテンツをリセットする」を

    管理画面から実行してみてください。

    クロールログを眺めて、該当するサイトがクロールされていることを確認してください。

    その他、なにかエラーや気になる点はないでしょうか?

    その上でフルクロール後に、増分を2回ほど回してみてください。

    (経験上、フルクロールは1度では「とりこぼし」を案外するので)


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答の候補に設定 山本春海 2011年10月28日 7:54
    • 回答としてマーク 山本春海 2011年11月7日 6:48
    2011年10月5日 4:07
  • ありがとうございます。

    リセットや、増分クロールを何度か動かしてみましたが、残念ながら状況は変わりませんでした。

    別のコンテンツソースを作成し、開始アドレスを付け替えた事により、設定を戻しても紐づかなくなってしまっているのでしょうか。。

     

    2011年10月18日 14:20
  • > 別のコンテンツソースを作成し、開始アドレスを付け替えた事により、設定を戻しても紐づかなくなってしまっているのでしょうか。

    障害としてありえないとは思いませんが、コンテンツソースの作成/削除、開始アドレスの再設定は

    普通の作業ですので、考えにくいですね。

     

    障害でないとすると、検索関連の設定を全面的に洗い直す必要があると思います。

    対象コンテンツは本当に検索を拒否していないか?想定外の除外ルールが設定されていないか?等。

    サイトレベルでかからないのか?コンテンツレベルなのか?も確認しておきたいところです。

    また、一つ気になるのが「新しく作成したコンテンツソースのクロールをしたところ、保存できずエラー発生」

    という状況がいまひとつ想像できない点でしょうか。クロールの実行に「保存」アクションは無い筈ですので、

    何を保存されて、どんなエラーが表示されたのか…?


    SharePoint/Office365導入検討・運用・活用支援: http://simplesso.jp BLOG: http://sharepointmaniacs.com/
    • 回答の候補に設定 山本春海 2011年10月28日 7:54
    • 回答としてマーク 山本春海 2011年11月7日 6:48
    2011年10月19日 7:40
  • こんにちは、schneepall さん。

    MSDN フォーラムのご利用ありがとうございます。オペレーターの山本です。
    しばらく経ちましたが、その後いかがでしょうか。

    参考になる情報をいただいているかと思いましたので、勝手ながら私のほうで一旦回答としてマークさせていただきました。
    中村 和彦 さん、情報ありがとうございました。

    アドバイスいただいているように、問題切り分けを行って結果やエラーの内容など投稿されると、他にも情報を得られるかもしれません。
    今後とも、MSDN フォーラムをよろしくお願いいたします。それでは。
                                                       
    日本マイクロソフト株式会社 フォーラム オペレーター 山本 春海

    2011年11月7日 6:48
  • ありがとうございます。

    結局、コンテンツソースを作成しなおし、とりあえず回避しています。

    2011年12月22日 1:07