none
Exchange2010 階層分けしたアドレス帳にメールアドレスを持たないユーザーが表示される RRS feed

  • 質問

  • お世話になっております。

    Exchange2010 でメールボックスのプロパティの属性を利用し、階層分けしたアドレス帳を運用しています。

    このアドレス帳にメールアドレスを持たないADユーザーが数人表示されている状態です。

    ADのユーザーとコンピュータから確認したところ、「表示されていないユーザー」では対応した属性が<未設定>となっており、

    「表示されているユーザー」は対応した属性が設定されている状態でした。これを<未設定>に変更し数日が経過したのですが

    相変わらずアドレス帳へは表示されている状況です。

    何か他に調整する項目があるのでしょうか。

    ご存じの方がいらっしゃいましたらご教示頂けるとありがたいです。

    よろしくお願いします。

    2017年6月16日 6:41

回答

  • 属性の設定をExchangeではなくADから直接変更したような場合、各アカウントごとに設定されている「どのアドレス帳に表示されるか」という showInAddressBook 属性が更新されず、頂いたような事象が発生いたします。

    Update-AddressList [表示のおかしいアドレス帳] (もしくはすべてのアドレス帳を更新 Get-AddressList | Update-AddressList)

    を実施頂きまして、事象が解消するか確認を頂けますでしょうか。

    【参考】Exchange サーバーのアドレス帳表示について
    https://blogs.technet.microsoft.com/exchangeteamjp/2012/12/20/exchange-3/

    2017年6月16日 17:24
  • 属性値は、msExchHideFromAddressLists でしょうか?

    単純に反映の問題のような気もしますが、

    genki_w さんの手順に加えて、アドレス帳への表示は、まず、OWAで確認するか、キャッシュモードをオフにした状態で確認してみてください。

    2017年6月17日 7:26

すべての返信

  • 属性の設定をExchangeではなくADから直接変更したような場合、各アカウントごとに設定されている「どのアドレス帳に表示されるか」という showInAddressBook 属性が更新されず、頂いたような事象が発生いたします。

    Update-AddressList [表示のおかしいアドレス帳] (もしくはすべてのアドレス帳を更新 Get-AddressList | Update-AddressList)

    を実施頂きまして、事象が解消するか確認を頂けますでしょうか。

    【参考】Exchange サーバーのアドレス帳表示について
    https://blogs.technet.microsoft.com/exchangeteamjp/2012/12/20/exchange-3/

    2017年6月16日 17:24
  • 属性値は、msExchHideFromAddressLists でしょうか?

    単純に反映の問題のような気もしますが、

    genki_w さんの手順に加えて、アドレス帳への表示は、まず、OWAで確認するか、キャッシュモードをオフにした状態で確認してみてください。

    2017年6月17日 7:26
  • 直接の回答とは関連ございませんが、最初から設定されているアドレス帳を確認頂ければわかるかと思われますが、属性ベースのアドレス帳を作成する場合、and条件として(Alias -ne $null)や(RecipientTypeDetails -eq 'RoomMailbox')など、Exchangeのアドレスを持たない物を含まない条件を必ず付与するようにすると、今回のようにメールアドレスを持たないオブジェクトが誤ってアドレス帳に載ってしまうことが防げるかと思います。

    ご確認頂ければ幸いです。

    2017年6月20日 2:08
  • フォーラムオペレーターの栗下 望です。
    mtu_io さん、こんにちは。

    ご質問いただいた内容についてはその後いかがでしょうか?

    genki.w さんと Hotaka さんよりアドバイスをいただいておりますので、
    確認いただき現在の状況をお知らせいただければ幸いです。

    既に問題が解決されておりましたら、
    参考になった回答に[回答としてマーク]を設定ください。

    よろしくお願いいたします。


    MSDN/TechNet Community Support 栗下 望

    2017年6月26日 5:49
    モデレータ
  • genki.w 様

    Hotaka 様

    ご回答いただき有難うございます。

    またご返信が遅くなりまして申し訳ありません。現在のところ改善されております。

    実施した作業としては、一度メールボックスを作成しその後メールボックスを無効化しました。

    Exchangeの運用自体あまり経験がなく、教えて頂いた下記コマンドをどうに実行すれば良く分からなかったので上記手段で解決致しました。

    Update-AddressList [表示のおかしいアドレス帳] (もしくはすべてのアドレス帳を更新 Get-AddressList | Update-AddressList)

    なぜこのようなことになってしまったかは不明ですが、現在のところ問題なくアドレス帳からは消えましたのでご報告致します。

    有難うございました。

    2017年6月28日 5:51