none
sysprepでのcopyprofileとMDTの関係について RRS feed

  • 質問

  • お世話になっております。

    Windows7をクライアント展開するに当たり、参照コンピュータのプロファイル情報をクライアントPCにそのまま展開したいと考えています。
    (コピーしたい情報はブラウザの情報です。)

    手順としては、参照コンピュータのユーザをAdministraorのみにして、以下の応答ファイルでsysprepします。
    ※関係ない設定項目は省略

    - <settings pass="specialize">
    - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <AutoLogon>
    - <Password>
      <Value>dABhAGsAdQBtAGEAUABhAHMAcwB3AG8AcgBkAA==</Value>
      <PlainText>false</PlainText>
      </Password>
      <Enabled>true</Enabled>
      <LogonCount>10</LogonCount>
      <Username>administrator</Username>
      </AutoLogon>
      <CopyProfile>true</CopyProfile>

     </component>

    上記sysprep後にイメージをキャプチャし、MDT2010を使用してクライアント展開しますが、プロファイルが上手くコピーされません。
    ※ユーザは展開後もadministratorのみです。

    ちなみに、上記でsysprepした参照コンピュータを起動し、「Windowsへようこそ」画面からセットアップして立ち上げた場合は
    問題なくプロファイルがコピーされています。

    次に、sysprep後に参照コンピュータを起動し、「Windowsへようこそ」画面からセットアップして立ち上げた状態で更にsysprep
    を行ってからキャプチャしたイメージを使ってMDT2010で展開した場合は上手くプロファイルがコピーできました。

    ここまでまとめると、sysprepを1回だけ行った場合、そのまま参照コンピュータを再度立ち上げてセットアップすればプロファイルがコピーされる。
    ただし、sysprepを1回行ったイメージをキャプチャしてMDT2010を使用して展開するとプロファイルがコピーされない。

    sysprepを行い、再度起動・セットアップ後、もう一度sysprepを行ったイメージをキャプチャした場合はMDT2010で展開
    を行ってもプロファイルがコピーされる。

    という動きになります。
    運用として2回必ずsysprepしても良いのですが、何故このような動作をするのか分かる方がいらっしゃれば
    是非とも原因や解決法をご教示いただければと思います。


    2012年10月9日 8:14