none
Windows7+Outlook2003+Exchange2003,2010共存環境でoutlook起動時にログイン認証が2回聞かれる RRS feed

  • 質問

  • 【サーバ環境】
    ドメインコントローラ:windows2008R2
    ExchangeServer:ExchangeServer2003とExchangeServer2010の共存環境
            (社内検証時はExchange2010のスタンドアロン環境でも同様の現象が発生)
    各ユーザのメールボックス:ExchangeServer2010上に存在

    【クライアント環境】
    OS:Windows7
    メーラ:outlook2003
    プロファイル:Exchangeキャッシュモードを使う

    【現象の概要】
    ・Windows7で複数のメールプロファイルを作成しログインした場合、ログイン時に認証が聞かれ(標準の動作)
     ログイン後数秒~数十秒経過後に再度ログインが聞かれる。(おかしな動作)
    ・Windows7で1つしかメールプロファイルを作成していない場合はログイン時のみ認証が聞かれ、再度認証は聞かれない。
    ・Exchangeキャッシュモードを使うのチェックをはずした場合、ログイン時は1回しか認証が聞かれないが、
     メール送受信を行うと2回目の認証が聞かれる。(おかしな動作)
    ・WindowsXPで同一サーバ環境でクライアントに複数のメールプロファイルを登録してもログインが2度聞かれるようなことはない。


    動作を見ていると複数プロファイルが登録されている場合に、前回接続したログイン、パスワードの情報を内部的に
    もっていて、別のプロファイルで再接続した場合にログイン後にメールボックスの情報を取得する際、前回ログイン
    したユーザ、パスワードで取得しにいき、認証が通らないため認証画面がでているように思います。

    認証方式はkerberos/NTLMパスワード認証、kerberosパスワード認証、NTLMパスワード認証で試しましたが
    変化はありませんでした。

    本現象の回避策、解決策をご教示願います。
    よろしくお願いします。

    2012年11月21日 6:18

回答

  • けえ様

    通常、ドメインに参加したクライアントに対してドメインのユーザーでログオンして利用している場合にはOutlook起動時にID/Passwordを要求されることはありません。これの前提はプロファイルの接続先メールボックスとして自分自身のメールボックスが設定されていることです。つまり、そもそもActiveDirectoryに対してきちんとログオンできていない状況が疑われます。

    また、説明の中で「1つのメールプロファイルしか作成していない場合」「複数のメールプロファイル」という表現がありますが、プロファイルの中で指定している接続先のメールボックスがどうなっているかによって意味合いがかなり異なってきますので、そのあたりも明示していただくとより回答が得られやすくなると思います。

    個人的には以下の情報を明記頂きたいです。
    ・ログオンしているユーザー(ドメインユーザーなのか、ローカルユーザーなのか)
    ・ログオン先コンピューターの状況(ドメイン参加済みか、そうでないか。ドメインコントローラーにきちんとログオンできるネットワークでの利用かどうか等)
    ・プロファイルの作成状況(接続先メールボックスの指定、同一プロファイル内で開いているメールボックスの数)

    まずは、以下のあたりから確認すると良いと思われます。

    ・DNSの設定がきちんとDomainControllerを指定していることを確認する。
    ・ログオン後、コマンドプロンプトを開き「set」とコマンドを実行し、logonserverを確認する。
    ・Kerbtray.exeを実行し、きちんとKerberosのチケットが取得できていることを確認する。

    参考になれば幸いです。

    • 回答の候補に設定 星 睦美 2012年12月10日 4:57
    • 回答としてマーク 星 睦美 2012年12月17日 6:32
    2012年12月3日 3:59

すべての返信

  • けえ様

    通常、ドメインに参加したクライアントに対してドメインのユーザーでログオンして利用している場合にはOutlook起動時にID/Passwordを要求されることはありません。これの前提はプロファイルの接続先メールボックスとして自分自身のメールボックスが設定されていることです。つまり、そもそもActiveDirectoryに対してきちんとログオンできていない状況が疑われます。

    また、説明の中で「1つのメールプロファイルしか作成していない場合」「複数のメールプロファイル」という表現がありますが、プロファイルの中で指定している接続先のメールボックスがどうなっているかによって意味合いがかなり異なってきますので、そのあたりも明示していただくとより回答が得られやすくなると思います。

    個人的には以下の情報を明記頂きたいです。
    ・ログオンしているユーザー(ドメインユーザーなのか、ローカルユーザーなのか)
    ・ログオン先コンピューターの状況(ドメイン参加済みか、そうでないか。ドメインコントローラーにきちんとログオンできるネットワークでの利用かどうか等)
    ・プロファイルの作成状況(接続先メールボックスの指定、同一プロファイル内で開いているメールボックスの数)

    まずは、以下のあたりから確認すると良いと思われます。

    ・DNSの設定がきちんとDomainControllerを指定していることを確認する。
    ・ログオン後、コマンドプロンプトを開き「set」とコマンドを実行し、logonserverを確認する。
    ・Kerbtray.exeを実行し、きちんとKerberosのチケットが取得できていることを確認する。

    参考になれば幸いです。

    • 回答の候補に設定 星 睦美 2012年12月10日 4:57
    • 回答としてマーク 星 睦美 2012年12月17日 6:32
    2012年12月3日 3:59
  • けえ さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    Masahiko Ebisuda さんからの返信が
    トラブルシューティングの参考になるのではないかと思います。
    今回は私のほうで[回答の候補] にさせていただきましたが、返信して質問を続けることができます。

    役立つ回答の場合にはオペレーターから[回答としてマーク] することもできますが、
    ぜひ投稿者から[回答としてマーク]いただけるとコミュニティの回答者へのよいフィードバックになります。

    ・自分の質問への回答をマークする必要があるのは、なぜですか。:
    http://social.technet.microsoft.com/Forums/ja-JP/help#258

    それでは今後ともTechNet フォーラムをよろしくお願いします。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美

    2012年12月10日 5:06