none
【SharePointserver2013】SharePoint 製品構成ウィザードがうまく設定できません RRS feed

  • 質問

  • ●SharePoint 製品構成ウィザードがうまく設定できなくて困っています。
    操作の大まかな流れを記しておきます。

    実施した操作の流れ

    ①[SharePoint2013 管理シェル] を起動
    ・Dos窓が開き、「ローカル ファームにアクセスできません」という趣旨のメッセージ

    ②[SharePoint 製品構成ウィザード]を起動
    ・サーバーファームへの接続 メニューで、
     ・既存のサーバーファームへの接続 を選択し[次へ]

    ・構成データベースの設定 メニューで、
     ・データベースサーバーに サーバー名を入力し
     ・[データベース名を取得]のボタンをクリック

    しばらくしてエラーメッセージが表示される
    サーバー側のアクセス権の設定などが抜けているのでしょうか?

    ◎サーバ環境

    OS:Windows Server2008 R2 Standard SP1(64bit)

    DB:SQLServer2008 R2

    設定が進まず困っています。

    ご存知の方いらっしゃいましたら是非ご教示下さい。

    よろしくお願いいたします。

    2018年3月7日 1:42

回答

  • SharePoint Server はドメイン環境に構成されることを前提としているところがあるので、オススメはドメインを構成してサーバーを参加させることです。

    今回の SharePoint Server をインストールしている理由が分からないのですが…、検証目的"だけ"であるのならば、SharePoint Server のインストールウィザードの途中にあった「完全」「スタンドアローン」の選択で「スタンドアローン」を選択しておくことで、ワークグループでも構成できるかと思います。

    ただし、その場合は一部機能に制限があったかと思いますので、繰り返しになりますが、ドメインを構成しておくことをお勧めします。

    • 回答としてマーク st-george 2018年3月14日 3:25
    2018年3月13日 5:36

すべての返信

  • st-george さん、こんにちは。フォーラム オペレーターの立花です。
    MSDN フォーラムへご投稿くださいましてありがとうございます。

    ご質問を拝見いたしましたところ、エラー メッセージの記載がございませんでした。
    エラー メッセージの詳細や、可能でしたら入力したサーバー名も記載いただいた方が
    返信が寄せられやすくなりますので、よろしければご検討くださいませ。

    それでは参加者皆様からのご返信をおまちください。


    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年3月7日 4:40
    モデレータ
  • こんにちは。

    管理シェルでエラーを出していることから、ファームに接続できていないのだと思いますが、以下の点を確認してみてはいかがでしょうか。

    • サーバーはファームに接続されているか。サーバーの全体管理が使えるのであれば、[このファームのサーバーの管理]からファームに接続しているサーバーの一覧が見えるかと思います。
    • ログインしているユーザーはローカルのAdministratorsかどうか。

    いずれにせよ、どういう状況で製品構成ウィザードを使いたいのか(新規?修復?アップグレード?)によると思いますので、もう少し詳しい状況を説明いただいたほうが回答を得やすいかと思います。

    2018年3月7日 5:48
  • Takashi Shinohara 様

    回答いただきありがとうございます。

    早速ですが、

    「SharePointサーバーの全体管理Webアプリケーションが作成されていないので、参照できません。SharePointサーバー管理Webアプリケーションを作成するには、SharePoint製品構成ウイザードを使用します。構成ウイザードをいますぐ起動しますか?」という内容のメッセージが表示されます。

    ・ログインユーザは、「Administrators」でした。

    ・製品構成ウィザードは、新規です。
    2018年3月8日 4:52
  • 立花様

    アドバイスありがとうございます。

    エラーメッセージなどをキャプチャでとっているのでその画像を添付したいのですが、

    投稿しようとすると、このサイトから、以下のうようなメッセージが表示されてしまい投稿が出来なくなってしまいます。

    「お客様のアカウントが確認されるまで、本文に画像やリンクを含むことはできません。」

    これを回避するにはどうしたらよいでしょうか?

    ど素人ですみません。

    2018年3月8日 4:58
  • st-george さん、こんにちは。フォーラム オペレーターの立花です。
    ご返信、ご対応くださいましてありがとうございます。

    また、画像を挿入できないとのことでお手数をおかけいたしております。

    本文に画像やリンクを含むことが出来ませんというエラーについて
    https://social.msdn.microsoft.com/Forums/ja-JP/6644446f-8110-48a6-8d95-29050d33b7ae?forum=announceja
    こちらの状況ですかね。


    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年3月8日 5:30
    モデレータ
  • 立花様

    ご助言ありがとうございます。

    大変参考になりました。

    ●SharePoint 2013 サーバーの全体管理を起動したときのメッセージ

    ●SharePoint2013管理シェル起動時の表示

    ●SharePoint基本設中のエラーメッセージ

    よろしくお願いいたします。


    2018年3月8日 6:18
  • st-george さん、フォーラム オペレーターの立花です。
    画像のご対応をくださいましてありがとうございます。

    それでは Takashi Shinohara さんや、
    フォーラム参加者の皆様からの返信をお待ちくださいませ。

    ※ [回答としてマーク] が設定されておりますと、情報が寄せられにくくなってしまうのと、
    私はオペレーターでございますので設定は大丈夫です、ありがとうございます。

    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年3月8日 6:44
    モデレータ
  • パッと見 SQL が別建ならファイアウォールかと思いましたが違いますかね。
    後はこのあたりですかねぇ (バージョンが違いますけど)
    SharePoint 2010 のインストール時のエラーメッセージについて
    https://social.technet.microsoft.com/Forums/ja-JP/dd17bac4-f2b8-4ef9-b4e8-ba7a247b7129/sharepoint-2010-?forum=sharepoint2010generalja
    しばらくSharePoint触っていないので全然違うかもしれません、すいません。
    2018年3月9日 0:52
  • おらごくうさんの通り、SQL Serverのポートが開いていないか、あとはアカウントの問題ですかね。

    SharePoint 2013 での初期展開の管理およびサービス アカウント

    にある、[セットアップ ユーザー アカウント]の要件を満たしているかご確認ください。

    ※前の投稿で確認をお願いした「ログインしているユーザーはローカルのAdministratorsかどうか」はリンク先の「セットアップを実行する各サーバーの Administrators グループのメンバー」のことです。

    2018年3月9日 1:11
  • おらごくう様

    メッセージありがとございます!

    ご案内いただいたリンク先の情報を早速見させていただきました。

    SharePointド素人ですので上手く噛み砕くことができるか心配ですが、手探りでトライしてみようと思います。

    ありがとうございました。

    2018年3月9日 2:02
  • 状況がわからずの返信で申し訳ないのですが…

    最初のご質問の投稿で、「既存のサーバーファームへの接続」を選択されているようですが、すでに SQL Server には Config_db などが作成されている状況なのでしょうか?

    2018年3月12日 3:23
  • OTA Hirofumiさん

    SQL Server には特になにもしていません。

    Windows Server2008 R2stにSQL Server2008R2がインストールされていまして

    そのサーバにSharePointをインストールしただけの状態です。

    すみません、サーバ系の分野があまり得意ではないので右も左もわからず設定はSQLServerは何も設定ができていない状況です。

    2018年3月12日 3:41
  • 「SharePoint 製品構成ウィザード」で「新しいサーバーファームの作成」を選んで実行した場合、SQL Server に SharePoint の基本動作に必要なデータベースや IIS に全体管理の Web アプリケーションが自動で作成されます。

    下記のブログの手順が参考になるかもしれません。

    SharePoint 2013 のインストール、初期構成手順
    http://sharepoint.orivers.jp/article/4971


    2018年3月12日 7:34
  • OTA Hirofumiさん

    ありがとうございます!!

    ご案内いただいたページの情報を参考に入力してみましたが、

    画像のように入力して「次へ」をクリックすると、

    「指定したユーザーは、ローカルアカウントです。ローカルアカウントはスタンドアロンのみで使用する必要があります。」というメッセージが表示されてしまいます。

    https://social.technet.microsoft.com/Forums/getfile/1238392

    ※画像の添付ができないのでとりあえずリンクを貼っておきます。

    2018年3月12日 8:09
  • すみません…画像が見られないのですが…

    今回のサーバーは Active Directory のドメインには参加していますか?ドメインのユーザーを利用してセットアップを進める必要があるかと思います。

    2018年3月13日 2:08
  • OTA Hirofumiさん

    ありがとうございます!!
    ADは導入していないので
    WORKGROUPで運用しています。

    2018年3月13日 2:19
  • すみません、まだ画像を貼ることができないのでリンクを貼っておきます。

    https://social.technet.microsoft.com/Forums/getfile/1238842

    2018年3月13日 4:31
  • SharePoint Server はドメイン環境に構成されることを前提としているところがあるので、オススメはドメインを構成してサーバーを参加させることです。

    今回の SharePoint Server をインストールしている理由が分からないのですが…、検証目的"だけ"であるのならば、SharePoint Server のインストールウィザードの途中にあった「完全」「スタンドアローン」の選択で「スタンドアローン」を選択しておくことで、ワークグループでも構成できるかと思います。

    ただし、その場合は一部機能に制限があったかと思いますので、繰り返しになりますが、ドメインを構成しておくことをお勧めします。

    • 回答としてマーク st-george 2018年3月14日 3:25
    2018年3月13日 5:36
  • OTA Hirofumiさん

    ありがとうございます!!かしこまりました。

    ご指導いただきましたとおりドメインを構成した後に再度トライしてみようと思います。
    ありがとうございました。

    2018年3月13日 5:47
  • OTA Hirofumiさん

    ありがとうございます。
    社内システムの都合ですぐにドメインへ移行する訳にいかず、取りえずインストール時に「スタンドアローン」を選択してインストールしてみました。
    ※あまり重要な情報ではないかもしれませんが、同様の事象でお困りの方のために載せておきます。

    インストール完了後に「
    SharePoint 2013 製品構成ウィザード」を実行しましたが順調に進められました。
    ただ、最後に「
    System.ArgumentExceptionの例外がスローされました」という内容のエラーメッセージが表示されました。

    このメッセージがどれほど重要なのかは今のところまだ判明していませんが、後に判明しましたらまたこちらに続報としてご案内したいと思います。

    2018年3月19日 2:32