locked
Problem with windows server backup - incorrect function RRS feed

  • 質問

  • I have a problem with a clients Windows Server 2008, trying to perform backup to an external hard disk. I always get the error 'Incorrect function' when about 99% complete.

    I have tried a number of deviecs with the same result. Obviously I'm getting worried about getting a clean backup for the client.

    Thanks in advance 

    Phil R
    ValeWest Ltd

    Event log attached below
    Log Name:      Microsoft-Windows-Backup
    Source:        Microsoft-Windows-Backup
    Date:          18/05/2009 12:40:29
    Event ID:      5
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      TEBAYSERVER.M6Diesel.local
    Description:
    Backup started at '18/05/2009 11:24:44' failed with following error code '2147942401'.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Backup" Guid="{1db28f2e-8f80-4027-8c5a-a11f7f10f62d}" />
        <EventID>5</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2009-05-18T11:40:29.375Z" />
        <EventRecordID>73</EventRecordID>
        <Correlation />
        <Execution ProcessID="9052" ThreadID="4500" />
        <Channel>Microsoft-Windows-Backup</Channel>
        <Computer>TEBAYSERVER.M6Diesel.local</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="BackupTemplateID">{748EE614-D7F7-4451-A543-0D4CDB4328CB}</Data>
        <Data Name="HRESULT">2147942401</Data>
        <Data Name="BackupState">12</Data>
        <Data Name="BackupTarget">F:</Data>
        <Data Name="NumOfVolumes">1</Data>
        <Data Name="BackupTime">2009-05-18T11:24:44.600Z</Data>
        <Data Name="HRESULT">2147942401</Data>
        <Data Name="VolumesInfo">&lt;VolumeInfo&gt;&lt;VolumeInfoItem Name="C:" OriginalAccessPath="C:" State="12" HResult="-2147024895" DetailedHResult="0" PreviousState="9" DataTransferred="23449042944" NumUnreadableBytes="0" TotalSize="23454909440" Flags="2" SSBTotalNoOfFiles="0" SSBTotalSizeOnDisk="0" SSBVhdSize="0"/&gt;&lt;/VolumeInfo&gt;</Data>
        <Data Name="DetailedHRESULT">0</Data>
        <Data Name="SourceSnapStartTime">2009-05-18T11:24:44.596Z</Data>
        <Data Name="SourceSnapEndTime">2009-05-18T11:25:32.571Z</Data>
        <Data Name="PrepareBackupStartTime">&lt;TimesList&gt;&lt;Time Time="2009-05-18T11:25:34.825Z" /&gt;&lt;/TimesList&gt;</Data>
        <Data Name="PrepareBackupEndTime">&lt;TimesList&gt;&lt;Time Time="2009-05-18T11:25:35.556Z" /&gt;&lt;/TimesList&gt;</Data>
        <Data Name="BackupWriteStartTime">&lt;TimesList&gt;&lt;Time Time="2009-05-18T11:25:35.556Z" /&gt;&lt;/TimesList&gt;</Data>
        <Data Name="BackupWriteEndTime">&lt;TimesList&gt;&lt;Time Time="2009-05-18T11:40:27.437Z" /&gt;&lt;/TimesList&gt;</Data>
        <Data Name="TargetSnapStartTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="TargetSnapEndTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="DVDFormatStartTime">&lt;TimesList&gt;&lt;/TimesList&gt;</Data>
        <Data Name="DVDFormatEndTime">&lt;TimesList&gt;&lt;/TimesList&gt;</Data>
        <Data Name="MediaVerifyStartTime">&lt;TimesList&gt;&lt;/TimesList&gt;</Data>
        <Data Name="MediaVerifyEndTime">&lt;TimesList&gt;&lt;/TimesList&gt;</Data>
        <Data Name="BackupPreviousState">9</Data>
        <Data Name="ComponentStatus">&lt;ComponentStatus&gt;&lt;/ComponentStatus&gt;</Data>
        <Data Name="SSBEnumerateStartTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="SSBEnumerateEndTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="SSBVhdCreationStartTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="SSBVhdCreationEndTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="SSBBackupStartTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="SSBBackupEndTime">1601-01-01T00:00:00.000Z</Data>
        <Data Name="SystemStateBackup">false</Data>
      </EventData>
    </Event>

    philr
    2009年5月18日 16:19

回答

すべての返信

  • Hi Phil,

    Thanks for reporting the issue.  To diagnose the issue further we will need some log files from your machine.  Can you please reattempt the backup?  Once it send us all files from:
    c:\Windows\Logs\WindowsServerBackup

    Send the files to absrivas-nospam@microsoft.com (Remove -nospam from the mail id to get the correct email id)

    Thanks
    Abhinav
    2009年5月20日 13:49
  • Hi Abhinav,

    Files from directory sent as requested after running a backup

    Hope this helps.

    Thanks in advance

    Phil R

    philr
    2009年5月20日 17:50
  • Hi Phil,

    This issue here is that windows backup sometimes fails to read the last sector on the volume.  This happens if the last sector is corrupted. 
    The symptom of this issue, as you observed, is that backup fails at a very late stage and fails consistently.  In such a situation if may fail with:
    "Incorrect function" (0x8007001) or,
    "Data error (cyclic redundancy check)" (0x80070017) or, 
    "The request could not be performed because of an I/O device error." (0x8007045d) or,
    "The drive cannot find the sector requested." (0x8007001b)

    In Windows server 2008 R2 we have fixed this issue.  As a workaround, you can try to shrink or extend the volume, whose backup is failing, by 2-3 MBs.

    Let us know if that worked.

    Thanks
    Abhinav
    2009年5月21日 6:34
  • Hi, Abhinav

    I've now had a chance to try your suggestion, while the system is quiet.
    However, I get the same error message when attempting to shrink the volume 'Incorrect Function'

    As a note, I had a lot of problems when I built this server last year. The problem was finding a suitable driver for the embedded HP SATA Raid Controller (x64). I had to pull it out and rebuild it a one point because the performance was  so bad.

    Don't know if this hints at anything

    Regards

    Phil R

    philr
    2009年5月23日 10:01
  • Hi Phil,
    Is it possible for you to extend the volume, if shrink is not working?  In case a second volume after your volume is preventing the extend, I can imagine that you could take a backup of that volume alone, then extend the first volume and then recreate the second volume again. After this you can restore all data of second volume using file restore option (volume restore will not work if the recreated volume size is less than original volume).

    Also, this issue may also be an indication that your drive is developing bad sectors.  You can run chkdsk on it to see if it is showing up lot of bad sectors.  If it does, then it is advisable to replace the drive.

    Thanks
    Abhinav
    2009年5月23日 18:46
  • Hi there,

    We are currently experiencing this same "Incorrect Function" error whilst trying to run backups on a recently implemented client's SBS 2008 server, on an HP ML110 G5 box. We also are using the same HP SATA Raid Controller driver for our storage arrays.

    Was this issue ever resolved Phil?

    Thanks,
    Ben
    2009年9月2日 5:47
  • 2009年9月7日 5:52
  • Thank you for the response Abhinav, unfortunately i am unable to shrink the C:\ volume on the server in question by even 1 megabyte as it appears to have some metadata stored in those last few blocks that refuse to be moved, even during an offline defrag with Perfectdisk 10. If you can give me any insight as to how i might go about resolving this it would be much appreciated.

    The exact error message i get when trying to shrink the volume is headed "Logical Disk Manager" and the error is simply "Access is denied.".
    2009年9月11日 0:41
  • I had similar issues while backing up on a external WD cloud , following articles provides nice work around to the issue

    http://www.grishbi.com/2014/11/windows-server-backup-failing-errors-incorrect-function-failure-preparing-backup-image/

    thx

    2015年1月27日 18:23