none
Windows Complete PC 復元で NIC を認識しない RRS feed

  • 質問

  • Windows Server バックアップを用いて Windows Server 2008 R1 SP2 x64 (仮に Svr.A とします) の全体バックアップを、同一ネットワーク上の別サーバー (Svr.B とします) に取得しました。

    リストアの試験を行う為、Svr.A に Windows Server 2008 R1 SP2 x64 のインストールメディアを挿入してそのメディアから起動し、Windows Complete PC 復元を行います。ネットワーク上に DHCP サービスがないので IP アドレスを静的に指定する必要があるかと思い、コマンドプロンプトで次のようにコマンドを入力したのですが、インターフェースの一覧に loopback しか表示されず、ネットワーク上の Svr.B 上に保存されているバックアップイメージを読み込むことができず困っております。

    >----
    startnet
    netsh interface ipv4 show interface
    <----

    IP アドレスの設定には次のコマンドを発行するつもりでした。PE のコマンドプロンプトでは日本語入力ができない為、一覧されるインターフェースの表示をコピーすることで対処しようとしています。

    >----
    netsh interface ipv4 set address name="ローカル エリア接続" source=static address=<IP アドレス> mask=<サブネットマスク>
    <----

    Svr.A と Svr.B のハードウェアは HP 社製 Prolient DL360 G6 及び DL380 G6 です。
    Svr.A の NIC は NC382iDP というものが該当するようです。x64 用のドライバを CD-RW に焼いておき、コマンドプロンプトの操作をする前に読み込んでみたりもしましたが、それだけでは状況は変わりませんでした。

    Svr.B へのアクセス権限は少なくとも別のサーバーからも Svr.A の元の Windows 起動時の環境からも読み書きができることを確認しています。ネットワークパスは目視ではありますが幾度も再確認しました。今回は Svr.A 自身の NIC が Windows PE 上で認識されていないことに主要因があるものと考えています。

    どなたか良いアイディアをお持ちでないでしょうか。
    ご助力いただければ幸いです。どうぞよろしくお願い致します。
    2010年7月16日 3:38

回答

  • mbcmu さん、こんにちは。
    フォーラムオペレーターの三沢健二です。

    やはり、NIC が認識されていない事が原因と思われます。

    ドライバーのインストール後、念のために下記のコマンドをお試しください。(startnet と処理が重なっているかもしれませんが、、)
    "wpeutil InitializeNetwork"


    もしかしたら、NIC のドライバーが対応していない可能性もありますので、一度ベンダーへご相談された方が良いかもしれません。

    "x:\WINDOWS\INF\" にある、"setupapi.dev.log" や "setupapi.app.log" を解析すると、ドライバーのインストール状況などが分かる場合もあります。


    あまり具体的なアドバイスが出来ずすみません。。。
    それでは、こちらの情報が少しでもお役にたてれば幸いです。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    • 回答としてマーク 服部清次 2010年7月29日 8:21
    2010年7月22日 7:51
    モデレータ

すべての返信

  • mbcmu さん、こんにちは。
    フォーラムオペレーターの三沢健二です。

    やはり、NIC が認識されていない事が原因と思われます。

    ドライバーのインストール後、念のために下記のコマンドをお試しください。(startnet と処理が重なっているかもしれませんが、、)
    "wpeutil InitializeNetwork"


    もしかしたら、NIC のドライバーが対応していない可能性もありますので、一度ベンダーへご相談された方が良いかもしれません。

    "x:\WINDOWS\INF\" にある、"setupapi.dev.log" や "setupapi.app.log" を解析すると、ドライバーのインストール状況などが分かる場合もあります。


    あまり具体的なアドバイスが出来ずすみません。。。
    それでは、こちらの情報が少しでもお役にたてれば幸いです。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    • 回答としてマーク 服部清次 2010年7月29日 8:21
    2010年7月22日 7:51
    モデレータ
  • mbcmu さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    mbcmu さんがこちらの質問を投稿されてから少し経ちましたが、その後の状況はいかがでしょうか?
    弊社の三沢健二の回答は、ご確認いただけましたでしょうか?

    今回、弊社の三沢の回答は、mbcmu さんのご質問に対するズバリな回答ではなかったかもしれませんが、、、
    1つの参考情報として役立てていただけるのではないかと思いましたので、勝手ながら、
    ひとまず私の方で [回答としてマーク] のチェックを付させていただきました。

    また何か困ったことがありましたら、ぜひ TechNet フォーラムをご利用ください。
    よろしくお願いします。
    それでは、また。


    __________________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2010年7月29日 8:22