none
テンプレート化したサイトでサブサイトを作成するとエラーが発生する。 RRS feed

  • 質問

  • こんにちは

    テンプレート化したサイトでサブサイトを作成するとエラーが発生します。

    ■サイト
    テンプレート化したサイトは以下を含んでおります。
    ・カスタムリスト
     →サイトコンテンツタイプギャラリーにコンテンツタイプを追加
     →追加したコンテンツタイプを適応
     →カスタムリストのコンテンツタイプ設定画面から列を非表示に設定
    ・ドキュメントライブラリ
     →サイトコンテンツタイプギャラリーにコンテンツタイプを追加
     →追加したコンテンツタイプを適応
     →カスタムリストのコンテンツタイプ設定画面から列を非表示に設定
    ・SharePoint Designerで設定したワークフロー(カスタムリスト・ドキュメントライブラリ)

    ■エラー内容
    エラー
    数式は、存在しない列を参照しています。入力した数式にスペルミスがないか確認するか、
    または列が存在しない場合は既存の列に変更してください。

    ■エラー後の動作不具合
    ・エラー発生後ブラウザを閉じ、作成予定だったサブサイトのURLを入力すると
     サブサイトが作成されている。
    ・コンテンツタイプで非表示にしていたドキュメントライブラリの列が表示されている。
    ・ドキュメントライブラリの列順が変更されている。


    ■質問1
    エラーおよびエラー後の動作不具合について回避方法があればお教えいただけますでしょうか?

    ■質問2
    エラーは発生するがサブサイトは作成されているようですが、
    現在認識している不具合以外に問題があれば教えていただけますでしょうか?


    ■動作環境
    Server:Windows 2003 R2、SharePoint 2007 SP2
    Client:Windows SEVEN

    何らかのヒントになるような情報があれば
    ご教示頂けますでしょうか。

    よろしくお願いいたします。

    2011年3月23日 4:52

回答

  • 中村 和彦さん
    paddle_tomoyaさん

    ご回答いただきありがとうございました。
    いただいた情報を元に、こちらの環境で色々と試してみたところ、
    原因と解決方法がわかりました。

    ■原因
    集計列の式エラー
    →集計列を含んだテンプレートからカスタムリスト(もしくはドキュメントライブラリ)を
     作成するとエラーが発生する。

    ■解決方法
    テンプレートから集計列を削除する。
    もしくはテンプレートの集計列の式を「=""」とする。

    本件、アドバイスいただきありがとうございました。
    今後ともよろしくお願いします。

    以上、よろしくお願いします。

    • 回答としてマーク ichigo5657 2011年4月4日 4:19
    2011年4月4日 4:19

すべての返信

  • いまひとつご質問の状況が把握できませんが、ヒントになれば。

    私の経験では、リストに「参照列」が含まれた場合、それをテンプレートにして「起こす」際にエラーが発生した記憶があります。

    テンプレートから参照列を除いてみてください。

    また

    >・コンテンツタイプで非表示にしていたドキュメントライブラリの列が表示されている。
    >・ドキュメントライブラリの列順が変更されている。

    これはエラーとはおそらく無関係だと思います。


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答の候補に設定 星 睦美 2011年3月29日 4:08
    • 回答としてマーク 星 睦美 2011年3月30日 4:19
    • 回答としてマークされていない ichigo5657 2011年4月4日 4:18
    2011年3月25日 2:07
  • こんにちは。

    エラー内容を見ると、中村 和彦さんがおっしゃるような事が原因のような気がします。

    あと、気になるのは下記くらいですね。。

    >・SharePoint Designerで設定したワークフロー(カスタムリスト・ドキュメントライブラリ

    以前に経験したのが、ワークフローを組み込んだものをDocAve(AvePoint社アドイン)で移行させたり、テンプレート化したりするとエラーになった記憶があります。

     

    今回はアドインなどを使っていないので、全く別の話になってしまうかもしれませんが…ヒントになれば。

    ワークフローを除いたり、試行錯誤しかなさそうです。




    • 回答の候補に設定 星 睦美 2011年3月29日 4:08
    • 回答としてマーク 星 睦美 2011年3月30日 4:19
    • 回答としてマークされていない ichigo5657 2011年4月4日 4:18
    2011年3月25日 3:00
  • ichigo5657 さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    今回は私から[回答としてマーク] をさせていただきました。

    ichigo5657 さんの環境での問題が原因と思われますので
    具体的なエラーの解決法は見つからないのですが、
    中村 和彦 さんとpaddle_tomoya さんからの返信が参考になればと思います。
    引き続き質問があれば[回答としてのマークの解除] をして返信できます。

    今後ともTechNet フォーラムをよろしくお願いします。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    2011年3月30日 4:20
  • 中村 和彦さん
    paddle_tomoyaさん

    ご回答いただきありがとうございました。
    いただいた情報を元に、こちらの環境で色々と試してみたところ、
    原因と解決方法がわかりました。

    ■原因
    集計列の式エラー
    →集計列を含んだテンプレートからカスタムリスト(もしくはドキュメントライブラリ)を
     作成するとエラーが発生する。

    ■解決方法
    テンプレートから集計列を削除する。
    もしくはテンプレートの集計列の式を「=""」とする。

    本件、アドバイスいただきありがとうございました。
    今後ともよろしくお願いします。

    以上、よろしくお願いします。

    • 回答としてマーク ichigo5657 2011年4月4日 4:19
    2011年4月4日 4:19